
<!DOCTYPE HTML>
<html lang="en" data-aem-fallback-locale="en-TH">
<head>
</meta>
</meta>
<meta />
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<script>digitalData={"product":[{"productInfo":{"productID":"310409"}}],"page":{"pageInfo":{"template":"releaseNoteKnown"}}};</script>
<meta name="Keywords" />
<meta name="description" content="This document contains the Vision Builder for Automated Inspection known issues that were discovered before and since the release of Vision Builder for Automated Inspection 2019. Known issues are performance issues or technical bugs that NI has acknowledged exist within this version of the product." />
<meta name="Country" content="TH" />
<meta name="Language" scheme="rfc3066" content="en" />
<meta name="Section" content="support" />
<meta name="ContentType" content="bugs" />
<meta name="PageType" content="leaf" />
<meta name="ProductCategories" content="310409" />
<meta name="GlobalScope" content="global" />
<meta name="DocumentID" content="09cbe9f5-e89c-454e-9129-c599e42c0e5c" />
<link rel="shortcut icon" type="image/x-icon" href="//www.ni.com/favicon.ico" />
<link rel="icon" type="image/x-icon" href="//www.ni.com/favicon.ico" />
<meta name="Robots" content="index, follow">
<meta name="DeliveredBy" content="CMS" />
<meta name="Date" scheme="iso8601" content="2020-08-21T17:31:00" /> 
<meta name="UpdateDate" scheme="iso8601" content="2020-08-21T17:30:45" /> 
<link rel="canonical" href="https://www.ni.com/en-th/support/documentation/bugs/20/vision-builder-for-automated-inspection-2019-known-issues.html" />
<meta name="docstatus" content="current" />
<meta name="cms_countrysite_s" content="en-th" />
<meta name="Template_s" content="release-notes---known-issues" />
<meta property="og:title" content="Vision Builder for Automated Inspection 2019 Known Issues" />
<meta property="og:description" content="This document contains the Vision Builder for Automated Inspection known issues that were discovered before and since the release of Vision Builder for Automated Inspection 2019. Known issues are performance issues or technical bugs that NI has acknowledged exist within this version of the product." />
<meta property="og:image" content="https://ni.scene7.com/is/image/ni/logo_2020?wid=450" />
<script>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</script>
</meta>
</meta>
<title>Vision Builder for Automated Inspection 2019 Known Issues - NI</title>
<meta name="ShortTitle" content="Vision Builder for Automated Inspection 2019 Known Issues" />
<meta name="EnglishShortTitle" content="Vision Builder for Automated Inspection 2019 Known Issues" />

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta name="Wrapper" content="yes" />
<meta name="wrapperid" content="default-nia" />

<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=0" />

<script type="text/javascript" src="/niassets/jquery/js/jquery.min.js"></script>

<script src="/niassets/js/niua.min.js"></script>

<script src="/niassets/js/loader.min.js"></script>

<script type="text/javascript" src="/niassets/jquery/js/jquery-migrate-1.2.1.min.js"></script>

<script type="text/javascript" src="/niassets/bootstrap/js/bootstrap.min.js"></script>

<script type="text/javascript" src="/niassets/jquery/jqueryui/js/jquery-ui.min.js"></script>

<link rel="stylesheet" href="/niassets/bootstrap/css/bootstrap.min.css">
<script type="text/javascript" src="/niassets/ni.min.js"></script>

<link rel="stylesheet" type="text/css" href="/niassets/jquery/jqueryui/css/jquery-ui.min.css">
<link rel="stylesheet" href="/niassets/ni.min.css">
<link rel="icon" href="/favicon.ico?v=1">
<script src="https://kit.fontawesome.com/5806b6a478.js"></script>

<style>
.ni-megamenu-solutions .img-responsive {
height: 201px;
width: 350px;
}
</style>

<script defer src="/niassets/flexslider/2.6/jquery.flexslider.js"></script>

<script src="/niassets/jquery/js/jquery.easing.1.3.js"></script>
<script src="/niassets/jquery/js/jquery.mousewheel.js"></script>
<link rel="stylesheet" href="/niassets/flexslider/2.6/flexslider.css" type="text/css" media="screen" />
<link rel="stylesheet" href="/etc.clientlibs/ni-commons/clientlibs/core-components.min.css" type="text/css">
<script type="text/javascript" src="/etc.clientlibs/clientlibs/granite/utils.min.js"></script>
<script type="text/javascript" src="/etc.clientlibs/ni-commons/clientlibs/core-components.min.js"></script>
</meta>
<script>
    var NI = NI || {};
    NI.utils = NI.utils || {};
    NI.utils.browserSize = function() {

        var envs = ['xs', 'sm', 'md', 'lg'];

        var $el = $('<div>');

        $el.appendTo($('body'));

        for (var i = envs.length - 1; i >= 0; i--) {
            var env = envs[i];

            $el.addClass('hidden-'+env);
            if ($el.is(':hidden')) {
                $el.remove();
                return env;
            }
        }

    }
</script>
<meta />
</head>
<body>
<div class="ni-page-wrap">
<div id='ZN_0wWxj0NUZX5UFeZ'>

</div>
<nav class="ni-wrapper-header  noindex hidden-print">


<ul class="flex-container">
<li class="ni-logo">
<a class="analytics-headerlogo-link" href="//www.ni.com"></a>
</li>

<li class="toggle">
<a href="javascript:void(0)">
<span class="icon-bar"></span>
<span class="icon-bar"></span>
<span class="icon-bar"></span>
</a>
<span class="sr-only">Toggle navigation</span>
</li>
<li class="mobile-spacer"></li>
<div class="header-menu">
<li class="solutions nia-menu-item dropdown mega-dropdown">
<a class="analytics-headersolutions-link" href="//www.ni.com/en-us/solutions.html">Solutions</a>
<div class="dropdown-menu mega-dropdown-menu">
<div class="ni-megamenu-desktop">
<div class="ni-megamenu-solutions">
<div class="row">
<div class="col-sm-12">
<span class="ni-megamenu-title">How we think about solutions</span>
<h2>We create solutions with you tailored to your industry needs.</h2>
</div>
</div>
<div class="row">
<div class="col-sm-4">
<div class="ni-live-image">
<a class="analytics-mmsolutions-image" href="//www.ni.com/en-us/innovations/semiconductor.html"><img src="//ni.scene7.com/is/image/ni/semiconductor_321" class="img-responsive"></a>
<p>Semiconductor </p>
</div>
</div>
<div class="col-sm-4">
<div class="ni-live-image">
<a class="analytics-mmsolutions-image" href="//www.ni.com/en-us/innovations/automotive.html"><img src="//ni.scene7.com/is/image/ni/automotive_321" class="img-responsive"></a>
<p>Automotive  </p>
</div>
</div>
<div class="col-sm-4">
<div class="ni-live-image">
<a class="analytics-mmsolutions-image" href="//www.ni.com/en-us/innovations/aerospace-defense.html"><img src="//ni.scene7.com/is/image/ni/aerospace_defense_govt_321" class="img-responsive"></a>
<p>Aerospace, Defense, &amp; Government </p>
</div>
</div>
</div>
<div class="row">
<div class="col-sm-4">
<div class="ni-live-image">
<a class="analytics-mmsolutions-image" href="//www.ni.com/en-us/innovations/electronics.html"><img src="//ni.scene7.com/is/image/ni/electronics_321" class="img-responsive"></a>
<p>Electronics </p>
</div>
</div>
<div class="col-sm-4">
<div class="ni-live-image">
<a class="analytics-mmsolutions-image" href="//www.ni.com/en-us/innovations/energy.html"><img src="//ni.scene7.com/is/image/ni/energy_321" class="img-responsive"></a>
<p>Energy</p>
</div>
</div>
<div class="col-sm-4">
<div class="ni-live-image">
<a class="analytics-mmsolutions-image" href="//www.ni.com/en-us/innovations/academic-research.html"><img src="//ni.scene7.com/is/image/ni/academic_research_321" class="img-responsive"></a>
<p>Academic &amp; Research</p>
</div>
</div>
</div>
<div class="row">
<div class="ni-rebrand-button">
<a class="analytics-mmsolutions-button" role="button" href="//www.ni.com/en-us/solutions.html">Learn about solutions </a>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="products nia-menu-item dropdown mega-dropdown">
<a class="analytics-headerproducts-link" href="//www.ni.com/en-us/shop.html">Products</a>
<div class="dropdown-menu mega-dropdown-menu">
<div class="ni-megamenu-desktop">
<div class="ni-megamenu-products">
<div class="row">
<div class="col-sm-3">
<h3>Software</h3>
<ul>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/labview.html">LabVIEW</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/electronic-test-instrumentation/application-software-for-electronic-test-and-instrumentation-category/what-is-teststand.html">TestStand</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/data-acquisition-and-control/flexlogger.html">FlexLogger</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/electronic-test-instrumentation/application-software-for-electronic-test-and-instrumentation-category/systemlink.html">SystemLink</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/data-acquisition-and-control/application-software-for-data-acquisition-and-control-category/what-is-diadem.html">DIAdem</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/data-acquisition-and-control/application-software-for-data-acquisition-and-control-category/what-is-veristand.html">VeriStand</a></li>
<li><a class="analytics-mmproducts-link" href="//www.optimalplus.com">Optimal+ is now NI</a></li>
</ul>
<h4>Software Suites</h4>
<ul>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/automated-test-software-suite">Automated Test Software Suite</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/embedded-control-and-monitoring-software-suite">Embedded Control and Monitoring Software Suite</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/hil-and-real-time-test-software-suite">HIL and Real-Time Software Suite</a></li>
</ul>
<h3>SERVICES</h3>
<ul>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/services/hardware/repair-replacement-services.html">Repair Services</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/services/hardware/calibration-services.html">Calibration</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/services.html">NI Services Program</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/courses-category#facet:&amp;productBeginIndex:0&amp;orderBy:&amp;pageView:grid&amp;pageSize:&amp;">Purchase Training</a></li>
</ul>
</div>
<div class="col-sm-3">
<h3>HARDWARE</h3>
<h4>Data Acquisition and Control </h4>
<ul>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/multifunction-io-category">Multifunction I/O</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/voltage-category">Voltage</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/current-category">Current</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/digital-io-category">Digital I/O</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/packaged-controllers-category">Packaged Controllers</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/compactdaq-chassis-category">CompactDAQ Chassis</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/temperature-category">Temperature</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/sound-and-vibration-category">Sound and Vibration</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/strain-pressure-and-force-category">Strain, Pressure, and Force</a></li>
</ul>
<ul>
<li>
<h4>Electronic Test and Instrumentation</h4>
</li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/oscilloscopes-category">Oscilloscopes</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/hardware/switches-category.html#">Switches</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/hardware/source-measure-units-category.html#">Source Measurement Units</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/gpib-serial-and-ethernet-category">GPIB, Serial, and Ethernet</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/digital-multimeters-category">Digital Multimeters</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/hardware/pxi-controllers-category.html#">PXI Controllers</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/hardware/pxi-chassis-category.html#">PXI Chassis</a></li>
</ul>
</div>
<div class="col-sm-3">
<h4>Wireless Design and Test</h4>
<ul>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/software-defined-radios-category">Software Defined Radios</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/rf-signal-generators-category">RF Signal Generators</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/vector-signal-transceivers-category">Vector Signal Transceivers</a></li>
</ul>
<h4>Accessories</h4>
<ul>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/power-accessories-category">Power Accessories</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/connectors-category">Connectors</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/cables-category">Cables</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/sensors-category">Sensors</a></li>
</ul>
</div>
<div class="col-sm-3">
<div class="ni-live-image">
<a class="analytics-mmproducts-image" href="//www.ni.com/en-us/shop/pc-based-measurement-and-control-system.html">
<div class="ni-live-text">
<h4>PC-Based Systems </h4>
<p>Benchtop Measurement and Test</p>
</div>
</a>
</div>
<div class="ni-live-image">
<a class="analytics-mmproducts-image" href="//www.ni.com/en-us/shop/compactrio.html">
<div class="ni-live-text">
<h4>CompactRIO </h4>
<p>Distributed Measurement and Control</p>
</div>
</a>
</div>
<div class="ni-live-image">
<a class="analytics-mmproducts-image" href="//www.ni.com/en-us/shop/pxi.html">
<div class="ni-live-text">
<h4>PXI</h4>
<p>High-Performance Test</p>
</div>
</a>
</div>
<div class="ni-live-image">
<a class="analytics-mmproducts-image" href="//www.ni.com/en-us/shop/software-portfolio.html">
<div class="ni-live-text">
<h4>Software</h4>
<p>Systems Engineering Software</p>
</div>
</a>
</div>
<div class="ni-rebrand-button">
<a class="analytics-mmproducts-button" role="button" href="//www.ni.com/en-us/shop.html">See all</a>
</div>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="perspectives nia-menu-item">
<a class="analytics-headerperspectives-link" href="//www.ni.com/en-us/perspectives.html ">Perspectives</a>
</li>
<li class="support nia-menu-item dropdown mega-dropdown">
<a class="analytics-headersupport-link" href="//www.ni.com/en-us/support.html">Support</a>
<div class="dropdown-menu mega-dropdown-menu">
<div class="ni-megamenu-desktop">
<div class="ni-megamenu-support">
<div class="row">
<div class="col-sm-3">
<h3>Resources</h3>
<ul>
<li><a class="analytics-mmsupport-link" href="//www.ni.com/en-us/support/downloads.html">Software Downloads</a></li>
<li><a class="analytics-mmsupport-link" href="//www.ni.com/myni/products/en/">Register and Activate</a></li>
<li><a class="analytics-mmsupport-link" href="//www.ni.com/manuals/">Product Documentation</a></li>
<li><a class="analytics-mmsupport-link" href="//learn.ni.com/training">Online Training</a></li>
<li><a class="analytics-mmsupport-link" href="//www.ni.com/kb/ ">KnowledgeBase</a></li>
<li><a class="analytics-mmsupport-link" href="//forums.ni.com/t5/Example-Programs/ct-p/code-documents">Code Examples</a></li>
</ul>
</div>
<div class="col-sm-9">
<div class="row">
<div class="col-sm-12">
<h3>Popular Software Downloads</h3>
 </div>
</div>
<div class="row">
<div class="col-sm-12">
<div class="ni-software-download-image">
<a class="analytics-mmsupport-image" href="//www.ni.com/en-us/support/downloads/software-products/download.labview-nxg.html"><img src="//ni.scene7.com/is/image/ni/labviewnxg?fmt=png-alpha">
<h3>LabVIEW NXG</h3>
</a>
</div>
<div class="ni-software-download-image">
<a class="analytics-mmsupport-image" href="//www.ni.com/en-us/support/downloads/software-products/download.labview.html"><img src="//ni.scene7.com/is/image/ni/labview?fmt=png-alpha&amp;amp;bgcolor=244,244,244">
<h3>LabVIEW</h3>
</a>
</div>
<div class="ni-software-download-image">
<a class="analytics-mmsupport-image" href="//www.ni.com/en-us/support/downloads/software-products/download.systemlink.html"><img src="//ni.scene7.com/is/image/ni/multisim">
<h3>SystemLink</h3>
</a>
</div>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-sm-3">
<h3>Request Support</h3>
<p>You can request repair, schedule calibration, or get technical support. A valid service agreement may be required.  </p>
<a class="analytics-mmsupport-link" href="//sine.ni.com/srm/app/getassistance">Open a service request</a>
</div>
<div class="col-sm-3">
<h3>Popular Driver Downloads</h3>
<a class="analytics-mmsupport-link" href="//www.ni.com/en-us/support/downloads/drivers/download.ni-daqmx.html">NI-DAQmx</a>
<p>Provides support for NI data acquisition and signal conditioning devices.  </p>
</div>
<div class="col-sm-3">
<a class="analytics-mmsupport-link" href="//www.ni.com/en-us/support/downloads/drivers/download.ni-visa.html">NI-VISA</a>
<p>Provides support for Ethernet, GPIB, serial, USB, and other types of instruments.  </p>
</div>
<div class="col-sm-3">
<a class="analytics-mmsupport-link" href="//www.ni.com/en-us/support/downloads/drivers/download.ni-488-2.html">NI-488.2</a>
<p>Provides support for NI GPIB controllers and NI embedded controllers with GPIB ports.  </p>
</div>
</div>
<div class="row">
<div class="ni-rebrand-button col-sm-12">
<a class="analytics-mmsupport-button" role="button" href="//www.ni.com/en-us/support.html">All support resources</a>
</div>
</div>
</div>
</div>
</div>
</li>
<li class="community nia-menu-item">
<a class="analytics-headercommunity-link" href="//forums.ni.com/">Community</a>
</li>
<li class="nia-menu-item  spacer"></li>
<li class="about nia-menu-item nia-utils">
<a class="analytics-header-link" href="//www.ni.com/en-us/about-ni.html">About</a>
</li>
<li class="contact nia-menu-item nia-utils">
<a class="analytics-header-link" href="//www.ni.com/en-us/contact-us.html">Contact Us</a>
</li>
<li class="nia-menu-item  nia-utils header-icon account">
<a class="account-link" href="#">
<svg viewbox="0 0 27.8 27.8">
<path d="M18.16,6.15a5,5,0,1,1-5-5A5,5,0,0,1,18.16,6.15Zm-1,8h-8a8,8,0,0,0-8,8v4h24v-4A8,8,0,0,0,17.14,14.16Zm-4-.49V26.13">
</path>
</svg>
</a>
<div class="account-content">
</div>
</li>
<li class="nia-menu-item nia-utils account-mobile">
<a class="analytics-headeraccount-link" href="//www.ni.com/myni/dashboard/">Account</a>
</li>
<li class="nia-menu-item  nia-utils header-icon wrapper-search">
<a href="#" id="wrapperSearchId">
<svg viewbox="0 0 26.33 26.84">
<circle cx="11.15" cy="11.15" r="10" />
<path d="M21.76,23.09l7.07,7.07" transform="translate(-3.64 -4.47)" />
</svg>
</a>
</li>
<li class="wrapper-search-form">
<form id="wrapper-search-form" name="autoComplete-global" type="GET" action="//search.ni.com/nisearch/app/main">
<div class="autoCompleteItem-global">
<input type="text" name="q" placeholder="Search for things like download LabVIEW" class="niAutocompleteInput" data-search-type="globalSearch">
<input type="hidden" value="" name="sn" id="snparam">
<input type="hidden" value="tech" name="ap" id="apparam">
<input type="hidden" value="en" name="lang" id="langparam">
<input type="hidden" value="" name="fil" id="filparam">

<button type="submit" class="search-submit">
<svg viewbox="0 0 26.33 26.84">
<circle cx="11.15" cy="11.15" r="10" />
<path d="M21.76,23.09l7.07,7.07" transform="translate(-3.64 -4.47)" />
</svg>
</button>
<button type="reset" class="close">
<i class="fal fa-times" aria-hidden="true"></i>
</button>
</div>
</form>
</li>
</div>
<li class="nia-menu-item nia-utils header-icon cart-badge" data-badge="0">
<a class="analytics-headercart-link" href="https://sine.ni.com/apps/utf8/nios.store?action=view_cart">
<svg viewbox="0 0 27.82 27.82">
<path class="header-icon" d="M4.71,21.73H20.52A9.72,9.72,0,0,0,30.24,12V8.24H4.71V21.73Z" transform="translate(-3.56 -3.71)"></path>
<path class="header-icon" d="M9.06,21.47v2.11a2.44,2.44,0,0,0,2.4,2.47H25.67M4.48,4.86H6.65A2.44,2.44,0,0,1,9.06,7.33V8.47" transform="translate(-3.56 -3.71)"></path>
<path class="header-icon" d="M21.58,29.18A1.2,1.2,0,1,0,22.78,28,1.2,1.2,0,0,0,21.58,29.18Zm-10.51,0A1.21,1.21,0,1,0,12.27,28,1.2,1.2,0,0,0,11.07,29.18Z" transform="translate(-3.56 -3.71)"></path>
</svg>
</a>
</li>
<div class="mobile-nav ni-megamenu-mobile" data-depth="0">
<input type="hidden" id="mobileNavPos">
<ul data-depth="0" style="display: block; left: 0px;">
<li>
<a href="javascript:void(0);" class="open-list analytics-headersolutions-link" data-target="1">Solutions
<span class="glyphicon glyphicon-menu-right arrow"></span>
</a>
<ul data-depth="1" style="display: none;">
<li><a href="//www.ni.com/en-us/innovations/semiconductor.html" class="analytics-mmsolutions-link closed-list">Semiconductor </a> </li>
<li><a href="//www.ni.com/en-us/innovations/automotive.html" class="analytics-mmsolutions-link closed-list">Automotive  </a> </li>
<li><a href="//www.ni.com/en-us/innovations/aerospace-defense.html" class="analytics-mmsolutions-link closed-list">Aerospace, Defense, &amp; Government </a> </li>
<li><a href="//www.ni.com/en-us/innovations/electronics.html" class="analytics-mmsolutions-link closed-list">Electronics </a> </li>
<li><a href="//www.ni.com/en-us/innovations/energy.html" class="analytics-mmsolutions-link closed-list">Energy</a> </li>
<li><a href="//www.ni.com/en-us/innovations/academic-research.html" class="analytics-mmsolutions-link closed-list">Academic &amp; Research</a> </li>
<li>
<div class="ni-rebrand-button">
<a class="analytics-mmsolutions-button" role="button" href="//www.ni.com/en-us/solutions.html">Learn about solutions </a>
</div>
</li>
</ul>
</li>
<li>
<a href="javascript:void(0);" class="open-list analytics-headerproducts-link" data-target="1">Products
<span class="glyphicon glyphicon-menu-right arrow"></span>
</a>
<ul data-depth="1" style="display: none;">
<li>
<h3>Software</h3>
</li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/labview.html">LabVIEW</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/electronic-test-instrumentation/application-software-for-electronic-test-and-instrumentation-category/what-is-teststand.html">TestStand</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/data-acquisition-and-control/flexlogger.html">FlexLogger</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/electronic-test-instrumentation/application-software-for-electronic-test-and-instrumentation-category/systemlink.html">SystemLink</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/data-acquisition-and-control/application-software-for-data-acquisition-and-control-category/what-is-diadem.html">DIAdem</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/data-acquisition-and-control/application-software-for-data-acquisition-and-control-category/what-is-veristand.html">VeriStand</a></li>
<li><a class="analytics-mmproducts-link" href="//www.optimalplus.com">Optimal+ is now NI</a></li>
<li>
<h4>Software Suites</h4>
</li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/automated-test-software-suite">Automated Test Software Suite</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/embedded-control-and-monitoring-software-suite">Embedded Control and Monitoring Software Suite</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/hil-and-real-time-test-software-suite">HIL and Real-Time Software Suite</a></li>
<li>
<h3>SERVICES</h3>
</li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/services/hardware/repair-replacement-services.html">Repair Services</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/services/hardware/calibration-services.html">Calibration</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/services.html">NI Services Program</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/courses-category#facet:&amp;productBeginIndex:0&amp;orderBy:&amp;pageView:grid&amp;pageSize:&amp;">Purchase Training</a></li>
<li>
<h3>HARDWARE</h3>
</li>
<li>
<h4>Data Acquisition and Control </h4>
</li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/multifunction-io-category">Multifunction I/O</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/voltage-category">Voltage</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/current-category">Current</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/digital-io-category">Digital I/O</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/packaged-controllers-category">Packaged Controllers</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/compactdaq-chassis-category">CompactDAQ Chassis</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/temperature-category">Temperature</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/sound-and-vibration-category">Sound and Vibration</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/strain-pressure-and-force-category">Strain, Pressure, and Force</a></li>
<li>
<h4>Electronic Test and Instrumentation</h4>
</li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/oscilloscopes-category">Oscilloscopes</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/hardware/switches-category.html#">Switches</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/hardware/source-measure-units-category.html#">Source Measurement Units</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/gpib-serial-and-ethernet-category">GPIB, Serial, and Ethernet</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/digital-multimeters-category">Digital Multimeters</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/hardware/pxi-controllers-category.html#">PXI Controllers</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/hardware/pxi-chassis-category.html#">PXI Chassis</a></li>
<li>
<h4>Wireless Design and Test</h4>
</li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/software-defined-radios-category">Software Defined Radios</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/rf-signal-generators-category">RF Signal Generators</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/vector-signal-transceivers-category">Vector Signal Transceivers</a></li>
<li>
<h4>Accessories</h4>
</li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/power-accessories-category">Power Accessories</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/connectors-category">Connectors</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/cables-category">Cables</a></li>
<li><a class="analytics-mmproducts-link" href="//www.ni.com/en-us/shop/select/sensors-category">Sensors</a></li>
<li>
<div class="ni-rebrand-button">
<a class="analytics-mmproducts-button" role="button" href="//www.ni.com/en-us/shop.html">See all</a>
</div>
</li>
</ul>
</li>
<li>
<a href="//www.ni.com/en-us/perspectives.html " class="closed-list analytics-headerperspectives-link">Perspectives</a>
</li>
<li>
<a href="javascript:void(0);" class="open-list analytics-headersupport-link" data-target="1">Support
<span class="glyphicon glyphicon-menu-right arrow"></span>
</a>
<ul data-depth="1" style="display: none;">
<li>
<h4>Resources</h4>
</li>
<li><a class="analytics-mmsupport-link closed-list" href="//www.ni.com/en-us/support/downloads.html">Software Downloads</a></li>
<li><a class="analytics-mmsupport-link closed-list" href="//www.ni.com/myni/products/en/">Register and Activate</a></li>
<li><a class="analytics-mmsupport-link closed-list" href="//www.ni.com/manuals/">Product Documentation</a></li>
<li><a class="analytics-mmsupport-link closed-list" href="//learn.ni.com/training">Online Training</a></li>
<li><a class="analytics-mmsupport-link closed-list" href="//www.ni.com/kb/ ">KnowledgeBase</a></li>
<li><a class="analytics-mmsupport-link closed-list" href="//forums.ni.com/t5/Example-Programs/ct-p/code-documents">Code Examples</a></li>
<li>
<h4>Popular Software Downloads</h4>
</li>
<li><a href="//www.ni.com/en-us/support/downloads/software-products/download.labview-nxg.html" class="analytics-mmsupport-link closed-list">LabVIEW NXG</a> </li>
<li><a href="//www.ni.com/en-us/support/downloads/software-products/download.labview.html" class="analytics-mmsupport-link closed-list">LabVIEW</a> </li>
<li><a href="//www.ni.com/en-us/support/downloads/software-products/download.systemlink.html" class="analytics-mmsupport-link closed-list">SystemLink</a> </li>
<li>
<h4>Popular Driver Downloads</h4>
</li>
<li><a href="//www.ni.com/en-us/support/downloads/drivers/download.ni-daqmx.html" class="analytics-mmsupport-link closed-list">NI-DAQmx</a> </li>
<li><a href="//www.ni.com/en-us/support/downloads/drivers/download.ni-visa.html" class="analytics-mmsupport-link closed-list">NI-VISA</a> </li>
<li><a href="//www.ni.com/en-us/support/downloads/drivers/download.ni-488-2.html" class="analytics-mmsupport-link closed-list">NI-488.2</a> </li>
<li>
<h4>Request Support</h4>
</li>
<li>
<span class="note">
You can request repair, schedule calibration, or get technical support. A valid service agreement may be required. 
</span>
<a href="//sine.ni.com/srm/app/getassistance" class="analytics-mmsupport-link closed-list bold">Open a service request</a>
</li>
<li>
<div class="ni-rebrand-button">
<a class="analytics-mmsupport-button" role="button" href="//www.ni.com/en-us/support.html">All support resources</a>
</div>
</li>
</ul>
</li>
<li>
</li>
<li>
<a href="//forums.ni.com/" class="closed-list analytics-headercommunity-link">Community</a>
</li>
<li>
<a href="//www.ni.com/en-us/about-ni.html" class="analytics-header-link closed-list">About</a>
</li>
<li>
<a href="//www.ni.com/en-us/contact-us.html" class="analytics-header-link closed-list">Contact Us</a>
</li>
<li>
<a href="//www.ni.com/myni/dashboard/" class="analytics-headeraccount-link closed-list">Account</a>
</li>
</ul>
</div>
</ul>
</nav>
<div class="container global-header-breadcrumb"></div>
<div id="tempDowntime">

</div>
<div class="container-fluid ni-aem-body">
<div class="clearfix" align="center"></div>
<div><div><div class="breadcrumb row parbase">
<div class="ni-body-copy-secondary container">
<div>
<a class="left " href="/en-th.html">Home</a>
<span class="delimiter"></span>
<a class="left " href="/en-th/support.html">Support</a>
<span class="delimiter"></span>
<a class="left " href="https://www.ni.com/manuals/">Documentation</a>
<span class="delimiter"></span>
<span class="left breadcrumb-last">Bugs</span>
</div>
</div>
</div> </div></div>
<div class="clearfix"><div class="ni-home">
<div>
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container ni-white ">
<div>
<div class="row">
<div class="shading-container  ni-padding-top-1x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="title aem-GridColumn aem-GridColumn--default--12">
<div>
<div class="ni-notransform ni-text-align-left">
<h1 lang="en">Vision Builder for Automated Inspection 2019 Known Issues</h1>
</div>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class=" clearfix">
<div class="row  ">
<div class="container">
<div class="row">
<div class="shading-container   col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="metadata-subtitle aem-GridColumn aem-GridColumn--default--12"><link rel="stylesheet" href="/niassets/font-awesome/css/font-awesome.min.css" type="text/css" />
<div class="subtitle-description lead">
<span class="lastModifiedDate">
Created Aug 21, 2020
</span>
</div>
<div class="subtitle-icons">
<ul class="list-unstyled">
<li>
<div class="icon" onclick="location.href='mailto:?subject='+document.title+'&amp;body='+window.location.href;">
<i class="fa fa-envelope"></i>
</div>
</li>
<li>
<div class="icon" onclick="window.print();">
<i class="fa fa-print"></i>
</div>
</li>
</ul>
</div>
</div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container   col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="document-archived-notification-bar notification-bar parbase aem-GridColumn aem-GridColumn--default--12">
<div>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-x ni-padding-top-x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="overview aem-GridColumn aem-GridColumn--default--12">
<div class="ni-padding-bottom-1x">
<div class="ni-padding-bottom-x">
<h2>Overview</h2>
</div>
<div>
<div lang="en">
<p>This document contains the Vision Builder for Automated Inspection known issues that were discovered before and since the release of Vision Builder for Automated Inspection 2019. Known issues are performance issues or technical bugs that NI has acknowledged exist within this version of the product.</p>
<p> </p>
<p>Not every issue known to NI appears on this list; it is intended to show the most severe and common issues that you may encounter and provide workarounds when possible. Other technical issues that you may encounter could occur through normal product use or system compatibility issues. You may find more information on these issues in <a href="/en-th/support/documentation/bugs/19/mmwave-ota-validation-test-software-1-0-known-issues.html?wcmmode=disabled#resources">NI’s Product Documentation, Knowledgebase, or Community</a>.</p>
</div>
</div>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-x  col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="link parbase aem-GridColumn aem-GridColumn--default--12">
<div>
<div>
<span>
<a href="#glossary">
Glossary of Terms
</a>
</span>
</div>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-x ni-padding-top-x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="rich-text-section parbase aem-GridColumn aem-GridColumn--default--12">
<div>
<div>
<div class="known-issues-table parbase">
<link rel="stylesheet" href="/etc.clientlibs/ni-content/components/specialty/known-issues-table/clientlibs.min.css" type="text/css">
<script type="text/javascript" src="/etc.clientlibs/ni-content/components/specialty/known-issues-table/clientlibs.min.js"></script>
<div>
<span class="ni-aem-table table-striped-even">
<table>
<tbody>
<tr>
<th class="sortable">
<div class="flex-container">
<p>Bug Number</p>
<svg class="ni-tooltip" data-trigger="click" data-content="The ID that you can use to track this bug" data-placement="top" data-name="Layer 1" id="Layer_1" viewBox="0 0 128 128" xmlns="http://www.w3.org/2000/svg">
<defs>
<style>
                    .cls-1 {
                        fill: #aaa;
                        fill-rule: evenodd;
                    }
                </style>
</defs>
<path class="cls-1" d="M64,0a64,64,0,1,0,64,64A64,64,0,0,0,64,0ZM75.61,93.41q-4.36,1.69-7,2.57a18.73,18.73,0,0,1-6,.89c-3.52,0-6.26-.84-8.22-2.53a8.09,8.09,0,0,1-2.93-6.41,21,21,0,0,1,.22-3.09,34.68,34.68,0,0,1,.71-3.56L56,68.65q.5-1.82.83-3.44a15,15,0,0,0,.33-3,4.5,4.5,0,0,0-1-3.37c-.68-.63-2-.95-3.89-.95a10.31,10.31,0,0,0-2.9.43c-1,.29-1.83.56-2.54.82l1-3.89c2.39-.95,4.66-1.76,6.84-2.44a20.91,20.91,0,0,1,6.18-1c3.5,0,6.2.83,8.09,2.48a8.17,8.17,0,0,1,2.84,6.46c0,.55-.06,1.51-.19,2.89a19.92,19.92,0,0,1-.72,3.8L67.21,80.06c-.29,1-.55,2.16-.79,3.46a17.73,17.73,0,0,0-.36,2.94c0,1.67.38,2.81,1.15,3.41a6.52,6.52,0,0,0,4,.91,11.57,11.57,0,0,0,3-.45,16.72,16.72,0,0,0,2.42-.8ZM75,42.36a8.74,8.74,0,0,1-6.1,2.31,8.83,8.83,0,0,1-6.13-2.31,7.42,7.42,0,0,1,0-11.21,8.79,8.79,0,0,1,6.13-2.33A8.69,8.69,0,0,1,75,31.15a7.45,7.45,0,0,1,0,11.21Z"></path>
</svg>
</div>
</th>
<th class="sortable">
<div class="flex-container">
<p>Legacy ID</p>
<svg class="ni-tooltip" data-trigger="click" data-content="The issue ID from a legacy system referring to the same bug" data-placement="top" data-name="Layer 1" id="Layer_1" viewBox="0 0 128 128" xmlns="http://www.w3.org/2000/svg">
<defs>
<style>
                    .cls-1 {
                        fill: #aaa;
                        fill-rule: evenodd;
                    }
                </style>
</defs>
<path class="cls-1" d="M64,0a64,64,0,1,0,64,64A64,64,0,0,0,64,0ZM75.61,93.41q-4.36,1.69-7,2.57a18.73,18.73,0,0,1-6,.89c-3.52,0-6.26-.84-8.22-2.53a8.09,8.09,0,0,1-2.93-6.41,21,21,0,0,1,.22-3.09,34.68,34.68,0,0,1,.71-3.56L56,68.65q.5-1.82.83-3.44a15,15,0,0,0,.33-3,4.5,4.5,0,0,0-1-3.37c-.68-.63-2-.95-3.89-.95a10.31,10.31,0,0,0-2.9.43c-1,.29-1.83.56-2.54.82l1-3.89c2.39-.95,4.66-1.76,6.84-2.44a20.91,20.91,0,0,1,6.18-1c3.5,0,6.2.83,8.09,2.48a8.17,8.17,0,0,1,2.84,6.46c0,.55-.06,1.51-.19,2.89a19.92,19.92,0,0,1-.72,3.8L67.21,80.06c-.29,1-.55,2.16-.79,3.46a17.73,17.73,0,0,0-.36,2.94c0,1.67.38,2.81,1.15,3.41a6.52,6.52,0,0,0,4,.91,11.57,11.57,0,0,0,3-.45,16.72,16.72,0,0,0,2.42-.8ZM75,42.36a8.74,8.74,0,0,1-6.1,2.31,8.83,8.83,0,0,1-6.13-2.31,7.42,7.42,0,0,1,0-11.21,8.79,8.79,0,0,1,6.13-2.33A8.69,8.69,0,0,1,75,31.15a7.45,7.45,0,0,1,0,11.21Z"></path>
</svg>
</div>
</th>
<th class="minimum-width">
<div class="flex-container">
<p>Description</p>
<svg class="ni-tooltip" data-trigger="click" data-content="Information to help identify the issue and potential workarounds" data-placement="top" data-name="Layer 1" id="Layer_1" viewBox="0 0 128 128" xmlns="http://www.w3.org/2000/svg">
<defs>
<style>
                    .cls-1 {
                        fill: #aaa;
                        fill-rule: evenodd;
                    }
                </style>
</defs>
<path class="cls-1" d="M64,0a64,64,0,1,0,64,64A64,64,0,0,0,64,0ZM75.61,93.41q-4.36,1.69-7,2.57a18.73,18.73,0,0,1-6,.89c-3.52,0-6.26-.84-8.22-2.53a8.09,8.09,0,0,1-2.93-6.41,21,21,0,0,1,.22-3.09,34.68,34.68,0,0,1,.71-3.56L56,68.65q.5-1.82.83-3.44a15,15,0,0,0,.33-3,4.5,4.5,0,0,0-1-3.37c-.68-.63-2-.95-3.89-.95a10.31,10.31,0,0,0-2.9.43c-1,.29-1.83.56-2.54.82l1-3.89c2.39-.95,4.66-1.76,6.84-2.44a20.91,20.91,0,0,1,6.18-1c3.5,0,6.2.83,8.09,2.48a8.17,8.17,0,0,1,2.84,6.46c0,.55-.06,1.51-.19,2.89a19.92,19.92,0,0,1-.72,3.8L67.21,80.06c-.29,1-.55,2.16-.79,3.46a17.73,17.73,0,0,0-.36,2.94c0,1.67.38,2.81,1.15,3.41a6.52,6.52,0,0,0,4,.91,11.57,11.57,0,0,0,3-.45,16.72,16.72,0,0,0,2.42-.8ZM75,42.36a8.74,8.74,0,0,1-6.1,2.31,8.83,8.83,0,0,1-6.13-2.31,7.42,7.42,0,0,1,0-11.21,8.79,8.79,0,0,1,6.13-2.33A8.69,8.69,0,0,1,75,31.15a7.45,7.45,0,0,1,0,11.21Z"></path>
</svg>
</div>
</th>
<th class="sortable minimum-width">
<div class="flex-container">
<p>Details</p>
<svg class="ni-tooltip" data-trigger="click" data-content="Version in which the issue was discovered and resolved" data-placement="top" data-name="Layer 1" id="Layer_1" viewBox="0 0 128 128" xmlns="http://www.w3.org/2000/svg">
<defs>
<style>
                    .cls-1 {
                        fill: #aaa;
                        fill-rule: evenodd;
                    }
                </style>
</defs>
<path class="cls-1" d="M64,0a64,64,0,1,0,64,64A64,64,0,0,0,64,0ZM75.61,93.41q-4.36,1.69-7,2.57a18.73,18.73,0,0,1-6,.89c-3.52,0-6.26-.84-8.22-2.53a8.09,8.09,0,0,1-2.93-6.41,21,21,0,0,1,.22-3.09,34.68,34.68,0,0,1,.71-3.56L56,68.65q.5-1.82.83-3.44a15,15,0,0,0,.33-3,4.5,4.5,0,0,0-1-3.37c-.68-.63-2-.95-3.89-.95a10.31,10.31,0,0,0-2.9.43c-1,.29-1.83.56-2.54.82l1-3.89c2.39-.95,4.66-1.76,6.84-2.44a20.91,20.91,0,0,1,6.18-1c3.5,0,6.2.83,8.09,2.48a8.17,8.17,0,0,1,2.84,6.46c0,.55-.06,1.51-.19,2.89a19.92,19.92,0,0,1-.72,3.8L67.21,80.06c-.29,1-.55,2.16-.79,3.46a17.73,17.73,0,0,0-.36,2.94c0,1.67.38,2.81,1.15,3.41a6.52,6.52,0,0,0,4,.91,11.57,11.57,0,0,0,3-.45,16.72,16.72,0,0,0,2.42-.8ZM75,42.36a8.74,8.74,0,0,1-6.1,2.31,8.83,8.83,0,0,1-6.13-2.31,7.42,7.42,0,0,1,0-11.21,8.79,8.79,0,0,1,6.13-2.33A8.69,8.69,0,0,1,75,31.15a7.45,7.45,0,0,1,0,11.21Z"></path>
</svg>
</div>
</th>
</tr>
<tr>
<td class="align-top">197928</td>
<td class="align-top">726965</td>
<td class="align-top">
<h4 class="summary">Shipping Example Inspections return validation errors when opened under a Simulated Target.</h4>
<p class="margin-above"><p style="color: rgb(51,51,51);font-size: 16.0px;margin-bottom: 30.0px;margin-top: 0.0px;">Shipping Example Inspections return validation errors when opened under a Simulated Target.</p></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p><p style="color: rgb(51,51,51);font-size: 16.0px;margin-bottom: 30.0px;margin-top: 0.0px;">To fix the error, open the Read Image File Step and look at the relative path specified &quot;..\DemoImg\NameOfThePartInspected&quot;. Point the step to the following absolute path: </p><span style="background-color: rgb(244,244,244);color: rgb(51,51,51);display: inline;font-size: 16.0px;"></span><p style="color: rgb(51,51,51);font-size: 16.0px;margin-bottom: 30.0px;margin-top: 0.0px;">&quot;C:\Users\Public\Documents\National Instruments\Vision Builder AI 2018\DemoImg\NameOfThePartInspected&quot;</p></p>
</div>
</td>
<td class="align-top" data-added-date="1557464400">
<p class="details-black">Reported Version:</p>
<p class="details-grey">Vision Builder for Automated Inspection 2018 SP1</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">N/A</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">May 10, 2019</p>
</td>
</tr>
<tr>
<td class="align-top">460634</td>
<td class="align-top">380612</td>
<td class="align-top">
<h4 class="summary">Using a TCP slave device with the Vision Builder AI API and the main Vision Builder AI application simultaneously can cause the device to stop communicating.</h4>
<p class="margin-above"><span style="display: inline;color: rgb(51,51,51);font-family: &quot;Helvetica Neue&quot; , Helvetica , Arial , sans-serif;font-size: 16.0px;">Using a TCP slave device with the Vision Builder AI API and the main Vision Builder AI application simultaneously can cause the device to stop communicating.</span></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p>There is currently no known workaround for this issue.</p>
</div>
</td>
<td class="align-top" data-added-date="1360908000">
<p class="details-black">Reported Version:</p>
<p class="details-grey">Vision Builder for Automated Inspection 2012</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">N/A</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Feb 15, 2013</p>
</td>
</tr>
<tr>
<td class="align-top">462190</td>
<td class="align-top">199035</td>
<td class="align-top">
<h4 class="summary">If you configure a step to pass or fail based on pixel distances and subsequently calibrate the image, the step compares calibrated values against pixel-based limits.</h4>
<p class="margin-above"><span style="display: inline;background-color: rgb(244,244,244);color: rgb(51,51,51);font-family: &quot;Helvetica Neue&quot; , Helvetica , Arial , sans-serif;font-size: 16.0px;">If you configure a step to pass or fail based on pixel distances and subsequently calibrate the image, the step compares calibrated values against pixel-based limits.</span></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p>There is currently no known workaround for this issue.</p>
</div>
</td>
<td class="align-top" data-added-date="1313730000">
<p class="details-black">Reported Version:</p>
<p class="details-grey">Vision Builder for Automated Inspection 2009</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">N/A</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Aug 19, 2011</p>
</td>
</tr>
<tr>
<td class="align-top">463363</td>
<td class="align-top">194211</td>
<td class="align-top">
<h4 class="summary">If you lose connection and reconnect to a remote target after starting an inspection in the Vision Builder AI Configuration interface, the inspection reopens in the Vision Builder Inspection interface.</h4>
<p class="margin-above"><div><span>If you lose connection and reconnect to a remote target after starting an inspection in the Vision Builder AI Configuration interface, the inspection reopens in the Vision Builder Inspection interface.<br /></span><span></span><br /></div></p>
<div class="workaround-container margin-above">
<p class="align-top"><b>Workaround:</b></p>
<p>There is currently no known workaround for this issue.</p>
</div>
</td>
<td class="align-top" data-added-date="1313730000">
<p class="details-black">Reported Version:</p>
<p class="details-grey">Vision Builder for Automated Inspection 2009</p>
<p class="details-black margin-above">Resolved Version:</p>
<p class="details-grey">N/A</p>
<p class="details-black margin-above">Added:</p>
<p class="details-grey added">Aug 19, 2011</p>
</td>
</tr>
</tbody>
</table>
</span>
</div></div>
</div>
</div>
</div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-1x ni-padding-top-1x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="overview aem-GridColumn aem-GridColumn--default--12">
<div class="ni-padding-bottom-1x">
<div class="ni-padding-bottom-x">
<h2>Final Time Issue Listed</h2>
</div>
<div>
<div lang="en">
<p>Issues found in this section will not be listed in future known issues documents for this product.</p>
</div>
</div>
</div></div>
<div class="richtext parbase aem-GridColumn aem-GridColumn--default--12">
<div class=" ni-notransform   " lang="en">
<p>There are currently no issues to list.</p>
</div></div>
<div class="known-issues-table parbase aem-GridColumn aem-GridColumn--default--12">
<div class="cq-placeholder" data-emptytext="Known Issues Table"></div>
</div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-1x ni-padding-top-1x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="overview aem-GridColumn aem-GridColumn--default--12">
<div class="ni-padding-bottom-1x">
<div class="ni-padding-bottom-x">
<h2>Additional Resources</h2>
</div>
<div>
<div lang="en">
<p><b>Explore Support Content and Product Documentation </b></p>
<p> </p>
<ul>
<li><a href="http://www.ni.com/kb/">Search the NI KnowledgeBase for a solution</a></li>
<li><a href="https://www.ni.com/manuals/">Learn how to get started and use the product</a></li>
</ul>
<p> </p>
<p><b>Ask the NI Community</b></p>
<p> </p>
<ul>
<li><a href="https://forums.ni.com/t5/Discussion-Forums/ct-p/discussion-forums">Collaborate with other users in our discussion forums</a></li>
<li><a href="http://search.ni.com/nisearch/app/main/p/ap/tech/lang/en/pg/1/sn/catnav:df/">Search the NI Community for a solution</a></li>
</ul>
<p> </p>
<p><b>Request Support from an Engineer</b></p>
<p> </p>
<p>A valid service agreement may be required, and support options vary by country</p>
<p> </p>
<ul>
<li><a href="https://sine.ni.com/srm/app/newrequest">Open a service request</a></li>
<li><a href="http://www.ni.com/services/software/benefits/">Purchase or renew support services</a></li>
</ul>
</div>
</div>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div class="row clearfix">
<div class="container  ">
<div>
<div class="row">
<div class="shading-container ni-padding-bottom-1x  col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
</div></div>
</div>
</div>
</div>
</div></div>
<div class="shading-container parbase aem-GridColumn aem-GridColumn--default--12">
<div id="glossary" class=" clearfix">
<div class="row ni-lightgrey ">
<div class="container">
<div class="row">
<div class="shading-container ni-padding-bottom-4x ni-padding-top-x col-xs-12   ">
<div class="aem-Grid aem-Grid--12 aem-Grid--default--12 ">
<div class="richtext parbase aem-GridColumn aem-GridColumn--default--12">
<div lang="en">
<h3>Glossary of Terms</h3>
<p> </p>
<ul>
<li><b>Bug ID</b> - When an issue is reported to NI, you may be given this ID or find it on ni.com.  You may also find IDs posted by NI on the discussion forums or in KnowledgeBase articles.</li>
<li><b>Legacy ID</b> – An older issue ID that refers to the same issue.  You may instead find this issue ID in older known issues documents.</li>
<li><b>Description</b> - A few sentences which describe the problem. The brief description given does not necessarily describe the problem in full detail.</li>
<li><b>Workaround</b> - Possible ways to work around the problem.</li>
<li><b>Reported Version</b> - The earliest version in which the issue was reported.</li>
<li><b>Resolved Version</b> - Version in which the issue was resolved or was no longer applicable. &quot;N/A&quot; indicates that the issue has not been resolved.</li>
<li><b>Date Added</b> - The date the issue was added to the document (not the reported date).</li>
</ul>
</div></div>
</div></div>
</div>
</div>
</div>
</div></div>
</div></div>
</div></div>
</div>


<div class="container">
<div id="cookieLaw" style="display: none;">
<div class="row">
<div class="col-xs-12 col-sm-10">
<p>This site uses cookies to offer you a better browsing experience. Learn more about our <a href="https://www.ni.com/en-us/about-ni/legal/privacy-statement.html" target="_blank">privacy statement</a> and <a href="https://www.ni.com/en-us/about-ni/legal/cookies.html" target="_blank">cookie policy.</a></p>
</div>
<div class="col-xs-12 col-sm-2 text-right">
<button id="btnUnderstood" class="ni-btn ni-btn-tertiary" style="text-transform:none" type="button">Yes, I accept</button>
</div>
</div>
</div>
</div>
<a href="#" id="contactSalesBtn" class="hidden" rel="popover" data-popover-default="Contact sales" data-popover-close="Close" data-popover-content-desktop="#contactSalesDesktop" data-popover-content-mobile="#contactSalesMobile"></a>
<div id="contactSalesDesktop" class="hidden">
<form>
<div class="questions" data-offset-width="316">
<p>What would you like to do? We can help you get started.</p>
<a href="#" class="primaryBtn block slideNavigator" data-popver-nextslide="1">Contact our sales team</a>
<a href="//www.ni.com/en-us/support.html" class="outlineBtn block supportNavigator">Looking for support? </a>
</div>
<div id="contactSalesform" data-offset-width="572" class="hidden">
<h3>How can we help?</h3>
<div class="row">
<div class="col-xs-6">
<div class="form-group">
<input type="text" class="form-control" id="first_name" name="first_name" maxlength="40" placeholder="First name" data-validation-required required />
<div class="ni-validation-messages">
<div data-message="required">This field is required</div>
<span class="fa fa-times-circle"></span>
</div>
</div>
</div>
<div class="col-xs-6">
<div class="form-group">
<input type="text" class="form-control" id="last_name" name="last_name" maxlength="80" placeholder="Last name" data-validation-required required />
<div class="ni-validation-messages">
<div data-message="required">This field is required</div>
<span class="fa fa-times-circle"></span>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-6">
<div class="form-group">
<input type="email" class="form-control" id="email" maxlength="80" name="email" placeholder="Business email" data-validation-required required />
<div class="ni-validation-messages">
<div data-message="required">This field is required</div>
<span class="fa fa-times-circle"></span>
</div>
</div>
</div>
<div class="col-xs-6">
<div class="form-group">
<input type="text" class="form-control" id="company" maxlength="40" name="company" placeholder="Company name" />
</div>
</div>
</div>
<div class="row">
<div class="col-xs-6">
<div class="form-group">
<input type="text" class="form-control" id="phone" name="phone" placeholder="Phone number" data-validation-required required />
<div class="ni-validation-messages">
<div data-message="required">This field is required</div>
<span class="fa fa-times-circle"></span>
</div>
</div>
</div>
<div class="col-xs-6">
<div class="form-group">
<select class="form-control countrList" id="country" maxlength="40" name="country">
<option selected disabled value="">Country</option>
</select>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<textarea class="form-control" id="description" name="description" rows="5" placeholder="Message"></textarea>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-8">
<div class="form-group">
<label class="checkbox-inline">
Every company tells you they’re serious about privacy. We’re not just any company. Learn about the steps we take to protect your personal data. <a href="http://www.ni.com/privacy">Review our Privacy Statement</a>.
</label>
</div>
</div>
<div class="col-xs-4">
<input type="button" class="primaryBtn block slideNavigator formSubmitter" data-popver-nextslide="2" value="Send" />
</div>
<div class="col-xs-12">
<hr />
</div>
</div>
<div class="row">
<div class="col-xs-6">
<a href="#" class="slideNavigator prevSlide" data-popver-nextslide="0"><i class="fas fa-chevron-left"></i></a>
</div>
<div class="col-xs-6 text-right phone"><div class="ni-contact-sales-number"></div></div>
</div>
</div>
<div class="thanksSlide hidden text-center" data-offset-width="572">
<p class="thanks">Thanks!</p>
<p class="thanksMsg">We'll be in touch soon!</p>
<img src="//www.ni.com/content/dam/web/scene7/images/logo_2020_white.svg" alt="" />
</div>
<input type="hidden" name="oid" value="">
<input type="hidden" name="action" value="">
<input type="hidden" name="description_prefix" value="Customer requesting help via Contact Sales Team form on ni.com.">
<input type="hidden" name="Privacy_Policy_Acceptance_Reason__c" value="Customer entered contact data and requested a callback on www.ni.com/contact-sales form.">
<input type="hidden" name="lead_source" value="ni.com - Sales Form">
<input type="hidden" name="recordType" value="012i0000000xsPz">
<input type="hidden" name="00Ni000000FoVoC" value="Request a Callback">
<input type="hidden" name="00Ni000000FoVoB" value="cREQ Date">
</form>
</div>
<div id="contactSalesMobile" class="hidden">
<form>
<div class="questions" data-offset-width="316">
<p>What would you like to do? We can help you get started.</p>
<a href="#" class="primaryBtn block slideNavigator" data-popver-nextslide="1">Contact our sales team</a>
<a href="//www.ni.com/en-us/support.html" class="outlineBtn block supportNavigator">Looking for support? </a>
</div>
<div class="mobileForm1 hidden" data-offset-width="316">
<h3>How can we help?</h3>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<textarea class="form-control" id="description" name="description" rows="8" placeholder="Message"></textarea>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-8">
<a href="#" class="slideNavigator prevSlide pull-left" data-popver-nextslide="0"><i class="fas fa-chevron-left"></i></a>
<div class="text-center phone"><div class="ni-contact-sales-number"></div></div>
</div>
<div class="col-xs-4 text-right">
<a href="#" class="primaryBtn block slideNavigator" data-popver-nextslide="2">Next</a>
</div>
</div>
</div>
<div class="mobileForm2 hidden" data-offset-width="316">
<h3>How can we help?</h3>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<input type="text" class="form-control" id="first_name" name="first_name" maxlength="40" placeholder="First name" data-validation-required required />
<div class="ni-validation-messages">
<div data-message="required">This field is required</div>
<span class="fa fa-times-circle"></span>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<input type="text" class="form-control" id="last_name" name="last_name" maxlength="80" placeholder="Last name" data-validation-required required />
<div class="ni-validation-messages">
<div data-message="required">This field is required</div>
<span class="fa fa-times-circle"></span>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<input type="email" class="form-control" id="email" maxlength="80" name="email" placeholder="Business email" data-validation-required required />
<div class="ni-validation-messages">
<div data-message="required">This field is required</div>
<span class="fa fa-times-circle"></span>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<input type="text" class="form-control" id="company" maxlength="40" name="company" placeholder="Company name" />
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<input type="text" class="form-control" id="phone" name="phone" placeholder="Phone number" data-validation-required required />
<div class="ni-validation-messages">
<div data-message="required">This field is required</div>
<span class="fa fa-times-circle"></span>
</div>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<select class="form-control countrList" id="country" maxlength="40" name="country">
<option selected disabled value="">Country</option>
</select>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-12">
<div class="form-group">
<label class="checkbox-inline">
Every company tells you they’re serious about privacy. We’re not just any company. Learn about the steps we take to protect your personal data. <a href="http://www.ni.com/privacy">Review our Privacy Statement</a>.
</label>
</div>
</div>
</div>
<div class="row">
<div class="col-xs-8">
<div class="phone"><div class="ni-contact-sales-number"></div></div>
</div>
<div class="col-xs-4 text-right">
<input type="button" class="primaryBtn block slideNavigator formSubmitter" data-popver-nextslide="3" value="Send" />
</div>
</div>
</div>
<div class="thanksSlide hidden text-center" data-offset-width="316">
<p class="thanks">Thanks!</p>
<p class="thanksMsg">We'll be in touch soon!</p>
<img src="//www.ni.com/content/dam/web/scene7/images/logo_2020_white.svg" alt="" />
</div>
<input type="hidden" name="oid" value="">
<input type="hidden" name="action" value="">
<input type="hidden" name="description_prefix" value="Customer requesting help via Contact Sales Team form on ni.com.">
<input type="hidden" name="Privacy_Policy_Acceptance_Reason__c" value="Customer entered contact data and requested a callback on www.ni.com/contact-sales form.">
<input type="hidden" name="lead_source" value="ni.com - Sales Form">
<input type="hidden" name="recordType" value="012i0000000xsPz">
<input type="hidden" name="00Ni000000FoVoC" value="Request a Callback">
<input type="hidden" name="00Ni000000FoVoB" value="cREQ Date">
</form>
</div>
<footer class="ni-wrapper-footer footer noindex hidden-print">
<div class="container-fluid footer-header"></div>
<div class="flex-container">
<div class="container-fluid footer-body">
<div>
<div class="row">
<div class="col-md-3 col-xs-12">
<div class="logo-container">
<img src="//ni.scene7.com/is/image/nipreprod/logo_forrest" class="logo" alt="" width="71">
<div class="slogan">
Engineer
<span class="indented">Ambitiously.</span>
</div>
</div>
</div>
<div class="col-md-2 col-xs-12">
<div class="section-title">Solutions</div>
<ul class="section-links">
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/semiconductor.html">Semiconductor</a>
</li>
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/automotive.html">Automotive</a>
</li>
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/aerospace-defense.html">Aerospace, Defense, &amp; Government</a>
</li>
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/academic-research.html">Academic &amp; Research</a>
</li>
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/wireless.html">Wireless</a>
</li>
<li>
 <a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/electronics.html">Electronics</a>
</li>
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/energy.html">Energy</a>
</li>
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/industrial-machinery.html">Industrial Machinery</a>
</li>
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/innovations/transportation-and-heavy-equipment.html ">Heavy Equipment</a>
</li>
<li>
<a class="analytics-footersolutions-link" href="//www.ni.com/en-us/partners.html">Partners</a>
</li>
</ul>
</div>
<div class="col-md-2 col-xs-12">
<div class="section-title">Orders</div>
<ul class="section-links">
<li>
<a class="analytics-footerorders-link" href="//www.ni.com/status/">Order Status and History</a>
</li>
<li>
<a class="analytics-footerorders-link" href="//sine.ni.com/apps/utf8/nios.store?action=purchase_form">Order by Part Number</a>
</li>
<li>
<a class="analytics-footerorders-link" href="//sine.ni.com/myproducts/app/main.xhtml">Activate a Product</a>
</li>
<li>
<a class="analytics-footerorders-link" href="//sine.ni.com/apps/utf8/niwq.retrieve_quote">Retrieve a Quote</a>
</li>
<li>
<a class="analytics-footerorders-link" href="//www.ni.com/en-us/about-ni/legal/service-terms.html">Terms of Service</a>
</li>
</ul>
</div>
<div class="col-md-2 col-xs-12">
<div class="section-title">Company</div>
<ul class="section-links">
<li>
<a class="analytics-footercompany-link" href="//www.ni.com/en-us/about-ni/leadership.html/">Leadership</a>
</li>
<li>
<a class="analytics-footercompany-link" href="//www.ni.com/en-us/about-ni/careers.html">Careers</a>
</li>
<li>
<a class="analytics-footercompany-link" href="//investor.ni.com/">Investor Relations</a>
</li>
<li>
<a class="analytics-footercompany-link" href="//www.ni.com/en-us/about-ni/newsroom.html">Newsroom</a>
</li>
<li>
<a class="analytics-footercompany-link" href="//www.ni.com/en-us/about-ni/corporate-responsibility.html">Corporate Responsibility</a>
</li>
<li>
<a class="analytics-footercompany-link" href="//www.ni.com/en-us/about-ni/corporate-quality.html">Supply Chain &amp; Quality</a>
</li>
<li>
<a class="analytics-footercompany-link" href="//www.ni.com/en-us/events.html">Events</a>
</li>
</ul>
</div>
<div class="col-md-2 col-xs-12">
<div class="section-title">Support</div>
<ul class="section-links">

<li>
<a class="analytics-footersupport-link" id="downloads" href="//www.ni.com/en-us/support/downloads.html">Downloads</a>
</li>

<li>
<a class="analytics-footersupport-link" id="manuals" href="//www.ni.com/manuals/">Product Documentation</a>
</li>

<li>
<a class="analytics-footersupport-link" href="//forums.ni.com/t5/Discussion-Forums/ct-p/discussion-forums">Discussion Forums</a>
</li>

<li>
<a class="analytics-footersupport-link" href="//sine.ni.com/srm/app/getassistance">Submit a Service Request</a>
</li>

<li>
<a class="analytics-footersupport-link" id="site-feedback" href="#"></a>
</li>
</ul>
<div class="socialIcons">
<div class="col-xs-6 col-sm-8 bg-line hidden-md"></div>
<div class="text-left">
<a class="analytics-footer-link" href="//www.facebook.com/NationalInstruments/">
<i class="fab fa-facebook"></i>
</a>
<a class="analytics-footer-link" href="//twitter.com/NIglobal">
<i class="fab fa-twitter"></i>
</a>
<a class="analytics-footer-link" href="//www.linkedin.com/company/national-instruments/">
<i class="fab fa-linkedin"></i>
</a>
<a class="analytics-footer-link" href="//www.youtube.com/nationalinstruments">
<i class="fab fa-youtube"></i>
</a>
</div>
</div>
</div>
</div>
<div class="row footer-bottomLinks pull-left">
<div class="col-xs-12">
<div>
<a class="global-gateway analytics-footer-link pull-left" href="/global-gateway/"><img src="" alt="" width="21" /><span></span></a>
</div>
<div class="legal pull-left">
<a class="analytics-footer-link" href="//www.ni.com/en-us/about-ni/legal.html">LEGAL</a>&nbsp;|&nbsp;
<a class="analytics-footer-link" href="//www.ni.com/en-us/about-ni/legal/privacy-statement.html">PRIVACY</a>
</div>
<div class="allRights"> &copy; <span class="copyright"></span> NATIONAL INSTRUMENTS CORP. ALL RIGHTS RESERVED.</div>
<div class="ni-contact-number-container">
</div>
</div>
</div>
</div>
</div>
</footer>
</div>
</body>
</html>