Archived: Multimedia Test Products and Development Environments Compatibility

NI does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

Overview

This page shows supported versions of the NI Multimedia Test hardware driver,NI Video Measurement Suite (VMS, formerly VideoMASTER), NI Picture Quality Analysis (PQA), NI Analog Video Generator (AVG), NI Digital Video Generator (DVG), NI AudioMASTER, NI DigAudio, NI CEC Analyzer (CEC), or NI EDID Update Utility (EDID), with NI Development Environment systems. Reference this information to ensure you install the correct version when upgrading or updating your system or software. Using incompatible versions may result in errors, missing palettes or functions, or devices and tasks failing to show up in NI Measurement & Automation Explorer (MAX).

Note that this article replaces KnowledgeBase 5V5CUJOP: Multimedia Test Products Supported Development Environments. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

 

Media Test Products and Development Environments Compatibility

The table below shows the supported development environments for the current product versions.

Products with TestStand support install their own step types into TestStand that can be found on the Insertion palette. Products with LabVIEW support install a LabVIEW API (a set of VIs) for programming in LabVIEW that can be found under Multimedia Test on the Functions palette.

For development environments that are supported, each product will support only certain versions. To determine which versions of each development environment are supported, please review the readme for your version of the Multimedia Test product. Readme files can be found on your installation media or through the download pages linked below. Note that NI-DigAudio is installed with AudioMASTER. The NI CEC Analyzer and NI EDID Update Utility are installed with either PQA or VMS.

These products can also be installed to newer versions of the supported development environments, even where they are not officially supported. See the Related Links below for more information.

Note: NI Multimedia Test products do not offer support for 64-bit versions of TestStand and will not install step types for 64-bit TestStand. PQA 2014 added support for LabVIEW 64-bit, so if you would like to use PQA in 64-bit TestStand, you must use the PQA LabVIEW API and then call your LabVIEW VI from TestStand using the LabVIEW Adapter.

For other versions of PQA and other Multimedia Test products without 64-bit LabVIEW support, you can use the 32-bit LabVIEW APIs for those products and call the 32-bit VIs out-of-process in 64-bit TestStand. 

Use this table to compare NI Multimedia Test Products and Microsoft Windows Compatibility
Multimedia Test Product Microsoft Windows Version
Server 2008 R2 Server 2003 R2 10 8.1 8 7 Vista XP (32 bit) 2000
AVG 3.1            
AVG 3.0                
AVG 2.3.1              
DVG 1.1              
DVG 1.0.3              
AudioMASTER 6.3        
AudioMASTER 6.2              
AudioMASTER 6.1                
AudioMASTER 6.0              
PQA 2014      
PQA 1.6        
PQA 1.5          
PQA 1.0              
VMS 3.2          
VMS 3.1              
VideoMASTER 3.0                
VideoMASTER 2.2                
VideoMASTER 2.1              

Compatible

Requires Service Pack

Not Fully Tested or Recommended