NI-Industrial Communications for EtherCAT and LabVIEW Compatibility

Overview

This page shows supported versions of NI-Industrial Communications for EtherCAT and LabVIEW development systems. Reference this information to ensure you install the correct toolkit version when upgrading or updating your system or software. Using incompatible versions may result in errors, or missing LabVIEW palettes or functions.

Note that this article replaces KnowledgeBase 5YEF595R : NI-Industrial Communications for EtherCAT and LabVIEW Version Compatibility. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

NI-Industrial Communications for EtherCAT and LabVIEW Compatibility

 

Use this table to compare NI-Industrial Communications for EtherCAT and LabVIEW Compatibility
NI IndCom for EtherCAT LabVIEW Version
8.6.1 2009 2009 SP1 2010 2010 SP1 2011 2011 SP1 2012 2012 SP1 2013 2013 SP1 2014 2014 SP1 2015 2015 SP1 2016 2017 2017 SP1 2018 2018 SP1 2019
1.0.3                                        
1.1                                      
1.2                                      
2.0                                    
2.1                                    
2.2                                  
2.3                                  
2.4                                  
2.5                                  
2.6                                  
2.7                                  
14.0                                  
14.5                                  
15.0                                  
16.0                                  
16.1                                  
17.0                                  
17.6                                  
18.0                                  
18.5                                  
19.0                                  


Compatible Version


Note: It is always recommended to have the latest version of the driver, as this will include up-to-date support of new hardware and new versions of software.

Note: NI-RIO is a requirement for NI-Industrial Communications for EtherCAT, so NI-Industrial Communications for EtherCAT and LabVIEW compatibility is determined based on the NI-RIO version being used. Make sure consult the NI-RIO and LabVIEW compatibility page as well as the NI-Industrial Communications for EtherCAT and NI-RIO compatibility page.