From 9:00 AM - 12:00 PM CDT on Saturday, June 6th, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Archived: LabVIEW RT and FieldPoint Controllers Compatibility

National Instruments does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

Overview



This page shows supported versions of FieldPoint Controllers with LabVIEW Real-Time development systems. Reference this information to ensure you install the correct toolkit version when upgrading or updating your system or software. Using incompatible versions may result in errors, or missing LabVIEW palettes or functions.

Note that this article replaces KnowledgeBase 37F9DEXD: Software Installation Compatibility for FieldPoint Real-Time Controllers. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

Contents

LabVIEW RT and FieldPoint Controllers Compatibility

Use this table to compare LabVIEW RT and FieldPoint Controllers Compatibility
Driver LabVIEW RT
2010 2011 2012 2013 2013 SP1 2014 SP1 2015 2015 SP1
FieldPoint
FP VI Manager        
NI-VISA
NI-Serial
NI-Watchdog        
NI-IRDA                
Data Socket        
PID Toolkit        
Modbus I/O Server        
Variable Client Support          


Compatible Version


Legacy LabVIEW RT and FieldPoint Controllers Compatibility

Use this table to compare Legacy LabVIEW RT and FieldPoint Controllers Compatibility
Driver Legacy LabVIEW RT
6.1.1 6.1.3 7.0 7.1 8.0 8.2 8.5 8.5.1 8.6 8.6.1 2009
FieldPoint
FP VI Manager
NI-VISA    
NI-Serial
NI-Watchdog
NI-IRDA          
Data Socket      
PID Toolkit          
Modbus I/O Server          
Variable Client Support        

 

Compatible Version


If you have LabVIEW Real-Time 6.0 or 6.1 installed on the controller, NI recommends that you upgrade to version 6.1.3 or later.  Versions 6.1.3 and later are available on the FieldPoint 4.1 CD. For version 6.1.1 and earlier, contact NI.

LabVIEW Real-Time 7.1 or later requires MAX 3.1or later and must be installed using MAX.  Refer to the Using the LabVIEW Real-Time Software Wizard topic in the Remote Systems help.  To begin this Wizard, click the + next to the controller you wish to use under Remote Systems.  Then right-click Software and select Add/Remove Software.  This will initialize the LabVIEW Real-Time Software Wizard.