From 8:00 PM Friday, July 23 - 7:00 PM CDT Saturday, July 24, ni.com will be undergoing system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

LabVIEW NXG Patch Installation Instructions

Contents

Getting Started

NI Package Manager is required to install all LabVIEW NXG patches. Before beginning, please confirm that NI Package Manager is installed on the computer.

Important: Installation modification tools such as NI Update Service must be closed while performing the operations detailed below. This will ensure that the administrative lock required to run an installation is available to NI Package Manager.

 

Installing the Patch

 

For users who installed LabVIEW NXG from physical media

  1. Open NI Package Manager
  2. Go to the tab labeled "Available" or "Browse Products"
  3. Choose "LabVIEW NXG" from the category "Programming Environments" and select the option to Install
  4. Click "Next" without selecting new products to install
  5. After NI Package Manager has installed your feeds, it will say that there is no operation to be performed
  6. Choose to exit the dialog by clicking the X at the top left of the screen. Do not choose to go back or your feeds will be uninstalled
  7. Go to the tab labeled "Upgrades" and refresh if necessary
  8. Choose "LabVIEW NXG <Version>"
  9. Accept the agreements and install

 

For users who have not installed LabVIEW NXG

  1. Open NI Package Manager
  2. Go to the tab labeled "Available"
  3. Choose "LabVIEW NXG <Version>"
  4. Accept the agreements and install

Note: It is not necessary to install LabVIEW NXG 1.0 prior to installing the patched version.

 

Verifying the Patch Installed Successfully

In NI Package Manager

  1. Go to the installed tab and search for "LabVIEW NXG"
  2. Choose the entry for LabVIEW NXG 
  3. Verify that the version under the "Release Details" view is the version you expect (e.g., "1.0.1")

 

In the LabVIEW NXG Environment

  1. Open LabVIEW NXG
  2. Go to the About screen under Help >> About LabVIEW NXG
  3. Verify that the version is the version you expect (e.g., "1.0.1")