Table Of Contents

How to Add a Requirement to a Package that Another NI Application or Driver Is Installed

Last Modified: May 15, 2019

Typically, a package will require that one or more other NI applications or drivers be installed in order for the contents of the package to function properly. For example, a package that contains LabVIEW VIs will require that a specific version of the LabVIEW Runtime is installed. Packages ensure that the other application or driver is installed by specifying a dependency relationship on the package that installs the other application or driver.

To do this, select your package in the Packages pane and click the Add Dependency drop down in the toolbar and then select Show Additional Sources to display the Add Dependency dialog. Use the dialog to add a dependency relationship on the package for the NI application or driver that needs to be installed before your package. Note that the application or driver must be installed on the current system to appear in the list of installed packages.

Once a package is added as a dependency, you can configure what versions are required by selecting the package dependency in the Package pane and setting the Version and Constraint properties in the Properties pane. The Constraint property allows you to control how strict the version requirement is (e.g., you can set the package to depend on a specific version, or depend on any version higher than a specified version). By default, the version is set to use the currently installed version. If you set the Version Type property to Custom, you can specify a version manually.

When the package is built, it will not contain the dependent packages. Instead, it will give an error during installation if the dependent package is not already installed or being installed at the same time.

When building a package installer or repository that contains your package, the dependent packages will be included in the installer or repository automatically.


Recently Viewed Topics