Table Of Contents

Using NI SystemLink Tags to Exchange Data between FlexLogger and External Tools

Last Modified: September 27, 2021

Configure your system to use SystemLink tags with a FlexLogger project to exchange data. SystemLink tags transmit and store measurement data and are analogous to FlexLogger channels.

NI recommends setting the read data rate at 1 Hz when using SystemLink tags. For channels that require a faster read data rate, consider using the FlexLogger Plugin Development Kit to create a custom LabVIEW plugin for your project. Refer to Adding a Plugin to Your Project for more information.
spd-note-tip
Tip  

To publish data to a remote system, set up remote publishing.

Exchanging Data with Python

Use SystemLink tags to exchange data between FlexLogger and Python.

What to Use

The following FlexLogger and Python software versions are required to use SystemLink tags:
  • Python 3.5 or later
  • FlexLogger 2020 R3 or later

What to Do

  1. Install Python.
  2. Install FlexLogger.
  3. Configure NI Web Server for Simple Local Access. For more information, refer to Configuring NI Web Server on ni.com.

spd-note-note
Note  

To exchange data with Python, create and configure a FlexLogger project. For more information, refer to Components of a FlexLogger Project and Creating a New Project.

  1. In your configured FlexLogger project, navigate to Project»Settings and enable the options you want to use.
    Option Steps
    Exchange data locally Enable Publish channels as local tags and Consume local tags.
    Publish data remotely
    1. Enable Publish channels and files remotely.
    2. If you are using SystemLink Cloud, enter your SystemLink Cloud API key.

    After enabling these options for the first time, restart your project.

  2. Install and run the NI FlexLogger Examples for Python located on GitHub.
    spd-note-note
    Note  

    For more information about the examples, refer to the repository readme on GitHub.

Exchanging Data with LabVIEW

Use SystemLink tags to exchange data between FlexLogger and LabVIEW.

What to Use

The following FlexLogger and LabVIEW software versions are required to use SystemLink tags:
  • LabVIEW 2017 or later (64-bit recommended)
  • FlexLogger 2018 R4 or later

What to Do

  1. Install LabVIEW.
  2. Install FlexLogger and select NI SystemLink Tag Support for LabVIEW <version> from the Additional items you may wish to install dialog.
  3. If you have already installed FlexLogger, complete the following steps to add NI SystemLink tag support.
    1. Open NI Package Manager and click Installed.
    2. Locate FlexLogger <version> and click the Install or remove related packages gear.
    3. Select NI SystemLink Tag Support for LabVIEW <version> and click Next.
    4. Follow the instructions to complete installation.

spd-note-note
Note  

To exchange data with LabVIEW, create and configure a FlexLogger project. For more information, refer to Components of a FlexLogger Project and Creating a New Project.

  1. In your configured FlexLogger project, navigate to Project»Settings and enable the options you want to use.
    Option Steps
    Exchange data locally Enable Publish channels as local tags and Consume local tags.
    Publish data remotely
    1. Enable Publish channels and files remotely.
    2. If you are using SystemLink Cloud, enter your SystemLink Cloud API key.

    After enabling these options for the first time, restart your project.

  2. Navigate to Program Files»National Instruments»FlexLogger <versionExamples»SystemLink Integration to locate FlexLogger Tag Examples.lvproj. This LabVIEW project contains several example VIs. Use these VIs to get started with exchanging data using the SystemLink tags. The examples include VIs for sending I/O data points to FlexLogger, importing I/O from an existing FlexLogger project, or programmatically controlling output values in FlexLogger.

Setting Up Remote Publishing

Set up your local system to remotely publish channels and files to SystemLink.

Publish channels to remotely monitor a test using a dashboard or collect data and backup files for processing later. You can use a SystemLink Server or SystemLink Cloud.
  1. Install and configure the application you want to use.
    Option Steps
    SystemLink Cloud
    1. Install and configure SystemLink Cloud. For more information, refer to Getting Started with SystemLink Cloud.
    2. Activate your SystemLink Cloud account. For more information, refer to Activating Your SystemLink Cloud Account on ni.com.
    SystemLink Server
    1. Install and configure SystemLink on your computer (the host) and the remote system where FlexLogger will publish data (the client). For more information, refer to Installing and Configuring SystemLink Server and Clients on ni.com.
    2. Set up a SystemLink Sever on your computer. For more information, refer to Setting Up a SystemLink Server on ni.com.
      spd-note-note
      Note  

      Since FlexLogger supports only HTTPS connections, use the HTTPS port setting when you set up SystemLink Server.

    3. Set up a SystemLink Client on the remote system where your data will be published. For more information, refer to Setting Up a SystemLink Client for Windows Targets on ni.com.
  2. In FlexLogger, navigate to File»Preferences»Preview Features.
  3. In the SystemLink section, enable the options you want to use.
    Option Steps
    SystemLink Cloud Select Enables options for SystemLink Cloud in Project>>Settings.
    SystemLink Server Select Enables options for SystemLink Server in Project>>Settings.
  4. Restart FlexLogger.
After setting up remote publishing, FlexLogger has the Publish channels and files remotely option under Project»Settings.

Recently Viewed Topics