Table Of Contents

Software Requirements

Version:
    Last Modified: May 15, 2018

    • Install application software and device drivers appropriate to your hardware configuration. Refer to the following table for software applications and device drivers that are compatible with C Series Functional Safety modules.
    Table 1. C Series Functional Safety Software Compatibility
    NI 9350 NI 9351
    Functional Safety Editor 2017 or later Functional Safety Editor 2018 or later
    LabVIEW 2017 or later LabVIEW 2017 SP1 or later
    LabVIEW Real-Time Module 2017 or later LabVIEW Real-Time Module 2017 SP1 or later
    CompactRIO Device Drivers 17.0 or later CompactRIO Device Drivers 17.6 or later
    • You must download a compiled User Program to the C Series Functional Safety module. You can create a User Program using the NI Functional Safety Editor. To download the necessary software, go to ni.com/info and enter Info Code safetydownload.
    • You must have a computer running 64-bit Windows 7, Windows 8.1, or later to install and use the Functional Safety Editor. The application is not compatible with 32-bit Windows versions.
    • The LabVIEW Real-Time Module is only available in 32-bit. If you are using the LabVIEW Real-Time Module, you must download 32-bit application software and device drivers to a computer running a 64-bit operating system.
    • You must verify and formally document that your safety application is not affected by any documented known issue. For a complete list of resources for determining the known issues for your software and firmware, refer to the Finding Resources section of this manual.
    spd-note-note
    Note  

    For minimum software support information, visit ni.com/info and enter the Info Code swsupport.


    Recently Viewed Topics