Erläuterung des LabVIEW-Blockdiagramms

Überblick

In dieser Einführung in das Blockdiagramm untersuchen wir das Konzept dieses Werkzeugs und die Beziehung zwischen dem Blockdiagramm und dem Frontpanel. Außerdem erfahren Sie, wie Sie das Blockdiagramm öffnen, Objekte auf der Funktionenpalette suchen und in das Blockdiagramm einfügen und verschiedene Symbole aus der Symbolleiste verwenden. Darüber hinaus lernen Sie, wie Sie ein einfaches Blockdiagramm erstellen, mit dem die wichtigsten Prinzipien der Erstellung von grafischem Programmcode in NI LabVIEW veranschaulicht werden.

Das Blockdiagramm enthält den Quellcode eines LabVIEW-Programms. Das Prinzip des Blockdiagramms besteht darin, den grafischen Quellcode auf eine logische und einfache Weise von der Benutzeroberfläche zu trennen. Frontpanel-Objekte werden im Blockdiagramm als Symbole dargestellt Anschlüsse im Blockdiagramm zeigen die Änderungen an den dazugehörigen Frontpanel-Objekten an und umgekehrt.  

Blockdiagrammfenster

Wenn Sie ein neues VI erstellen oder öffnen, öffnet sich das Frontpanel automatisch. Um das Blockdiagramm aufzurufen, wählen Sie in der Menüleiste Fenster»Blockdiagramm anzeigen. Darüber hinaus können Sie durch Drücken der Tastenkombination<Strg+E> zwischen dem Blockdiagramm und dem Frontpanel wechseln.


Blockdiagrammobjekte und -umgebung

Zu den Blockdiagrammobjekten zählen Anschlüsse, SubVIs, Funktionen, Konstanten, Strukturen und Verbindungen, über die Daten zwischen den Blockdiagrammobjekten übertragen werden. Mit den LabVIEW-Werkzeugen können Sie VIs erstellen, bearbeiten und auf Fehler untersuchen. Ein Werkzeug ist die spezielle Betriebsart des Mauszeigers, sodass die Betriebsart dem Symbol des ausgewählten Werkzeugs entspricht LabVIEW entscheidet die Auswahl des Werkzeugs auf Grundlage der aktuellen Mausposition. Sie können das benötigte Werkzeug manuell auswählen, indem Sie es in der Werkzeugpalette auswählen (wählen Sie in der Menüleiste Ansicht»Werkzeugpalette). Jetzt können Sie Ihr gewünschtes Werkzeug auswählen, das ausgewählt bleibt, bis Sie ein anderes Werkzeug aus der Werkzeugpalette auswählen.

Um Objekte im Blockdiagramm zu platzieren, ziehen Sie sie einfach per Drag&Drop aus der Funktionenpalette. Die Funktionenpalette wird automatisch angezeigt, wenn Sie mit der rechten Maustaste auf eine beliebige Stelle im Arbeitsbereich des Blockdiagramms klicken. Sie enthält Funktionen, Konstanten, Strukturen und einige SubVIs.

Beachten Sie die beiden Schaltflächen oben in der Funktionenpalette.

         Der Reißnagel heftet die Funktionenpalette an das Blockdiagramm.

  Die Schaltfläche Suchen öffnet einen Suchdialog, in dem Sie Funktionen nach Namen suchen können.

Klicken Sie auf die Schaltfläche Suchen, um die Funktionen-Suchmaschine zu starten. Der Start dauert einen Augenblick.

Mit diesem Werkzeug können Sie eine Funktion nach ihrem Namen suchen, wenn Sie diese nicht finden.

Wenn Sie die gewünschte Funktion sehen, klicken Sie sie doppelt an und LabVIEW springt zu der Stelle auf der Funktionenpalette, an der Sie diese Funktion finden können.

Hinweis: Gehen Sie zum Ändern der auf der Funktionenpalette sichtbaren Unterpaletten wie folgt vor:

1.       Verbinden Sie die Funktionenpalette mit dem Blockdiagramm.

 

2.       Beachten Sie, dass die Schaltfläche Ansichtangezeigt wird, wenn Sie die Funktionenpalette an das Blockdiagramm anschließen.

3.       Wählen Sie Ansicht und anschließend Sichtbare Kategorien ändern aus dem Kontextmenü.

4.       Im Dialogfeld Sichtbare Kategorien ändern können Sie die Paletten auswählen, die am häufigsten verwendet werden, oder auf Alle auswählen klicken, um alle Paletten einzubeziehen.

Zum Ändern der Darstellung des Blockdiagramms wählen Sie Werkzeuge»Optionenaus der Menüleiste aus. Wählen Sie im Dialogfeld Optionen die Kategorie Blockdiagramm aus. Hier können Sie die Darstellung Ihres Blockdiagramms anpassen. Um Platz im Blockdiagramm zu sparen, deaktivieren Sie die Option Frontpanel-Elemente als Symbole darstellen.


Anschlüsse

Mit Anschlüssen wird die Darstellung von Frontpanel-Objekten im Blockdiagramm dargestellt. Zudem haben sie Ein- und Ausgänge, über die Daten zwischen dem Frontpanel und dem Blockdiagramm ausgetauscht werden. Ähnlich wie Parameter und Konstanten in befehlsorientierten Programmiersprachen gibt es Anschlüsse in zwei Typen: Bedien- und Anzeigeelementanschlüsse sowie Knotenanschlüsse. Die Anschlüsse der Bedien- und Anzeigeelemente gehören zu den jeweiligen Elementen auf dem Frontpanel.

In dem obigen Beispiel werden die Daten, die Sie in die Frontpanel-Elemente a und b eingeben, in das Blockdiagramm über ihre jeweiligen Steueranschlüsse a und b eingegeben. Anschließend passieren die Daten die Additions- und Subtraktionsfunktion. Wenn die Additions- und die Subtraktionsfunktion ihre Berechnungen abgeschlossen haben, erzeugen sie neue Werte. Die Datenwerte fließen zu den Anzeigeklemmen, wo sie die Frontpanel-Anzeigeelemente a+b und a-b aktualisieren.

Konstanten, Bedien- und Anzeigeelemente

Bedienelemente, Anzeigen und Konstanten fungieren als Eingänge und Ausgänge des Blockdiagrammalgorithmus. Bedienelemente empfangen ihre Werte vom Frontpanel und leiten Daten an andere Blockdiagrammobjekte weiter. Anzeigeelemente empfangen ihre Werte von der Logik des Blockdiagramms und leiten Daten vom Blockdiagramm an das Frontpanel weiter. Konstanten leiten Daten an das Objekt weiter, mit dem sie verbunden sind. Überlegen Sie sich, ob Sie einen Algorithmus zur Berechnung der Dreiecksfläche verwenden möchten. Sie haben möglicherweise das folgende Frontpanel und das dazugehörige Blockdiagramm.

Die KonstanteDreiecksfaktorwird nicht unbedingt auf dem Frontpanel angezeigt, außer möglicherweise als Dokumentation für den Algorithmus. Sie leitet einfach den Wert 0,5an die Multiplikationsfunktion weiter. Beachten Sie, dass die Blockdiagrammanschlüsse Basis (cm) und Höhe (cm) anders aussehen als der Anschluss Fläche(cm^2). Es gibt zwei wesentliche Unterschiede zwischen Anzeige- und Bedienelementen im Blockdiagramm. Der erste ist ein Pfeil am Anschluss, der die Richtung des Datenflusses anzeigt. Bei Bedienelementen zeigt der Pfeil an, dass die Daten den Anschluss verlassen, und bei Anzeigeelementen zeigt er an, dass die Daten in den Anschluss eingehen. Der zweite Unterschied sind die Ränder der Anschlüsse. Bedienelemente haben einen dicken Rand, Anzeigeelemente einen schmaleren.

Bedien- und Anzeigeelemente können entweder im Blockdiagramm oder auf dem Frontpanel erstellt werden. Diese Anleitung demonstriert dies in einem späteren Abschnitt.

Blockdiagrammknoten

Knoten sind Objekte im Blockdiagramm, die Ein- und/oder Ausgänge haben und Funktionen in einem laufenden VI ausführen. Knoten entsprechen Anweisungen, Operatoren, Funktionen und Unterprogrammen in befehlsorientierten Programmiersprachen. Knoten sind Funktionen, SubVIs oder Strukturen. Strukturen sind Prozesssteuerungselemente wie Case-Strukturen, For-Schleifen oder While-Schleifen, die in einer späteren Übung behandelt werden. In der folgenden Abbildung sehen Sie einige Beispiele für Blockdiagrammknoten.

 

 

Funktionen

Funktionen sind die grundlegenden Ausführungselemente in LabVIEW. Funktionen haben keine Frontpanel- oder Blockdiagrammfenster, haben aber Eingangs- und Ausgangsanschlüsse für den Datenaustausch ähnlich wie Bedien- und Anzeigeelemente. Ob ein Blockdiagrammobjekt eine Funktion ist, lässt sich am hellgelben Hintergrund des Symbols feststellen. Die Funktionenpalette enthält Funktionen, die in Gruppen angeordnet sind, basierend auf der Art der Funktion, die sie ausführen. Sehen Sie sich die Unterpalette Numerisch nach Funktionen an, die numerische Operationen durchführen.

 

Es gibt viele verschiedene Arten von Funktionen. Denken Sie daran, dass eine Funktion einen blassgelben Hintergrund hat, wie die unten dargestellten Funktionen.   

SubVIs

SubVIs sind VIs, die zur Verwendung in einem anderen VI erstellt wurden oder bereits auf der Funktionenpalette enthalten sind. Jedes VI ist als SubVI verwendbar. Wenn Sie doppelt auf ein SubVI im Blockdiagramm klicken, wird das Frontpanel des SubVIs angezeigt und Sie können auf das Blockdiagramm zugreifen. Nachfolgend finden Sie einige Beispiele für die SubVIs der Funktionenpalette.

Strukturen

Strukturen, die For-Schleifen, Case-Strukturen und While-Schleifen umfassen, werden zur Prozesssteuerung verwendet. Diese werden in einer späteren Anleitung behandelt. Sie können die Unterpalette Strukturen aus der Funktionenpalette unter Programmierung öffnen.

Nachfolgend finden Sie einige Beispiele für verschiedene Strukturen und deren Darstellung im Blockdiagramm.

Erstellen Sie nun das unten dargestellte Blockdiagramm. Gehen Sie dazu wie folgt vor:

1.       Öffnen Sie ein leeres VI von der Symbolleiste aus. Wählen Sie Datei»Neues VI.

2.       Fügen Sie zwei Multiplikationsfunktionen in das Blockdiagramm ein, indem Sie sie von der Unterpalette Numerisch unter Programmierung in das Blockdiagramm ziehen. Wiederholen Sie den Vorgang, um eine zweite Multiplikationsfunktion in das Blockdiagramm einzufügen.

Tipp: Zum Kopieren eines Objekts im Blockdiagramm halten Sie die <Strg>-Taste gedrückt, während Sie das Objekt anklicken und ziehen.

3.       Bewegen Sie den Mauszeiger über die Funktion ganz links, so dass die Ein- und Ausgangsanschlüsse angezeigt werden. Wenn Sie den Mauszeiger über einen der Anschlüsse bewegen, wird die Leitungsspule zusammen mit dem Namen des Anschlusses angezeigt, über den Sie den Mauszeiger bewegen.

Um ein Bedienelement für deny-Anschluss zu erstellen, bewegen Sie den Mauszeiger über das Element und klicken Sie mit der rechten Maustaste auf das Element.

Machen Sie das Gleiche für denx-Anschluss der Multiplikationsfunktion links, so dass für jeden Eingangsanschluss ein Bedienelement vorhanden ist.

4.       Verbinden Sie den Ausgangsanschluss der linken Multiplikationsfunktion mit dem x-Eingang der rechten Multiplikationsfunktion, indem Sie den Mauszeiger über den Ausgangsanschluss bewegen. Wenn er sich in die Leitungsspule verwandelt, klicken Sie bei gedrückter Maustaste auf den gewünschten Eingang.

5.       Erstellen Sie die Dreiecksfaktor-Konstante 0,5, indem Sie mit der rechten Maustaste auf den y-Eingangsanschluss der Multiplikationsfunktion klicken und Erstellen»Konstante auswählen. Sie können den Wert einer Konstante ändern, indem Sie die Konstante doppelt anklicken, um den Text hervorzuheben und den neuen Wert eingeben. Geben Sie 0,5 ein und drücken Sie die <Eingabe>-Taste.

  

6.       Klicken Sie nun mit der rechten Maustaste auf den Ausgang der rechten Multiplikationsfunktion und wählen Sie Erstellen»Anzeigeelement, um ein Anzeigeelement zu erstellen, das den Wert der Blockdiagrammlogik an das Frontpanel übergibt.

Tipp: Zum Einfügen von Kommentaren im Blockdiagramm oder auf dem Frontpanel klicken Sie das Blockdiagramm doppelt an und geben Sie den Kommentar in das automatisch erstellte Textfeld ein.

Sie können die Namen von Anzeigeelementen, Bedienelementen und Konstanten ändern, indem Sie die Beschriftung doppelt anklicken und den gewünschten Namen eingeben. Wenn keine Beschriftung angezeigt wird, klicken Sie mit der rechten Maustaste auf das gewünschte Objekt und wählen Sie Sichtbare Objekte»Beschriftung.

7.       Sehen Sie sich nun das Frontpanel an, das durch Ihre Arbeit am Blockdiagramm erzeugt wurde, indem Sie <Strg+E> drücken oder Fenster»Frontpanel anzeigen auswählen. Beachten Sie, dass die beiden Bedienelemente Basis(cm) und Höhe(cm) und das Anzeigeelement Fläche(cm^2) automatisch erzeugt und auf dem Frontpanel platziert wurden. Sie starten dieses Programm, nachdem Sie sich mit den Symbolen der Symbolleiste vertraut gemacht haben.  

 

Symbolleiste des Blockdiagramms

Wenn Sie ein VI ausführen, wird die folgende Symbolleiste im Blockdiagramm angezeigt. Mit Hilfe der Schaltflächen in der Blockdiagramm-Symbolleiste können Sie das VI auf Fehler untersuchen. Diese Schaltflächen werden in einer späteren Anleitung behandelt.

        Klicken Sie auf die Schaltfläche Ausführen, um Ihr VI auszuführen. Sie müssen Ihren Programmcode nicht kompilieren, denn LabVIEW kompiliert ihn automatisch. Sie können ein VI ausführen, wenn die Schaltfläche Ausführen als durchgehender weißer Pfeil (links) angezeigt wird.

        Die Schaltfläche Ausführen wird als fehlerhaft angezeigt, wenn das VI, das Sie erstellen oder bearbeiten, Fehler enthält. Wenn die Schaltfläche Ausführen nach dem Verdrahten des Blockdiagramms immer noch defekt erscheint, ist das VI defekt und kann nicht ausgeführt werden. Beim Anklicken dieser Schaltfläche wird eine Fehlerliste mit allen Fehlern und Warnungen angezeigt.  

        Klicken Sie auf Wiederholt ausführen, um das VI auszuführen, bis Sie die Ausführung abbrechen oder anhalten. Beim erneuten Anklicken dieser Schaltfläche wird die wiederholte Ausführung deaktiviert.

        Während das VI ausgeführt wird, wird die Schaltfläche Ausführung abbrechen angezeigt. Klicken Sie auf diese Schaltfläche, um das VI sofort anzuhalten, sofern es keine andere Möglichkeit zum Abbrechen gibt. Wenn das VI von mehreren laufenden VIs verwendet wird, ist die Schaltfläche ausgegraut.

Achtung: Die Schaltfläche Ausführung abbrechen stoppt das VI unmittelbar, auch vor Beenden der aktuellen Iteration. Bei VIs mit externen Ressourcen (z. B. angeschlossenen Geräten) können die Ressourcen beim Abbrechen einen undefinierten Zustand annehmen, wenn sie nicht zurückgesetzt oder ordnungsgemäß freigegeben werden. Zur Vermeidung dieses Problems sollten VIs immer eine Stopp-Schaltfläche haben.

        Klicken Sie auf Pause, um ein laufendes VI anzuhalten. Wenn Sie auf die Schaltfläche Pause klicken, markiert LabVIEW die Stelle im Blockdiagramm, an der die Ausführung angehalten wurde, und die Schaltfläche Pause wird rot dargestellt. Beim erneuten Anklicken der Schaltfläche Pause wird die VI-Ausführung fortgesetzt.

  Wählen Sie das Pulldown-Menü Texteinstellungen, um die Schrifteinstellungen für die ausgewählten Teile Ihres VI zu ändern, einschließlich Größe, Schriftstil und Farbe.

    Klicken Sie auf das Pulldown-Menü Objekte ausrichten, um Objekte entlang der Achsen auszurichten, etwa vertikal, an einer Begrenzungslinie und links.  

    Klicken Sie auf das Pulldown-Menü Objekte anordnen, um die Größe mehrerer Frontpanel-Objekte auf dieselbe Größe zu ändern.

    Klicken Sie auf das Pulldown-Menü Neu ordnen, wenn sich Ihre Objekte überlappen und Sie definieren möchten, welches Objekt vor oder hinter einem anderen liegt. Wählen Sie eines der Objekte mit dem Positionierwerkzeug aus und wählen Sie dann zwischen Um eins nach vorn, Um eins nach hinten, Nach vorn und Nach hinten.  

        Klicken Sie auf die Schaltfläche Kontexthilfe anzeigen, um die Anzeige der Kontexthilfefenster zu ein-/auszublenden.

        Texteingabe wird angezeigt, um Sie daran zu erinnern, dass ein neuer Wert verfügbar ist, um einen alten Wert zu ersetzen. Die Schaltfläche Texteingabe verschwindet, wenn Sie darauf klicken, die Taste <Eingabe> drücken oder auf den Frontpanel- oder Blockdiagramm-Arbeitsbereich klicken.

Ausführen eines VIs vom Blockdiagramm aus

Klicken Sie abschließend auf die Schaltfläche Wiederholt ausführen im soeben erstellten VI und ändern Sie die Werte auf dem Frontpanel. Beobachten Sie, wie das Ändern der Kontrollwerte von a und b den Anzeigeelementwert von a*b aktualisiert.

 

Die Werte, die in die Bedienelemente auf der Vorderseite eingefügt wurden, werden an das Blockdiagramm weitergeleitet, und das Ergebnis, das durch die Blockdiagramm-Logik berechnet wird, wird an das Frontpanel-Anzeigeelement weitergeleitet.

Beenden Sie das VI über die Schaltfläche Ausführung abbrechen. Speichern und schließen Sie das VI, indem Sie Datei»Speichern aus der Menüleiste auswählen und anschließend auf die Schaltfläche Schließen in der rechten oberen Ecke des Frontpanels klicken.

Das Blockdiagramm ist der grundlegende Aspekt jedes virtuellen Instruments. Es steuert alles vom Datenfluss bis hin zum Datenaustausch mit dem Frontpanel.  Für einen LabVIEW-Programmierer ist es entscheidend, ein klares und solides Verständnis von der Funktionsweise des Blockdiagramms zu haben.

 


Video           Die LabVIEW-Umgebung          Startseite Module          FIRST-Gruppe