Archiviert: Kompatibilität von NI-Produkten mit Microsoft Windows 8

NI does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

Überblick

Im folgenden Dokument finden Sie die unterstützten NI-Softwareversionen für Windows 8. Die Tabellen enthalten verfügbare Software, Treiber, Zusatzpakete und Toolkits sowie deren mindestens erforderliche Versionen für Windows 8.

Inhalt

Wodurch unterscheiden sich die 32-Bit- und 64-Bit-Versionen von Windows 8?

Windows 8 (32 Bit) kann sowohl mit x86- als auch x64-Hardware ausgeführt werden. Ähnlich wie bei Windows XP bietet die 32-Bit-Version von Windows 8 lediglich Zugriff auf 32-Bit-Adressen. Deshalb ist Windows 8 (32 Bit) selbst beim Ausführen auf x64-Hardware auf 4 GB RAM beschränkt. 64-Bit-Treiber und -Software, die von Haus aus für 64-Bit-Betriebssysteme entwickelt wurden, können nicht unter der 32-Bit-Version von Windows 8 ausgeführt werden.

Windows 8 (64 Bit) kann nur auf x64-Hardware installiert werden. Diese Version des Betriebssystems ermöglicht Software den Zugriff auf Hardware über 64-Bit-Adressen. Dadurch kann auf wesentlich größere Speicherbereiche zugegriffen werden.  Um erfolgreich unter Windows 8 (64-Bit) zu laufen, müssen alle Treiber über native 64-Bit-Unterstützung verfügen. Die meisten 32-Bit-Softwareanwendungen können auf Windows 8 jedoch in einer 64-Bit-Emulationsschicht ausgeführt werden.

Detaillierte Informationen zu Unterschieden zwischen der 32-Bit- und der 64-Bit-Version von Windows finden Sie im Tutorial Einsatz von NI-Produkten mit 32-Bit- und 64-Bit-Windows-Betriebssystemen.

Known Compatibility Issues

Probleme mit der Schnellstartfunktion

NI empfiehlt seinen Kunden dringend, die Schnellstartfunktion zu deaktivieren.

Reparieren von NI-Software nach einem Upgrade

Das Reparieren von NI-Software nach dem Upgrade von Windows 8 auf Windows 8.1 kann zum Verlust von Zugriff auf Hardware führen, die mit reparierten Treibern verknüpft ist. Führen Sie eine zweite Reparatur an den betroffenen NI-Gerätetreibern durch, um diese in einen ausführbaren Zustand zurückzuversetzen.

Software

Die folgenden Softwarepakete von NI sind mit den nachstehend aufgeführten 32- und 64-bit-Versionen von Windows 8 kompatibel. Ab 2013 wird für die neuen Versionen aller Produkte von NI die Kompatibilität mit Windows 8 in der Readme-Datei des jeweiligen Produkts dokumentiert. Antworten auf alle Fragen zur Kompatibilität einer Softwareanwendung mit den 64-Bit-Versionen von Windows und LabVIEW erhalten Sie in der Readme-Datei für die entsprechende Produktversion.

Hinweis: In der Tabellenspalte „Windows 8 (64 Bit) (mit 32-Bit-Software)“ finden Sie die erste Version der jeweiligen 32-Bit-Software, die innerhalb der Emulationsschicht „Windows on Windows“ (WOW64) ausgeführt werden kann.

NI-Software-Kompatibilität mit Windows 8 32-Bit und 64-Bit
NISoftware Windows 8 (32 Bit) Windows 8 (64 Bit) Windows 8 (64 Bit)
(mit 32-Bit-Software) (mit 64-Bit-Software)
GPIB-Serial Converter Software 19.0 Nicht zutreffend 19.0
InsightCM Server Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Analog Video Generator 3.1 3.1 Nicht unterstützt
NI Analog Waveform Editor 1.2.1 1.2.1 Nicht unterstützt
NI AudioMASTER Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Automated Test Software Suite NIWeek 2016 NIWeek 2016 NIWeek 2016
NI-Builder für Batch-Installationsprogramme 1.0 1.0 Nicht unterstützt
NI Calibration Executive 3.5 – 5.0 3.5 6.0
NI Calibration Executive für Traditional DAQ Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Developer Suite NIWeek 2010 NIWeek 2010 NIWeek 2010
NI DIAdem 2012 SP1 2012 SP1 2015
NI Digital Video Generator Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Digital Waveform Editor 3.0 3.0 Nicht unterstützt
NI FlexLogger Nicht zutreffend Nicht zutreffend 2018 R2
NI Functional Safety Editor Nicht unterstützt Nicht unterstützt Sept. 17
NI-I/O-Trace1 3.0.2 3.0.2 3.0.2
NI InstrumentStudio Nicht zutreffend Nicht zutreffend 2018
NI LabVIEW (32 Bit) 2012 2012 Nicht unterstützt
NI LabVIEW (64 Bit) Nicht unterstützt 2012 2012
NI LabVIEW Communications System Design Software Nicht unterstützt Nicht unterstützt 1.0
NI LabVIEW Communications System Design Suite Nicht unterstützt Nicht unterstützt 1.0
NI LabVIEW Education Edition 2012 2012 Nicht unterstützt
NI LabVIEW für LEGO® MINDSTORMS 2012 2012 Nicht unterstützt
NI LabVIEW NXG Nicht unterstützt Nicht unterstützt 1.0
NI LabVIEW Run-Time Engine (32 Bit) 2009 SP1 2009 SP1 Nicht unterstützt
NI LabVIEW Run-Time Engine (64 Bit) Nicht unterstützt 2009 SP1 2009 SP1
NI LabVIEW SignalExpress 2012 2012 Nicht unterstützt
NI LabVIEW Student Edition NIWeek 2010 NIWeek 2010 NIWeek 2010
NI LabWindows/CVI 2012 2012 2012
NI LabWindows/CVI Run-Time Engine 2012 2012 2012
NI Lookout 6.7 6.7 Nicht unterstützt
NI MATRIXx Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Measurement and Automation Explorer 5.3.3 5.3.3 Nicht unterstützt
NI Measurement Studio 2012 2012 2012
NI Multisim 13.0 13.0 Nicht unterstützt
NI Package Builder 19.0 19.0 19.0
NI-Paketmanager 19.0 19.0 17.0
NI Picture Quality Analysis (PQA) 1.6 1.6 Nicht unterstützt
NI Real-Time Hypervisor Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Requirements Gateway 2012 2012 Nicht unterstützt
NI-Software für FRC 2013 2013 2013
NI Software Platform Bundle NIWeek 2010 NIWeek 2010 NIWeek 2010
NI Switch Executive 3.6 3.6 2015
NI SystemLink Client Nicht zutreffend Nicht zutreffend 17.0
NI SystemLink Server Nicht zutreffend Nicht zutreffend 17.0
NI Test Integration Adapter for IBM Rational Quality Manager 2.0 2.0 Nicht unterstützt
NI TestStand 2012 2012 2014
NI Ultiboard 13.0 13.0 Nicht unterstützt
NI-Update-Dienst 15.0 15.0 17.0
NI VeriStand 2011 SP1 – 2018 SP1 2011 SP1 – 2018 SP1 2019
NI Video Measurement Suite (VMS) Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Vision Builder for Automated Inspection 2012 2012 2014 SP1
NI-Volumenlizenzmanager 3.0 3.0 Nicht unterstützt

1 NI Spy wurde ab Version 3.0 in „NI-I/O-Trace“ umbenannt

Zusatzpakete und Toolkits

Folgende Zusatzpakete und Toolkits von NI sind mit den aufgeführten Versionen von Windows 8 (32 Bit) und Windows 8 (64 Bit) kompatibel:

Hinweis: In der Tabellenspalte „Windows 8 (64 Bit) (mit 32-Bit-Software)“ finden Sie die erste Version der jeweiligen 32-Bit-Software, die innerhalb der Emulationsschicht „Windows on Windows“ (WOW64) ausgeführt werden kann.

Kompatibilität der Zusatzpakete und Toolkits mit Windows 8 32-Bit und 64-Bit
Zusatzpakete und Toolkits von NI Windows 8 (32 Bit) Windows 8 (64 Bit) Windows 8 (64 Bit)
(mit 32-Bit-Software) (mit 64-Bit-Software)
FlexLogger Plugin Development Kit Nicht zutreffend Nicht zutreffend 1.0
NI Automotive Diagnostic Command Set 1.1.1 1.1.1 15.0.0
NI Bluetooth Toolkit 1.1 1.1 14.0
NI Combustion Analysis System Software 2013 2013 Nicht unterstützt
NI ECU Measurement and Calibration Toolkit 2.2.1 2.2.1 15.0.0
NI FM/RDS Measurement Suite 1.0 1.0 Nicht unterstützt
NI GNSS Measurement Suite 3.0 3.0 Nicht unterstützt
NI GPS Simulation Toolkit 2.0.1 2.0.1 Nicht unterstützt
NI GSM-EDGE Toolkit 1.1 1.1 Nicht unterstützt
NI InsightCM SDK 2.0 2.0 Nicht unterstützt
NI LabVIEW Adaptive Filter Toolkit 2012 2012 Nicht unterstützt
NI LabVIEW Advanced Signal Processing Toolkit 2012 2012 2018
NI LabVIEW Analytics and Machine Learning Toolkit 2017 2017 2018
NI LabVIEW Application Builder 2012 2012 2012
NI LabVIEW Biomedical Toolkit 2012 2012 Nicht unterstützt
NI LabVIEW C Generator Toolkit 2011 2011 Nicht unterstützt
NI LabVIEW Communications MIMO Application Framework Nicht unterstützt Nicht unterstützt 1.0
NI LabVIEW Control Design and Simulation Module 2012 2012 2016
NI LabVIEW Database Connectivity Toolkit 2012 2012 2019
NILabVIEW DataFinder Toolkit 2012 2012 Nicht unterstützt
NI LabVIEW Datalogging and Supervisory Control Module 2013 2013 Nicht unterstützt
NI LabVIEW Desktop Execution Trace Toolkit 2012 2012 2016
NI LabVIEW Digital Filter Design Toolkit 2012 2012 2018
NI LabVIEW Electrical Power Toolkit 2011 2011 Nicht unterstützt
NI LabVIEW Embedded für ARM Module 2012 2012 Nicht unterstützt
NI LabVIEW for Wireless Sensor Networks Module 2012 2012 Nicht unterstützt
NI LabVIEW FPGA Module 15.01 15.01 Nicht unterstützt
NI LabVIEW FPGA Xilinx ISE Nicht unterstützt1 Nicht unterstützt1 Nicht unterstützt
NI LabVIEW FPGA Xilinx Vivado Nicht unterstützt1 Nicht unterstützt1 Nicht unterstützt
NI LabVIEW GPS Modulation Toolkit 2.0.1 2.0.1 Nicht unterstützt
NI LabVIEW Internet Toolkit Nicht getestet2 Nicht getestet2 Nicht unterstützt
NI LabVIEW Jitter Analysis Toolkit 2012 2012 Nicht unterstützt
NI LabVIEW LEGO® MINDSTORMS® NXT Module 2012 2012 Nicht unterstützt
NI LabVIEW MathScript RT Module 2012 2012 2016
NI LabVIEW Mobile Module 2011 SP1 2011 SP1 Nicht unterstützt
NI LabVIEW Modulation Toolkit 4.3.3 4.3.3 4.3.3
NI LabVIEW Multicore Analysis and Sparse Matrix Toolkit 2012 2012 2012
NI LabVIEW myRIO Toolkit 2013 2013 Nicht unterstützt
NI LabVIEW OPC UA Toolkit 2017 2017 2018
NI LabVIEW PID and Fuzzy Logic Toolkit 2012 2012 Nicht unterstützt
NI LabVIEW Real-Time Execution Trace Toolkit 2.0.5 2.0.5 Nicht unterstützt
NI LabVIEW Real-Time Module 2012 SP1 2012 SP1 Nicht unterstützt
NI LabVIEW Report Generation for Microsoft Office Toolkit 2013 2013 20143
NI LabVIEW roboRIO Toolkit 2015 2015 Nicht unterstützt
NI LabVIEW Robotics Module 2012 2012 Nicht unterstützt
NI LabVIEW Simulation Interface Toolkit 2012 2012 Nicht unterstützt
NI LabVIEW SoftMotion Module 2012 2012 Nicht unterstützt
NI LabVIEW Statechart Module 2012 2012 Nicht unterstützt
NI LabVIEW System Identification Toolkit 2012 2012 Nicht unterstützt
NI LabVIEW Touch Panel Module 2012 2012 Nicht unterstützt
NI LabVIEW Unit Test Framework 2012 2012 2016
NI LabVIEW VI Analyzer Toolkit 2012 2012 2016
NI LabWindows/CVI Execution Profiler 1.0 1.0 1.0
NI LabWindows/CVI Modulation Toolkit 4.1 4.1 Nicht unterstützt
NI LabWindows/CVI PID Control Toolkit 2.1 2.1 2.1
NI LabWindows/CVI Real-Time Module 2012 2012 Nicht unterstützt
NI LabWindows/CVI Signal Processing Toolkit 7.0.2 7.0.2 Nicht unterstützt
NI LabWindows/CVI Spectral Measurements Toolkit 2.6.3 2.6.3 2.6.3
NI LabWindows/CVI SQL Toolkit 2.2 2.2 2.2
NI-Lizenzmanager 3.7 3.7 3.7
NI LTE Measurement Suite 2.0.1 2.0.1 Nicht unterstützt
NI Measurement Suite für Fixed WiMAX 1.0 1.0 Nicht unterstützt
NI Measurement Suite für Mobile WiMAX 1.0.1 1.0.1 Nicht unterstützt
NI Motion Assistant 2.8 2.8 Nicht unterstützt
NI-OPC-Server 2013 2013 Nicht unterstützt
NI Picture Quality Analysis 1.5 1.5 Nicht unterstützt
NI-RFFastACP 1.0.0 1.0.0 1.0.0
NI-RFPM Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI RM-RDS Toolkit 1.0.1 1.0.1 Nicht unterstützt
NI Software Calibration Management Toolkit 2013 2013 Nicht unterstützt
NI Sound and Vibration Measurement Suite 2012 2012 2012 (ohne Konfiguration des Express-VIs)
NI Spectral Measurements Toolkit 2.6.3 2.6.3 2.6.3
NI SystemLink Server - Test Module Nicht zutreffend Nicht zutreffend 18.0
NI TDMS 2.4.0 2.4.0 2.4.0
NI TestStand ATML Toolkit 2013 2013 2017
NI TestStand Semiconductor Module 2012 2012 2014
NI Vision Development Module 2012 2012 2012
NI Vision Development Module Run-Time 2012 2012 2012
NI-VRTS Nicht zutreffend 1.5 1.5
NI WCDMA/HSPA Measurement Suite 1.0.1 1.0.1 Nicht unterstützt
NI Wireless Test Module 1.0.1 1.0.1 Nicht unterstützt
NI WLAN Toolkit 3.0 3.0 14.0
RFIC-Testsoftware Nicht unterstützt 3.0 3.0
Zusatzpaket zur Steuerung von Halbleitergeräten für InstrumentStudio Nicht zutreffend Nicht zutreffend 2019
Third Party Licensing & Activation Toolkit 2012 2012 2012
VCSEL I-V-Testsoftware Nicht unterstützt Nicht unterstützt Nicht unterstützt

 

1 Das LabVIEW FPGA Module wird teilweise unter Windows 8 unterstützt. Sämtliche Funktionen, die eine lokale Installation der Xilinx-Werkzeuge erfordern, werden nicht unterstützt. Das liegt daran, dass die vom LabVIEW FPGA-Modul verwendeten Xilinx-Werkzeuge offiziell keine Unterstützung für Windows 8 bieten.

2 Der Funktionsumfang des veralteten LabVIEW Internet Toolkits ist ab August 2012 in LabVIEW integriert.

3 Das LabVIEW Report Generation Toolkit für Microsoft Office bietet keine Unterstützung unter Windows 8, wird aber unter Windows 8.1 unterstützt.

Hardwaretreiber

Die folgenden Hardwaretreiber von NI sind mit den hier aufgeführten Versionen von Windows 8 (32 Bit) und Windows 8 (64 Bit) kompatibel.

Hinweis: In der Tabellenspalte „Windows 8 (64 Bit) (mit 32-Bit-Software)“ finden Sie die erste Version der jeweiligen 32-Bit-Software, die innerhalb der Emulationsschicht „Windows on Windows“ (WOW64) ausgeführt werden kann.

NI-Hardwaretreiber-Kompatibilität mit Windows 8 32-Bit und 64-Bit
NI-Treiber Windows 8 (32 Bit) Windows 8 (64 Bit) Windows 8 (64 Bit)
(mit 32-Bit-Software) (mit 64-Bit-Software)
NI-435X Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI-488.2 3.1 3.1 3.1
NI-5640R 1.7 1.7 Nicht unterstützt
NI-568x 1.1 1.1 1.2
NI-5690 1.1 1.1 Nicht unterstützt
NI-845x 2.1 2.1 2.1
NI-CAN 2.7.4 2.7.4 Nicht unterstützt
Gerätetreiber für NI CompactRIO August 2015​ August 2015​ August 2015​
NI-DAQmx 8.9.5 8.9.5 8.9.5
NI-DAQmx Base 3.4 3.4 Nicht unterstützt
NI-DCPower 1.7.5 1.7.5 1.7.5
NI-Digital Pattern Driver Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI-DMM 3.0.6 3.0.6 3.0.6
NI-DNET Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI ELVISmx 4.4 4.4 Nicht unterstützt
NI-Embedded CAN für sbRIO Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI-FBUS 4.1.1 4.1.1 Nicht unterstützt
NI-FGEN 2.9.1 2.9.1 2.9.1
NI-FieldPoint 6.0.11 6.0.11 Nicht unterstützt
NI FlexRIO 12.0 12.0 12.0
NI-HSDIO 2.0 2.0 2.0
NI-IMAQ 4.7 4.7 4.7
NI-IMAQ I/O 2.6 2.6 2.6.1
NI-IMAQdx 4.0 4.0 4.0
NI-Industrial Communications für 60870-5 1.1 1.1 Nicht unterstützt
NI-Industrial Communications für 61850 2.0 2.0 Nicht unterstützt
NI-Industrial Communications für CANopen 1.0.3 1.0.3 Nicht unterstützt
NI-Industrial Communications für DeviceNet 2.2 2.2 Nicht unterstützt
NI-Industrial Communications für DNP3 2.0 2.0 Nicht unterstützt
NI-Industrial Communications für EtherCAT 16.0 16.0 Nicht unterstützt
NI-Industrial Communications für EtherNet/IP 1.2.1 1.2.1 1.2.1
Gerätetreiber für NI-Industrie-Controller 15.5 15.5 15.5
NI IVI Compliance Package 4.6 4.6 4.6
NI-Motion 8.4 8.4 Nicht unterstützt
NI-OSI 1 2.1 Nicht unterstützt
NI-PAL 2.9.1 2.9.1 2.9.1
NI PXI Platform Services 3.2 3.2 3.2
NI PXI-5660 1.7.2 Nicht unterstützt Nicht unterstützt
NI PXIe-5644R/5645R/5646R Instrument Design Libraries 1.1 1.1 Nicht unterstützt
NI-PXIe-659x Instrument Design Libraries 14.0 14.0 14.0
NI-PXImc 1.0 1.0 1.0
NI-RFmx Demod 1.0 1.0 1.0
NI-RFmx SpecAn 1.0 1.0 1.0
NI-RFSA 2.6 2.6 2.6
NI-RFSG 1.8.5 1.8.5 1.8.5
NI-RIO 12.0 12.0 12.0
Gerätetreiber für Multifunktionsmodule der R-Serie von NI mit rekonfigurierbarer I/O August 2014​ August 2014​ August 2014​
NI-Scope 3.9.7 3.9.7 3.9.7
NI-Serial 3.9 3.9 3.91
NI-SLSC 1.0 1.0 1.0
NI-SWITCH 4.6.1 4.6.1 4.6.1
NI Sync 3.3.5 3.3.5 3.3.5
NI System Configuration 5.3.3 5.3.3 5.3.3
NI-TimeSync 1.1.5 1.1.5 Nicht unterstützt
NI-USRP 1.3 1.3 14.0
NI-VirtualBench 1.0 1.0 1.0
NI-VISA 5,2 5,2 5,2
NI Vision Acquisition Software August 2012 August 2012 August 2012
NI-VNA 2.0 2.0 2.0
NI-VXI Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI-WSN 1.5 1.5 Nicht unterstützt
NI-XNET 1.6 1.6 14.0