Semiconductor Device Control Add-On for InstrumentStudio 2021 Known Issues

Überblick

This document contains the Semiconductor Device Control Add-On for InstrumentStudio known issues that were discovered before and since the release of Semiconductor Device Control Add-On for InstrumentStudio 2021. Known issues are performance issues or technical bugs that NI has acknowledged exist within this version of the product.

 

Not every issue known to NI appears on this list; it is intended to show the most severe and common issues that you may encounter and provide workarounds when possible. Other technical issues that you may encounter could occur through normal product use or system compatibility issues. You may find more information on these issues in NI’s Product Documentation, Knowledgebase, or Community.

Bug Number

Legacy ID

Description

Details

520

Register view page loads slowly for large register maps

If a large register map is loaded (for example, 1000 registers under the same IP block), the application becomes slow when loading and displaying the register details. As the number of registers increases, the application continues to slow down further.

Workaround:

The register view displays information one IP block at a time, so the slowness in rendering is due to large number of registers in a IP block. Avoid this by splitting the registers across different IP blocks, thus limiting the number of registers displayed at once.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

658

Register view page loads slowly after communicating with several registers in the same session

When device communication runs for a long time through either the UI or API (monitoring), the register view page loading time slows by few seconds.

Workaround:

The device activity log gets filled with transactions when the device communication runs for a long time. Avoid this by clearing the device activity using the Clear Log button.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

589

Clicking the "Read all registers and fields" button in the small panel doesn't read all register and field details across all IP blocks

Performing a Read all operation in the small panel reads registers and fields from only one IP block. It does not read all the registers and fields from all IP blocks.

Workaround:

This behavior is similar to the behavior in the large panel, where Read all will read only the selected IP block registers in large panel. Use the large panel and select the required IP block to read all registers and fields at once for all IP blocks.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

672

The Semiconductor Device Control Add-On does not resize smoothly at lower screen resolutions

When resizing InstrumentStudio on a monitor with a lower screen resolution, the Semiconductor Device Control Add-On becomes hidden and horizontal and vertical scroll bars are enabled.

Workaround:

NI recommends using a 920x1080 screen resolution and setting your Scale and Layout Windows setting to100%. For monitors with lower resolution, use the scroll bar to access different areas of the UI.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

558

Monitor and control operation for the Semiconductor Device Control Add-On doesn't work on my machine

When a user tries to take control of a device session in InstrumentStudio or in one of the APIs, the device is unresponsive.

Workaround:

This happens when the port used by the Semiconductor Device Control Add-On for control and monitor is used by another application. In this case, ensure no other application is using the same port. The default port is 5001.

You can change the port number for the Semi Device Control Add-On by modifying the control-monitor-port field in the configuration file at C:\Program Files\National Instruments\Semi Device Control\ ConfigInfo.json. Change the port number in the file and restart the application. This file will be replaced by future software updates, so this approach is only recommended if the default port cannot be opened.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

570

The control feature does not respond when at a breakpoint in Visual Studio

The Semiconductor Device Control Add-On in InstrumentStudio Control Mode feature does not respond when at a breakpoint in Visual Studio. Control Mode capability doesn't work when the .NET API is used in the Visual Studio IDE.  Monitoring functionality works as expected and the control capability works when the breakpoint is removed or Visual Studio program is running.

Workaround:

Setting a breakpoint in a Visual Studio application will break all running threads. User should break the main thread and resume the control thread in the Visual Studio. To achieve this, after hitting the breakpoint in Visual Studio, follow these steps:

1. In the Visual Studio IDE, navigate to  Debug > Windows > Threads
2. Find the “Main Thread”, right click > freeze
3. Press F5 / continue to let the other threads execute

This will run all threads except the main thread and allow control capability from InstrumentStudio.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

673

The Semiconductor Device Control Add-On is not visible under the layout creation window

The Semiconductor Device Control Add-On is not visible under the layout creation window when a user starts InstrumentStudio. Package Manager shows the Semi Device Control Add-On and InstrumentStudio packages are installed. 

Workaround:

The Semiconductor Device Control Add-On will be visible under layout creation when the software is properly installed and you've selected the Enable hosted applications setting in InstrumentStudio . This setting is enabled by default for InstrumentStudio on the active user login but is not automatically enabled for the following scenarios:
  1. New user logs in Windows
  2. The preference is manually overridden
  3. InstrumentStudio is open during Semi Device Control installation
To enable the hosted application feature in InstrumentStudio, navigate to File > Preference > Hosted application and select the Enable Hosted Application checkbox.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

665

Traditional Chinese characters cannot be used as inputs in the Semiconductor Device Control Add-On

On Windows operation systems with the Traditional Chinese language pack, users can input characters into the user interface, but the strings cannot be used or saved by the Semiconductor Device control Add-On.

Workaround:

The Semiconductor Device Control Add-On does not support the Windows Traditional Chinese language pack. To work around this, temporarily user can use the English keyboard settings to input characters.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

664

Messages are not logged properly when two InstrumentStudio projects with the Semiconductor Device Control Add-On run simultaneously

When two InstrumentStudio instances with the Semiconductor Device Control Add-On are open and running, only one instance of the application logs the error message of both instances, and the other doesn't.

Workaround:

Using two instances of the Semiconductor Device Control Add-On simultaneously is not supported.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Nov 5, 2020

587

The Semiconductor Device Control Add-On small panel does not load when InstrumentStudio is started

The Semiconductor Device Control Add-On small panel does not load when InstrumentStudio is started. Clicking Try Again when the InstrumentStudio project contains a large panel does not solve this issue. That's because the large panel has not been loaded into memory yet before the InstrumentStudio project opens on a small panel.

Workaround:

  1. Navigate to the large panel in InstrumentStudio to load the large panel into memory.
  2. Navigate back to the small panel and then click Try Again.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2019

Resolved Version:

N/A

Added:

Oct 25, 2021

831

Execute Script API does not throw an error as expected when the Wait Until Complete? parameter is set to False

When the Wait Until Complete? parameter is set to False, a script will run asynchronously in parallel and any errors occurred will be logged to the application logs. Therefore, the Execute Script API does not throw an error as expected. 

Workaround:

Use the Get Logs API, located at <National Instruments>\LabVIEW 20xx\instr.lib\Semi Device Control\Utils, to obtain the error information. NI recommends you validate the script in InstrumentStudio before running it.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2021

Resolved Version:

N/A

Added:

Oct 25, 2021

835

An unexpected error occurs when InstrumentStudio runs a script immediately after aborting an executing script

When running a new script immediately after aborting an executing script, InstrumentStudio throws an error indicating that a script is already running. This error occurs randomly due to the race condition when users run and abort scripts fast and repeatedly. If the Plugin has not completed the script aborting procedure before running a new script, an error will be thrown. 

Workaround:

Wait to run a new script until the script aborting procedure is complete.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2021

Resolved Version:

N/A

Added:

Oct 25, 2021

828, 829, and 838

Not all commands are logged to the Device Activity section when using the Executing Script API

This is expected behavior and mostly happens for short test programs that execute only a few commands. The Execute Script API was designed to begin execution before it connects with InstrumentStudio so that the Execute Script API can run faster to take more expedient tests. 

Workaround:

There is currently no known workaround for this issue.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2021

Resolved Version:

N/A

Added:

Oct 25, 2021

1057

Dynamic settings can be configured before communication starts when using the Semiconductor Device Control APIs

When using the Semiconductor Device Control panels in InstrumentStudio, users can configure the dynamic settings only after the communication starts. When using the Semiconductor Device Control APIs to automate configuration, users can configure the dynamic settings before the communication starts, which causes unexpected test results. 

Workaround:

Use the Instantiate API and Start API to create and start a semiconductor device control session and then configure the dynamic settings.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2021

Resolved Version:

N/A

Added:

Oct 25, 2021

1059

Sequences cannot load Execute Script and Execute Script Command steps from projects created using a previous version of the Semiconductor Device Control APIs

When opening a sequence that was created using a previous version of the Semiconductor Device Control APIs, the sequence reports that it cannot load steps that use custom step types of the Execute Script and the Execute Script Command because the prototype does not match the member found.

Workaround:

Reload the prototype in TestStand by performing one of the following procedures:
  1. Clicking the exclamation point next to the .NET invocation. 
  2. Clicking the Reload Assemblies and Prototypes button. 

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2021

Resolved Version:

N/A

Added:

Oct 25, 2021

1072

Demo files from previous versions are removed after installing the Semiconductor Device Control Add-On 2021 for InstrumentStudio

Any InstrumentStudio project or SDC configuration (.sdcconfig) files that reference demo files in C:\Users\Public\Documents\National Instruments\Semi Device Control (64-bit) will refer to invalid files because the installer removes these upon update. 

Workaround:

These files are replaced by the new installer. The way to fix this to to update the paths with the following steps:
  1. Open the project created using the previous version.
  2. Update the project locations of the register map and script file.

Reported Version:

Semiconductor Device Control Add-On for InstrumentStudio: 2021

Resolved Version:

N/A

Added:

Oct 25, 2021

Final Time Issue Listed

Issues found in this section will not be listed in future known issues documents for this product.

There are currently no issues to list.

Additional Resources

Explore Support Content and Product Documentation 

 

 

Ask the NI Community

 

 

Request Support from an Engineer

 

A valid service agreement may be required, and support options vary by country

 

Glossary of Terms

 

  • Bug ID - When an issue is reported to NI, you may be given this ID or find it on ni.com.  You may also find IDs posted by NI on the discussion forums or in KnowledgeBase articles.
  • Legacy ID – An older issue ID that refers to the same issue.  You may instead find this issue ID in older known issues documents.
  • Description - A few sentences which describe the problem. The brief description given does not necessarily describe the problem in full detail.
  • Workaround - Possible ways to work around the problem.
  • Reported Version - The earliest version in which the issue was reported.
  • Resolved Version - Version in which the issue was resolved or was no longer applicable. "N/A" indicates that the issue has not been resolved.
  • Date Added - The date the issue was added to the document (not the reported date).