Aktualisieren oder Wiederherstellen eines VIs aus einer anderen LabVIEW-Version


Ich möchte ein VI, das in einer Version von LabVIEW erstellt wurde, in einer anderen Version von LabVIEW öffnen.  In manchen Fällen erhalte ich den Fehler 1126 (0x466): Die VI-Version ist zu alt und kann nicht in die aktuelle LabVIEW-Version umgewandelt werden.

Wie kann ich mein VI aktualisieren oder wiederherstellen?


Die Antwort hängt von der zum Speichern des VIs verwendeten LabVIEW-Version ab, sowie von der Version von LabVIEW, die Sie zum Öffnen des VIs verwenden. Die folgende Tabelle listet alle möglichen Szenarien auf.

 

 LabVIEW-Konvertierungskit erforderlich
 Zwischenversion zur Konvertierung erforderlich
 Konvertierungskit und Zwischenversion erforderlich
 VI erfolgreich geöffnet
 Speichern in Vorgängerversion verfügbar
 Mehrere Versionen für die Wiederherstellung erforderlich

Es gibt sechs mögliche Szenarien:

 LabVIEW-Konvertierungskit erforderlich

Um ein VI aus LabVIEW 3.x oder älteren Versionen zu laden, müssen Sie das LabVIEW-VI-Konvertierungskit verwenden.  Dies ist kostenlos bei National Instruments erhältlich. Die Teilenummer dieses Kits für Windows und Macintosh lautet 776874-03.

VIs von UNIX müssen auf einen Mac oder PC übertragen werden, auf dem das VI in LabVIEW 4.0 konvertiert und anschließend wieder nach UNIX übertragen werden kann. Das LabVIEW-VI-Konvertierungskit ist nicht im Online-Katalog verfügbar. Wenden Sie sich direkt an die Vertriebsabteilung von National Instruments, um das Konvertierungskit kostenfrei anzufordern.

Das Konvertieren von VIs ist ein mehrstufiger Prozess, bei dem VIs in einer Version von LabVIEW massenkompiliert werden.  Sowohl LabVIEW 3.1.1 als auch LabVIEW 4.0.1 sind auf der CD des LabVIEW-VI-Konvertierungskits für PC und Mac verfügbar. Sie können beide Versionen direkt von der CD ausführen.

Da sich viele VIs im Laufe der Zeit geändert haben, müssen Sie unter Umständen einige der VIs im Code manuell ersetzen.

   Zwischenversion für die Konvertierung erforderlich

Um ein mit älteren Versionen als LabVIEW 6 erstelltes VI in LabVIEW 8.5 oder neuer zu öffnen, müssen Sie das VI in eine beliebige LabVIEW-Version zwischen 6 und 8.2 konvertieren.  National Instruments empfiehlt ein Upgrade auf LabVIEW 8.2.1, da es sich um die LabVIEW-Version handelt, die der aktuellen Version am nächsten kommt. Kunden, die am Standard Service Program (SSP) teilnehmen, können ältere Versionen von LabVIEW über das myNI-Konto herunterladen.

Wenn Sie nur einige wenige VIs aktualisieren möchten, öffnen Sie die zu aktualisierenden VIs in LabVIEW 8.2.1 und speichern Sie die Dateien.  Mit "Datei»Alle speichern" können Sie alle geöffneten VIs speichern.  Wenn Sie viele Dateien aktualisieren möchten, können Sie die Massenkompilierungsfunktion in LabVIEW verwenden. Es kann eine einzelne Datei oder ein gesamtes Verzeichnis für die Massenkompilierung ausgewählt werden. Die Elemente werden in der neuen Version geöffnet, gespeichert und anschließend geschlossen. Wählen Sie zur Massenkompilierung Ihrer VIs "Werkzeuge»Fortgeschritten»Massenkompilierung" aus. Weitere Informationen zur Massenkompilierung finden Sie in der Hilfe zu LabVIEW 2017 unter Dialogfeld "Massenkompilierung".

 Konvertierungskit und Zwischenversion erforderlich

Um ein VI von LabVIEW 2.x oder 3.x auf die Version 8.5 oder neuer zu aktualisieren, werden sowohl das Konvertierungskit als auch eine Zwischenversion benötigt. Befolgen Sie die oben für das Konvertierungskit beschriebenen Schritte, um das VI von LabVIEW 2.x oder 3.x auf LabVIEW 4.0.1 zu aktualisieren. Gehen Sie dann nach den für die Zwischenversion beschriebenen Schritten vor, um das VI von LabVIEW 4.0.1 auf Version 8.5 oder neuer zu aktualisieren.

  VI erfolgreich geöffnet

Das VI kann mit der neueren Version von LabVIEW geöffnet werden. Es wird jedoch nicht garantiert, dass das VI ohne vorherige Bearbeitung ordnungsgemäß ausgeführt werden kann. Weitere Informationen finden Sie in den Hinweisen zum Upgrade für die Version von LabVIEW, auf die Sie ein Upgrade durchführen möchten.

  Speichern in Vorgängerversion verfügbar

Das VI kann für eine frühere Version von LabVIEW gespeichert werden.  Gehen Sie in LabVIEW 8 oder neueren Versionen zu "Datei»Für vorige Version speichern". Wählen Sie in LabVIEW 7 oder älteren Versionen "Datei»Mit Optionen speichern" und dann "Für vorige Version" aus.

Beim Wiederherstellen von LabVIEW-Code für ältere Versionen müssen viele Faktoren berücksichtigt werden.  Weitere Informationen finden Sie auf der Seite Revert LabVIEW Files to a Previous Version.

 Mehrere Versionen für die Wiederherstellung erforderlich

Ihre Zielversion ist nicht direkt von Ihrer derzeitigen Version aus verfügbar. Sie benötigen mehrere Versionen von LabVIEW für die Wiederherstellung.  Um beispielsweise ein VI aus LabVIEW 8.6 nach LabVIEW 7.1 zu verschieben, müssen Sie es zuerst in LabVIEW 8.0 speichern.  In Tabelle 1 finden Sie die LabVIEW-Versionen, die zum Wiederherstellen Ihrer VIs erforderlich sind.

 

Links auf thematisch verwandte Seiten