Kompatibilität von NI-DAQmx und Microsoft Windows

Überblick

Auf dieser Seite werden die von verschiedenen Versionen von Betriebssystemen von Microsoft Windows unterstützten Versionen des Hardwaretreibers NI-DAQmx aufgelistet. Lesen Sie diese Angaben, um sicherzustellen, dass Sie die korrekte Version der Software installieren, wenn Sie Ihr Betriebssystem aktualisieren oder Ihren Programmcode auf ein neues System übertragen. Bei Verwendung von inkompatiblen Softwareversionen, können Fehler auftreten. Windows kann möglicherweise den Treiber für Ihr Gerät nicht erkennen und demzufolge nicht danach suchen oder Geräte werden nicht ordnungsgemäß im Windows-Gerätemanager oder im NI Measurement & Automation Explorer (MAX) angezeigt.

Dieses Dokument ersetzt den KnowledgeBase-Artikel 6HQ994XC: Kompatibilität unterschiedlicher Versionen von Windows und NI-DAQmx. In manchen NI-Dokumenten wird möglicherweise noch das veraltete Dokument erwähnt. Wenn Sie von der URL des veralteten Dokuments auf diese Seite weitergeleitet wurden, aktualisieren Sie bitte Ihre Bookmarks.

Inhalt

Tabelle zur Kompatibilität von NI-DAQmx und verschiedenen Versionen von Desktop-Betriebssystemen von Microsoft Windows

Sie sollten nicht nur die Kompatibilität des Betriebssystems, sondern auch die der Anwendung berücksichtigen, mit welcher der DAQmx-Treiber verwendet werden soll. Weitere Informationen erhalten Sie im Abschnitt "Weitere Informationen" und Angaben zur Kompatibilität für spezifische Geräte finden Sie in der "Readme zu NI-DAQmx".

 

Mit Hilfe dieser Tabelle können Sie verschiedene Versionen von NI-DAQmx mit kompatiblen Versionen des Windows-Desktop-Betriebssystems vergleichen.
NI‑DAQmx Microsoft Windows - Desktop Versions
XP1 Vista2 7 8 8.1 10
9.5.5            
9.6            
9.6.1            
9.6.2            
9.7            
9.7.5            
9.8            
9.9            
14.0            
14.1            
14.2            
14.5            
14.5.1            
15.0            
15.0.1            
15.1            
15.1.1            
15.5            
15.5.1            
16.0            
16.1            
17.0            
17.1            
17.1.1            
17.5            
17.6            
18.0            
18.1            
18.5            
18.6            
1 nur 32-bit
2 nur Business Edition

Für Service Pack (SP)-Anforderungen finden Sie in den folgenden:

  • Windows XP: SP3 oder höher
  • Windows Vista: SP1 oder höher
  • Windows 7: SP1 oder höher


  Kompatible Version
  Service Pack erforderlich


Angaben zur Kompatibilität von älteren Versionen von NI-DAQmx und Windows finden Sie im Dokument "DAQmx Windows Compatibility Table" im Abschnitt Downloads dieses Dokuments.


Tabelle zur Kompatibilität von NI-DAQmx und verschiedenen Versionen von Server-Betriebssystemen von Microsoft Windows

Mit Hilfe dieser Tabelle können Sie verschiedene Versionen von NI-DAQmx mit kompatiblen Versionen des Windows-Server-Betriebssystems vergleichen.
NI‑DAQmx Microsoft Windows - Server Editions
2003 R21 2008 R22 2012 R22
9.5.5      
9.6      
9.6.1      
9.6.2      
9.7      
9.7.5      
9.8      
9.9      
14.0      
14.1      
14.2      
14.5      
14.5.1      
15.0      
15.0.1      
15.1      
15.1.1      
15.5      
15.5.1      
16.0      
16.1      
17.0      
17.1      
17.1.1      
17.5      
17.6      
18.0      
18.1      
18.5      
18.6      
1 nur 32-bit
2 nur 64-bit

Für Service Pack (SP)-Anforderungen finden Sie in den folgenden:

  • Windows Server 2003 R2: SP2 oder höher
  • Windows Server 2008 R2: SP1 oder höher


  Kompatible Version
  Service Pack erforderlich


Angaben zur Kompatibilität von älteren Versionen von NI-DAQmx und Windows finden Sie im Dokument "DAQmx Windows Compatibility Table" im Abschnitt Downloads dieses Dokuments.


Unterstützung für Windows Embedded Standard (WES) 7

Manche Compact-Controller von National Instruments werden mit einer von NI angepassten Version von WES 7 (einschließlich aller Softwarepakete zur Ausführung von NI-Treibern und -Software) geliefert. Dies ist die einzige Version von WES 7, die von NI-DAQmx unterstützt wird. Andere Versionen von WES werden von National Instruments nicht unterstützt.


Downloads

Requirements

 

Software

Driver: NI-DAQmx 16.0