Kompatibilität von NI-Produkten mit Microsoft Windows 10

Überblick

Microsoft Windows 10 ist die neueste Version des Betriebssystems Windows. Windows 10 unterscheidet sich sehr stark von vorherigen Windows-Versionen. Funktionen von Windows 7 und 8 wurden in Windows 10 miteinander kombiniert. Darüber hinaus wartet das Betriebssystem mit vielen neuen Funktionen auf. Erfahren Sie anhand der nachfolgend aufgeführten Ressourcen, wie sich Windows 10 auf die Arbeit von Ingenieuren und Wissenschaftlern auswirkt und ob sich die neue Version für Ihre Anforderungen eignet. Lernen Sie zudem bewährte Vorgehensweisen für die Entwicklung technischer und wissenschaftlicher Anwendungen mit Windows 10 kennen.

Inhalt

Migration vorhandener Anwendungen auf Windows 10

Vorhandene Anwendungen unter Windows 7 und Windows 8 sollten auch unter Windows 10 problemlos arbeiten. Hardwaretreiber und Entwicklungsumgebungen müssen jedoch mindestens auf die Version von August 2015 aktualisiert werden.

Zugriff auf Software von NI in Windows 10

In Windows 10 gibt es wieder das Startmenü, wodurch sich die Art des Zugriffs auf Ihre NI-Produkte ändert. Verknüpfungen der oberen Ebene wie MAX sind alphabetisch geordnet im „Alle Apps“-Startmenü aufgeführt. Alle untergeordneten Verknüpfungen befinden sich in dem Menü unter dem Abschnitt für NI.

Wie schon unter Windows 8 arbeiten Softwareprodukte von NI nicht als Windows-Store-App, und mit NI-Software erstellte Anwendungen können nicht als Windows-Store-App verwendet werden. Der Grund dafür ist, dass der erforderliche Zugriff auf die Win32 API vom Betriebssystem limitiert ist.

Bekannte Kompatibilitätsprobleme

Silverlight-Support 

Manche NI-Komponenten benötigen für ein ordnungsgemäßes Arbeiten Microsoft Silverlight. Der Standard-Browser in Windows 10, Microsoft Edge, unterstützt Silverlight nicht. Google Chrome unterstützt Silverlight ebenfalls nicht mehr. Windows 10 enthält zur Abwärtskompatibilität den Internet Explorer 11, der Silverlight unterstützt. Alle Silverlight-Seiten, die vom MAX aufgerufen werden, verwenden den Internet Explorer. Silverlight-basierte Seiten, die manuell unter Verwendung eines Standard-Browsers wie Edge oder Chrome gestartet werden, lassen sich aufgrund der fehlenden Unterstützung für Silverlight nicht öffnen. Weitere Informationen zur Verwendung von Silverlight-basierten Seiten auf Windows 10 finden Sie im KnowledgeBase-Artikel Remote Front Panels, NI Network Browser, and the Web Interface (WIF) Do Not Work in Google Chrome Version 42 or Higher

Probleme mit der Schnellstartfunktion

NI empfiehlt seinen Kunden dringend, die Schnellstartfunktion zu deaktivieren. Weitere Informationen finden Sie unter KnowledgeBase: Hardware wurde nicht erkannt oder ist bei aktivierter Schnellstartfunktion unter Windows 8 nicht funktionsfähig.

Reparieren von NI-Software nach einem Upgrade

Das Reparieren von NI-Software nach dem Upgrade auf Windows 10 kann zum Verlust von Zugriff auf Hardware führen, die mit reparierten Treibern verknüpft ist. Führen Sie eine zweite Reparatur an den betroffenen NI-Gerätetreibern durch, um diese in einen ausführbaren Zustand zurückzuversetzen. Dieses Problem trat erstmalig beim Upgrade von Windows 8.0 auf 8.1 auf und betrifft auch Upgrades auf Windows 10.

Verwendung der Kompatibilitätstabellen für Windows 10

  • In der Tabellenspalte „Windows 10 (64 Bit) (mit 32-Bit-Software)“ finden Sie die erste Version der jeweiligen 32-Bit-Software, die innerhalb der Emulationsschicht „Windows on Windows“ (WOW64) ausgeführt werden kann.
  • In den folgenden Tabellen bedeutet Nicht unterstützt, dass der Endnutzer in seiner 64-Bit-Softwareumgebung keine 32-Bit-NI-Software verwenden kann. Nicht zutreffend bedeutet, dass die Bitanzahl der Software für diese Version des Betriebssystems nicht vorhanden ist oder keine gültige Konfiguration aufweist. Beispielsweise stehen für die Entwicklungsumgebungen MAX oder LabWindows™/CVI™ keine ausführbaren Dateien in 64-Bit-Version zur Verfügung. Sie funktionieren jedoch unter der 64-Bit-Version von Windows 10. Ein 64-Bit-Programm lässt sich auf einem 32-Bit-Betriebssystem nicht ausführen.

Kompatibilität von NI-Produkten mit Microsoft Windows 10

Wie unterscheiden sich die 32-Bit- und 64-Bit-Version von Windows 10?

Windows 10 (32 Bit) kann sowohl auf x86- als auch auf x64-Hardware ausgeführt werden. Ähnlich wie bei Windows XP (32 Bit) bietet die 32-Bit-Version von Windows 10 lediglich Zugriff auf 32-Bit-Adressen. Deshalb ist Windows 10 (32 Bit) selbst bei der Ausführung auf x64-Hardware auf 4 GB RAM beschränkt. 64-Bit-Treiber und -Software, die von Haus aus für 64-Bit-Betriebssysteme entwickelt wurden, können nicht unter der 32-Bit-Version von Windows 10 ausgeführt werden.

Die 64-Bit-Version von Windows 10 kann nur auf x64-Hardware installiert werden. Diese Version des Betriebssystems ermöglicht Software den Zugriff auf Hardware über 64-Bit-Adressen. Dadurch kann auf wesentlich größere Speicherbereiche zugegriffen werden.  Um erfolgreich unter Windows 10 (64-Bit) zu laufen, müssen alle Treiber über native 64-Bit-Unterstützung verfügen. Die meisten 32-Bit-Softwareanwendungen können auf Windows 10 jedoch in einer 64-Bit-Emulationsschicht ausgeführt werden.

Detaillierte Informationen zu Unterschieden zwischen der 32-Bit- und der 64-Bit-Version von Windows finden Sie im Tutorial Einsatz von NI-Produkten mit 32-Bit- und 64-Bit-Windows-Betriebssystemen.

Software

Da Windows 10 im August 2015 fast zeitgleich mit Software von NI veröffentlicht wurde, war zu dem Zeitpunkt keine Windows-10-Unterstützung für diese NI-Software dokumentiert. Basierend auf Tests nach der Veröffentlichung von Windows 10 sind die folgenden Softwarepakete von NI mit den Versionen von Windows 10 (32 Bit) und Windows 10 (64 Bit) kompatibel. Ab 2016 wird für die neuen Versionen und Service-Pack-Updates aller Produkte von NI die Kompatibilität mit Windows 10 in der Readme-Datei des jeweiligen Produkts dokumentiert. Antworten auf alle Fragen zur Kompatibilität einer Softwareanwendung mit den 64-Bit-Versionen von Windows und LabVIEW erhalten Sie in der Readme-Datei für die entsprechende Produktversion.

Hinweis: Am 1. Mai 2021 wird die NI-Software die Unterstützung für Microsoft Windows 7 (32- und 64-Bit), Windows 8.1 (32- und 64-Bit), Windows Server 2008 R2, Windows Server 2012 R2 und alle 32-Bit-Windows-Betriebssysteme einstellen. Hard- und Software von NI, die nach dem 1. Mai 2021 herausgegeben wurde, wird auf diesen Betriebssystemen nicht korrekt installiert oder ausgeführt werden können. Ausführliche Informationen zur Unterstützung von Betriebssystemen durch NI-Produkte finden Sie unter https://www.ni.com/r/win32bitsupport. Produktspezifische Informationen finden Sie in der Readme-Datei.

Software von NI Windows 10 (32 Bit) Windows 10 (64 Bit) Windows 10 (64 Bit)
(mit 32-Bit-Software) (mit 64-Bit-Software)
GPIB-Serial Converter Software 19.0 Nicht zutreffend 19.0
InsightCM Server Nicht unterstützt Nicht unterstützt Nicht unterstützt
LabVIEW Communications System Design Software Nicht zutreffend Nicht zutreffend 2.0
LabVIEW Communications System Design Suite Nicht zutreffend Nicht zutreffend 2.1
LabVIEW NXG Nicht zutreffend Nicht zutreffend 1.0
NI Analog Video Generator Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Analog Waveform Editor Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI AudioMASTER Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Calibration Executive 3.6–5.0 3.6 6.0
NI DIAdem 2015 SP1 2015 SP1 2015 SP1
NI Digital Video Generator Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Digital Waveform Editor 3.0 3.0 Nicht zutreffend
NI FlexLogger Nicht zutreffend Nicht zutreffend 2018 R2
NI Functional Safety Editor Nicht unterstützt Nicht unterstützt Sept. 17
NI-I/O-Trace 15.0 15.0 15.0
NI InstrumentStudio Nicht zutreffend Nicht zutreffend 2018
NI LabVIEW (32 Bit) 2015 SP1 2015 SP1 Nicht zutreffend
NI LabVIEW (64 Bit) Nicht zutreffend Nicht zutreffend 2015 SP1
NI LabVIEW für LEGO® MINDSTORMS 2016 2016 Nicht zutreffend
NI LabWindows/CVI Run-Time Engine 2015 2015 2015
NI LabWindows™/CVI™ 2015 2015 Nicht zutreffend
NI Lookout (Lookout FDS) Nicht unterstützt Nicht unterstützt Nicht zutreffend
NI MATRIXx 7.2.8 7.2.8 7.2.8
NI Measurement & Automation Explorer (MAX) 15.0 15.0 Nicht zutreffend
NI Measurement Studio 2015 2015 2015
NI Multisim 14.0.1 14.0.1 Nicht unterstützt
NI Package Builder 19.0 19.0 19.0
NI-Paketmanager 19.0 19.0 17.0
NI Picture Quality Analysis (PQA) Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Real-Time Hypervisor Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI Requirements Gateway 2014 2014 Nicht zutreffend
NI SignalExpress Nicht zutreffend Nicht zutreffend Nicht zutreffend
NI Switch Executive 2017 2017 2017
NI SystemLink Client Nicht zutreffend Nicht zutreffend 17.0
NI SystemLink Server Nicht zutreffend Nicht zutreffend 17.0
NI TestStand 2014 SP1 2014 SP1 2014 SP1
NI Ultiboard 14.0.1 14.0.1 Nicht unterstützt
NI-Update-Dienst 2.3 2.3 17.0
NI VeriStand 2015–2018 SP1 2015–2018 SP1 2019
NI Video Measurement Suite (VMS) Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI VirtualBench 16.0 16.0 16.0
NI Vision Builder for Automated Inspection 2015 2015 2015

 

Zusatzpakete und Toolkits

Folgende Zusatzpakete und Toolkits von NI sind mit den aufgeführten Versionen von Windows 10 (32 Bit) und Windows 10 (64 Bit) kompatibel: 

Software von NI Windows 10 (32 Bit) Windows 10 (64 Bit) Windows 10 (64 Bit)
(mit 32-Bit-Software) (mit 64-Bit-Software)
FlexLogger Plugin Development Kit Nicht zutreffend Nicht zutreffend 1.0
NI Automotive Diagnostic Command Set 15.0 15.0 15.0
NI Bluetooth Toolkit (Run-Time, Erzeugung, Analyse) 15.0 15.0 15.0
NI Combustion Analysis System 2015 2015 Nicht unterstützt
NI ECU Measurement and Calibration Toolkit 15.0 15.0 15.0
NI FM/RDS Measurement Suite 1.0 Nicht unterstützt Nicht unterstützt
NI GNSS Simulation Toolkit 3.0 Nicht unterstützt Nicht unterstützt
NI InsightCM SDK 2.0 2.0 Nicht unterstützt
NI LabVIEW Advanced Signal Processing Toolkit 15.03 15.03 2018
NI LabVIEW Analytics and Machine Learning Toolkit 2017 2017 2018
NI LabVIEW Application Builder 2015 SP1 2015 SP1 2015 SP1
NI LabVIEW C-Generator 20153 20153 Nicht zutreffend
NI LabVIEW Communications MIMO Application Framework Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI LabVIEW Control Design and Simulation Module 20153 20153 2016
NI LabVIEW Database Connectivity Toolkit 20153 20153 2019
NI LabVIEW DataFinder Toolkit 2016 2016 Nicht unterstützt
NI LabVIEW Datalogging and Supervisory Control Module 20153 20153 Nicht zutreffend
NI LabVIEW Desktop Execution Trace Toolkit 20153 20153 2016
NI LabVIEW Digital Filter Design Toolkit 20153 20153 2018
NI LabVIEW Electrical Power Toolkit 2016 2016 Nicht zutreffend
NI LabVIEW Embedded für ARM Module Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI LabVIEW FPGA-Modul1 2017 2017 2018
NI LabVIEW FPGA Xilinx ISE1 Nicht unterstützt Nicht unterstützt Nicht zutreffend
NI LabVIEW FPGA Xilinx Vivado1 Nicht zutreffend 2018 2018
NI LabVIEW MathScript RT Module 20153 20153 2016
NI LabVIEW Mobile Module Nicht zutreffend Nicht zutreffend Nicht zutreffend
NI-LabVIEW-Modul für LEGO MINDSTORM Nicht zutreffend Nicht zutreffend Nicht zutreffend
NI LabVIEW myRIO Toolkit 20153 20153 Nicht zutreffend
NI LabVIEW OPC UA Toolkit 2017 2017 2018
NI LabVIEW PDM Erfassungs-Toolkit Nicht unterstützt 2020 Nicht unterstützt
NI-LabVIEW-Toolkit PID und Fuzzy-Logik 2 2015 SP1 2015 SP1 2015 SP1
NI LabVIEW Real-Time Module 2015 SP1 2015 SP1 Nicht zutreffend
NI LabVIEW Report Generation Toolkit für Microsoft Office 20153 20153 20153
NI LabVIEW roboRIO Toolkit 20153 20153 Nicht zutreffend
NI LabVIEW Robotics Module 20153 20153 Nicht zutreffend
NI LabVIEW SoftMotion Module 20153 20153 Nicht zutreffend
NI LabVIEW Statechart Module 20153 20153 Nicht zutreffend
NI LabVIEW Touch Panel Module Nicht unterstützt Nicht unterstützt Nicht zutreffend
NI LabVIEW Unit Test Framework Toolkit 20153 20153 2016
NI LabVIEW VI Analyzer Toolkit 20153 20153 2016
NI LabVIEW Wireless Sensor Network (WSN) Module 20153 20153 Nicht zutreffend
NI LabWindows/CVI Execution Profiler Toolkit 1.0 1.0 1.0
NI LabWindows/CVI PID Control Toolkit 2.1 2.1 Nicht zutreffend
NI LabWindows/CVI Real-Time Module 2015 2015 Nicht zutreffend
NI LabWindows/CVI Signal Processing Toolkit 7.0.2 7.0.2 Nicht zutreffend
NI LabWindows/CVI SQL Toolkit 2.3 2.3 2.3
NI-Lizenzmanager 3.7 3.7 3.7
NI Modulation Toolkit 15.0 15.0 15.0
NI Motion Assistant Nicht unterstützt Nicht unterstützt Nicht zutreffend
NI-OPC-Server 2016 2016 Nicht unterstützt
NI-RFFastACP 1.0.0 1.0.0 1.0.0
NI-RFmx 1.2 1.2 1.2
NI-RFPM Nicht unterstützt 16.0.0 16.0.0
NI Software Calibration Management Toolkit für LabVIEW 2015 2015 Nicht unterstützt
NI Sound and Vibration Measurement Suite 15.0 15.0 15.0 (ohne Konfiguration des Express-VIs)
NI Spectral Measurements Toolkit 15.0 15.0 15.0
NI SystemLink Server - Test Module Nicht zutreffend Nicht zutreffend 18.0
NI TDMS 15.0 15.0 15.0
NI TestStand ATML Toolkit 2013 2013 2017
NI Vision Development Module 2015 SP1 2015 SP1 2015 SP1
NI-VRTS Nicht zutreffend 1.5 1.5
NI WLAN Toolkit 15.0 15.0 15.0
RFIC-Testsoftware Nicht unterstützt 3.0 3.0
Zusatzpaket zur Steuerung von Halbleitergeräten für InstrumentStudio Nicht zutreffend Nicht zutreffend 2019
TestStand Semiconductor Module 2016 2016 2016
VCSEL I-V-Testsoftware Nicht unterstützt Nicht unterstützt 20.0


1
Das LabVIEW-FPGA-Modul wird teilweise unter Windows 10 unterstützt. Bei den für Ihre NI-FPGA-Hardware verwendeten Xilinx-Tools ist dies eventuell nicht der Fall. Weitere Informationen liefert das Dokument Kompatibilität des LabVIEW-FPGA-Moduls mit Windows 10

2 2 Das NI-LabVIEW-Toolkit PID und Fuzzy-Logik war ab LabVIEW 2014 im Basis-LabVIEW enthalten.

3 Diese Softwareversion unterstützt Windows 10 nur bei Verwendung mit LabVIEW 2015 SP1.

Hardwaretreiber

Die folgendenHardwaretreibervon NI sind mit den nachfolgend aufgeführten Versionen von Windows 10 (32 Bit) und Windows 10 (64 Bit) kompatibel.

Software von NI Windows 10 (32 Bit) Windows 10 (64 Bit) Windows 10 (64 Bit)
(mit 32-Bit-Software) (mit 64-Bit-Software)
Assistent zur Instrumenten-I/O 15.0 15.0 15.0
FieldPoint 15.0 15.0 Nicht unterstützt
NI-488.2 15.5 15.5 15.5
NI-568x 15.0 15.0 15.0
NI-5690 15.0 15.0 15.0
NI-845x 15.0 15.0 15.0
NI-CAN 15.0 15.0 Nicht zutreffend
Gerätetreiber für NI CompactRIO 15.5 15.5 15.5
NI-DAQmx 15.5 15.5 15.5
NI-DCPower 15.2 15.2 15.2
NI-DCPower .NET API 17.1 17.1 17.1
NI-Digital Pattern Driver 16.01 16.0 16.0
NI-DMM 15.2 15.2 15.2
NI-DMM .NET API 15.2 15.2 15.2
NI-ELVISmx 16.0 16.0 Nicht unterstützt
NI-Embedded CAN für sbRIO Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI-FBUS 15.0 15.0 Nicht zutreffend
NI-FGEN 16.0 16.0 16.0
NI-FlexRIO 15.1 15.1 15.1
NI High Speed Serial 15.0 15.0 15.0
NI-HSDIO 16.0 16.0 16.0
NI HWS 15.0 15.0 Nicht unterstützt
NI-IMAQ 15.5 15.5 15.5
NI-IMAQ I/O 15.5 15.5 15.5
NI-IMAQdx 15.5 15.5 15.5
NI-Industrial Communications für CANopen 15.0 15.0 Nicht zutreffend
NI-Industrial Communications für DeviceNet 15.0 15.0 Nicht zutreffend
NI-Industrial Communications für DNP3 14.0 14.0 Nicht zutreffend
NI-Industrial Communications für EtherCAT (NI-ECAT) 16.0 16.0 Nicht unterstützt
NI-Industrial Communications für EtherNet/IP 15.0 15.0 15.0
NI-Industrial Communications für IEC 60870-5 1.1 (mit 1.1.1-Patch) 1.1 (mit 1.1.1-Patch) Nicht zutreffend
NI-Industrial Communications für IEC 61850 15.0 15.0 Nicht zutreffend
NI IVI Compliance Package 15.0 15.0 15.0
NI-Motion 15.0 15.0 Nicht zutreffend
NI-OSI 15.0 15.0 Nicht zutreffend
NI-P2P 15.0 15.0 15.0
NI-PXImc 16.0 16.0 16.0
NI PXI Platform Services 15.1 15.1 15.1
NI PXI-5624R Digitizer Instrument Design Libraries Nicht unterstützt Nicht unterstützt Nicht unterstützt
NI PXI-5644R/5645R/5646R Instrument Design Libraries (VST) 15.0.2 15.0.2 Nicht unterstützt
NI PXI-5660 15.0 Nicht unterstützt Nicht unterstützt
NI-RFSA 15.0.2 15.0.2 15.0.2
NI-RFSA .NET API 16.0 16.0 16.0
NI-RFSG 15.0.2 15.0.2 15.0.2
NI-RFSG .NET API 16.0 16.0 16.0
NI-RIO 15.0 15.0 15.0
Gerätetreiber für Multifunktionsmodule der R-Serie von NI mit rekonfigurierbarer I/O 15.0 15.0 15.0
NI-Scope 16.0 16.0 16.0
NI-Scope .NET API 2.0 2.0 2.0
NI-Serial 17.0 17.0 17.0
NI-SLSC 1.0 1.0 1.0
NI-Switch 16.0 16.0 16.0
NI-Switch .NET API 17.0 17.0 17.0
NI-Sync 15.0.1 15.0.1 15.0.1
NI System Configuration 15.0 15.0 15.0
NI-TimeSync 15.0 15.0 Nicht unterstützt
NI-USRP 14.5 14.5 14.5
NI-VISA 15.0.1 15.0.1 15.0.1
NI-VISA .NET API 15.0 15.0 15.0
NI-VNA 16.0 16.0 16.0
NI-VXI 16.0 16.0 16.0
NI-WSN 15.0 15.0 Nicht unterstützt
NI-XNET 15.0 15.0 15.0
RMX-410x-Netzgerätetreiber Nicht zutreffend 20.7 20.7

 

1 Der NI-D20.7igital Pattern Driver unterstützt nur die Nutzung unter 32-Bit-Versionen von Windows, aber bietet keine Unterstützung für die Entwicklung unter 32-Bit-Windows.