Archived: LabVIEW 2009 SP1 NI SoftMotion Module Bug Fixes

NI does not actively maintain this document.

This content provides support for older products and technology, so you may notice outdated links or obsolete information about operating systems or other relevant products.

Overview

This document has been archived and is no longer updated by National Instruments.

The following items are the IDs and titles of a subset of issues fixed between LabVIEW 2009 NI SoftMotion Module and LabVIEW 2009 SP1 NI SoftMotion Module. If you have a CAR ID, you can search this list to validate that the issue has been fixed.

Bug Fixes

ID Fixed Issue
133351 Interactive Test Panel and Gain Tuning Panel sometimes show a very small value instead of 0.
156262 Cannot map SolidWorks sensors to a Home switch.
156263 Position Compare function block does not work with SolidWorks axes.
165662 Incorrect error -77044 (bufferUpdateInvalidError) returned when you try to update points during a finite contour move.
166061 Incorrect fault returned when the SolidWorks simulation reaches the end of its specified duration.
166464 No error returned when attempting to start a step response in the Gain Tuning Panel dialog box when the axis is not active.
167594 Position Error Exceeded LED does not work in the Gain Tuning Panel dialog box.
170153 Switching the NI Scan Engine from Configuration mode to Active mode on an EtherCAT backplane can cause NI 951x modules to fault with a Heartbeat Communication Fault.
170953 Large SolidWorks assemblies may timeout when starting the simulation the first time.
172448 Cannot clear faults on NI 951x modules in Active mode if the fault originally occurred in Configuration mode.
173474 Errors returned when running a VI that uses a SolidWorks axis before deploying the axis.
174572 Deleting, then re-adding an axis in the Axis Manager dialog box leads to an "Invalid Configuration" error.
175298 Changes to the digital input mapping using Standard mode do not show up after switching to Graphical mode.
175999 NI 951x modules cannot be enabled if any module using the NI Scan Engine has a fault.
176269 You cannot configure Encoder 1 when the Axis Configuration dialog box is set to "Use Graphical Mode."
176793 Cannot drag NI SoftMotion resources from the LabVIEW Project Explorer window to the block diagram when using NI SoftMotion Module Lite.
178157 FPGA to RT synchronization VIs are missing from the NI SoftMotion FPGA palette.
178539 Having two or more simulated axes above any SolidWorks axes in the LabVIEW Project Explorer window causes a NIMC_invalidIndexSpecifiedError (-77075) when switching to Active mode.
178798 Interactive Test Panel dialog box plots do not work.
178851 Some SolidWorks error messages are not displayed if the LabVIEW Real-Time module is not installed.
179734 You cannot run the RT Scan Synchronization VIs faster than 5 ms.
179783 Position jump when using an NI SoftMotion axis in a coordinate space and then using it outside of the coordinate space as a slave axis.
181155 Velocity override percentage only applies to current move and is lost when next move starts.

Glossary of Terms

 

  • Bug ID - When an issue is reported to NI, you may be given this ID or find it on ni.com.  You may also find IDs posted by NI on the discussion forums or in KnowledgeBase articles.
  • Legacy ID – An older issue ID that refers to the same issue.  You may instead find this issue ID in older known issues documents.
  • Description - A few sentences which describe the problem. The brief description given does not necessarily describe the problem in full detail.
  • Workaround - Possible ways to work around the problem.
  • Reported Version - The earliest version in which the issue was reported.
  • Resolved Version - Version in which the issue was resolved or was no longer applicable. "N/A" indicates that the issue has not been resolved.
  • Date Added - The date the issue was added to the document (not the reported date).