TDMS 2.0 FAQ

Publish Date: Aug 07, 2013 | 4 Ratings | 4.00 out of 5 |  PDF

With LabVIEW 2009 and DIAdem 11.1 (USI 1.7) National Instruments introduced TDMS 2.0. To add TDMS 2.0 support to former versions of DIAdem, LabVIEW Storage VIs and LabWindows/CVI DIAdem Connectivity Library, please download and install the TDMS 2.0 stand-alone installer.

 

Table of contents


Q: What's new in TDMS 2.0?
With TDMS 2.0 file writing speed has been increased by a factor of 4 resulting in file writing benchmarks up to 400 MB/s. Additionally writing TDMS files has now been integrated directly into the NI-DAQmx driver resulting in the easiest and fastest way to stream data on the NI platform.

 Q: Which software installs TDMS 2.0?
TDMS 2.0 installs with LabVIEW 2009 and DIAdem 11.1 (USI 1.7).

Q: How can I read TDMS 2.0 files with my already installed software?
To read TDMS 2.0 files with former versions of DIAdem, LabVIEW, LabWindows/CVI and MeasurementStudio, please download and install the TDMS 2.0 stand-alone installer. TDMS 2.0 can access TDMS 2.0 files as well as TDMS 1.0 files.

Q: Can I still read TDMS 1.0 files with LabVIEW 2009 or DIAdem 11.1?
Yes, reading TDMS 1.0 files is still supported with LabVIEW 2009 and DIAdem 11.1. Even more you do not even need to know whether your TDMS file is of version 1.0 or 2.0; this is handled by TDMS under the hood.

Q: How can I store TDMS 1.0 files with LabVIEW 2009 TDM Streaming VIs?
The TDM Streaming VIs offers a switch (file format version) in the TDMS Open function which allows you to choose between storing TDMS 1.0 files or TDMS 2.0 files. The default is TDMS 2.0.

Q: How can I store TDMS 1.0 files with DIAdem 11.1?
DIAdem 11.1 stores TDMS 2.0 files by default. You need to install the TDMS 1.0 DataPlugin and choose 'National Instruments TDM Streaming 1.0' (Save as type) in the File>>Save As dialog to allow DIAdem 11.1 to store TDMS 1.0 files. You can still store TDMS 2.0 files after the installation of the TDMS_1_0 DataPlugin.

Q: How can I store TDMS 1.0 files with LabVIEW 2009 Storage VIs
The LabVIEW 2009 Storage VIs store TDMS 2.0 files by default. You need to install the TDMS 1.0 DataPlugin and choose 'TDMS 1.0' in the Open Data Storage Express VI  to store TDMS 1.0 files. You can still store TDMS 2.0 files after the installation of the TDMS_1_0 DataPlugin.

Q: Does installing TDMS 2.0 affect existing applications?
After installing the TDMS 2.0 stand-alone installer, existing LabVIEW, DIAdem, LabWindows CVI, and Measurement Studio applications will continue to store TDMS 1.0 files. However, these applications will now be able to read TDMS 2.0 files. You can make your LabVIEW application store TDMS 2.0 files by upgrading to the newest version of LabVIEW.

Q: Why can I no longer store TDMS 1.0 files after installing DIAdem 11.1?
DIAdem use a common software component (USI) together with other National Instruments Software installed on that same computer. With the installation of DIAdem 11.1 or any National Instrument software containing USI 1.7 (or higher) DIAdem, the LabVIEW Storage VIs and the LabWindows/CVI 8.1 DIAdem Connectivity Library will store TDMS 2.0 files by default. You need to install the TDMS 1.0 DataPlugin to store TDMS 1.0 files with the LabVIEW Storage VIs or DIAdem.

 

Related Links:
TDM Streaming (TDMS) DataPlugin Download
Learn more about the NI TDM (Technical Data Management) file format.

 

Back to Top

Bookmark & Share

Ratings

Rate this document

Answered Your Question?
Yes No

Submit