LabVIEW 8.6.1 Bug Fixes

Publish Date: Feb 26, 2009 | 2 Ratings | 3.00 out of 5 |  PDF

Overview

The following items are the IDs and titles of a subset of issues fixed between LabVIEW 8.6 and LabVIEW 8.6.1. If you have a CAR ID, you can search this list to validate that the issue has been fixed.

 

ID Legacy ID Fixed Issue
44114 4GPD8CUD Using Reinitialize to Default Value on XControl resets data, but not the display of the control.
57016 44DLSS7Q Major grids disappear on waveform graph
90672 400C2N00 The server.tcp.acl config token is not copied over during a build application
100582 - NIReport.llb: "report in" and "report out" parameters are not localized in any of the VIs
106270 - Custom probes not cached for any wire type that has an embedded LabVIEW class (cluster, array, refnum)
109046 - Custom probe of any type containing LabVIEW class doesn't show up in Custom Probe menu
109454 - Custom Wire Artwork does not immediately redraw when replacing LabVIEW class
110820 - Right-click copy data in reentrant clones crashes LabVIEW when nested typedefs are involved
112372 - LabVIEW installer "insufficient OS" dialog has a trailing "\n"
113638 - Connectivity palette is not set to sync to directory, but should
115082 - Application Builder[LV DVD] Product missing in the LV startup dialog box
115978 - Breakpoint Failure
116663 - MathScript in Linux - Pop up plot freezes after saving an eps image.
116882 - Negative constant wired directly to count terminal (N) of For Loop with auto-indexing output tunnels produces "out of memory" error or crash
117216 - Instrument Driver Project Wizard reports empty dependency error in report
117382 - Application builder requests password for dynamic VI
117659 - Control drag copy of multiple controls within a cluster throws internal error
117709 - Unbundling class private data control elements by name follows different rules than regular typedefs
118210 - Language info is not shown at uninstallation dialog
118665 - In-place Variant To/From Element is always broken
118826 - Numeric localization codes do not work
119144 - Wide string caching is very problematic for SCC case sensitivity issues, causes other odd behavior
119615 4EI92JAI Application created after converting a build script is missing menu bar
119890 - LabVIEW UDP Broadcast on Multiple NICs Does Not Work On Vista
119916 - Perforce Command Line provider slower than Perforce SCM on operations involving large number of files.
120012 - NI_AB_API_SDIST Build.vi displays popup dialogs
120048 - lvanlys.out and lvblas.out have duplicate symbols
120322 - crash after running express save for previous
120393 - The Web server returns a 405 error in response to PUT requests
120456 - Loading a Model in the Sensor Mapping Express VI Crashes LabVIEW
120749 - Can't drag and drop test file items into libraries
120751 - Add UTF preference pages to built-in preferences dialog
120793 - dependencies that don't report callers
121448 - ni::variable::Variable leaks a Variant
121526 - Loading a class when its ancestry is reserved can crash
121636 - LabVIEW hangs on 3D_Graph when running Analyzer test if SCC is enabled.
121671 - Switching to "Files" tab is slow with large project
121833 - Alarm dialog rounds alarm limits to integers when opened - erases previous settings
121889 - Conditionally used variable actually used as variable definition in nested if statement
121981 - MathScript Node breakpoint popup behavior is different when VI is running
122079 - Application Builder build spec ignores remove front panel and block diagram flags at build time for the items listed in the dependencies node of the project tree.
122604 - Possibly Corrupt Type Def Cluster Controls will not print in multiple versions of LabVIEW
122856 - The XControl Facade does not get the Panel Resize event when the XControl is inside a reentrant clone
122857 - Bundle by Name does not work for XControls which contain Cluster Typedefs
123115 - The feedback node terminals can turn black and lose data type when connected to structures
123312 - 100ms delay when sending small packets with Logos XT on VxWorks
123406 - Upgrade llb from 8.5 to 8.6 - llb now crashes whenever you click the broken run arrow
123618 - Incorrect behavior of copy and paste XControl.
123651 - Labview crashes when you change plot names in mixed signal graph
123716 - Unflattening LV object array from xml results in error
123728 - Decimate Array wired to Feedback Node Initializer within Loop Crashes LabVIEW on Second Iteration
123755 - VI conversion fails within a lvlib
124319 - Call to VI server method App.Get VI.CPTM RC is slower in 8.6
124463 - LabVIEW Hanging on Launch With Expired VI Analyzer License
124781 - Reverting lvlibs in Project Explorer breaks links
124804 - System Exec VI does not work on Russian Windows XP
124834 - Error 1106 using Unflatten from XML on Class with Enum
125185 - FB Typedef Ring Controls show up as #'s when you create a constant
125408 - Attempt to read consolidated type info from future version VI
125525 - Interpolate 2D throws error -20145 whenever non-square array is input into Z terminal.
125695 - Some dialogs don't allow to input eastern characters
125724 - When the Address Book Web Service example is executed after deployed, the internal server error occurred.
125835 - LabVIEW Remote Front Panel 8.6 on Linux Distribution
125899 - Memory Leak when reading from binary file in While Loop
126200 - Call by Reference crashes LV 8.6 when using application refnum
128091 - Typing values in cursor legend of Intensity graph will crash LabVIEW 8.6
128115 - Incorrect Behavior in case structure execution
128247 - LabVIEW Call Library Node has incorrect "data type" for Waveforms and therefore does not work in 8.6
128520 - LabVIEW 8.6 Crashes if TDMS Write has Invalid File Reference
128657 - Locked (No Password) VI property does not save in 8.6
129245 - Revert VI with function blocks not updating project tree
129282 - The LabVIEW 8.6 Standard Run-Time Engine Installer available online updates the USI component
129876 - Desktop Execution Trace Toolkit help server plug-in doesn't return localized target name
130294 - Digital Graph causes LabVIEW to crash when displaying digital signal subsets
130634 - The search results are broken for lverror.chm in Korean and Japanese
131181 - Web Services application builder servers page broken
131428 - I/O control drop-down commands broken
131714 - Access violation in LabVIEW while using digital waveform graph

 

* Requires you to manually recompile VIs to correct the problem. Refer to the Recompiling VIs for Bug Fixes section of the LabVIEW 8.6.1 Readme for more information about manually recompiling VIs.

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit