LabVIEW NXG 4.0 Known Issues

Publish Date: Nov 05, 2019 | 0 Ratings | 0.00 out of 5 | Print

Overview

This document contains known issues for the LabVIEW NXG 4.0 Application Software. Not every issue known to NI will appear on this list; it is intended to only show the severe and more common issues that can be encountered.

Fields

Each Issue appears as a row in the table and includes these fields:
  • Issue ID
  • Issue Title
  • Problem Description
  • Workaround
  • Reported Version - the earliest version of LabVIEW NXG in which the issue was reported
  • Resolved Version - version the issue was resolved or was no longer applicable
  • Date Added - the date the issue was added to the document (not reported date)


Document Organization

There are two versions of the known issues list available:

LabVIEW NXG Known Issues by Category
LabVIEW NXG Known Issues by Date

Please refer to Developer Zone Article "LabVIEW Known Issues Categories Defined" for an explanation of the categories and what types of issues are in each category.

Contacting NI

You can contact us by phone, email, or the discussion forums. Visit the NI Website to contact us. If you are contacting NI in regards to a specific issue, be sure to reference the ID number given in this document. If you have feedback on this specific document, please contact NI on this NI Developer Zone post.

Known Issues by Category

The following items are known issues in LabVIEW NXG 4.0 sorted by Category.

Building and Distributing LabVIEW Applications
685018 Applications built with NXG 2.1 crash without dialogue without the NXG 2.1 Runtime installed
Controls and Indicators
482816 Selection in Array of Clusters of Arrays constant loses focus.
630075 IO constants cannot be resized when contained within a cluster connected to a G Type.
634781 Graph controls and indicators do not always display their data when viewed through remote desktop.
605135 Some strings remain in English rather than localized language when converted to LabVIEW NXG
741521 SMTP VIs with ä ö ü or similar characters do not display correctly
Documentation
722500 Context Help does not show what was saved in the gType document
Functions, VIs, and Express VIs
514789 Autotuning PID Online.VI Example Reads Proportional Gain 'NaN' with the Relay Technique.
721553 Event Loop, In Place Element Structure, and Timed Loop do not create correctly when dragging from Right to Left (instead of Left to Right)
LabVIEW Object Oriented Programming
599434 Dynamic dispatch controls are not supported inside structures
LabVIEW Project
599881 Empty folders in project don't show up in the files pane when opening a project
Menus
644397 Workbooks do not restore maximized after minimizing the environment window with a maximized workbook open.
643608 Right clicking on a tunnel of queue of numeric type shows the numeric palette
Miscellaneous
595278 Undo does not work for the Create SubVI from Selection operation.
596355 Shared Library Interface functions are not available in the Diagram palette.
584767 Some UI elements in the environment may not display correctly using custom DPI settings.
631907 Some keyboard shortcuts don't work with an AZERTY keyboard
661634 Enums may not be compatible after Flattening and Unflattening to/from Byte Array
741521 SMTP VIs with ä ö ü or similar characters do not display correctly
711967 LabVIEW NXG does not function correctly when license files are moved from default location.
721553 Event Loop, In Place Element Structure, and Timed Loop do not create correctly when dragging from Right to Left (instead of Left to Right)
Upgrade - Migration
641719 Projects with large file hierarchy error out during conversion with unclear error message



ID Known Issue
Building and Distributing LabVIEW Applications
685018

Return
Applications built with NXG 2.1 crash without dialogue without the NXG 2.1 Runtime installed
With only the NXG 2.0 Runtime, applications built in NXG 2.1 will crash silently and not explain the reason they failed to execute.

Workaround: Install the NXG 2.1 Runtime

Reported Version: 5.3    Resolved Version: N/A    Added: 02/26/2018
Controls and Indicators
482816

Return
Selection in Array of Clusters of Arrays constant loses focus.
Selecting an array inside a cluster inside another array loses focus when hovering over another element of the top array. This makes it difficult to edit the items in the inner-most array.

Workaround: N/A

Reported Version: R3    Resolved Version: N/A    Added: 05/22/2017
630075

Return
IO constants cannot be resized when contained within a cluster connected to a G Type.
IO constants can be resized manually when contained within a cluster constant. However, IO constants cannot be resized once the containing cluster is connected to a G Type. The IO control in the G Type can be resized but this change is not reflected in any connected constants.

Workaround: Disconnect the cluster from the G Type, resize the IO constant, and then reconnect to the G Type.

Reported Version: 4.9    Resolved Version: N/A    Added: 05/22/2017
634781

Return
Graph controls and indicators do not always display their data when viewed through remote desktop.
When viewing a Panel from a remote desktop, the data on a graph control or indicator may not be visible. The graph or indicator will appear as thought it contains no data, although the data is still present.

Workaround: Disable hardware graphics acceleration under Filer >> Preferences >> Editor Tab. The graph data should now be visible.

Reported Version: 4.9    Resolved Version: 5.0    Added: 05/22/2017
605135

Return
Some strings remain in English rather than localized language when converted to LabVIEW NXG
When setting a localized dictionary and converting from LabVIEW to LabVIEW NXG, some strings may remain in English. Specifically, strings that are labels instead of captions will appear in English

Workaround: Set a caption for controls prior to conversion or update text after conversion

Reported Version: 4.8    Resolved Version: N/A    Added: 02/26/2018
741521

Return
SMTP VIs with ä ö ü or similar characters do not display correctly
Sending an e-mail via SMTP VIs with ä ö ü or similar characters in the subject field replaces those characters with question marks.

Workaround: Use ISO 8bit encodings.
Start with: =?iso-8859-1?Q?[Subject goes here]?=
Replace "[Subject goes here]" (including the brackets) with the text. Anywhere there's a special character, you'll need to get the hex value. Replace the special characters with: =xx where xx is the hex value

Reported Version: 3.1.1    Resolved Version: N/A    Added: 10/01/2019
Documentation
722500

Return
Context Help does not show what was saved in the gType document
When using the context help in the Class Hierarchy viewer, the description and help link of the gType classes does not reflect what is entered and saved in the gType document.
It just shows "No description available." for all classes.

Workaround: No work around currently.

Reported Version: 3.0.1    Resolved Version: N/A    Added: 10/07/2019
Functions, VIs, and Express VIs
514789

Return
Autotuning PID Online.VI Example Reads Proportional Gain 'NaN' with the Relay Technique.
When running the Autotuning PID Online.vi example, with the Relay Technique the "Tuned PID gains" output of proportional gain (Kc) shows "NaN" when the program believes tuning is completed by flashing "tuning completed?".

Workaround: Tune the individual terms first. Start by first tuning for P until the response is stable. Then continue to tune by switching to PI. Lastly, repeat the process for PID.

Reported Version: 4.8    Resolved Version: N/A    Added: 05/22/2017
721553

Return
Event Loop, In Place Element Structure, and Timed Loop do not create correctly when dragging from Right to Left (instead of Left to Right)
There are some structures that do not create correctly when dragging from right to left (instead of left to right). The structure will create and expand in the Y-axis correctly but will stay to the right of the point where the mouse clicked before dragging, and remain in the smallest width possible. I expect all of them to expand in the X-axis to follow the mouse drag when moving to the left.
The structures affected are Event Loop, In Place Element Structure, and Timed Loop.

Workaround: Create the structures left to right, instead of right to left.

Reported Version: 2.0    Resolved Version: N/A    Added: 10/07/2019
LabVIEW Object Oriented Programming
599434

Return
Dynamic dispatch controls are not supported inside structures
Placing a dynamic dispatch control inside of a structure provides the following error:
The run-time type is not propagated from dynamic dispatch input to dynamic dispatch output. You must ensure that there is a wire path that flows to all dynamic dispatch indicators.

Workaround: Remove the control from the structure and the error will clear.

Reported Version: 4.7    Resolved Version: N/A    Added: 02/26/2018
LabVIEW Project
599881

Return
Empty folders in project don't show up in the files pane when opening a project
When you open a project with empty folders, those don't show up in the files pane.

Workaround: N/A

Reported Version: 4.7.1    Resolved Version: 4.8    Added: 01/23/2018
Menus
644397

Return
Workbooks do not restore maximized after minimizing the environment window with a maximized workbook open.
A maximized workbook window will minimize when the environment window is minimized. Restoring the environment window will also restore the workbook window but not in the maximized view.

Workaround: Maximize the workbook window manually after restoring the environment window.

Reported Version: 4.9.1    Resolved Version: N/A    Added: 05/22/2017
643608

Return
Right clicking on a tunnel of queue of numeric type shows the numeric palette
For most data types, the right click menu from the queue terminals shows the palette queue. Right clicking on a tunnel of numeric type shows the numeric palette.

Workaround: Manually drop from the queue palette instead of right-clicking.

Reported Version: 4.9    Resolved Version: N/A    Added: 01/23/2018
Miscellaneous
595278

Return
Undo does not work for the Create SubVI from Selection operation.
When using the shortcut to undo a Create SubVI from Selection operation, the subVI that was created will be deleted but the nodes that were present will not be replaced on the diagram.

Workaround: Use Edit> Undo instead of Ctrl+Z

Reported Version: R4    Resolved Version: N/A    Added: 08/19/2016
596355

Return
Shared Library Interface functions are not available in the Diagram palette.
Functions configured in a SLI document cannot be accessed directly from the palette or Quick Drop.

Workaround: To add a function to the diagram of a VI, first, open the SLI document in a separate window. With both the SLI and the diagram of the VI open in different windows, click and drag the SLI function name onto the diagram.

Reported Version: 4.7.1    Resolved Version: N/A    Added: 08/25/2016
584767

Return
Some UI elements in the environment may not display correctly using custom DPI settings.
Some UI elements may display incompletely if using a custom Windows DPI setting of 125%, or similar.

Workaround: Use default DPI settings.

Reported Version: 4.5.2 (R-Comms2)    Resolved Version: N/A    Added: 05/22/2017
631907

Return
Some keyboard shortcuts don't work with an AZERTY keyboard
The following shortcuts do not work properly when using an AZERTY keyboard:

Ctrl-' (Toggle the diagram grid on/off)
Shift-Ctrl-; (Toggle Smart Guides on/off)
Ctrl-[ (Set or delete Breakpoint)
Ctrl-] (Set or Delete Probe)
Ctrl-. (Abort )

Workaround: N/A

Reported Version: Unknown    Resolved Version: N/A    Added: 01/23/2018
661634

Return
Enums may not be compatible after Flattening and Unflattening to/from Byte Array
In certain cases, converting an enum using Flatten to Byte Array and then back with Unflatten from Byte Array can cause it to be incompatible with the original enum. This causes problems when trying to wire it into another VI looking for the enum.

Workaround: Use the enum the Unflatten from Byte Array creates automatically to clear the error

Reported Version: 5.2    Resolved Version: N/A    Added: 02/26/2018
741521

Return
SMTP VIs with ä ö ü or similar characters do not display correctly
Sending an e-mail via SMTP VIs with ä ö ü or similar characters in the subject field replaces those characters with question marks.

Workaround: Use ISO 8bit encodings.
Start with: =?iso-8859-1?Q?[Subject goes here]?=
Replace "[Subject goes here]" (including the brackets) with the text. Anywhere there's a special character, you'll need to get the hex value. Replace the special characters with: =xx where xx is the hex value

Reported Version: 3.1.1    Resolved Version: N/A    Added: 10/01/2019
711967

Return
LabVIEW NXG does not function correctly when license files are moved from default location.
LabVIEW NXG will not function when the license files for NXG have been removed from the C:\ProgramData\National Instruments\License Manager\Licenses folder.
The behavior will be that the splash screen will appear, then disappear and nothing happens.

Workaround: Move the license files back into the correct location.

Reported Version: 2.1.1    Resolved Version: N/A    Added: 10/07/2019
721553

Return
Event Loop, In Place Element Structure, and Timed Loop do not create correctly when dragging from Right to Left (instead of Left to Right)
There are some structures that do not create correctly when dragging from right to left (instead of left to right). The structure will create and expand in the Y-axis correctly but will stay to the right of the point where the mouse clicked before dragging, and remain in the smallest width possible. I expect all of them to expand in the X-axis to follow the mouse drag when moving to the left.
The structures affected are Event Loop, In Place Element Structure, and Timed Loop.

Workaround: Create the structures left to right, instead of right to left.

Reported Version: 2.0    Resolved Version: N/A    Added: 10/07/2019
Upgrade - Migration
641719

Return
Projects with large file hierarchy error out during conversion with unclear error message
The conversion tool adds hierarchy to the project structure during conversion that extends the length of the file path. As a result, file paths can become too long for Windows and create a situation where the conversion utility cannot find files at paths that do not exist. This will result in the following error: Conversion could not find this file at specified path
The reason for the file not found is not clear in the action being made.

Workaround: Make shorter file paths initially so the added hierarchy doesn't extend beyond Windows file path limits

Reported Version: 4.8.1    Resolved Version: N/A    Added: 02/26/2018

Document last updated on 10/16/2019

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit