NI-Sync Limitations on Linux Desktop and NI Linux Real-Time

Publish Date: Aug 23, 2019 | 0 Ratings | 0.00 out of 5 | Print

Overview

In some cases, features discussed in the NI-Sync documentation are unavailable on either Linux Desktop or NI Linux Real-Time. This document should be used to understand the limitations of NI-Sync when working on these platforms.

1. API Support

  • The following graphical utilities are not available:
    • LabVIEW Express VIs
    • The Measurement and Automation Explorer (MAX) graphical configuration utility
    • Soft front panels
  • Linux Desktop only: NI-Sync only provides development support for LabVIEW 64-bit and C/C++/ANSI C. See the NI-Sync ReadMe for information on what versions are supported.
  • The NI-Sync API supports a limited property set.
    • Linux Desktop only: Only the following properties are supported:
      • PFI Threshold
      • Serial Number
    • Linux RT only: See your the version specific NI-Sync Help for more information on which properties are supported.

 

Back to Top

2. Hardware Support

  • PXIe-6674T
    • The following features are not supported:
      • Synchronous routing
      • Clock generation
      • Measure Frequency VI
      • Calibration VIs
    • Limited trigger routing is supported. Visit this page for more information.
  • PXI-6683(H)
    • Linux Desktop only: The PXI-6683(H) is currently unsupported.
    • Linux RT only: For more information on PXI-6683(H) support on Linux RT, visit this page.

 

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit