LabVIEW NXG 2.0 Web Module Known Issues

Publish Date: Feb 02, 2018 | 0 Ratings | 0.00 out of 5 | Print

Overview

This document contains known issues for the LabVIEW NXG 2.0 Web Module. Not every issue known to NI will appear on this list; it is intended to only show the severe and more common issues that can be encountered. The LabVIEW 2017 Platform Known Issues contains a full listing of known issues, including LabVIEW toolkits and modules.

Fields

Each Issue appears as a row in the table and includes these fields:
  • Issue ID
  • Issue Title
  • Problem Description
  • Workaround
  • Reported Version - the earliest version of DAQExpress in which the issue was reported
  • Resolved Version - version the issue was resolved or was no longer applicable
  • Date Added - the date the issue was added to the document (not reported date)


Document Organization

There are two versions of the known issues list available:

LabVIEW NXG Web Module Known Issues by Category
LabVIEW NXG Web Module Known Issues by Date

Please refer to Developer Zone Article "LabVIEW Known Issues Categories Defined" for an explanation of the categories and what types of issues are in each category.

Contacting NI

You can contact us by phone, email, or the discussion forums. Visit the NI Website to contact us. If you are contacting NI in regards to a specific issue, be sure to reference the ID number given in this document. If you have feedback on this specific document, please contact NI on this NI Developer Zone post.

Known Issues by Category

The following items are known issues in LabVIEW NXG 2.0 Web Module sorted by Category.

Controls and Indicators
663972 Error messages from the HTTP Client API are truncated
664047 Internal error when creating an I64 ring with multiple items
665293 Selecting a custom color for a plot on a Chart does not properly update the plot's color
666046 Radio Button Group does not resize when additional Radio Buttons are added
666287 Warning when copying a Graph from a VI's Diagram to a Web VI's Diagram
666581 Dragging multiple arrays into a tab control can cause visual issues
666615 A JavaScript error occurs when running a Web VI that uses a Queue reference inside of a Cluster
666971 A JavaScript error occurs when using a Data Grid on a Tab Control with paging enabled.
667006 Internal errors occur when calling a Web VI with a subVI that has an output inside of a Disable Structure
667678 Error clusters always display information in the source string even if no error occurred
669498 Data Grid headers fail to render when running a Web VI or built Web Application
676137 Clicking and dragging to select multiple items within a cluster on the front panel fails
676407 Controls always use their default values when left in the Unplaced Items tray
672725 Data Grid column headers are not visible when a Web VI is running
External Code
673324 Adding items to the FrontPanelCanvas
tags in the HTML panel always places the new items at the top of the section
Functions, VIs, and Express VIs
664268 VI snippets do not create controls on the Panel when placed in a Web VI
666182 When attempting to create a sub VI from code on a Web VI, you can only create a sub Web VI
667139 Queue references cannot be built into an array
669020 String to Number functions may return incorrect values when converting to I64 or U64 data types in Web VIs
670753 Creating a Web VI under a Web Application from the Files pane of the Web Application template project results in a broken Web VI
671454 Providing a username and password when a cross-origin request results in a 401 has varying behavior between browsers. In the LabVIEW NXG editor this will result in a timeout.
LabVIEW Project
667774 The Output tab does not allow horizontal scrolling
Menus
673125 Unsupported items appear in the "New" menu within a Web Application



ID Known Issue
Controls and Indicators
663972

Return
Error messages from the HTTP Client API are truncated

Workaround: Use the "Explain Error" method to receive the full message

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
664047

Return
Internal error when creating an I64 ring with multiple items
A JavaScript error occurs when adding multiple items to a Ring Control with an I64 representation

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
665293

Return
Selecting a custom color for a plot on a Chart does not properly update the plot's color

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
666046

Return
Radio Button Group does not resize when additional Radio Buttons are added

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
666287

Return
Warning when copying a Graph from a VI's Diagram to a Web VI's Diagram
When you copy a VI's Diagram contents and paste them on a Web VI's Diagram, a warning will appear if one of the items is a Graph indicator.

Workaround: Delete the graph terminal and create a new Graph in the Web VI

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
666581

Return
Dragging multiple arrays into a tab control can cause visual issues

Workaround: Save the Web VI and reopen it, or drag a single element into the tab at a time

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
666615

Return
A JavaScript error occurs when running a Web VI that uses a Queue reference inside of a Cluster

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
666971

Return
A JavaScript error occurs when using a Data Grid on a Tab Control with paging enabled.
If a Data Grid with paging enabled is placed on a tab that is not the default tab, a JavaScript error will occur when the tab is selected

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
667006

Return
Internal errors occur when calling a Web VI with a subVI that has an output inside of a Disable Structure

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
667678

Return
Error clusters always display information in the source string even if no error occurred

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
669498

Return
Data Grid headers fail to render when running a Web VI or built Web Application

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
676137

Return
Clicking and dragging to select multiple items within a cluster on the front panel fails

Workaround: Manually select the items within the cluster while holding Shift

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
676407

Return
Controls always use their default values when left in the Unplaced Items tray
If you place a control on the front panel and change its value, that value will be used. However, if you move the control back to the Unplaced Items tray, the value that is passed over the wire is its default value. Moving the control back to the front panel shows the value that was entered, not the default.

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
672725

Return
Data Grid column headers are not visible when a Web VI is running
At edit time, the column headers of a data grid are visible. When you run the Web VI in LabVIEW NXG, or run a built web application in a browser, the headers are no longer visible.

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 02/02/2018
External Code
673324

Return
Adding items to the FrontPanelCanvas
tags in the HTML panel always places the new items at the top of the section
Because the items that are added are always at the top of the section, the content that is added will always appear behind the content that LabVIEW NXG creates

Workaround: Set the z-index property for the item that is being added

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
Functions, VIs, and Express VIs
664268

Return
VI snippets do not create controls on the Panel when placed in a Web VI

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
666182

Return
When attempting to create a sub VI from code on a Web VI, you can only create a sub Web VI

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
667139

Return
Queue references cannot be built into an array
When you index an array of queue references, the resulting reference is not a valid reference

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
669020

Return
String to Number functions may return incorrect values when converting to I64 or U64 data types in Web VIs
When converting from strings to 64-bit numbers, the String to Number functions (Decimal String to Number, Hex String to Number, etc.) can return unexpected results

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
670753

Return
Creating a Web VI under a Web Application from the Files pane of the Web Application template project results in a broken Web VI
When you create a new Web VI from the Files pane as described, the Web VI is targeted to the "This Computer" target. Web VIs will only compile if they are targeted to a "Web Server" target

Workaround: Open the Web VI and select a Web Server target from the target dropdown selection

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
671454

Return
Providing a username and password when a cross-origin request results in a 401 has varying behavior between browsers. In the LabVIEW NXG editor this will result in a timeout.

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
LabVIEW Project
667774

Return
The Output tab does not allow horizontal scrolling

Workaround: Copy the text from the Output tab into another location and read the message there

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018
Menus
673125

Return
Unsupported items appear in the "New" menu within a Web Application
The "New" menu that appears when you right click on a namespace from within a Web Application displays unsupported items such as Resource Collections, etc. These items are not supported on a Web Server target and will be broken.

Workaround: N/A

Reported Version: 2.0    Resolved Version: N/A    Added: 01/23/2018

Document last updated on 2/2/2018

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit