CompactRIO Device Drivers 2017 Q2 Patch

Publish Date: Jun 16, 2017 | 0 Ratings | 0.00 out of 5 | Print

Table of Contents

  1. Fixed Issue
  2. System Requirements
  3. Installing the Patch

1. Fixed Issue

When using a RIO controller in Scan or Hybrid Mode, you can access I/O Variables normally (Scanned Access), or using Direct Access. NI has discovered an issue with an internal component of Scan Mode that can cause write operations to output channels to occasionally fail to update the associated hardware line when using Direct Access.

 

This only affects a subset of RIO users. In order to potentially see this behavior, you must be both:

  • Writing to an I/O Variable Directly using one of these two methods:
  • VI Located in Data Communication >> Shared Variable >> I/O Variable >> Direct Write

  • Using a multi-core controller running Phar Lap ETS or NI Linux RT (commonly cRIO-903x, cRIO-906x, cRIO-908x, sbRIO-96x7, and sbRIO-9651)


Back to Top

2. System Requirements

This patch updates a component distributed by CompactRIO Device Drivers 16.0.0 or 16.1.0. You must have at least one of these products installed before you can apply this patch. Refer to the corresponding readme for system requirements and supported operating systems: Downloads: NI CompactRIO 16.0.


Back to Top

3. Installing the Patch

After you have CompactRIO 16.0.0 or 16.1.0 installed, NI Update Service will allow you to download and install the 16.1.1 patch. The patch is also available from ni.com/downloads.

Once this patch is installed on the development computer, you will need to also install it to your RIO controller. To do so:

  1. Open NI MAX
  2. Locate your target
  3. Select Add/Remove Software by right clicking on Software
  4. In the Software Wizard, select NI CompactRIO 16.0 – August 2016 under the version of LabVIEW you use
  5. In the add-ons screen, select NI-RIO IO Scan 16.1.1

Continue through the wizard to install NI-RIO IO Scan 16.1.1 to the controller. Once this has finished, the fix will be live. The fix also includes a new warning (error code 65734) that will be thrown when using a single hardware line in a program with Scanned Access and Direct Access. This warning will also be populated as a minor Scan Engine fault. For more information about this warning, see KB 7JTDTKHI.

Note: The 16.1.1 fix can be used by LabVIEW 2013 SP1, 2014 SP1, 2015 SP1, and LabVIEW 2016 users.

 

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit