NI-Industrial Communications for CANopen and LabVIEW Compatibility

Publish Date: Jul 30, 2019 | 0 Ratings | 0.00 out of 5 | Print

Overview

This page shows supported versions of the NI-Industrial Communications for CANopen hardware driver with LabVIEW development systems. Reference this information to ensure you install the correct version when upgrading or updating your system or software. Using incompatible versions may result in errors, missing LabVIEW palettes or functions, or devices and tasks failing to show up in NI Measurement & Automation Explorer (MAX).

Note that this article replaces KnowledgeBase 5YE3II5R: NI-Industrial Communications for CANopen and LabVIEW Version Compatibility. Some NI manuals may still reference the previous document. If you were redirected from the previous KnowledgeBase URL, please update your bookmarks accordingly.

1. NI-Industrial Communications for CANopen and LabVIEW Compatibility

Use this table to compare NI-Industrial Communications for CANopen and LabVIEW Compatibility
NI Ind Com for CANopen LabVIEW Version
2010 SP1 2011 SP1 2012 SP1 2013 SP1 2014 SP1 2015 SP1 2016 SP1 2017 SP1 2018 SP1 2019
1.0                    
1.0.1                    
1.0.2                    
1.0.3                    
14.5*                    
15.0                    
16.0                    
17.0                    
18.0                    
19.0                    


*CANopen 14.5 is no longer available on the web. Please see the additional resource section below for details.

  Compatible

Back to Top

2. Additional Resources

 

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit