NI WLAN Toolkit 2017 Q1 Patch Details

Publish Date: Dec 12, 2016 | 0 Ratings | 0.00 out of 5 | Print

The NI WLAN Toolkit 2017 Q1 Patch is available for the NI WLAN Toolkit. NI recommends that you install this patch for all versions from 14.0 to 15.5.
The NI WLAN Toolkit 2017 Q1 Patch is also available via the Update Service. If you already have the NI WLAN Toolkit installed, the Update Service will update your computer with the NI WLAN Toolkit 2017 Q1 Patch that fixes the following issue.


ID: 610307
Description:  On a machine that has NI PXI Platform Services, NI-VISA Runtime, or NI-XNET Runtime installed, one of the following issues can be caused by the WLAN Toolkit installer:
          • niqpxi.dll is downgraded when you upgrade the WLAN Toolkit
          • niqpxi.dll is removed when you uninstall the WLAN Toolkit

This might cause:
          • PXI devices to disappear from the device tree in NI-MAX
          • Incorrect detection of a PXI slot. The most obvious indication of this error is that the PXI slot of a device is reported as -1                   in NI-MAX or when you query this information via the NI system configuration API.  


The presence of the niqpxi dll can be verified at the installation location at C:\Windows\System32. The downgraded version of the niqpxi dll will have the version 1.0.0.49152 (1.0.0f0).

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit