Archived: LabVIEW 2010 Real-Time Module Known Issues and Bug Fixes

Publish Date: Jul 22, 2018 | 0 Ratings | 0.00 out of 5 | Print

Overview

This document has been archived and is no longer updated by National Instruments.

This document contains the known issues for the LabVIEW 2010 Real-Time Module. In addition, you can find a list of known issues from previous versions of the LabVIEW Real-Time Module in the LabVIEW Real-Time Module 2009 Readme. Not every issue known to NI will appear on this list; it is intended only to show the severe and more common issues that can be encountered. Each Issue appears as a row in the table and includes these fields:
  • Issue ID - the number in at the top of each of the cells in the first column. When you report an issue to NI, you may be given this ID, you can also find IDs posted by NI on the discussion forums or in Knowledge Base articles.
  • Legacy ID (optional) - If an issue has a legacy ID from NI's legacy/deprecated bug reporting database, you will see it appear on a separate line directly below the Issue ID in the table, or to the right of the Issue ID in the table of contents (separated by a space).
  • Issue Title: in italics - it describes the issue in one sentence or less
  • Problem Description - a few sentences which describe the problem in further detail. The brief description given does not necessarily describe the problem in full detail, and it is expected that you might want more information on an issue. If you would like more information on an issue feel free to contact NI (contact information below) and reference the ID number given in the document.
  • Workaround - possible ways to work around the problem. The workarounds that appear in the document are not always tested by NI and are not guaranteed to resolve the issue. If a workaround refers you to the NI KnowledgeBase, please visit www.ni.com/kb/ and enter that KB number in the search field to locate the specific document.
  • Reported Version - the earliest version of LabVIEW the issue was reported in. If you discover the issue appears in an earlier version of LabVIEW than is reported in this field, you can report that to NI (contact information below) to have the field updated.
  • Resolved Version - version the issue was resolved or was no longer applicable. If an issue has not been resolved "N/A" will be reported.
  • Date Added - the date the issue was added to the document (not the reported date)

    Known Issues by Date

    The following items are known issues in LabVIEW 2010 Real-Time Module sorted by Date.

    216548 Scan Engine Flags do not Display in Execution Trace Toolkit Traces from Phar Lap Targets
    234411 RT Web Service Build error 1502
    242695 PXIe-8133 Hypervisor system displays invalid configuration message after configuring in Hypervisor Configuration Manager



    ID Known Issue
    216548

    Return
    Scan Engine Flags do not Display in Execution Trace Toolkit Traces from Phar Lap Targets
    NI Scan Engine flags Scan Period, Mode Chance, Fault Added, and Fault Cleared do not display in Execution Trace Toolkit traces. This only occurs on Phar Lap ETS targets.
    Reported Version: 2010    Resolved Version: 2012    Added: 08/03/2010
    234411

    Return
    RT Web Service Build error 1502
    When building a web service for an RT Target error 1502 can occur. This error can occur when building a web service with a web method that contains a VI from the Web Services Palette.

    Workaround: Check the "Remove unused member of project libraries" in the Additional Exclusions category of the Web Service build specification.

    Reported Version: 2010 32-bit    Resolved Version: 2011    Added: 08/03/2010
    242695

    Return
    PXIe-8133 Hypervisor system displays invalid configuration message after configuring in Hypervisor Configuration Manager
    After configuring a PXIe-8133 controller with the NI Real-Time Hypervisor Manager, changing cards to the recommended slot, and restarting the controller, an error message during startup says "The NI Real-Time Hypervisor configuration is invalid".

    Workaround: The solution is discussed in KB 5CO9KBH1: Why do I get the Error Message "The NI Real-Time Hypervisor configuration is invalid" after Configuring my PXIe-8133 Controller?

    Reported Version: 2010    Resolved Version: NI Real-Time Hypervisor 2.1    Added: 08/25/2010

    Known Issues by Category

    The following items are known issues in LabVIEW 2010 Real-Time Module sorted by Category.

    Hypervisor
    242695 PXIe-8133 Hypervisor system displays invalid configuration message after configuring in Hypervisor Configuration Manager
    Installation and Activation
    242695 PXIe-8133 Hypervisor system displays invalid configuration message after configuring in Hypervisor Configuration Manager
    Miscellaneous
    216548 Scan Engine Flags do not Display in Execution Trace Toolkit Traces from Phar Lap Targets
    Web Server/Web Services
    234411 RT Web Service Build error 1502



    ID Known Issue
    Hypervisor
    242695

    Return
    PXIe-8133 Hypervisor system displays invalid configuration message after configuring in Hypervisor Configuration Manager
    After configuring a PXIe-8133 controller with the NI Real-Time Hypervisor Manager, changing cards to the recommended slot, and restarting the controller, an error message during startup says "The NI Real-Time Hypervisor configuration is invalid".

    Workaround: The solution is discussed in KB 5CO9KBH1: Why do I get the Error Message "The NI Real-Time Hypervisor configuration is invalid" after Configuring my PXIe-8133 Controller?

    Reported Version: 2010    Resolved Version: NI Real-Time Hypervisor 2.1    Added: 08/25/2010
    Installation and Activation
    242695

    Return
    PXIe-8133 Hypervisor system displays invalid configuration message after configuring in Hypervisor Configuration Manager
    After configuring a PXIe-8133 controller with the NI Real-Time Hypervisor Manager, changing cards to the recommended slot, and restarting the controller, an error message during startup says "The NI Real-Time Hypervisor configuration is invalid".

    Workaround: The solution is discussed in AE KB 5CO9KBH1: Why do I get the Error Message "The NI Real-Time Hypervisor configuration is invalid" after Configuring my PXIe-8133 Controller?

    Reported Version: 2010    Resolved Version: NI Real-Time Hypervisor 2.1    Added: 08/25/2010
    Miscellaneous
    216548

    Return
    Scan Engine Flags do not Display in Execution Trace Toolkit Traces from Phar Lap Targets
    NI Scan Engine flags Scan Period, Mode Chance, Fault Added, and Fault Cleared do not display in Execution Trace Toolkit traces. This only occurs on Phar Lap ETS targets.

    Reported Version: 2010    Resolved Version: 2012    Added: 08/03/2010
    Web Server/Web Services
    234411

    Return
    RT Web Service Build error 1502
    When building a web service for an RT Target error 1502 can occur. This error can occur when building a web service with a web method that contains a VI from the Web Services Palette.

    Workaround: Check the "Remove unused member of project libraries" in the Additional Exclusions category of the Web Service build specification.

    Reported Version: 2010 32-bit    Resolved Version: 2011    Added: 08/03/2010

    Document last updated on 8/25/2010

    Back to Top

    Bookmark & Share


    Ratings

    Rate this document

    Answered Your Question?
    Yes No

    Submit