Archived: LabVIEW 2010 Toolkits Known Issues

Publish Date: Jul 22, 2018 | 0 Ratings | 0.00 out of 5 | Print

Overview

This document has been archived and is no longer updated by National Instruments.

This document contains known issues for LabVIEW 2010 toolkits. The following toolkits are included:
  • Adaptive Filter Toolkit
  • Advanced Signal Processing Toolkit
  • Database Connectivity Toolkit
  • Desktop Execution Trace Toolkit
  • Digital Filter Design Toolkit
  • PID and Fuzzy Logic Toolkit
  • Report Generation Toolkit for Microsoft Office
  • Simulation Interface Toolkit
  • System Identification Toolkit
  • Unit Test Framework Toolkit
Not every issue known to NI will appear on this list; it is intended to only show the severe and more common issues that can be encountered. If a particular LabVIEW toolkit is not listed below, it currently has no known issues.

The LabVIEW 2010 Platform Known Issues contains a full listing of known issues, including LabVIEW Development System and modules.

Contacting NI

You can contact us by phone, email, or the discussion forums. Visit the NI Website to contact us. If you are contacting NI in regards to a specific issue, be sure to reference the ID. If you have feedback on this document, please contact NI on this NI Developer Zone post.

Known Issues by Category

The following items are known issues in LabVIEW 2010 Toolkits sorted by Category.

Toolkit - Desktop Execution Trace Toolkit
144704 DETT can record "DeQueue Element Awake" - "Awoke with Data" events in the wrong thread
224367 Desktop Execution Trace Toolkit does not trance a LabVIEW built DLL called from LabVIEW
280872 Desktop Execution Trace Toolkit 2010 Does Not Trace VI Executions Under LabVIEW 2010 Japanese
281507 Desktop Execution Trace Toolkit 2010 Does Not Highlight the Traced Items Under LabVIEW 2010 Japanese
Toolkit - Other
177698 [PID and Fuzzy Logic] Center of Sums, Center of Maximum, Mean of Maximum may give NaN result
173851 [SysID]Context help of two options in the Rebuild Missing Data step shows broken links
287441 [PID and Fuzzy Logic] Fuzzy System Designer missing is keyboard shortcuts in menu
211954 [SysID] Estimate Frequeny Response Step in System Identification Assistant does not save settings
249413 [SysID] "a" is not supported as a symbolic variable
257100 [SIT] Deleting an indicator in SIT 2010 VI breaks VI and does not recompile automatically
276747 [SIT] Large arrays are grayed out and will not map to a Simulink model using the Simulation Interface Toolkit
301408 [SIT] SIT fails to create correct path for replay file on PXI controllers
Toolkit - Report Generation
188911 Control image alignment incorrect when "new report page" VI is used
249185 Unable to Create Report from Macro-Enabled Word or Excel Template (.dotm file)
Toolkit - Unit Test Framework
120941 Code Coverage analysis is not supported on LabVIEW Real-Time
160115 lvtest file can not be added to the LabVIEW project if it is in multi-level libraries
175831 Cannot create a test for an XY Graph
171553 File load conflict after dragging multiple LV Classes to another context
254858 ATML/XML Report Causes HTML Report to Generate an Incomplete Report
300593 LabVIEW Unit Test Framework cannot find base LabVIEW Class



ID Known Issue
Toolkit - Desktop Execution Trace Toolkit
144704

Return
DETT can record "DeQueue Element Awake" - "Awoke with Data" events in the wrong thread
The code that records the particular event ("DeQueue Element Awake" - "Awoke with Data") can happen in such a way that we record it in the thread that enqueues the data. It does not mean that the primitive is actually waking up in the same thread.

Workaround: N/A

Reported Version: 1    Resolved Version: N/A    Added: 02/20/2009
224367

Return
Desktop Execution Trace Toolkit does not trance a LabVIEW built DLL called from LabVIEW
Because of the way LabVIEW calls DLLs built in the same or different versions, DETT cannot trace a LabVIEW built DLL.

Workaround: N/A

Reported Version: 2009    Resolved Version: N/A    Added: 08/02/2010
280872

Return
Desktop Execution Trace Toolkit 2010 Does Not Trace VI Executions Under LabVIEW 2010 Japanese
When Destop Execution Trace Toolkit 2010 (DETT) is installed and used under LabVIEW 2010 Japanese, it launches but does not show any tracing behaviors at all.

Workaround: N/A

Reported Version: 2010    Resolved Version: 2011    Added: 08/02/2011
281507

Return
Desktop Execution Trace Toolkit 2010 Does Not Highlight the Traced Items Under LabVIEW 2010 Japanese
Double-clicking a trace item does not highlight the item in question in the block diagram. Instead Error Code 1510 is returned.

Workaround: N/A

Reported Version: 2010    Resolved Version: N/A    Added: 08/02/2011
Toolkit - Other
177698

Return
[PID and Fuzzy Logic] Center of Sums, Center of Maximum, Mean of Maximum may give NaN result
The Center of Sums, Center of Maximum, Mean of Maximum functions give a NaN result for an output variable if this variable contains a Gaussian or a Sigmoid membership function.

Workaround: N/A

Reported Version: 2009    Resolved Version: N/A    Added: 08/05/2009
173851

Return
Context help of two options in the Rebuild Missing Data step shows broken links
On the Configuration tab, the context help of Specify upper limit and Specify lower limit options under Stimulus shows broken links.

Workaround: N/A

Reported Version: 2009    Resolved Version: 2011    Added: 10/01/2009
287441

Return
[PID and Fuzzy Logic] Fuzzy System Designer missing is keyboard shortcuts in menu
The Fuzzy System Designer main user interface is missing the keyboard shortcut associations in the menu file.

Workaround: N/A

Reported Version: 2010    Resolved Version: 2011    Added: 03/24/2011
211954

Return
[SysID] Estimate Frequeny Response Step in System Identification Assistant does not save settings
The value of "Frequency in log" and "Magnitude in dB" are not saved when you save a project. If the project is reopened, these two controls have been reset.

Workaround: N/A

Reported Version: 2010    Resolved Version: 2011    Added: 07/24/2011
249413

Return
[SysID] "a" is not supported as a symbolic variable
If you use "a" as a symbolic variable in System Identification Toolkit, you might encounter unexpected results since "a" is used as a variable internally in the System Identification Toolkit.

Workaround: N/A

Reported Version: 2009    Resolved Version: 2011    Added: 07/24/2011
257100

Return
[SIT] Deleting an indicator in SIT 2010 VI breaks VI and does not recompile automatically
Deleting an indicator from a compiled VI results in a broken error because of a blank event structure inside the SIT portion of the block diagram. Opening the SIT Connection Manager and clicking OK to recompile the SIT portion of the block diagram does not recompile the code and the VI remains broken.

Workaround: Manualy change the mapping in the Connection Manager and then click ok.

Reported Version: 2010    Resolved Version: N/A    Added: 08/02/2011
276747

Return
[SIT] Large arrays are grayed out and will not map to a Simulink model using the Simulation Interface Toolkit
The Simulation Interface Toolkit cannot map an array larger than 10 elements to a Simulink model. If an array larger than 10 elements is mapped in the SIT Connection Manager, the array will become grayed out on the front panel.

Workaround: Break up larger arrays into several smaller arrays with 10 or less elements. Re-combine the elements in Simulink by using the "Mux" block.

Reported Version: 2010    Resolved Version: N/A    Added: 08/02/2011
301408

Return
[SIT] SIT fails to create correct path for replay file on PXI controllers
Error 14112 when using a replay file with SIT with some PXI controls. 8101 and 8108 models have shown this behavior.

Workaround: Change Filename = "/1.tdms" to Filename = "1.tdms" in the ini file located at / replay config/

Reported Version: 2010    Resolved Version: N/A    Added: 08/02/2011
Toolkit - Report Generation
188911

Return
Control image alignment incorrect when "new report page" VI is used
When using the "append control image to report" VI, the alignment of some images is ignored when the "new report page" VI is used between appended images. This problem only exists with Office 2007. Other versions - Office 2003 and Office 2010 do not exhibit this behavior.

Workaround: Place a "new report line" VI between appending the image and the "new page" VI

Reported Version: 2009 32-bit    Resolved Version: N/A    Added: 06/16/2010
249185

Return
Unable to Create Report from Macro-Enabled Word or Excel Template (.dotm file)

Workaround: Add "mtod" to the case containing Word_Create_Document.vi to properly handle these templates. This case structure can be found within the NI_Word:lvclass:new report subVI.vi

Reported Version: 2010 32-bit    Resolved Version: N/A    Added: 10/29/2010
Toolkit - Unit Test Framework
120941

Return
Code Coverage analysis is not supported on LabVIEW Real-Time
The Unit Test Framework Toolkit cannot measure code coverage on real-time (RT) targets. The result will always be zero.

Workaround: N/A

Reported Version: 1    Resolved Version: N/A    Added: 02/06/2009
160115

Return
lvtest file can not be added to the LabVIEW project if it is in multi-level libraries
If lvtest file is in a library, and the library is the sublibrary of another library, the lvtest file can not be added to the LabVIEW project by draging&droping from disk to the project or by using popup menu "Add >> Files..."

Workaround: N/A

Reported Version: 2009    Resolved Version: N/A    Added: 06/16/2009
175831

Return
Cannot create a test for an XY Graph
If the VI has a XY Graph control as input or output, creating a test for this VI will fail (usually with the error "The following control name is not unique"). You will get an error saying that the control name is not unique.

Workaround: N/A

Reported Version: 1    Resolved Version: N/A    Added: 06/23/2009
171553

Return
File load conflict after dragging multiple LV Classes to another context
You will get loading conflict for lvtest files if you open a project which has multiple LV Classes and those classes have lvtest files of the same name. Loading any VI will also be very slow if you have this loading conflict in your project.

Workaround: Rename the lvtest files to different names. Or remove those lvtest files from the project and re-add them.

Reported Version: 2009    Resolved Version: N/A    Added: 08/05/2009
254858

Return
ATML/XML Report Causes HTML Report to Generate an Incomplete Report
When generating an HTML report of a Unit Test, selecting to also generate an ATML/XML report will result in losing the Test Details section of the HTML report.

Workaround: N/A

Reported Version: 2010    Resolved Version: 2011    Added: 08/02/2011
300593

Return
LabVIEW Unit Test Framework cannot find base LabVIEW Class
If you have a VI that contains the LabVIEW base Class you will receive a message "Class type Not Found" when trying to load a .lvtest file.

Workaround: Create your own parent class and make Class 1 inherit from it. Use that parent class object as indicator in test VI. Don't use the built-in LabVIEW Object.

Reported Version: 2010    Resolved Version: N/A    Added: 08/02/2011

Document last updated on 8/2/2011

Back to Top

Bookmark & Share


Ratings

Rate this document

Answered Your Question?
Yes No

Submit