TestStand 2019 Readme

May 2019

This document contains information about TestStand 2019. Refer to the NI TestStand Help for information about getting started with TestStand, such as system requirements, licensing information, and installation instructions. If you do not activate a TestStand license, TestStand operates in Evaluation Mode.

Refer to the What's New in TestStand topics for TestStand 2019 in the NI TestStand Help for detailed information about new features and other changes since TestStand 2017 SP1. Refer to the What's New in TestStand topics for previous versions of TestStand in the NI TestStand Help for information about new features, compatibility and known issues, and bug fixes for those versions.


System Requirements

Supported Operating Systems

Supported Microsoft Software

Application Software Support

Activating TestStand Licenses

Installation Instructions

Upgrading TestStand 2019 Beta to TestStand 2019

Migrating to the Current Version of TestStand 2019

Product Security and Critical Updates

Known Issues

Bug Fixes

Behavior Changes

Accessing the Help

Finding Examples

Automating the Installation of NI Products

Using NI Software with Microsoft Windows 10

Using NI Software with Microsoft Windows 8.1

Additional TestStand Resources

Legal Information


System Requirements

National Instruments recommends the system requirements described in the following table to run TestStand 2019.

Requirement Recommended Minimum
Processor Pentium G1 or equivalent Pentium 4/M or equivalent
Memory 2GB 1 GB
Disk space for TestStand (32- or 64-bit) 1 GB
Disk space for Microsoft .NET Framework version 4.6.2, if not already installed 2.5 GB
Disk space for device drivers from the National Instruments Device Drivers DVD Amount of space required varies depending on the drivers you install. Install only the drivers necessary for the hardware you will use.
Video adapter 1366 x 768 or higher 1024 x 768 resolution

Note  National Instruments recommends that you install Microsoft Hotfix 2588507 for 64-bit Windows operating systems. Visit ni.com/info and enter the Info Code mshotfix for more information about Microsoft Hotfix 2588507.

Supported Operating Systems

Use the Microsoft Windows operating systems and service packs described in the following table with TestStand 2019. You can run 32-bit TestStand 2019 on 32-bit Microsoft Windows operating systems or on 64-bit Windows operating systems, as shown in the following table. 64-bit TestStand 2019 requires a 64-bit version of Windows 7 or later or Windows Server 2008 or later.

Operating System Edition Service Pack (or equivalent) Comments
Windows 10 Professional, Enterprise Build 1703 For more information about NI support for Windows 10, visit ni.com/windows10.
Windows 8.1 Professional, Enterprise Refer to the Using NI Software with Microsoft Windows 8.1 section below for more information about using TestStand on Windows 8.1. For more information about NI support for Windows 8.1, visit ni.com/windows8.
Windows 7 Starter, Professional, Enterprise, Ultimate SP1 Refer to the TestStand and Windows 7/Vista section of the NI TestStand Version 2012 Release Notes for more information about using TestStand on Windows 7. Visit ni.com/info and enter the Info Code exgmjr to locate the NI TestStand Version 2012 Release Notes.
Windows Server 2012 (64-bit) Enterprise R2 TestStand supports only R2 editions of Windows Server.
Windows Server 2008 (64-bit) Enterprise R2

Note  National Instruments recommends that you install Microsoft Hotfix 2588507 for 64-bit Windows operating systems. Visit ni.com/info and enter the Info Code mshotfix for more information about Microsoft Hotfix 2588507.

Note  In 2016 TestStand dropped support for Windows Vista, Windows XP, Windows Server 2003, and installations of Windows 7 without any service packs. TestStand 2019 will not install or run on an unsupported OS. You cannot deploy or distribute applications that use TestStand 2019 to an unsupported OS. Additionally, after installing TestStand 2019, you cannot use any installers built on this computer with any version of LabVIEW, LabVIEW NXG, LabWindows™/CVI™, NI TestStand™, or Measurement Studio on an unsupported OS.

For more information about the changes to our OS support for 2019, refer to KB 79UC78LS, Why Does my LabVIEW, LabWindows/CVI, Measurement Studio, or TestStand Built Installer Fail on Windows XP/Vista and Server 2003?.

Note  Support for Windows 32-bit operating systems may require disabling physical address extension (PAE). To learn how this might affect your system and what actions you might need to take, visit ni.com/info and enter the Info Code PAESupport.

1 NI software installs VC2015 Runtime and .NET 4.6.2. Windows 8.1 and Windows Server 2012 R2 require Microsoft updates to support these items. Refer to Microsoft KB2919442 and KB2919355 for more information about how to install these updates.

2 NI software is signed with a SHA-256 certificate. Windows 7 SP1, Windows Embedded Standard 7 SP1, and Windows Server 2008 R2 SP1 require Microsoft updates to support SHA-256. Refer to Microsoft KB3033929 for more information about how to install this security update.

Supported Microsoft Software

Use the following Microsoft software with TestStand 2019:

  • Microsoft Internet Explorer 11, 10, 9, or 8

    Note  As of TestStand 2019, features such as graph control are supported only in Internet Explorer 11.

  • Microsoft Visual Studio 2017, 2015, or 2013, (Visual Studio 2012 and earlier are not supported.)
  • Microsoft .NET Framework 4.6.2

TestStand includes features that automate Visual Studio for debugging, generating, and editing code module source code. Visual Studio Express Editions do not support these features.

The .NET and Microsoft Foundation Class (MFC) examples include projects and solutions created in Visual Studio 2013.

Application Software Support

TestStand 2019 provides full support for the following application software versions, including service packs. If you are not using NI application software, refer to Microsoft Visual Studio Support.

Supported National Instruments Software for 32-bit TestStand

Software Versions Supported by TestStand 2019 Allowed but not Supported Comments
LabVIEW NXG 3.1, 3.0
LabVIEW (32- and 64-bit) 2019, 2018 SP1, 2017 SP1, 2016 2018, 2017, 2015 SP1, 2014 SP1

LabVIEW examples and user interfaces use files created with LabVIEW 2016.

TestStand API support files for LabVIEW use files saved with LabVIEW 2014 SP1.

TestStand 32-bit supports calling 32-bit VIs using LabVIEW 32-bit RTE, and 32- and 64-bit VIs using the LabVIEW ADE.

LabWindows™/CVI™ 2019, 2017, 2015 SP1, 2013 SP2 Earlier versions of LabWindows™/CVI™

LabWindows™/CVI™ examples, user interfaces, and API use files created with LabWindows™/CVI™ 2013 SP2.

TestStand 32-bit supports calling only 32-bit code modules.

NI Switch Executive 2015, 3.6, 3.5
Requirements Gateway 2018, 2014, 2012

Supported National Instruments Software for 64-bit TestStand

Software Versions Supported by TestStand 2019 Allowed but not Supported Comments
LabVIEW NXG 3.1, 3.0
LabVIEW (32- and 64-bit) 2019, 2018 SP1, 2017 SP1, 2016 2018, 2017, 2015 SP1, 2014 SP1

LabVIEW examples and user interfaces use files created with LabVIEW 2016.

TestStand API support files for LabVIEW use files saved with LabVIEW 2014 SP1.

TestStand 64-bit supports calling 64-bit VIs using LabVIEW 64-bit RTE, and 32- and 64-bit VIs using the LabVIEW ADE.

LabWindows™/CVI™ 2019, 2017, 2015 SP1, 2013 SP2 Earlier versions of LabWindows™/CVI™

LabWindows™/CVI™ examples, user interfaces, and API use files created with LabWindows™/CVI™ 2013 SP2.

TestStand 64-bit supports calling only 64-bit code modules.

NI Measurement Studio - Visual Studio MFC Legacy Support Measurement Studio classes cannot be used in 64-bit applications.
NI Switch Executive 2018, 2015
Requirements Gateway 2018, 2014, 2012 1.1

TestStand can execute code modules developed with versions of ADEs other than the listed supported versions, but National Instruments performs only limited testing with earlier versions of ADEs. TestStand might be able to execute code modules developed with versions of ADEs later than the listed supported versions, but National Instruments cannot ensure support for versions released after TestStand 2019. Visit ni.com/info and enter the Info Code tslcp for more information about the TestStand life cycle policy.

Microsoft Visual Studio Support

TestStand 2019 supports the following Microsoft Visual Studio versions and associated programming languages.

Programming Languages Visual Studio Versions Supported by TestStand 2019
.NET Framework 4.6.2 Languages
(Visual C#, Visual Basic .NET)
2013, 2015, or 2017

Recommended Database Client Software

Use the following recommended database client software with the database components included with TestStand:

  • Microsoft Access—(64-bit TestStand) Use the Microsoft Office 12.0 Access Database Engine OLE DB Provider. You can download this provider from the Microsoft website at www.microsoft.com.

    Note  You cannot install the Microsoft Office 12.0 Access Database Engine OLE DB Provider with 32-bit Microsoft Office. Visit ni.com/info and enter the Info Code 64TSaccdb to access the National Instruments support article, Using Microsoft Access Databases with 64-bit TestStand, for more information about installing this provider.

  • Microsoft SQL Server—Use the SQL Server Native Client 10.0 or later or the Microsoft OLE DB Provider for SQL Server provider.
  • Oracle—Use the latest Oracle Provider for OLE DB and Oracle Client software. National Instruments recommends Oracle Client 12c Release 1, version 12.1.0.1.0 or later. You can download the Oracle Provider from the Oracle website at www.oracle.com.

    Note National Instruments does not recommend using the Microsoft OLE DB Provider for Oracle because it does not support all the OLE DB features TestStand requires.

    Note Oracle recommends using Oracle Provider 11.1.0.6.0 or later if you want to read 64-bit integer values stored in NUMBER columns.

  • MySQL—Use the MySQL Open Database Connectivity (ODBC) Driver 5.1 or later.
  • Sybase SQL Anywhere—Use the Adaptive Server Anywhere ODBC Driver 10.0 or later.

Activating TestStand Licenses

After you install TestStand, you must use the NI Activation Wizard to activate the software or initiate the evaluation period for the software.

National Instruments offers a variety of licenses for the different ways you can use TestStand in development and deployment applications. You can select from the following types of licenses:

  • TestStand Development System License
  • TestStand Custom Sequence Editor License
  • TestStand Debug Deployment Environment License
  • TestStand Base Deployment Engine License

In most cases, when you first install TestStand, you activate a TestStand Development System License. Use the other licenses to activate TestStand on computers to which you deploy TestStand custom sequence editors or user interfaces you develop.

Contact a local National Instruments representative for more information or for questions about specific licensing needs.

Note  If you upgrade TestStand with a service pack release by installing TestStand or a deployment that includes the TestStand Engine, the TestStand Engine on the computer becomes unlicensed. You must reactivate the license on the computer. A TestStand Development System License or a Debug Deployment Environment License must be current with the Standard Service Program (SSP) to reactivate a service pack license. You can reactivate a Custom Sequence Editor License for a service pack upgrade, even if the SSP for the original license lapsed. A TestStand Base Deployment License does not require SSP to reactivate a service pack license.

Refer to the Licensing Options for TestStand Systems section of Chapter 1, Introduction to TestStand , of the Getting Started with TestStand manual for information about how to use the available licenses when you build a TestStand-based test solution. Use the following descriptions only as a reference for the licensing options. Visit ni.com/activate for more information about activating TestStand licenses. Visit ni.com/teststand to purchase a TestStand license.

Note  This document does not replace the National Instruments Software License Agreement installed in the <Program Files>\National Instruments \Shared\MDF\Legal\license\NIReleased directory.

TestStand Evaluation Package

When you run TestStand in Evaluation Mode, the software expires after 7 days. You can generate a User Profile at ni.com to extend the evaluation period for an additional 45 days.

The Evaluation Mode software runs as a fully functional TestStand Development System during the evaluation period. You can activate a license at any point during or after the evaluation period.

TestStand Development System License (777777-35)

Activate the TestStand Development System License to develop and edit test sequences and to save sequence files within the TestStand Sequence Editor, within a TestStand custom sequence editor, or programmatically using the TestStand API. This license also grants the right to develop custom sequence editors and operator interfaces. You must have an ni.com User Profile to activate a TestStand Development System license.

TestStand Custom Sequence Editor License (777775-35)

Activate the TestStand Custom Sequence Editor License to develop and edit test sequences and sequence files within a custom sequence editor or programmatically using the TestStand API.

TestStand Debug Deployment Environment License (779851-35)

The TestStand Debug Deployment Environment License offers the most flexibility for deploying TestStand and LabVIEW-based, LabWindows/CVI-based, and Measurement Studio-based systems.

Activate this license to install the development versions of TestStand, LabVIEW, LabWindows/CVI, Measurement Studio, and any corresponding add-on toolkits on a single test station so you can debug deployed test applications on the test station. This license grants the right to make minor edits to fix bugs in deployed test applications but does not grant the right to perform any development tasks using TestStand, LabVIEW, LabWindows/CVI, or Measurement Studio on the test station.

You cannot activate and deactivate the TestStand Debug Deployment Environment License and reuse it on multiple computers. If you need to use a single debug license across multiple computers, contact National Instruments for more information about the Concurrent TestStand Debug Deployment Environment License.

TestStand Base Deployment Engine License (777774-35)

The TestStand Base Deployment Engine License is the minimum license required for all deployed TestStand-based applications. Activate this license to deploy the TestStand Runtime, a TestStand Operator Interface, and sequence files to the single test station to which the license applies. This license does not grant the right to perform any development tasks using the TestStand Sequence Editor, a TestStand custom sequence editor, or the TestStand API.

Installation Instructions

Unless you specify another location during installation, the TestStand installer copies core files to <Program Files>\National Instruments\TestStand 2019.

You cannot install TestStand 2019 over a previous version, such as TestStand 2017 SP1, and you cannot install TestStand 2019 in the default installation directory for a previous version. If you installed a previous version of TestStand in a non-default directory, you can uninstall the previous version of TestStand and install TestStand 2019 to that directory.

Note  If you uninstall one bitness of a TestStand version, National Instruments recommends that you use the TestStand Version Selector to reactivate the remaining bitness of that version and launch TestStand to properly register its components.

Note  You cannot install TestStand to a network path or a mapped network path. You must install TestStand on a local computer.

National Instruments recommends exiting all programs before running the TestStand installer. Applications that run in the background, such as virus scanning utilities, might cause the installer to take longer than necessary to complete.

Complete the following steps to install TestStand.

  1. Log on as an administrator or as a user with administrator privileges.
  2. Insert the TestStand installation media and follow the instructions that appear on the screen.

    National Instruments recommends installing the complete TestStand program. If you perform a custom installation and do not install all the TestStand features, you can run the installation program again later to install additional features.

    Note  If you do not install some TestStand features and then you later use the standard Windows Control Panel facility for adding and removing programs to install the features, the features might not correctly register, and TestStand will display a COM error the next time you launch TestStand. This error occurs even if you restart the computer after you use the Windows Control Panel to install the features. National Instruments recommends that you reactivate TestStand using the TestStand Version Selector after you install the features.

Installing Additional Software Components

Note  TestStand includes the device driver software on a DVD. If you require device driver software on CDs, visit ni.com/info and enter the Info Code drivercd.

TestStand installs the following additonal software components:

  • .NET Framework 4.6.2
  • LabVIEW 2018 SP1 Run-Time Engine (RTE)
  • LabWindows™/CVI™ 2019 RTE
  • LabWindows™/CVI™ SQL Toolkit 2.4
  • National Instruments Session Manager
  • NI Update Service
  • NI License Manager
  • TestStand Version Selector

Note  TestStand can use newer versions of the LabVIEW RTE when you install LabVIEW on a development system. You can include newer versions of the LabVIEW RTE in deployments using the Drivers and Components dialog box of the TestStand Deployment Utility. Refer to the TestStand Help for more information about the Drivers and Components dialog box.

The National Instruments Device Driver DVD contains the following suggested components:

  • National Instruments Measurement & Automation Explorer (MAX)
  • Interchangeable Virtual Instrument (IVI) Compliance Package (ICP)
  • To use IVI, download and install IVI-compliant drivers from the Instrument Driver Network, located at ni.com/devzone/idnet.

    Installing Multiple Versions of TestStand on the Same Computer

    You can install TestStand 2019 on a computer that contains a previous TestStand version, but you cannot install TestStand 2019 over a previous TestStand version. You cannot install TestStand 2019 in the default installation directory for a previous version of TestStand. For example, TestStand 2019 does not install in <Program Files>\National Instruments \TestStand 2017 . If you installed a previous version of TestStand in a non-default directory, you can uninstall the previous version of TestStand and install TestStand 2019 to that directory.

    Using the TestStand Version Selector

    The TestStand Version Selector application indicates the active version of TestStand and can activate a different version of TestStand. Although you can install more than one version of TestStand on a computer, only one version of TestStand can be active and can run at a time.

    The TestStand Version Selector application, TSVerSelect.exe, is located in the <Program Files>\National Instruments\Shared\TestStand Version Selector directory. You can launch the TestStand Version Selector in the following ways:

    • (Windows 8.1) Click the NI Launcher tile on the Start screen and select TestStand Shared»TestStand Version Selector.
    • (Windows 10 or 7) Select Start»All Programs»National Instruments»TestStand Shared»TestStand Version Selector.

    The Current Active Version control shows the currently active version of TestStand. Select a version in the Installed TestStand versions control and click the Make Active button to activate a specific version of TestStand. The Path where 32-bit version is installed and Path where 64-bit version is installed controls show the locations of the selected version of TestStand. When activation is complete, the selector displays a message to indicate success or display any warnings. Click the Launch 32-bit or Launch 64-bit button to run the sequence editor application for the active version of TestStand.

    If you activate TestStand 2019 and run a TestStand User Interface from a previous TestStand version, the user interface uses the TestStand 2019 Engine, step types, and components. If you activate a previous TestStand version and run a TestStand 2019 User Interface or the sequence editor, those applications do not function correctly.

    Note  The TestStand Version Selector does not typically require administrator privileges to activate a specific version of TestStand on Microsoft Windows 10/8.1/7. To require administrator privileges for using the TestStand Version Selector, add the /reqadmin command-line option to the selector shortcut.

    Refer to the TestStand Help for more information about using the TestStand Version Selector.

    Upgrading TestStand 2019 Beta to TestStand 2019

    Before you install the final release version of TestStand 2019, you must first uninstall TestStand 2019 Beta and then manually delete the <TestStand Public>\TestStand 2019\User Interfaces directory.

    Migrating to the Current Version of TestStand

    If you are upgrading from TestStand 2010 or later, you can use the TestStand Migration Utility to migrate customizations and configuration settings from the earlier version of TestStand. You can also upgrade manually. Visit ni.com/info and enter the Info Code tsmigrate for more information about migrating to the current version of TestStand, including information about tasks you need to perform to upgrade manually from TestStand 4.2.1 or earlier.

    You can also migrate from 32-bit TestStand 2019 to 64-bit TestStand 2019 or from 64-bit TestStand 2019 to 32-bit TestStand 2019. Refer to the Cross-Bitness Migration section of this document for more information about migrating to or from 64-bit TestStand 2019.

    Migrating from TestStand 2010 or Later Using the TestStand Migration Utility

    Complete the following steps to use the TestStand Migration Utility to copy settings, configuration, and public component files from the directories of TestStand 2010 or later to the current version of TestStand.

    1. Launch the TestStand Migration Utility.
      Platform Description
      Windows 8.1 Click the NI Launcher tile on the Start screen and select TestStand»Tools»Compatibility»TestStand Migration Utility.
      Windows 10 or 7 Select Start»All Programs»National Instruments»TestStand»Tools»Compatibility»TestStand Migration Utility.

      If you have more than one version of TestStand installed on the computer, the utility launches a dialog box in which you can specify the previous version of TestStand from which you want to migrate.

      Note  When you migrate from TestStand 2010 SP1 or TestStand 2010 to the current version of TestStand, the utility migrates the report and database options to the format for result processing configuration options for the current version of TestStand. Refer to the the TestStand Help for more information about the using the TestStand Migration Utility. Visit ni.com/info and enter the Info Code tsmigrate for more information about using the utility to migrate result processing configuration options.

    2. Select the previous version of TestStand.

      The utility checks the computer for all the files you can migrate to determine whether the files have changed since installation. The utility launches a status indicator dialog box during this process. When the utility finishes checking the files for changes, the utility main window launches.

    3. Use the Files to Copy control to select the files you want to copy.

      By default, the utility selects files you added or modified in the previous version of TestStand.

    4. Expand the directories in the Files to Copy control to view the files you can migrate and whether those files have changed since installation.

      The Conflicts column includes any conflicts that might affect the migration of the files you specify.

      Note   The utility overwrites any file you create or modify in the current version of TestStand if the file also exists in the corresponding directory of the previous version of TestStand and if you select the file in the Files to Copy control. Although the utility creates a backup copy of all overwritten files, verify that the utility will not overwrite any files you intend to keep in the version of TestStand to which you are migrating.

    5. Click Migrate Files to begin the migration.

      When the migration completes successfully, the utility generates a text file report that contains the results of the migration, including where the utility stored the file backups and which files were moved.

      Note  Consider the following behavior when using the TestStand Migration Utility:

      • The utility only moves files and does not update any other information or settings, such as registry keys.
      • If the <TestStand Public>\Components directory of the previous version of TestStand includes files installed by an installer other than the TestStand installer, you might need to use that specific installer to move the files for the files to function and uninstall properly from the <TestStand Public>\Components directory of TestStand 2019.

        National Instruments recommends that you use an installer that targets TestStand 2019 to install any such components instead of using the utility to copy the components. However, some installed components can function properly when copied to another directory and are safe to migrate with the utility.

      • The Migration Utility does not copy files in the <TestStand>\Examples, <TestStand>\Tutorial, or <TestStand>\AdapterSupport directories. These directories do not appear in the Files to Migrate column of the utility.

    Cross-Bitness Migration

    National Instruments recommends upgrading to 64-bit TestStand 2019 from a prior 32-bit version in two steps. First, upgrade to 32-bit TestStand 2019 and validate that the system works as expected. Then, migrate from 32-bit TestStand 2019 to 64-bit TestStand 2019. Performing the upgrade in two steps can help isolate the root cause of issues you encounter.

    Migrating to 64-bit TestStand 2019 might require additional manual steps after the Migration Utility completes. You must update bitness-specific files to support the new architecture. For example, if the Migration Utility copies a LabWindows/CVI DLL code module from 32-bit TestStand to 64-bit TestStand, 64-bit TestStand cannot load the 32-bit DLL. You must replace the 32-bit DLL with an equivalent 64-bit DLL. Additionally, code modules you place or install under the <TestStand Public> directory might require additional work depending on the type and implementation of the code module.

    Refer to the 64-bit TestStand and Migrating from 32-bit TestStand book in the Fundamentals book of the TestStand Help for more information about migrating between 32- and 64-bit TestStand.

    Migrating TestStand 2010 SP1 or Earlier Result Processing Options to the Current Version of TestStand

    The TestStand 2012 or later process models include significant changes to implement a plug-in architecture for model sequence files. TestStand 2012 or later uses the plug-in mechanism to decouple result processing from the process models. As part of this change, the result processing options move from the TestStandModelReportOptions.ini and TestStandDatabaseOptions.ini files into a single ResultProcessing.cfg file, located in the <TestStand Application Data>\Cfg directory, that stores configuration information for all result processing model plug-ins.

    The result processing options files from TestStand 2010 SP1 or earlier are not compatible with TestStand 2012 or later process models. Refer to the Process Model Result Processing Plug-in Architecture section of the TestStand 2012 New Features topic in the TestStand Help for more information about the TestStand 2012 or later process models. Refer to the Using the Legacy Model Switcher Tool section of the TestStand 2012 New Features topic in the TestStand Help for more information about using the Legacy Model Switcher tool to use the equivalent legacy TestStand 2010 process models.

    The following table describes the migration actions you can select in the TestStand Migration Utility to migrate the result processing configuration options from TestStand 2010 SP1 or earlier to the current version of TestStand.

    Note The utility does not support migrating the configuration files from TestStand 2010 SP1 or earlier if you modified the ReportOptions or DatabaseOptions data types defined in the default process models.

    Migration Action Description
    Apply to new models Creates a new configuration in a configuration set named Migrated from TestStand <Version>. The utility automatically selects a unique name for the configuration if the utility has already used the default name in a previously completed migration. Refer to the migration report for the specific configuration names the utility uses.
    Apply to legacy models Copies the options files from TestStand 2010 SP1 or earlier to the current TestStand directory so you can use the previous configurations with the equivalent legacy TestStand 2010 process models in the current version of TestStand. When you migrate database options, the utility renames TestStandDatabaseOptions.ini to TestStandDatabaseSchemas.ini.
    Apply to new and legacy models Adds a new configuration in the Migrated from TestStand <Version> configuration set and copies the options files from a previous version of TestStand.

    If you are upgrading from TestStand 4.2.1 or earlier, you can manually migrate result processing options for use with TestStand 2012 or later process models or the equivalent legacy TestStand 2010 process models. Visit ni.com/info and enter Info Code tsmigrate for more information about manually migrating result processing options to TestStand 2019.

    Product Security and Critical Updates

    Visit ni.com/security to view and subscribe to receive security notifications about NI products. Visit ni.com/critical-updates for information about critical updates from NI.

    Known Issues

    You can access the software and documentation known issues list online. Refer to the National Instruments website for an up-to-date list of known issues in TestStand 2019.

    Bug Fixes

    Refer to the List of Bug Fixes in TestStand 2019 on the National Instruments website for a list of a subset of issues fixed in TestStand 2019. This is not an exhaustive list of issues fixed in TestStand 2019. If you have a Corrective Action Request (CAR) ID, you can search this list to determine whether the issue has been fixed.

    Behavior Changes

    (Windows) When you build an installer in TestStand, the default name of the executable changed from setup.exe to install.exe. This behavior change may have potential impact to post-build processes that rely on the setup.exe name. To specify a different name for the executable, use the Installer name option on the Product Information page of the Installer Properties dialog box.

    IVI Step Types

    TestStand 2019 does not natively include IVI step types. Visit the NI website to download IVI step types for TestStand 2019.

    Deprecation of the INI File Format

    Configuring TestStand files to save using the INI file format is deprecated in TestStand 2019. Saving files in the INI file format will be deprecated in a future release of TestStand. In TestStand 2019, the following user interfaces now restrict you to selecting only the XML or binary formats:

    • The File Format Options dialog box displayed when you select the File tab of the Station Options dialog box.
    • The General tab of the Sequence File Properties dialog box displayed when you select Edit»Sequence File Properties in the Sequence Editor.
    • The Update Sequence Files tool displayed when you select the Tools menu in the Sequence Editor.
    • Note  If you change a file you store in an SCC system from INI (or XML) to binary, you must update the SCC system to set the file type as binary. Otherwise, the SCC provider may incorrectly process the binary content of the file as white space and produce a corrupt file.

    Accessing the Help

    Refer to the NI TestStand Help for information about TestStand 2019. You can access the NI TestStand Help in the following ways:

    • Select Help»NI TestStand Help in the sequence editor.
    • (Windows 10) Select Start and launch the NI Launcher application, and select TestStand»TestStand Documentation»TestStand Help.
    • (Windows 8.1) Click the NI Launcher tile on the Start screen and select TestStand»TestStand Documentation»TestStand Help.
    • (Windows 7 or earlier) Select Start»All Programs»National Instruments»TestStand» TestStand Documentation»TestStand Help .

    Finding Examples

    TestStand includes a variety of example programs that you can use to help you learn key concepts or to serve as a starting point for applications you create. You can browse the examples in the following ways:

    • Open the Examples.tsw workspace file located in the <TestStand Public>\Examples directory.
    • Open an example sequence file from the subdirectories of the <TestStand Public>\Examples directory.

    Select Help»Find Examples to launch the NI TestStand Example Programs Help from the TestStand Sequence Editor.

    Automating the Installation of NI Products

    You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes.

    If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

    For more information about automating the installation of NI products, refer to the following KnowledgeBase articles:

    Using NI Software with Microsoft Windows 10

    Microsoft Windows 10 is the latest version of the Windows operating system and features significant changes compared to previous versions. Windows 10 introduces several new capabilities and also combines features from both Windows 7 and Windows 8. For more information about NI support for Windows 10, visit ni.com/windows10.

    Using NI Software with Microsoft Windows 8.1

    When you install NI software on Microsoft Windows 8.1, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, Measurement & Automation Explorer (NI MAX), and NI Launcher. For more information about NI support for Windows 8.1, visit ni.com/windows8.

    Additional TestStand Resources

    Refer to the Technical Support page at ni.com/support and search for TestStand to access the TestStand Support website, which contains online documentation, KnowledgeBase articles, tutorials, example code, discussion forums, and other resources.


    Legal Information

    Copyright

    © 2000–2019 National Instruments. All rights reserved.

    Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

    NI respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

    End-User License Agreements and Third-Party Legal Notices

    You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

    • Notices are located in the <National Instruments>\_Legal Information and <National Instruments> directories.
    • EULAs are located in the <National Instruments>\Shared\MDF\Legal\license directory.
    • Review <National Instruments>\_Legal Information.txt for information on including legal information in installers built with NI products.

    U.S. Government Restricted Rights

    If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

    IVI Foundation Copyright Notice

    Content from the IVI specifications reproduced with permission from the IVI Foundation.

    The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

    Trademarks

    Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on NI trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

    Patents

    For patents covering the NI products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the NI Patent Notice at ni.com/patents.

    376434F-01