Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

LabVIEW 2015 Model Interface Toolkit Readme

August 2015

This file contains important information about the LabVIEW Model Interface Toolkit, including installation instructions, system requirements, and known issues.

Overview

System Requirements

Application Software Support

Installation Instructions

New Features

Upgrade and Compatibility Issues

Documentation Corrections

Known Issues

Accessing the Software and Help

Finding Examples

Automating the Installation of NI Products

How to Use NI Software with Microsoft Windows 8

NI Software Support for Microsoft Windows Vista, Windows XP, and Windows Server 2003


Overview

The LabVIEW Model Interface Toolkit allows you to connect simulation models from a variety of simulation environments and programming languages to real-world I/O.

System Requirements

The LabVIEW 2015 Model Interface Toolkit requires the LabVIEW 2015 Full or Professional Development System (32-bit) and any system requirements for LabVIEW 2015. Refer to the LabVIEW Readme for additional system requirements and supported operating systems for LabVIEW 2015.

To integrate and run your existing compiled models, you need only the Model Interface Toolkit installed. However, to perform other tasks with models you need additional software, as the following list describes:

If you use other modeling environments, contact your model vendor for requirements for developing a model and converting it into a compiled model.

Application Software Support

The following table lists the application software versions, including service packs, supported by the Model Interface Toolkit 2015.

Application SoftwareVersions Supported by Model Interface Toolkit
LabVIEW Full or Professional Development System (32-bit) 2015

Installation Instructions

Complete the following steps to install the Model Interface Toolkit:

  1. On a computer with the LabVIEW Development System installed, insert the VeriStand DVD you received with your purchase and run the VeriStand installer.
  2. Select the Model Interface Toolkit item on the feature selection screen of the VeriStand installer.
  3. (Optional) Select the NI VeriStand Model Framework item if you want to compile models developed in C/C++ or the Simulink software.
  4. (Optional) Select the NI VeriStand LabVIEW Model Support item if you want to compile LabVIEW VIs into models.
  5. (Optional) If your application requires integration with NI hardware, leave the NI Device Drivers DVD item selected. When prompted, insert the NI Device Drivers DVD and follow the instructions that appear on screen to install the appropriate hardware drivers.

Note  If you purchased this product with an NI Software Suite or NI Product Bundle, use the installation media that shipped with your purchase to install this product.

Product Security and Critical Updates

Visit ni.com/security to view and subscribe to receive security notifications about NI products. Visit ni.com/critical-updates for information about critical updates from NI.

New Features

The LabVIEW 2015 Model Interface Toolkit contains the following new features.

Support for Intel x64-based Targets

The LabVIEW 2015 Model Interface Toolkit supports models compiled for Intel x64-based targets that run the NI Linux Real-Time operating system.

For information on compiling models for NI Linux Real-Time targets, refer to the help topic Compiling a Model from The MathWorks, Inc. Simulink® Software (Model Interface Toolkit) in the LabVIEW Help.

Upgrade and Compatibility Issues

The VeriStand Model Framework contains changes to the files you use to develop and compile models in C/C++ and third-party modeling environments. If your system contains models compiled with previous versions of the Model Framework, choose from the following options for continuing to use the models in VeriStand 2015:

New Location for VeriStand Model Framework Examples

The example models included with the Model Framework are located at RootDrive:\VeriStand\version\ModelInterface\custom\examples.

Documentation Corrections

Documentation Corrections

The following topics in the LabVIEW Help contain gaps or outdated information:

Known Issues

You can access the software and documentation known issues list online. Visit ni.com/info and enter the Info Code LVMIT2015KI for an up-to-date list of known issues in the LabVIEW 2015 Model Interface Toolkit.

Bug Fixes

The following items are the IDs and titles of a subset of issues fixed in the Model Interface Toolkit. This is not an exhaustive list of issues fixed in the current version of the toolkit. If you have a CAR ID, you can search this list to validate the issue has been fixed.

ID Fixed Issue
519509 Compilation of a The MathWorks, Inc. Simulink® model with Data Store Memory fails for NI Linux Real-Time targets
507923 Compilation of The MathWorks, Inc. Simulink® model fails when using alias or fixed-point types in bus objects
486719 Compilation of The MathWorks, Inc. Simulink® model fails when a referenced model uses tunable parameters

Accessing the Software and Help

To access the Model Interface Toolkit VIs, select View»Functions Palette from the block diagram in LabVIEW and navigate to the Control Design & Simulation»Model Interface palette. You also can right-click any blank space on the block diagram to display the Functions palette.

Refer to the Toolkits»Model Interface Toolkit book on the Contents tab of the LabVIEW Help for more information about the Model Interface Toolkit.

Finding Examples

Select Help»Find Examples from LabVIEW to launch the NI Example Finder. LabVIEW examples for the Model Interface Toolkit are located in the labview\examples\Control and Simulation\Model Interface directory. You can modify an example VI to fit an application, or you can copy and paste from one or more examples into a VI that you create.

Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes. However, starting with the August 2012 releases (products using NI Installers version 3.1 or later), you may need to perform additional steps before or during a silent installation of NI software.

If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

For more information about automating the installation of NI products, refer to the following KnowledgeBase articles:

How to Use NI Software with Microsoft Windows 8.x

When you install NI software on Microsoft Windows 8.x, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, Measurement & Automation Explorer (NI MAX), and NI Launcher.

Using NI Launcher

NI Launcher helps you find and launch installed NI products. It provides you with a method of finding NI products similar to the Start menu in previous versions of Microsoft Windows. To use NI Launcher, click the NI Launcher tile in the Apps view. NI Launcher launches the desktop and opens a menu containing a list of NI products. Click any NI product to launch it.

Note  NI MAX does not appear as a desktop shortcut when installed on Microsoft Windows 8.x. You can launch NI MAX either from the Apps view or from within NI Launcher.

Pinning Frequently Used Applications

For convenience, you can pin your most-used NI applications, such as MAX, to either the Start screen or the Taskbar on the desktop, as necessary:

Current ApplicationIcon LocationPin to Action
Windows 8.x DesktopDesktop TaskbarRight-click application and select Pin to Taskbar
Windows 8.x Desktop Start screenRight-click application and select Pin to Start
Windows 8.x Start screenDesktop TaskbarRight-click application and select Pin to taskbar from the menu bar on the bottom of the screen

Finding All Programs

If you want to find a particular application or related files, such as documentation files, from the Start screen, you can access all installed files from the Apps view. To get to the Apps view, right-click anywhere on the Start screen and select All apps (Windows 8.0) or click the down arrow on the bottom left of the screen (Windows 8.1).

For more information about NI support for Windows 8.x, visit ni.com/windows8.

NI LabVIEW Drops Support for Microsoft Windows Vista, Windows XP, and Windows Server 2003 in 2016

NI LabVIEW will drop support for Microsoft Windows Vista, Windows XP, and Windows Server 2003 as of July 1, 2016. Versions of LabVIEW that ship after July 1, 2016 will not install or run on Windows Vista, Windows XP, or Windows Server 2003. For detailed information about NI application software product life cycles, visit ni.com/info and enter one of the following Info Codes:

Product Info Code
LabVIEWlifecycle
LabWindows™/CVI™cvi_lifecycle
Measurement Studiomstudiolifecycle
TestStandtslcp
DIAdemddlcp
SignalExpressselcp
VeriStandnivslifecycle

Important Information

Copyright

© 2013-2015 National Instruments. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

NI respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on NI trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the NI products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the NI Patent Notice at ni.com/patents.

375381A-01