NI-SCOPE 18.7 Readme

November 2018

This file contains important information about the NI-SCOPE driver, including installation instructions, new features, and known issues.

If you plan to use LabVIEW NXG, refer to LabVIEW NXG Support and Considerations.


Overview

System Requirements

Supported Operating Systems

Application Software Support

Installation Instructions

Product Security and Critical Updates

New Features

Supported Hardware

Known Issues

Bug Fixes

Accessing the Help

Finding Examples

LabVIEW NXG Support and Considerations

Automating the Installation of NI Products

Using NI Software with Microsoft Windows 10

Using NI Software with Microsoft Windows 8.1

Legal Information


Overview

NI-SCOPE is an NI instrument driver that enables you to implement multirecord acquisition, continuous acquisition, multiboard synchronization, more than 50 measurement and analysis functions, and the functionality of traditional oscilloscopes. NI-SCOPE is an interchangeable virtual instrument (IVI)–compliant instrument driver, and it features a set of operations and properties that exercise the functionality of the oscilloscope and includes an interactive soft front panel and examples.

System Requirements

NI-SCOPE 18.7 has the following requirements:

  • 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor
  • 1 GB RAM (32-bit) or 2 GB RAM (64-bit)
  • A screen resolution of 1,024 x 768
  • If you are running your application on an RT target, at least 128 MB of memory

Supported Operating Systems

NI-SCOPE 18.7 supports the following operating systems:

  • Windows 10/8.11/7 SP12
  • Windows Embedded Standard 7 SP12
  • Windows Server 2012 R21
  • Windows Server 2008 R2 SP12
  • Linux
    • Red Had Enterprise Linux Desktop + Workstation 6.x, 7.x
    • CentOS 7.x
    • OpenSUSE Leap 42.2, 42.3

Note  In 2016, NI-SCOPE dropped support for Windows Vista, Windows XP, Windows Server 2003, and installations of Windows 7 without any service packs. NI-SCOPE will not install or run on an unsupported OS. You cannot deploy or distribute applications that use NI-SCOPE to an unsupported OS. Additionally, after installing NI-SCOPE 18.7, you cannot use any installers built on this computer with any version of LabVIEW, LabWindows™/CVI™, NI TestStand™, or Measurement Studio on an unsupported OS.

For more information about the changes to our OS support for 2016, refer to KB 79UC78LS, Why Does My NI ADE Installer Fail on Windows XP/Vista and Windows Server 2003?.

Note  Support for Windows 32-bit operating systems may require disabling physical address extension (PAE). To learn how this might affect your system and what actions you might need to take, visit ni.com/info and enter the Info Code PAESupport.

1 NI software installs VC2015 Runtime and .NET 4.6.2. Windows 8.1 and Windows Server 2012 R2 require Microsoft updates to support these items. Refer to Microsoft KB2919442 and KB2919355 for more information about how to install these updates.

2 NI software is signed with a SHA-256 certificate. Windows 7 SP1, Windows Embedded Standard 7 SP1, and Windows Server 2008 R2 SP1 require Microsoft updates to support SHA-256. Refer to Microsoft KB3033929 for more information about how to install this security update.

Application Software Support

NI-SCOPE supports the following application software versions, including service packs. If you are not using NI application software, refer to Microsoft Visual Studio Support.

Application SoftwareVersions Supported by NI-SCOPE
LabVIEW2015, 2016, 2017, 2018
LabVIEW NXG3.0
LabVIEW Real-Time Module32014 SP1 or later
LabWindows™/CVI™2013 SP1 or later
LabWindows™/CVI™ Real-Time Module2013 SP1 or later

3No support for legacy devices, the PXIe‑5110/5111/5113, the PXIe‑5163, or the PXIe-5164 and PXIe-517x reconfigurable oscilloscopes.

Microsoft Visual Studio Support

If you are using the NI-SCOPE .NET Class Library, the .NET Framework 4.0 (minimum) is required. The NI-SCOPE .NET Class Library can be used with the Visual C# or Visual Basic .NET programming languages in any Visual Studio version that can target the .NET Framework 4.0 or the .NET Framework 4.5.

To use the .NET API, you must select the .NET Framework 4.0 Languages Support or the .NET Framework 4.5 Languages Support packages in the NI-SCOPE installer to install the .NET class libraries in addition to the NI device driver. For information about versions of the .NET Framework and the drivers each supports, as well as the download location of the installer files, refer to the National Instruments .NET Driver Support document at ni.com/info and enter Info Code NETAPIdriversupport.

Installation Instructions

NI-SCOPE is available for download from ni.com/downloads/drivers. NI-SCOPE installs NI-DAQ if it is not already installed or if an earlier version of NI-DAQ is installed. NI-DAQ support files will be installed if you have LabVIEW or LabWindows/CVI in your system. However, the only component that NI-SCOPE needs from NI-DAQ is the device driver.

Upgrading from a Previous Version of NI-SCOPE

  • From NI-SCOPE 1.0 and 1.1—NI-SCOPE does not install over NI-SCOPE 1.0 or 1.1. You must uninstall these versions of NI-SCOPE before installing a later version of NI-SCOPE.
  • From NI-SCOPE 1.5 and later—NI-SCOPE automatically uninstalls any previous version that is greater or equal to 1.5. If you have modified any old examples, these will be overwritten by the new versions.

Uninstalling NI-SCOPE

As part of the NI-SCOPE installation, the following software is installed. To completely remove the NI-SCOPE installation from your system, you must also remove all of the following packages:

  • NI-DAQmx 17.1.1
  • NI Measurement & Automation Explorer 18.0
  • NI Hierarchical Waveform Storage 18.0
  • NI I/O Trace 18.5

Notice  Several of the software packages listed above are shared with other NI software packages. If you attempt to remove a piece of software that something else is dependent on, a message launches to warn you about the software dependencies. You can choose to either uninstall all of the software or to leave the shared software installed. If you choose to uninstall the shared software, some of your other NI software may no longer function correctly.

Installing NI-SCOPE for LabVIEW NXG

NI automates LabVIEW NXG installation using NI Package Manager. Visit ni.com/info and enter the Info Code NIPMDownload to download NI Package Manager. Refer to the NI Package Manager Manual for more information about installing, removing, and upgrading NI software using NI Package Manager.

Product Security and Critical Updates

Visit ni.com/security to view and subscribe to receive security notifications about NI products. Visit ni.com/critical-updates for information about critical updates from NI.

New Features

  • NI‑SCOPE 18.7 adds support for Linux.
  • NI‑SCOPE 18.7 adds support for CableSense to the PXIe‑5110, PXIe‑5111, PXIe‑5113, PXIe‑5160, and PXIe‑5162 oscilloscopes.
  • NI‑SCOPE 18.7 adds support for the PXIe‑5163 oscilloscope.
  • NI‑SCOPE 18.7 adds support for variable rate external sample clocks to the PXIe‑5170 and PXIe‑5171 reconfigurable oscilloscopes.
  • NI‑SCOPE 18.6 adds support for the PXIe‑5110, PXIe‑5111, and PXIe‑5113 oscilloscopes.
    • NI‑SCOPE 18.6 adds support for glitch, width, and runt triggering to the PXIe‑5110, PXIe‑5111, and PXIe‑5113.
  • NI‑SCOPE 18.5 adds support for LabVIEW NXG 3.0.

Supported Hardware

The following table details the hardware models supported in NI-SCOPE.

Hardware Device Supported Under Windows 10/Windows 8.1 (32-bit)/7 (32-bit)1 Supported Under Windows 10/Windows 8.1 (64-bit)/7 (64-bit)1
NI-DAQmx-Based Oscilloscopes
PXI/PCI-51022
Yes
No
PCMCIA/USB/AT-51022
No
No
PXI/PXIe/PCI-5105
Yes
Yes
PXI/PCI-51122
Yes
No
PXI/PXIe/PCI-5114
Yes
Yes
PXI/PXIe/PCI-5122
Yes
Yes
PXI/PCI-5124
Yes
Yes
USB-5132/5133
Yes
Yes
PXI/PCI-5142
Yes
Yes
PXI/PCI-5152
Yes
Yes
PXI/PCI-5153
Yes
Yes
PXI/PCI-5154
Yes
Yes
PXIe-5160/5162
Yes
Yes
PXIe-5185/5186
Yes
Yes
PXI-56202
Yes
No
PXI-56212
No
No
PXIe-5622
Yes
Yes
PXI-5900
Yes
Yes
PCI-59112
No
No
PXI/PCI-5922
Yes
Yes
SDI-Based Oscilloscopes
PXIe-5110
Yes
Yes
PXIe-5111
Yes
Yes
PXIe-5113
Yes
Yes
5164 Oscilloscopes
PXIe-5163
Yes
Yes
PXIe-5164
Yes
Yes
517x Oscilloscopes
PXIe-5170
Yes
Yes
PXIe-5171
Yes
Yes
PXIe-5172
Yes
Yes
1MXI Express and MXI-4 are supported on Windows 10/8.1/7.
2Legacy devices.

Device-specific information about these modules is included in the NI High-Speed Digitizers Help.

Known Issues

You can access the software and documentation known issues list online. Refer to the NI website for an up-to-date list of known issues in NI-SCOPE 18.7.

Bug Fixes

The following items are the IDs, versions, and descriptions of a subset of issues fixed in NI-SCOPE releases. This is not an exhaustive list of issues fixed in the current version of NI-SCOPE. If you have a CAR ID, you can search this list to validate that the issue has been fixed.

ID Fixed Version Fixed Issue
716977 18.7 Implemented various fetch performance improvements for the PXIe‑5110/5111/5113, PXIe‑5164, PXIe‑5170, PXIe‑5171, and PXIe‑5172.
639493 17.2 Fixed an issue in which committing a new clocking configuration for the PXIe-5164 without previously phase locking the clock and resetting the device caused LabVIEW to crash.
641640 17.2 Fixed an issue causing Traditional NI-DAQ (Legacy) devices to be missing from the NI-SCOPE full installer.
546023 16.1 Fixed an issue in which C examples failed to compile in Visual Studio 2015.

Accessing the Help

  • For help with the NI-SCOPE driver, refer to the NI High-Speed Digitizers Help, accessible by selecting Help»NI High-Speed Digitzers Help.
  • For help with the NI-SCOPE Soft Front Panel, refer to the NI-SCOPE Soft Front Panel Help, accessible by selecting Help»Online Help.

Finding Examples

NI-SCOPE ships with several examples for LabVIEW, LabWindows/CVI, Measurement Studio, MSVC, Visual C++, and Microsoft Visual Basic that will help you develop your software. These examples illustrate how to perform the most common operations with your hardware. To find the examples, go to Start»Programs»National Instruments»NI-SCOPE»Examples.

For LabVIEW examples, select HelpFind Examples from LabVIEW to launch the NI Example Finder. LabVIEW examples for NI-SCOPE are located in the labview\examples\instr\niScope directory. You can modify an example VI to fit an application, or you can copy and paste from one or more examples into a VI that you create.

LabVIEW NXG Support and Considerations

The following sections detail considerations for using LabVIEW NXG with NI-SCOPE.

LabVIEW NXG Operating Systems and System Requirements

Software support for LabVIEW NXG differs in the following ways:

  • System requirements—Only 64-bit (x64) processors are supported.
  • Operating system—Only 64-bit operating systems are supported. Refer to the Supported Operating Systems section for more information.

LabVIEW NXG Hardware Support

The following table details the hardware models supported in NI-SCOPE with LabVIEW NXG.

Hardware Device Supported Under Windows 10/Windows 8.1 (32-bit)/7 (32-bit)1 Supported Under Windows 10/Windows 8.1 (64-bit)/7 (64-bit)1
NI-DAQmx-Based Oscilloscopes
PXI/PXIe/PCI-5105
Yes
Yes
PXI/PXIe/PCI-5114
Yes
Yes
PXI/PXIe/PCI-5122
Yes
Yes
PXI/PCI-5124
Yes
Yes
USB-5132/5133
Yes
Yes
PXI/PCI-5142
Yes
Yes
PXI/PCI-5152
Yes
Yes
PXI/PCI-5153
Yes
Yes
PXI/PCI-5154
Yes
Yes
PXIe-5160/5162
Yes
Yes
PXIe-5185/5186
Yes
Yes
PXIe-5622
Yes
Yes
PXI-5900
Yes
Yes
PXI/PCI-5922
Yes
Yes
SDI-Based Oscilloscopes
PXIe-5110
Yes
Yes
PXIe-5111
Yes
Yes
PXIe-5113
Yes
Yes
5164 Oscilloscopes
PXIe-5163
Yes
Yes
PXIe-5164
Yes
Yes
517x Oscilloscopes
PXIe-5170
Yes
Yes
PXIe-5171
Yes
Yes
PXIe-5172
Yes
Yes
1MXI Express and MXI-4 are supported on Windows 10/8.1/7.

LabVIEW NXG Help

View context help in LabVIEW by pressing <Ctrl-H> and hovering over an object.

Search for items using the search bar in the upper right corner of the LabVIEW window. You can also view context help for the search results.

Additional documentation is available online at ni.com/manuals.

LabVIEW NXG Examples

Launch LabVIEW and click the Learning tab.

LabVIEW lessons are located in the Lessons tab, and LabVIEW Examples are located in the Examples tab. Follow the instructions in the lessons and examples.

Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes.

If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

For more information about automating the installation of NI products, refer to the following KnowledgeBase articles:

Using NI Software with Microsoft Windows 10

Microsoft Windows 10 is the latest version of the Windows operating system and features significant changes compared to previous versions. Windows 10 introduces several new capabilities and also combines features from both Windows 7 and Windows 8. For more information about NI support for Windows 10, visit ni.com/windows10.

Using NI Software with Microsoft Windows 8.1

When you install NI software on Microsoft Windows 8.1, you will notice a few additional tiles in the Apps view, including shortcuts to NI application software products such as NI LabVIEW, Measurement & Automation Explorer (NI MAX), and NI Launcher. For more information about NI support for Windows 8.1, visit ni.com/windows8.


Legal Information

Copyright

© 1999–2018 National Instruments. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

NI respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

  • Notices are located in the <National Instruments>\_Legal Information and <National Instruments> directories.
  • EULAs are located in the <National Instruments>\Shared\MDF\Legal\license directory.
  • Review <National Instruments>\_Legal Information.txt for information on including legal information in installers built with NI products.

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on NI trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the NI products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the NI Patent Notice at ni.com/patents.

375360R-01