NI Vision Acquisition Software Release Notes

September 2011

This file contains important information about National Instruments Vision Acquisition Software, and is organized into the following sections:

New Features
Upgrade Considerations for Legacy NI-IMAQ for IEEE 1394 Cameras
Minimum System Requirements
Software Support
Installation
Configuring NI-IMAQ
Configuring NI-IMAQdx
Known Issues
Documentation

NI Vision Acquisition Software allows you to acquire, display, and save images; control digital I/O on National Instruments image acquisition devices; and configure your driver software and hardware.

The readme.html file for each NI Vision Acquisition Software driver is installed to the following default locations, where <National Instruments> is the location to which National Instruments software is installed. For a list of known issues, refer to the individual driver readmes.

  • NI-IMAQ<National Instruments>\NI-IMAQ\Docs\readme.html
  • NI-IMAQdx<National Instruments>\NI-IMAQdx\Docs\readme.html
  • NI-IMAQ I/O<National Instruments>\NI-IMAQ IO\Docs\readme.html

New Features

This release of Vision Acquisition Software includes the following new features:

NI-IMAQ 4.6.1

NI-IMAQ is driver software for NI 17xx smart cameras, as well as analog, parallel digital, and Camera Link image acquisition devices.

  • Support for the NI PCIe-1473R Camera Link frame grabber

NI-IMAQdx 3.9.1

NI-IMAQdx is driver software that supports IEEE 1394, GigE Vision, DirectShow-compatible USB, and IP cameras.

  • Support for NI 177x smart cameras

NI-IMAQ I/O 2.5

NI-IMAQ I/O is the National Instruments I/O device driver software for controlling the digital I/O on IEEE 1394 hardware.


Upgrade Considerations for Legacy NI-IMAQ for IEEE 1394 Cameras

NI-IMAQdx no longer supports Legacy NI-IMAQ for IEEE 1394 Cameras. This version of NI-IMAQdx uninstalls the Legacy NI-IMAQ for IEEE 1394 Cameras feature of NI-IMAQdx 3.3 or earlier. If you require Legacy NI-IMAQ for IEEE 1394 Cameras, you must download and install it separately. Visit ni.com/info and enter the info code legacy1394 for information about how to install Legacy NI-IMAQ for IEEE 1394 Cameras. This version of NI-IMAQdx does not affect separate installations of Legacy NI-IMAQ for IEEE 1394 Cameras.


Minimum System Requirements

The development computer must meet the following requirements to run NI Vision Acquisition Software:

Processor Pentium 4 1 GHz or equivalent
Memory 512 MB RAM
Display 1,024 × 768 resolution video adapter with a 16-bit display
Minimum Recommended
Free Hard Disk Space
Vision Acquisition Software 2 GB
NI-IMAQ 1 GB
NI-IMAQdx 1 GB
NI-IMAQ I/O 1.5 GB
Operating System Windows 7/Vista/XP (32-bit)/Server 2008 R2/Server 2003 R2 (32-bit)
Browser Microsoft Internet Explorer 5.0 or later

Software Support

This section describes the operating systems and application development environments (ADEs) supported by NI Vision Acquisition Software.

Operating Systems

  • LabVIEW Real-Time Module 8.6 or later
  • Windows 7/Vista/XP (32-bit) SP2/Server 2008 R2/Server 2003 R2 (32-bit). Refer to the following table for more information.

Note  NI Vision Acquisition Software does not support Windows Server non-R2 editions.



Device Windows 7 32-bit/Windows Vista 32-bit/XP (32-bit)/Server 2003 R2 (32-bit) Windows 7 64-bit/Windows Vista 64-bit/Server 2008 R2
NI 1405 Yes Yes*
NI 1407 Yes Yes*
NI 1408 No No
NI 1409 Yes Yes*
NI 1410 Yes Yes*
NI 1411 Yes Yes*
NI 1422 Yes Yes*
NI 1424 Yes Yes*
NI 1426 Yes Yes*
NI 1427 Yes Yes*†
NI 1428 Yes Yes*
NI 1429 Yes Yes*†
NI 1430 Yes Yes*†
NI 1433 Yes Yes*†
NI 1435 Yes Yes*†
NI 1473R Yes Yes*†
NI 1483 Yes Yes*
NI 8231 Yes Yes
NI 8234 Yes Yes
NI 8235 Yes Yes
NI 8252 Yes Yes
NI 8254R Yes Yes
NI 8255R Yes Yes
*  Applications developed using LabVIEW 8.2.1 or later will run on systems with more than 3 GB of physical memory. Applications developed using other development environments, such as Microsoft Visual C, Visual Basic, and .Net, are limited to systems with 3 GB or less of physical memory. All 32-bit applications, including those developed using LabVIEW, may not allocate more than 2 GB of memory total.

  A firmware update is available for this device to allow non-LabVIEW applications to run on systems with more than 3 GB of physical memory. To update the device firmware, launch MAX and select Tools»NI Vision»Update NI-IMAQ Device Firmware.

Development Environments

  • LabVIEW 8.6 and later
  • LabVIEW Real-Time Module 8.6 or later
  • LabWindows/CVI 8.1 or later
  • Microsoft Visual C/C++ 6.0 or later
  • Microsoft Visual Basic 6.0 or later
  • Microsoft Visual Studio .NET 2005 and 2008 (except NI-IMAQ I/O)

Additional Software

You can also use NI-IMAQ, and NI-IMAQdx with the following National Instruments software packages to prototype, benchmark, and deploy your applications.

  • NI Vision Development Module 7.1 or later
  • NI Vision Builder for Automated Inspection (Vision Builder AI) 2.5 or later

Installation Instructions

Complete the following steps to install NI Vision Acquisition Software:

Note: You must have administrator access to install the NI Vision Acquisition Software.

  1. Insert the NI Vision Acquisition Software installation media.
  2. If you do not have autorun enabled, double-click autorun.exe. If you have autorun enabled, autorun.exe runs automatically.
  3. Follow the onscreen instructions.

NI-IMAQ and NI-IMAQdx integrate with MAX, the National Instruments utility for configuring and testing your measurement and automation system. The MAX icon appears on your desktop after you install NI Vision Acquisition Software.

Installing from an NI Software Suite or NI Product Bundle

If you purchased this product with an NI Software Suite or NI Product Bundle, use the installation media that shipped with your purchase to install this product.


Configuring NI-IMAQ

Complete the following steps to install an image acquisition device and configure NI-IMAQ:

Note: You must install NI-IMAQ before installing your image acquisition device.

Caution: Power off and unplug the computer before installing your hardware. Wait for any motherboard LEDs to power off before proceeding, since some computers remain powered for some time after being unplugged.

  1. Install your image acquisition device, and connect the camera. Refer to the device documentation for specific hardware installation instructions.
  2. Run MAX.
    1. Double-click the MAX icon on the desktop. You can use MAX to modify camera properties. Once you have saved these properties, they become the default settings for all NI-IMAQ applications.
    2. Expand Devices and Interfaces and NI-IMAQ Devices to display a list of the image acquisition devices installed on your computer.
  3. Select a camera file, and acquire an image.
    1. Click the plus sign next to the image acquisition device to expand the menu tree and list the available channels or ports. Right-click the channel or port to display a list of available cameras.
    2. Select the appropriate camera type from the list. Camera type selection varies according to the image acquisition device installed.
    3. To change the camera settings, modify the parameters at the bottom of the image viewer panel.
    4. You can acquire an image in the following ways:
      • Use the Snap button to acquire and display a single image with the image acquisition device.
      • Use the Grab button to acquire images continuously. A grab allows you to focus the camera.

Tip: For a complete list of supported cameras, right-click the channel or port, select Camera, and click Search ni.com.

Note: Refer to the right side of the MAX user interface, which displays context-sensitive help, for information about configuring image acquisition devices with MAX.

Configuring a Remote PXI/Compact PCIe Image Acquisition Device

Use MAX to install NI-IMAQ for LabVIEW Real-Time from the host machine onto the target system. The NI-IMAQ for LabVIEW Real-Time components enable the remote device to acquire and analyze images as directed by the host machine.

Note: Install NI-IMAQ and the LabVIEW Real-Time Module on the remote system before you install and configure the image acquisition device. Follow the steps in the MAX help window to install software.

Tip: Configuring remote image acquisition devices is similar to configuring local image acquisition devices, except that the procedure for working with camera files is different. Refer to the Measurement & Automation Explorer Help for NI-IMAQ for information about working with camera files on remote image acquisition devices.

  1. Launch MAX.
  2. In the Configuration tree, expand Remote Systems.
  3. Expand the appropriate system.
  4. Expand Devices and Interfaces.
  5. Expand NI-IMAQ Devices.
  6. Expand the device you want to configure.

Refer to the Measurement & Automation Explorer Help for NI-IMAQ for information about configuring specific NI image acquisition devices. You can access this help file from the MAX Help menu by selecting Help»Help Topics»NI Vision»NI-IMAQ.


Configuring NI-IMAQdx

Complete the following steps to install and configure NI-IMAQdx.

If you are using a USB camera, ensure that the camera is compatible with DirectShow, and that the camera driver is installed and functioning. For specific information about drivers and camera compatibility, consult your camera manufacturer documentation.

Instructions for configuring an IEEE 1394 or GigE Vision camera are included in the Measurement & Automation Explorer Help for NI-IMAQdx. You can access this help file from the MAX Help menu by selecting Help»Help Topics»NI Vision»NI-IMAQdx.

Installing IEEE 1394 Hardware

Install your IEEE 1394 interface card. Follow the installation instructions provided by the manufacturer.

Installing the High Performance GigE Vision Driver

If you have an Intel Pro/1000 Series gigabit Ethernet Network Interface Card (NIC), it is recommended that you install the High Performance GigE Vision Driver. This will ensure optimized performance and minimal configuration. To associate your hardware with the high performance driver, complete the following steps.

  1. Install your NIC.
    1. If Windows does not prompt you to choose a driver, proceed to step 2.
    2. If Windows prompts you to choose a driver, proceed to step 3.
  2. Right-click the NIC in the Device Manager, and select Update Driver.
  3. Choose not to connect to the Windows Update Web site, and click Next.
  4. Choose to Install from a list or a specific location, and click Next.
  5. Choose Don't Search. I will choose the driver to install.
  6. Click Next.
  7. Select National Instruments GigE Vision driver from the list, and click Next.
  8. Click Finish.

    Note: Windows may return a warning stating that the driver is unsigned. It is safe to ignore the warning.

Installing the Universal GigE Vision Driver

NI-IMAQdx will work with any standard gigabit Ethernet NIC. To use NI-IMAQdx with a standard gigabit Ethernet NIC, complete the following steps:

  1. Install the NIC and any related drivers. Refer to the NIC device documentation for installation instructions.
  2. Enable jumbo frames (frame packet size is greater than 1,500 bytes) on your NIC.
    1. Right-click the NIC in the Device Manager, and select Properties.
    2. Click the Advanced tab, and Jumbo Frames will appear in the Property list if supported by your NIC.
    3. Select the largest frame size available and click OK.

    Note: The procedure for enabling jumbo frames on your NIC may vary by manufacturer. Refer to the NIC device documentation for more information about enabling jumbo frames.

  3. Disable the Windows Firewall or any additional third party firewalls on the port. Windows Firewall can be disabled on individual ports from the Advanced tab of the Windows Firewall applet.

Configuring Multiple Ports

If you plan to use multiple ports with NI-IMAQdx, complete the following steps:

  1. Open the Network Connections window in Windows, and select all of the ports that cameras will be connected to by holding <Ctrl> while clicking each port.
  2. Right-click one of the selected ports, and choose Bridge Connections.

    Note: If you are not using the High Performance Driver, you will be unable to use jumbo frames on bridged devices.

Configuring NI-IMAQdx for Windows

Complete the following steps to configure NI-IMAQdx for Windows:

  1. Connect the camera.
  2. Run MAX.
    1. Double-click the MAX icon on your desktop. You can use MAX to modify camera attributes. After you have saved these attributes, they become the default settings for all NI-IMAQdx or NI Vision applications.
    2. Expand Devices and Interfaces»NI-IMAQdx in the configuration tree to display a list of the cameras installed on your computer.
    3. For IEEE 1394 cameras, NI-IMAQdx may not be associated with the camera. If this is the case, change the associated driver by right-clicking the camera and selecting Driver»NI-IMAQdx.
    4. Select the camera from the list. You then can view or modify the camera attributes on the Camera Attributes tab located below the image viewer.

Tip: Click the Show Help button to display the help window on the right side of the image viewer. Move your mouse over the properties to view context-sensitive help in the bottom half of the help window.

Configuring NI-IMAQdx for the LabVIEW Real-Time Module

If you are using a Windows development machine, the LabVIEW Real-Time Module, and an RT target, complete the following steps to install and configure NI-IMAQdx:

Note: NI-IMAQdx does not support USB cameras on the LabVIEW Real-Time Module.

  1. Install NI-IMAQdx software on your Windows development machine.
  2. Ensure that your RT target is connected to the same subnet as the Windows development machine.
  3. Run MAX.
    1. Double-click the MAX icon on your desktop.
    2. Expand the Remote Systems list in the configuration tree.
    3. Select your RT target in the list.
    4. Configure your network settings. Refer to the Remote Systems Help in MAX (Help»Help Topics»Remote Systems) for instructions about configuring network settings.
  4. Install NI-IMAQdx on the RT target.
    1. Click the Software item below the RT target in the configuration tree.
    2. Click Install Software on the MAX toolbar to launch the LabVIEW Real-Time Install Software Wizard.
    3. Select NI-IMAQdx RT, as well as any additional software you would like to install on the target machine.
    4. Click Next. Review the list of software you selected to install.
    5. Click Next to begin downloading the software to the target machine. When MAX has finished downloading the software, it restarts the remote device.
    6. Click Finish.
  5. Connect your camera to your remote system.
  6. Press <F5> to refresh the MAX configuration tree. Your camera should be listed in the Remote Systems list.

    Tip: Press <F5> to refresh the configuration tree whenever you connect a new device to an RT target.

  7. Expand Devices and Interfaces»NI-IMAQdx in the configuration tree to display a list of the cameras installed on your computer.
  8. Select the camera from the list. You then can view or modify the camera attributes from the Camera Attributes panel located below the image viewer.

Known Issues

NI-IMAQ

  • The NI PCIe-1433 or NI PXIe-1435 may lose the first image of a triggered acquisition if the attached camera is in a triggered mode that does not drive the line valid signal while waiting.
  • The NI-IMAQ .NET API is not supported on the NI PCI-1408.
  • When you upgrade from NI Vision Acquisition Software 8.0, .NET support and examples are not installed. To install .NET support, uninstall NI Vision Acquisition Software 8.0 and install a later version NI Vision Acquisition Software. If you already have a later version of NI Vision Acquisition Software installed, you must repair the installation to add .NET support and examples.

NI-IMAQdx

  • When you upgrade from NI Vision Acquisition Software 8.0, the .NET support and examples are not installed. To install support for .NET, uninstall NI Vision Acquisition Software 8.0, and then install a later version NI Vision Acquisition Software. If you already have a later version of NI Vision Acquisition Software installed, you must repair the installation to add .NET support and examples.
  • Plugging a device into an IEEE 1394 bus causes a bus reset. If there are any ongoing acquisitions, the acquisition continues, but it is possible that a frame could be dropped. If you have an application in which it is important to get every frame, you should protect against devices being plugged into the bus.
  • Windows OS Issues
    • Updating your computer to Windows XP Service Pack 2 may decrease the performance of your IEEE 1394 devices running with an IEEE 1394b host interface, such as the NI PCIe-8255R. Refer to the NI KnowledgeBase article 3J0A446W or Microsoft Knowledge Base article 885222 for more information.
    • When switching drivers, you may find that the camera does not always appear in the MAX configuration or in your Device Manager. To correct this, disconnect the IEEE 1394 camera from your IEEE 1394 adapter and reconnect it. You can also press the <F5> key to refresh.
  • Using Multiple Cameras
    • The IIDC 1394-based Digital Camera Specification version 1.30 allows up to 16 cameras and one controller to exist on an IEEE 1394 bus at one time. Multiple cameras connected to a single adapter share the same IEEE 1394 bus and the available bandwidth for that bus. To simultaneously acquire images from multiple cameras, select a video mode for each camera so that the total bandwidth does not exceed the bandwidth capability of the bus.
    • Note: NI-IMAQdx returns an Insufficient Resources error if you perform an acquisition that requires more bandwidth than is available on the bus.

      To use multiple cameras simultaneously at full speed, connect each camera to a separate IEEE 1394 adapter. You cannot simultaneously acquire images at maximum bandwidth from multiple cameras when all cameras are connected to the same bus.

NI-IMAQ I/O

  • In LabVIEW 8.6, the Abort and Reset FPGA Interface methods will not execute if there is an error coming into the node. As a work around, route the error around the method nodes. Close and Reset if Last Reference executes as expected.
  • When you upgrade from NI Vision Acquisition Software 8.0, the .NET support and examples are not installed. To install support for .NET, uninstall NI Vision Acquisition Software 8.0, and then install a later version NI Vision Acquisition Software. If you already have a later version of NI Vision Acquisition Software installed, you must repair the installation to add .NET support and examples.
  • When creating LabVIEW FPGA applications for NI-IMAQ I/O devices, the digital inputs ISO_POWER_PRESENT and USER_DIP are low true signals. Also, digital outputs should be treated as outputs only. Trying to use an output on your device as a digital output and a digital input in your LabVIEW FPGA block diagram will result in a compilation error.
  • Configuring the shutdown states on an NI-IMAQ I/O device while the default personality is running on the FPGA can affect the value of the isolated output lines. Drive the isolated outputs with the value you expect after configuring shutdown states.
  • If you need to call multiple instances of the Open FPGA VI Reference function, National Instruments recommends running them sequentially and not simultaneously.
  • The host VI might import improperly to LabVIEW 8.2 or later if any of the following conditions apply: you use constants for the HW Exec Ref parameter on the block diagram, you use Call By Reference Nodes that pass the HW Exec Ref parameter, or you use strict type definitions of the HW Exec Ref parameter with property nodes to get or set their value. Open the host VI and manually replace all instances of the HW Exec Ref that are broken with the new HW Exec Ref coming from the Open FPGA VI Reference function.
  • A host VI created with the LabVIEW FPGA Module 1.x might have used the Abort method with an Invoke Method function or as part of the Close FPGA VI Reference function. The import utility replaces the Abort method with the Reset method. The Abort method in the LabVIEW FPGA Module 1.x resets the FPGA VI to default values. The Reset method in the LabVIEW FPGA Module 8.2 resets the FPGA VI to default values. In the LabVIEW FPGA Module 8.2, the Abort method stops the FPGA VI but does not reset the values to their default values. By replacing the Abort method with the Reset method, the import utility preserves behavior of your program. No action on your part is necessary.
  • Pop-up windows are not supported in executables running on Real-Time (RT) targets. Therefore, no window pops up to indicate when an FPGA VI is programmatically downloaded by a host VI running on an RT target.
  • Host VIs that contain the FPGA Interface functions might take a long time to open because the FPGA Interface functions need several support files to manage the interface with FPGA VIs. The FPGA Interface functions also verify the status of the FPGA VI when you open the host VI.
  • When adding an existing IMAQIO-5 FPGA target in LabVIEW 8.0 with the LabVIEW FPGA Module 8.0, the IMAQIO-5 FPGA target will not appear in the Add Targets and Devices configuration tree, and <No Items Found> is displayed in the configuration tree. Refer to National Instruments KnowledgeBase 3UGCL2D3 for instructions to correct this issue. To determine which FPGA your device uses, refer to the LabVIEW Help and search for NI-IMAQ I/O Reference.
  • NI Compact Vision System
    • When you use the LabVIEW Application Builder to create an executable on an NI CVS-1450 Series compact vision system, create the executable in the default directory for LabVIEW Real-Time startup applications (c:\ni-rt\startup). If you do not create the executable in the default directory, the application cannot connect to the FPGA code.

Documentation

The NI Vision Acquisition Software documentation is installed onto your hard drive with NI Vision Acquisition Software. The documentation ships as Adobe Acrobat portable document format (PDF) files and HTML Help files. To view the NI Vision Acquisition Software documentation, select Start»All Programs»National Instruments»Vision»Documentation.

Note: You must have Adobe Acrobat Reader installed to view the PDFs. Refer to the Adobe Systems Incorporated Web site at www.adobe.com to download the latest version of Adobe Reader.

NI LabVIEW Documentation

You can access the NI-IMAQ VI Reference Help and the NI-IMAQdx VI Reference Help from the LabVIEW Help menu. In LabVIEW, select Help»NI Vision for LabVIEW Help.

.NET Documentation

The NI Vision Acquisition Software .NET documentation merges into the NI Measurement Studio Help. The NI Measurement Studio Help integrates into the Visual Studio Combined Help Collection under the Measurement Studio node in the Table of Contents. In order for links from Measurement Studio help topics to .NET Framework help topics to work, you must install the product documentation for Visual Studio, which installs the MSDN Library. This requires a secondary installation during the Visual Studio installation process.

The NI Measurement Studio Help is in the Microsoft Help 2.0 format and requires a Microsoft Help 2.0 viewer to be displayed. A Microsoft Help 2.0 viewer is installed with both Microsoft Visual Studio and the Microsoft .NET Framework SDK. The SDK is freely available from MSDN at http://www.microsoft.com/downloads. If you do not have either of these products, you will need a standalone Microsoft Help 2.0 viewer to display the documentation. Some Help 2.0 viewers are available for download, such as Helpware's H2Viewer.

  • NI Measurement Studio Help—Contains reference information about NI Vision for .NET objects. Describes how to create machine vision and image processing applications in Visual Basic .NET and C# using the NI Vision Development Module. You can launch the NI Measurement Studio Help in the following ways:

    If you have Measurement Studio installed:

    • From the Windows Start menu, select Start»All Programs»National Instruments»<Measurement Studio>»Measurement Studio Documentation, where <Measurement Studio> is the location to which Measurement Studio is installed. The help launches in a stand-alone help viewer.
    • From Visual Studio, select Measurement Studio»NI Measurement Studio Help.

    If you do not have Measurement Studio installed:

    • From Visual Studio, select Help»Contents to view the Visual Studio table of contents. The NI Measurement Studio Help is listed in the table of contents.

Copyright

© 2011 National Instruments Corporation. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

Trademarks

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section on ni.com/legal for more information about National Instruments trademarks.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the National Instruments products, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your CD, or ni.com/patents.