Company Events Academic Community Support Solutions Products & Services Contact NI MyNI

LabVIEW 2016 FPGA Module Readme

June 2016

This file contains important information about the LabVIEW FPGA Module, including system requirements, installation instructions, descriptions of new features, upgrade and compatibility issues, known issues, and a partial list of bugs fixed for this release.

Overview

FPGA Module System Requirements

FPGA Compile Farm Server System Requirements

Installation Instructions

NI Software Support for Microsoft Windows 7, Windows Vista, Windows XP, and Windows Server 2003

Product Security and Critical Updates

New Features and Changes

Known Issues

Bug Fixes

Upgrade and Compatibility Issues

Accessing the Help

Finding Examples

Automating the Installation of NI Products

Legal Information


Overview

With the LabVIEW FPGA Module, you can create VIs that run on NI FPGA targets, such as Reconfigurable I/O (RIO) devices. The FPGA Module helps you design complex systems by providing a highly-integrated development environment, a large ecosystem of IP libraries, a high-fidelity simulator, and debugging features. The FPGA Module also includes FPGA IP Builder and the FPGA Compile Farm Server. You can use FPGA IP Builder to efficiently implement your LabVIEW algorithms for FPGA targets and to generate FPGA code that meets specific performance requirements. FPGA IP Builder supports only a subset of FPGA targets. Visit ni.com/info and enter the Info Code exvxfe for a list of supported targets. You can use the FPGA Compile Farm Server to offload compiles to dedicated computers.

FPGA Module System Requirements

The development computer is a PC or NI PXI/PXI Express system on which you install LabVIEW and the FPGA Module. You can also install the Xilinx compilation tools on your development computer to compile LabVIEW FPGA VIs locally. However, if the FPGA design or target requires more than 2 GB of memory, NI recommends you install the Xilinx compilation tools on a separate computer. This computer is referred to as the remote compile worker.

Visit ni.com/info and enter the Info Code XilinxCompileTools for more information about the NI hardware supported by each Xilinx compilation tool.

The development computer must meet the following system requirements:

1 Memory requirements vary according to both the FPGA target and the FPGA VI you create for that target.

2 You must use a 64-bit OS to address 4 GB of RAM.

3 NI software is signed with a SHA-256 certificate. Windows 7 SP1, Windows Embedded Standard 7 SP1, and Windows Server 2008 R2 SP1 require Microsoft updates to support SHA-256. Refer to Microsoft KB3033929 for more information about how to install this security update.

Refer to the LabVIEW Readme for additional system requirements and supported operating systems for LabVIEW 2016.

FPGA Compile Farm Server System Requirements

If you install the FPGA Compile Farm Server on a separate computer, you can configure that computer to be a remote compile farm server. If you install the Xilinx compilation tools on a separate computer, you can configure that computer to be a remote compile worker.

Refer to the Setting Up a Remote Compile Farm Server or Compile Worker section of this document for information about setting up and using a local or remote compile farm server or compile worker. Visit ni.com/info and enter the Info Code XilinxCompileTools for more information about the NI hardware supported by each Xilinx compilation tool.

The remote compile farm server must meet the following minimum system requirements:

You can use either a Windows or Linux computer as a compile worker. Refer to the Xilinx Compilation Tools Readme for the operating system to obtain information about the minimum system requirements.

Installation Instructions

This section provides information about installing the FPGA Module and related components.

Note  If you are upgrading from a previous version of LabVIEW, you must install the LabVIEW 2016 FPGA Module before mass-compiling existing FPGA VIs. Otherwise, some FPGA-specific VIs might have mutation issues.

Installing the FPGA Module on a Development Computer

Complete the following steps to install LabVIEW and the FPGA Module:

  1. Log in as an administrator or as a user with administrative privileges.
  2. Insert the LabVIEW Platform media. To request additional LabVIEW Platform media, refer to the NI website. If you purchased this product with an NI Software Suite or NI Product Bundle, use the installation media that shipped with your purchases to install this product.
  3. Follow the instructions on the screen to install and activate the following software in this order:
    • LabVIEW
    • FPGA Module
    • Xilinx Compilation Tools—Install these compilation tools on the development computer if you want to compile your LabVIEW FPGA VIs locally. You must install these tools on your development computer if you plan to use the Configure Component-Level IP wizard, configure the IP Integration Node, incorporate Xilinx IP, use FPGA IP Builder, or use third-party simulation. Refer to your hardware documentation for information about the FPGA chip in your device and install the appropriate set of tools. Visit ni.com/info and enter the Info Code XilinxCompileTools for more information about the NI hardware supported by each Xilinx compilation tool.
      • Xilinx Compilation Tools for Windows—Install these compilation tools if you will compile your FPGA VIs on a Windows computer. The Xilinx compilation tools for Windows include Vivado 2015.4 and ISE 14.7.
      • Xilinx Compilation Tools for Linux—Install these compilation tools if you will compile your FPGA VIs on a Linux computer. The Xilinx compilation tools for Linux include Vivado 2015.4 and ISE 14.7.
      • Xilinx 10.1 Compilation Tools—Install the Xilinx 10.1 compilation tools if your FPGA device contains a Xilinx Virtex II chip. To download the Xilinx 10.1 compilation tools, refer to ni.com/info and enter the Info Code FPGATool101.
      Note  To configure the IP Integration Node, or use the Configure Component-Level IP wizard on Virtex-II devices, you also must install the Xilinx Compilation Tool for ISE 14.7. Xilinx IP and simulation exports are not supported on Virtex-II FPGA devices.
    • (Optional) FPGA Compile Farm Server—Use the FPGA Compile Farm Server to distribute FPGA VI compile jobs across multiple remote computers.

      Note  Use the LabVIEW FPGA Compile Cloud Service to increase the development efficiency by offloading compile jobs to multiple computers in a cloud environment.
    • (Optional) LabVIEW Real-Time Module—Use the LabVIEW Real-Time Module to program the real-time OS on NI PXI, NI PXI Express, NI CompactRIO, and NI Single-Board RIO devices. You have a temporary license for this product.
    • Device Driver—Device drivers contain driver software for most FPGA targets. Refer to your FPGA target hardware documentation for information about additional or different device drivers you need.

In addition to installing program files and documentation in the LabVIEW directory, the installer also puts files from Xilinx in the x:\NIFPGA directory, where x is the drive on which you installed LabVIEW. The FPGA Module uses these files to compile FPGA VIs into code that runs on an FPGA target.

Setting Up a Remote Compile Farm Server or Compile Worker

You can use the LabVIEW Platform media to install the FPGA Compile Farm Server to offload compiles to dedicated computer. You must install the FPGA Compile Farm Server separately on any remote machine that you want to use to manage your compilations. Also, you must install the Xilinx compilation tools on any machine that you want to use as a remote compile worker. Visit ni.com/info and enter the Info Code XilinxCompileTools for more information about the NI hardware supported by each Xilinx compilation tool.

NI also offers the LabVIEW FPGA Compile Cloud Service to increase the development efficiency by offloading compile jobs to multiple computers in a cloud environment. Visit ni.com/trycompilecloud for information about the LabVIEW FPGA Compile Cloud.

LabVIEW 2016 FPGA Module Drops Support for Microsoft Windows 7 RTM, Windows Vista, Windows XP, and Windows Server 2003

With this release, the LabVIEW FPGA Module drops support for Microsoft Windows 7 RTM (with no service pack), Windows Vista, Windows XP, and Windows Server 2003. The LabVIEW 2016 FPGA Module and later will not install or run on an unsupported OS. You cannot deploy or distribute applications that use the LabVIEW 2016 FPGA Module to an unsupported OS. Additionally, after installing the LabVIEW 2016 FPGA Module, you cannot use any installers built on this computer with any version of LabVIEW, LabWindows™/CVI™, NI TestStand™, or Measurement Studio on an unsupported OS.

For more information about the changes to our OS support for 2016, refer to KB 79UC78LS, Why Does my LabVIEW, LabWindows/CVI, Measurement Studio, or TestStand Built Installer Fail on Windows XP/Vista and Server 2003?.

Product Security and Critical Updates

Visit ni.com/security to view and subscribe to receive security notifications about NI products. Visit ni.com/critical-updates for information about critical updates from NI.

New Features and Changes

The LabVIEW 2016 FPGA Module includes the addition of a new suite of Xilinx compilation tools, Vivado 2015.4. Visit ni.com/info and enter the Info Code XilinxCompileTools for more information about the NI hardware supported by each Xilinx compilation tool.

Known Issues

You can access the software and documentation known issues list online. Refer to the NI website for an up-to-date list of known issues in the FPGA Module.

Bug Fixes

The following items are the IDs and titles of a subset of issues fixed in the FPGA Module. This is not an exhaustive list of issues fixed in the current version of the FPGA Module. If you have a CAR ID, you can search this list to validate that the issue has been fixed.

ID Fixed Issue
577377 FPGA User-Controlled I/O Sampling functions are broken in the Japanese version of LabVIEW 2015 and LabVIEW 2015 SP1
574086 IP Integration Node and Component Level IP can fail to generate simulation files in Vivado 2014.4
568649 FPGA VI Reference wire can become broken across structures and subVIs when the referenced bitfile changes
550239 A case structure that contains global variables and more than 32 cases can fail FPGA compilation
545362 The output valid terminal is missing if the FFT Express VI is configured to perform single channel, single sample transformation outside an SCTL
534464 The Tick Count Express VI in microseconds does not roll over in simulation
495744 VIs remain open after a project closes if the project contains a DMA FIFO that has an FXP data type
549466 The Linear Algebra Matrix Multiply function can return wrong simulation results when N=1 and Output pattern is Row-Wise Element
542770 Copying code from a subVI in a .lvlib that contains an SCTL or the FPGA I/O node can cause LabVIEW to hang or crash when you close the owning project
521795 The Sampling Probe Watch Window does not update unless the highlight execution mode is turned on
512546 When you compile an FPGA design on Vivado targets, specifically the USB-7856R, the compilation might hang during the place phase

Upgrade and Compatibility Issues

This section provides information about upgrading from the LabVIEW 2015 FPGA Module to the LabVIEW 2016 FPGA Module. Refer to previous versions of the LabVIEW FPGA Module Release and Upgrade Notes, available on ni.com/manuals, for changes in previous version of the FPGA Module.

Note  The LabVIEW FPGA Module Release and Upgrade Notes document was deprecated from the 2016 release.

Note  NI recommends that you test all FPGA designs after upgrading. Upgrading the FPGA Module requires upgrading to a new version of the Xilinx compilation tools. This upgrade can change the timing or resource utilization characteristics of FPGA VIs you developed in previous versions or cause these VIs to fail to compile.

VIs that Contain an IP Integration Node

If you open a VI saved in a previous version of LabVIEW that contains an IP Integration Node, you must regenerate support files for the IP. To regenerate the support files, select Tools»FPGA Module»Regenerate IP Integration Nodes Support Files from LabVIEW and follow the on-screen instructions.

Note  If LabVIEW fails to update all support files, re-add the IP Integration Node to the VI and generate the support files for the IP Integration Node.

If the IP Integration Node contains Xilinx Vivado IP configuration (.xci) files, you must regenerate the configuration files in the latest Xilinx compilation tool for Vivado. After regenerating the configuration files, re-add the files to the IP Integration Node, re-add the IP Integration Node to the VI, and generate the support files for the IP Integration Node.

VIs that Contain a Xilinx IP Node

If you open a VI saved in a previous version of LabVIEW that contains a Xilinx IP node, you must regenerate support files for the Xilinx IP node. To regenerate the support files, select Tools»FPGA Module»Regenerate IP Integration Node Support Files from LabVIEW and follow the on-screen instructions. (Xilinx Vivado) After regenerating the support files, verify the behavior of the Xilinx IP node. Reconfigure the Xilinx IP node if its behavior has changed.

Tip  (Xilinx Vivado) You can also regenerate the support files by double-clicking the Xilinx IP node and clicking the Upgrade Xilinx IP button.

Accessing the Help

Refer to the LabVIEW Help, accessible by selecting Help»LabVIEW Help from LabVIEW, for information about the FPGA Module.

Finding Examples

Select Help»Find Examples from LabVIEW to launch the NI Example Finder. You can modify an example VI to fit an application, or you can copy and paste from one or more examples into a VI that you create.

Automating the Installation of NI Products

You can automate the installation of most NI products using command-line arguments to suppress some or all of the installer user interface and dialog boxes. However, starting with the August 2012 releases (products using NI Installers version 3.1 or later), you may need to perform additional steps before or during a silent installation of NI software.

If the NI product you are installing uses Microsoft .NET 4.0, the .NET installer may run before any NI software installs and may require a reboot before the installation of NI software begins. To avoid a .NET reboot, install .NET 4.0 separately before you install NI software.

For more information about automating the installation of NI products, refer to the following KnowledgeBase articles:


Legal Information

Copyright

© 2003–2016 National Instruments. All rights reserved.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

NI respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

Third-Party Copyright Notices

The SharpZipLib_Notice.pdf file contains a third-party copyright notice for third-party components used by certain FPGA Module features. The following directory is the default installation location for the file, but the location might vary depending on the configuration of the local computer:

\National Instruments\LabVIEW <version>\FPGA\Legal\

End-User License Agreements and Third-Party Legal Notices

You can find end-user license agreements (EULAs) and third-party legal notices in the following locations after installation:

U.S. Government Restricted Rights

If you are an agency, department, or other entity of the United States Government ("Government"), the use, duplication, reproduction, release, modification, disclosure or transfer of the technical data included in this manual is governed by the Restricted Rights provisions under Federal Acquisition Regulation 52.227-14 for civilian agencies and Defense Federal Acquisition Regulation Supplement Section 252.227-7014 and 252.227-7015 for military agencies.

IVI Foundation Copyright Notice

Content from the IVI specifications reproduced with permission from the IVI Foundation.

The IVI Foundation and its member companies make no warranty of any kind with regard to this material, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The IVI Foundation and its member companies shall not be liable for errors contained herein or for incidental or consequential damages in connection with the furnishing, performance, or use of this material.

Trademarks

Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on NI trademarks. Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents

For patents covering the NI products/technology, refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the NI Patent Notice at ni.com/patents.

374737F-01