Getting Started with the LabWindows™/CVI™ Real-Time Module

This document provides an introduction to the LabWindows™/CVI™ Real-Time Module. Refer to this document for installation and configuration instructions and information about creating a real-time (RT) project.

Installing the Real-Time Module Software on a Host Computer

You must first install the Real-Time Module software on a host computer. Then you can configure and install software on the RT target.

To install and use the Real-Time Module software, you must have the following:

- **Free Disk Space**—In addition to the minimum system requirements for LabWindows/CVI, you must have at least 250 MB of free disk space for the Real-Time Module software. Refer to the LabWindows/CVI Release Notes for minimum system requirements.
- **RT Target**—The LabWindows/CVI Real-Time Module supports NI RT Series PXI controllers, NI Real-Time Industrial Controllers, stand-alone NI CompactDAQ systems, and desktop PCs converted to RT targets.
- Refer to the Using Desktop PCs as RT Targets with the Real-Time Module document for more information about converting a desktop computer to an RT target.


Configuring the RT Target

After you install LabWindows/CVI and the RT module, you must use Measurement & Automation Explorer (MAX) to configure the RT target and to install software and drivers on the RT target. MAX provides access to NI devices and systems and can communicate with networked RT targets, also known as remote systems.

Complete the following steps to configure the RT target. The following sections describe these steps in more detail.

1. Boot the RT target into LabVIEW RT.
2. Configure network settings.
3. Install software on the RT target.
4. Configure I/O.
5. Configure system settings.
6. Configure time settings.

Refer to the Measurement & Automation Explorer Help for a complete tutorial about configuring the RT target. Select Help»MAX Help to access this help file, and then refer to the MAX Remote Systems Help section.

Tip The Measurement & Automation Explorer Help refers to the LabVIEW Real-Time Module. However, you can apply the same concepts when you use the LabWindows/CVI Real-Time Module.

Booting the RT Target into LabVIEW RT

Before you begin configuration, make sure your remote system is booted into LabVIEW Real-Time. If your RT target came with only LabVIEW Real-Time preinstalled on its hard drive, the system is already set up to boot into LabVIEW Real-Time. Many NI RT targets have DIP switches or BIOS settings for booting into LabVIEW Real-Time. For more information, refer to the Booting Into the LabVIEW Real-Time Module topic in the Measurement & Automation Explorer Help.

You can permanently format the hard drive and configure it to boot directly into RT using the Tools»Desktop PC Utility USB Drive command in MAX.

Configuring Network Settings

Note For the initial configuration, you must connect networked RT targets to the same network subnet as the host computer from which you launch MAX.

1. Connect the RT target to the network and power on the target.
2. Launch MAX and expand the Remote Systems item in the MAX configuration tree.
3. Select the RT target from the Remote Systems list. Some RT targets will be listed with an automatically configured name or IP address while other targets will be listed as 0.0.0.0.
4. Specify a name for the RT target in the System Settings tab.
5. Configure the IP address settings in the Network Settings tab using one of the following options:
   • Select the DHCP or Link Local item from the Configure IPv4 Address option to obtain an IP address automatically.
   • Select the Static item from the Configure IPv4 Address option and specify an IP address.
6. Click Save to commit the changes.
7. Click Yes to reboot the RT target when prompted.
Installing Software on the RT Target

Use the LabVIEW Real-Time Software Wizard in MAX to install the software and drivers from the host computer on the RT target. With the LabVIEW Real-Time Software Wizard, you can view and change the software that is installed on the target. Click Help in the wizard for more information about installing and uninstalling software on the RT target.

Complete the following steps to launch the LabVIEW Real-Time Software Wizard:

1. Launch MAX.
2. Find and expand your RT target under the Remote Systems item in the MAX configuration tree, right-click Software, and select Add/Remove Software.
   When you select Add/Remove Software, MAX launches the LabVIEW Real-Time Software Wizard. This displays all the National Instruments software and drivers installed on the host computer that you can install on a selected RT target.
3. Select the software you want to install on the RT target, click the icon next to the software, and select Install the feature.

Some components are automatically included as dependencies of other components. For more information about the features listed in the wizard, select the feature to view a description.

The following list describes components you might commonly install.

- **Ethernet Drivers**—MAX automatically selects the appropriate Ethernet driver(s) for the RT target when you install the LabWindows/CVI Run-Time Engine for RT component.
- **LabVIEW Real Time**—MAX selects this item automatically when you install the LabWindows/CVI Run-Time Engine for RT component.
  - **NI RT Extensions for SMP (MultiCore Support)**—Install this item to take advantage of parallel processing on a multiple-CPU system.

  **Note** If you have multiple versions of a component installed on the host computer, the most recent version is selected by default. You can choose to install another version.

- **LabWindows/CVI Network Streams for RT**—Install this item if your application uses functions from the Network Streams Library.
- **LabWindows/CVI Network Variable for RT**—Install this item if your application uses functions from the Network Variable Library.

  **Note** Single-CPU systems perform best without the NI RT Extensions for SMP. Also, some applications, such as those that consist mainly of single-point I/O, can achieve lower latency on a multicore system by using a single CPU without the NI RT Extensions for SMP.
• **LabWindows/CVI Run-Time Engine for RT**—Install this item to add support for LabWindows/CVI RT applications on the RT target. This component is required for all LabWindows/CVI RT applications.

• **Language Support for LabVIEW RT**—Install this item if you are using strings in your RT application containing ASCII characters above 127 or multibyte characters. After installing this item on the RT target, you can configure the locale in MAX by selecting the target in the Remote Systems item in the MAX configuration tree, selecting the System Settings tab, and modifying the Locale option.

• **NI Hardware Drivers**—Install the appropriate drivers for any other hardware libraries that you use in your application. For example, install the NI-DAQmx component if your application uses functions from the NI-DAQmx Library.

• **Network Variable Engine**—MAX automatically selects this item when you install the LabWindows/CVI Network Variable for RT component.

• **NI Web-Based Configuration and Monitoring**—Install this item to use a Web browser to monitor and configure an RT target.

• **State System Publisher**—Install this item to monitor CPU and memory usage for an RT target from the NI Distributed System Manager.

• **USB Support**—Install this item to enable support for accessing USB thumbdrives.

• **Variable Client Support for LabVIEW RT**—MAX automatically selects this item when you install the LabWindows/CVI Network Variable for RT component.

4. When you finish selecting the software you want to install, click Next and continue following the instructions on the screen.

**Configuring I/O**

You must configure any National Instruments I/O devices before you can use them from a LabWindows/CVI RT application. For information about how to correctly configure I/O devices, refer to the documentation for that hardware.

**Configuring System Settings**

1. Select the System Settings tab to configure system-level settings for the RT target.

2. Configure the Locale option to match the language you use for strings in your RT application. This option is available only when you install the Language Support for LabVIEW RT component on the RT target. This option determines the code page that LabWindows/CVI uses when processing strings containing ASCII characters above 127 or multibyte characters.

**Configuring Time Settings**

1. Select the Time Settings tab to configure date and time settings for the RT target.

2. Use the Time Zone option to configure the time zone for the RT target. You can use this setting with time and date functions to provide accurate time information relative to the time zone setting.
Using NI Web-Based Monitoring and Configuration

If you install NI Web-Based Monitoring and Configuration, you can use a Web browser to monitor and configure the RT target.

**Note** You must install Microsoft Silverlight to use NI Web-Based Monitoring and Configuration. If you have not installed Microsoft Silverlight, NI Web-Based Monitoring and Configuration prompts you to do so.

1. In a Web browser, enter the URL `http://[IP address of the RT target]` to access Web-based monitoring and configuration for the remote system.
2. Click the **Login** button in the top-right corner of the page.
3. Enter **Admin** in the **User name** field.
4. Leave the **Password** field blank.
5. Click the **OK** button.
6. When you log in, you can view and change system, network, security, and time settings; view console output remotely; access the file system remotely; and so on.

For more information about NI Web-Based Monitoring and Configuration, refer to the *LabWindows/CVI Real-Time Module Help*.

Configuring an RT Project

After you configure the RT target, you can create an RT application on the host computer and then run the application on an RT target. The applications that you create with the LabWindows/CVI Real-Time Module are DLLs.

Complete the following steps to create a DLL and specify an RT target directly from LabWindows/CVI.

1. Create a project in LabWindows/CVI using RTmain instead of main as the entry point function for the program. Select **Edit»Insert Construct»RTmain** to insert the RTmain code into the program source.
2. Select **Build»Configuration»Debug** or **Build»Configuration»Release** to specify the active configuration for the project.
3. Select **Build»Target Type»Dynamic Link Library** to configure the project to generate a DLL.
4. Select **Build»Target Settings** to open the Target Settings dialog box. Select **Real-time only** in the **Run-time support** option. If you specify this option, LabWindows/CVI does not link to the entire set of LabWindows/CVI libraries but instead links to only those libraries supported on an RT system.
5. Click **OK** to exit the dialog box.
6. Select **Build»Build** to create the DLL.

You also can use a project template to create an RT DLL. The project template includes basic settings for RT projects described in the preceding section. To select a project template,
select **File»New»Project from Template.** In the New Project from Template dialog box, select **Real-Time Target Application.**

## Specifying an RT Target

Complete the following steps to select the RT target on which to run your RT application.

1. Select **Run»Select Execution Target for Debugging** to view a list of previously configured RT targets. Select the RT target you want to use from the list, if it is available.

2. To configure a new RT target, select **Run»Select Execution Target for Debugging»New Execution Target.**

3. In the New Real-Time Execution Target dialog box, enter the computer name or IP address of the RT target in the **Hostname/IP Address** option and click **OK** to exit the dialog box.

## Running an RT Application

Select **Run»Debug Project** to run your RT application.

---

**Note**  If you select **Run»Configuration»Release**, LabWindows/CVI displays a warning message. Click **Continue** to download and run the release DLL on the RT target.

LabWindows/CVI automatically builds the DLL and downloads the DLL and any DLLs that are statically linked to it onto the specified RT target. LabWindows/CVI places the files that it automatically downloads in the **NI-RT\CVI\temp** folder. LabWindows/CVI emptied the folder when you reset the RT device.

While you run your RT application, LabWindows/CVI displays a **<<Running on target>>** menu in the upper left corner of the LabWindows/CVI environment. The menu contains the following options, which you can use for debugging and for shutting down the RT application:

- **Toggle Breakpoint**—Turn on or turn off a breakpoint on the selected line when a Source window is active.
- **Break Execution**—Suspend execution of the program.
- **Simulate RT Shutting Down**—End program execution. This option causes the **RTIsShuttingDown** function to return 1, giving the RT application an opportunity to run any necessary cleanup code and exit. The RT target does not reboot.
- **Abort Execution and Reboot Target**—End program execution and reboot the RT target. The application cleanup code is not guaranteed to finish running before the RT target reboots.
- **Disconnect from RT target**—Disconnect LabWindows/CVI from the RT target while the RT application continues running on the target. Once you disconnect from the RT target, you cannot reconnect LabWindows/CVI to the RT application that is running.
Getting Started with the LabWindows/CVI Real-Time Module

Debugging an RT Application

If you select Build»Configuration»Debug, you can debug the DLL from the LabWindows/CVI environment as you would debug any other application. For example, you can set breakpoints and watch expressions, step through code, view and edit variable values, and so on. For more information about debugging in LabWindows/CVI, refer to the Using LabWindows/CVI» Debugging Tools section of the LabWindows/CVI Help.

Using the Real-Time Execution Trace Toolkit

The LabWindows/CVI Real-Time Module includes a limited time full-featured evaluation of the Real-Time Execution Trace Toolkit.

Use the Real-Time Execution Trace Toolkit to analyze the timing and execution of an RT application. Use the Execution Trace functions in the Real-Time Utility Library to capture the timing and execution data of functions and threads in an application running on an RT target. The Real-Time Execution Trace Tool displays the timing and event data, or trace session, on the host computer.

In LabWindows/CVI, select Tools»Real-Time Execution Trace Tool to launch the Real-Time Execution Trace Tool. Refer to the LabWindows/CVI Help for more information about using the Real-Time Execution Trace Toolkit to analyze RT applications.

Deploying an RT Application

When you finish developing your RT application, you can deploy it to an RT target. After you deploy the RT application, the RT application runs automatically every time the RT target reboots.

Select Run»Install Program to Real-Time Execution Target to deploy your RT application. This option performs the following actions:

- Checks that the release configuration of the DLL has been built; if not, LabWindows/CVI prompts you to build the DLL or cancel.
- Deploys the release DLL and any statically linked DLLs to the NI-RT\CVI folder on the RT target.
- Sets the release DLL as a startup DLL.
- Displays a dialog box indicating that the DLL was copied and prompting you to reboot the RT target.

If you have additional support files that you need to deploy, complete the following steps:

1. Select Run»Manage Files on Real-Time Execution Target to launch the LabWindows/CVI Real-Time File Copy Utility.
2. Click Add Files and browse to any support files that your application requires. The utility immediately copies the files to the NI-RT\CVI folder on the RT target.
3. Click Done when you finish adding support files.
Where to Go from Here

Refer to the following resources for more information about the LabWindows/CVI Real-Time Module:

- The *LabWindows/CVI Real-Time Module Help* section of the *LabWindows/CVI Help* includes conceptual information about real-time programming techniques, application architectures, and Real-Time Module software features you can use to create real-time applications. Select **Help»Contents** in LabWindows/CVI to access the *LabWindows/CVI Help*.

- Use the NI Example Finder, available by selecting **Help»Find Examples** in LabWindows/CVI, to browse or search for example programs. You also can access the example programs from the `samples\CVI samples\realtime` directory.