Worldwide Technical Support and Product Information

ni.com

National Instruments Corporate Headquarters
11500 North Mopac Expressway  Austin, Texas 78759-3504  USA  Tel: 512 683 0100

Worldwide Offices
Australia 1800 300 800, Austria 43 662 457990-0, Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,
Canada 800 433 3488, China 86 21 5050 9800, Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,
Finland 358 (0) 9 725 72511, France 01 57 66 24 24, Germany 49 89 7413130, India 91 80 41190000,
Israel 972 3 6393737, Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400,
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, Poland 48 22 328 90 10, Portugal 351 210 311 210,
Russia 7 495 783 6851, Singapore 1800 226 5886, Slovenia 386 3 425 42 00, South Africa 27 0 11 805 8197,
Spain 34 91 640 0085, Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, Taiwan 886 02 2377 2222,
Thailand 662 278 6777, Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

For further support information, refer to the Technical Support and Professional Services appendix. To comment on National Instruments documentation, refer to the National Instruments Web site at ni.com/info and enter the info code feedback.

© 2006–2010 National Instruments Corporation. All rights reserved.
Important Information

Warranty
The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THEREFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. Any action against National Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges; fire, flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, recording, in storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

BSIM3 and BSIM4 are developed by the Device Research Group of the Department of Electrical Engineering and Computer Science, University of California, Berkeley and copyrighted by the University of California.

The ASM51 cross assembler bundled with Multisim MCU is a copyrighted product of MetaLink Corp. (www.metaice.com).

MPASM™ macro assembler and related documentation and literature is reproduced and distributed by Electronics Workbench under license from Microchip Technology Inc. All rights reserved by Microchip Technology Inc. MICROCHIP SOFTWARE OR FIRMWARE AND LITERATURE IS PROVIDED "AS IS," WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL MICROCHIP BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY ARISING OUT OF OR IN CONNECTION WITH THE SOFTWARE OR FIRMWARE OR THE USE OF OTHER DEALINGS IN THE SOFTWARE OR FIRMWARE.

Anti-Grain Geometry - Version 2.4
Copyright (C) 2002-2004 Maxim Shemanarev (McSeem)

Permission to copy, use, modify, sell and distribute this software is granted provided this copyright notice appears in all copies. This software is provided "as is" without express or implied warranty, and with no claim as to its suitability for any purpose.

Anti-Grain Geometry - Version 2.4
Copyright (C) 2002-2005 Maxim Shemanarev (McSeem)

1. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
2. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
3. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.

The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Trademarks
National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section on ni.com/legal for more information about National Instruments trademarks.

Electronics Workbench, Multisim and Ultiboard are trademarks of National Instruments.

Portions of this product obtained under license from Bartels Systems GmbH.
Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency, partnership, or joint-venture relationship with National Instruments.

Patents
For patents covering National Instruments products/technology, refer to the appropriate location: Help » Patents in your software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.

Some portions of this product are protected under United States Patent No. 6,560,572.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF HARM TO PROPERTY OR PERSONS, INCLUDING THE RISK OF BODILY INJURY AND DEATH SHOULD NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.
The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options to a final action. The sequence Tools»Clear ERC Markers»Entire design directs you to pull down the Tools menu, select the Clear ERC Markers item, and select Entire design from the resulting dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to avoid injury, data loss, or a system crash.

**bold** Bold text denotes items that you must select or click in the software, such as menu items and dialog box options. Bold text also denotes parameter names.

*italic* Italic text denotes variables, emphasis, a cross-reference, or an introduction to a key concept. Italic text also denotes text that is a placeholder for a word or value that you must supply.

**monospace** Text in this font denotes text or characters that you should enter from the keyboard, sections of code, programming examples, and syntax examples. This font is also used for the proper names of disk drives, paths, directories, programs, subprograms, subroutines, device names, functions, operations, variables, filenames, and extensions.

**monospace bold** Bold text in this font denotes the messages and responses that the computer automatically prints to the screen. This font also emphasizes lines of code that are different from the other examples.

**monospace italic** Italic text in this font denotes text that is a placeholder for a word or value that you must supply.
## Contents

### Chapter 1
**Educators’ Guide**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Circuit Creator’s Name</td>
<td>1-1</td>
</tr>
<tr>
<td>Using Restrictions</td>
<td>1-2</td>
</tr>
<tr>
<td>Setting Global Restrictions</td>
<td>1-2</td>
</tr>
<tr>
<td>General Global Restrictions</td>
<td>1-3</td>
</tr>
<tr>
<td>Simplified Version</td>
<td>1-4</td>
</tr>
<tr>
<td>Global Analyses Restrictions</td>
<td>1-4</td>
</tr>
<tr>
<td>Setting Circuit Restrictions</td>
<td>1-5</td>
</tr>
<tr>
<td>Setting Passwords for Restrictions</td>
<td>1-7</td>
</tr>
<tr>
<td>Link to Education Resources</td>
<td>1-7</td>
</tr>
</tbody>
</table>

### Chapter 2
**Breadboarding**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Breadboarding Overview</td>
<td>2-1</td>
</tr>
<tr>
<td>Breadboard Settings</td>
<td>2-1</td>
</tr>
<tr>
<td>3D Options</td>
<td>2-3</td>
</tr>
<tr>
<td>Placing Components on the Breadboard</td>
<td>2-4</td>
</tr>
<tr>
<td>Appearance of 3D Components</td>
<td>2-6</td>
</tr>
<tr>
<td>Wiring Placed Components</td>
<td>2-7</td>
</tr>
<tr>
<td>Placing a Jumper</td>
<td>2-7</td>
</tr>
<tr>
<td>Changing Jumper Wire Color</td>
<td>2-9</td>
</tr>
<tr>
<td>Viewing Component Information</td>
<td>2-9</td>
</tr>
<tr>
<td>Two-terminal Components</td>
<td>2-10</td>
</tr>
<tr>
<td>Manipulating the Breadboard View</td>
<td>2-11</td>
</tr>
<tr>
<td>Breadboard Netlist dialog box</td>
<td>2-12</td>
</tr>
<tr>
<td>DRC and Connectivity Check</td>
<td>2-13</td>
</tr>
</tbody>
</table>

### Chapter 3
**Virtual NI ELVIS**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview</td>
<td>3-1</td>
</tr>
<tr>
<td>The Virtual NI ELVIS I Schematic</td>
<td>3-1</td>
</tr>
<tr>
<td>NI ELVIS I Instruments</td>
<td>3-4</td>
</tr>
<tr>
<td>Oscilloscope</td>
<td>3-5</td>
</tr>
<tr>
<td>IV Analyzer and Multimeter</td>
<td>3-6</td>
</tr>
<tr>
<td>Function Generator</td>
<td>3-8</td>
</tr>
<tr>
<td>Power Supplies</td>
<td>3-9</td>
</tr>
</tbody>
</table>
Contents

The Virtual NI ELVIS II Schematic ................................................................. 3-9
Enabling NI ELVIS II Schematic Instruments for Simulation .................. 3-12
NI ELVIS II Instruments ............................................................................. 3-13
   Oscilloscope ................................................................................... 3-14
   Dynamic Signal Analyzer ................................................................. 3-15
   Bode Analyzer ............................................................................... 3-17
   Digital Multimeter .......................................................................... 3-18
   Arbitrary Waveform Generator .................................................... 3-19
   Function Generator ....................................................................... 3-20
   Variable Power Supply ................................................................. 3-22
   Digital Reader .............................................................................. 3-24
   Digital Writer ............................................................................... 3-26
   NI ELVISmx Instruments Toolbar ............................................... 3-27
NI ELVIS Prototyping Boards ............................................................... 3-29
   Wiring Placed Components in 3D Mode ........................................ 3-34

Chapter 4
PLD Schematics

Overview ...................................................................................................................... 4-1
   Components ........................................................................................... 4-2
   Port Connectors ...................................................................................... 4-2
   PLD Toolbar .......................................................................................... 4-3
   PLD Components Toolbar ....................................................................... 4-4
Creating a PLD Schematic ....................................................................................... 4-6
   Subcircuits and Hierarchical Blocks ..................................................... 4-8
      Placing PLDs as Subcircuits and Hierarchical Blocks .................. 4-9
      Placing a New PLD as a Subcircuit ................................................. 4-9
      Placing a New PLD as a Hierarchical Block .................................... 4-9
      Placing a New PLD Subcircuit in a PLD Schematic .................... 4-9
      Placing a New PLD Hierarchical Block in a PLD Schematic ......... 4-10
      Placing an Existing PLD Schematic as a Hierarchical Block in a
      PLD Schematic .............................................................................. 4-10
   Adding Components to a PLD Schematic ......................................... 4-10
   PLD Configuration File ......................................................................... 4-11
   Adding Port Connectors to a PLD Schematic ...................................... 4-11
   Port Connector Dialog Box .................................................................... 4-12
PLD Settings Dialog Box ....................................................................................... 4-13
   Port Connectors Tab ........................................................................... 4-13
      Add Defined Connector dialog box .................................................. 4-14
      General Tab ................................................................................... 4-14
Chapter 5
Ladder Diagrams

Overview....................................................................................................................... .5-1
Creating a Ladder Diagram............................................................................................5-1
AND Rungs and OR Rungs ..........................................................................................5-7
Sample Circuits..............................................................................................................5-10
  Holding Tank...................................................................................................5-10
  Conveyor Belt..............................................................5-17
  Traffic Light ..............................................................5-23

Appendix A
Technical Support and Professional Services

Index
Multisim is the schematic capture and simulation application of National Instruments Circuit Design Suite, a suite of EDA (Electronics Design Automation) tools that assists you in carrying out the major steps in the circuit design flow. Multisim is designed for schematic entry, simulation, and feeding to downstage steps, such as PCB layout.

In addition to the professional features that are detailed in the Multisim Help, there are a number of education-specific features that are outlined in this manual.

This chapter describes the tools that Multisim offers to let you exercise greater control over the program’s interface and functionality when sharing circuits with students, as well as to set certain aspects of a circuit’s behavior for instructional purposes.

Some of the described features may not be available in your edition of Multisim. Refer to the NI Circuit Design Suite Release Notes for a description of the features available in your edition.

**Circuit Creator’s Name**

Multisim provides a feature by which the name of the creator of each circuit is stored with that circuit. Educators can take advantage of this feature to identify the student who, for example, created the circuit being submitted as the answer to an assignment (provided that the student uses his/her own copy of the program to create the circuit). The name appears in the Circuit Restrictions dialog box, which you can view as long as no passwords have been set. Refer to the Setting Circuit Restrictions section for more information.
Using Restrictions

Restrictions are useful in a number of ways:

- when you are designing circuits for demonstration purposes and want to limit the functionality available to students.
- when you are sharing circuits with students and want:
  - to prevent them from being able to edit the circuit in any way
  - to limit the types of modifications they can make to a circuit
  - to limit the types of analyses they can perform on it
  - to limit the information they can see about certain parts of the circuit (for example, the value of a resistor you want them to calculate).

You can set global-level restrictions, which become default Multisim settings, or circuit-level restrictions, which affect only specific circuits.

To ensure that only you can set or modify restrictions, you can use passwords which can protect both global and circuit restrictions. It is important that you set passwords immediately when using restrictions that you want to keep secure against any modification by students. The password for global restrictions is encrypted and stored in the Multisim program file. The password for circuit restrictions (for restricting only a particular circuit) is encrypted and stored in the circuit file.

Setting Global Restrictions

Use global restrictions to set the basic level of functionality of Multisim available to students in all circuits with which they will work. You can select a default path where circuits are to be saved, hide databases and the In Use List, and determine whether students may edit components or place instruments.

You can also hide complicated instruments and analysis options from the menus by using the simplified version. Refer to the Simplified Version section for more information.

Note Global restrictions are overridden by circuit restrictions if the circuit restrictions are saved with the circuit. Refer to the Setting Circuit Restrictions section for more information.
General Global Restrictions

Complete the following steps to set general global restrictions:

1. Choose **Options»Global Restrictions**. The **Password** dialog box appears.

   **Note** The **Password** dialog also appears if you select **Options»Circuit Restrictions**, if you have previously set a password by clicking **Password** from the **Circuit Restrictions** dialog box. Refer to the **Setting Circuit Restrictions** section for information about the **Circuit Restrictions** dialog box.

2. Enter the default password **Rodney** (this is case sensitive) and click **OK**. The **Global Restrictions** dialog box appears.

   **Note** You should change the default password. Refer to the **Setting Passwords for Restrictions** section for more information.

3. Click the **General** tab.

4. Set the default path and location where students find and save files in the **Circuit Path** field.

5. Set the following as desired in the **Toolbars** box:
   - **Disable Instruments toolbar**—Makes instruments unavailable to be placed in the circuit.
   - **Disable In-Use List toolbar**—Hides the **In Use List**.

6. Set the following as desired in the **Databases** box:
   - **Disable database editing**—Ensures that students cannot edit components in the database.
   - **Disable Master database component access**—Hides the Multisim Master database and component groups and families from the interface.
   - **Disable Corporate database component access**—Hides the corporate database and component groups and families from the interface.
   - **Disable User database component access**—Hides the “user” database and component groups and families from the interface.

7. Click **OK**. Your options are immediately set for all circuits, unless you have set circuit restrictions. Refer to the **Setting Circuit Restrictions** section for more information.
Simplified Version

The simplified version restricts students to only certain instruments and analyses. The simplified version can also be locked, preventing students from turning it off with Options»Simplified Version and having access to all analyses and instruments.

Complete the following steps to set up the simplified version:

1. Display the General tab of the Global Restrictions dialog box.
2. Set your options by enabling one of the following options:
   - Lock simplified—Disables the Options»Simplified Version menu option.
   - Simplified version—Changes the interface display by hiding the more complex functions and restricting the available instruments and analyses. If the simplified version is restricted, it will be greyed out in the Options menu.
   - Full version—Displays the full default interface without restrictions.
3. Click OK.

Your options are immediately set for all circuits, unless you have set circuit restrictions. Refer to the Setting Circuit Restrictions section for more information.

Global Analyses Restrictions

Complete the following steps to set global analyses restrictions:

1. From the Global Restrictions dialog box, click the Analysis tab.
2. Enable the desired analyses by selecting their checkboxes and click OK. Only the analyses you check will be enabled in the Simulate»Analyses menu or when the student clicks the Grapher/Analyses List button in the Main toolbar.

Note Refer to the Analysis section of the Multisim Help for more information on analyses.

These options are immediately set for all circuits, unless you have set circuit restrictions. Refer to the Setting Circuit Restrictions section for more information.
Setting Circuit Restrictions

Use circuit restrictions to set restrictions on individual circuits. Circuit restrictions override global restrictions. They are saved with your circuit and invoked each time the circuit is loaded. In addition to hiding databases and setting available analyses, you can set a schematic to be read-only (not editable by students), you can hide components’ values, faults and uses in analyses, and you can lock subcircuits to make them unavailable for opening by students.

Note  Remember that circuit restrictions only apply to the current circuit; when you create a new circuit, only the global restrictions will apply. Refer to the Setting Global Restrictions section for more information. If you want circuit restrictions to apply to a new circuit, you will need to reset those restrictions each time you create a new circuit.

Complete the following steps to set general circuit restrictions:

1. Choose Options»Circuit Restrictions. If you have created a password, you will be prompted for it. Refer to the Setting Passwords for Restrictions section for more information. Enter your password in the Password dialog box, and click OK. The Circuit Restrictions dialog box appears.

2. Click the General tab and set the desired options by enabling the appropriate checkboxes. Select from the following options:
   - **Schematic read-only**—Prevents students from saving the circuit, and hides components bins. Students will only be able to draw wires between instruments and an open pin on an existing connector. Also, they can only remove wires that are between an instrument and a connector.
   - **Circuit description read-only**—Prevents students from changing the contents of the Description Box.
   - **Hide component values**—Marks the Values tab of components’ properties dialog boxes with an “X” and hides values. You may wish to provide false values using labels.
   - **Hide component faults**—Marks the Faults tab of components’ properties dialog boxes with an “X”, and hides faults.
   - **Lock subsheets**—Prevents students from opening subcircuits and hierarchical blocks and seeing their contents. Students must measure the input and output of a hidden subsheet to determine its contents.
   - **Disable Instruments toolbar**—Makes instruments unavailable to be placed on the circuit.
   - **Disable In-Use List toolbar**—Disables the In-Use List for the current circuit.
• **Disable Multisim Master database component access**—Hides the Multisim Master database and components groups and families from the current circuit.

• **Disable User database component access**—Hides the user database and components groups and families from the current circuit.

• **Disable Corporate database component access**—Hides the corporate database and components groups and families from the interface.

**Note** The Circuit creator name is taken from the operating system.

3. Click OK. The options you select are immediately invoked in the circuit.

4. To have the restrictions apply each time the circuit is opened, choose File » Save to save the restrictions in the circuit file.

Complete the following steps to set circuit analyses restrictions:

1. From the Circuit Restrictions dialog box, click the Analysis tab.

2. Enable the desired analyses by selecting their checkboxes and click OK. Only the analyses you check will be enabled in the Simulate » Analyses menu or when the student clicks the Grapher/Analyses List button in the Main toolbar.

**Note** Refer to the Analysis section in the Multisim Help for more information on analyses.

3. To have these analyses apply each time the circuit is opened, choose File » Save to save the restrictions.

Complete the following steps to set circuit breadboard restrictions:

1. From the Circuit Restrictions dialog box, click the Breadboard tab.

2. Set the following as desired:

   • **Highlight target holes**—Disable if you do not wish to see where the targets for jumper wires are when placing them on the breadboard.

   • **Completion feedback**—Disable if you do not wish components and wires on the schematic to change color as they are placed and wired on the breadboard.

3. Click OK.

**Note** For details on breadboarding, refer to Chapter 2, *Breadboarding*. 
Setting Passwords for Restrictions

When using restrictions, you should create a password immediately to ensure that your settings are secure.

Complete the following steps to create/change a password:
1. For global restrictions, choose Options»Global Restrictions. 
   Or
   For circuit restrictions, choose Options»Circuit Restrictions.
2. Enter a password if prompted to do so.

   Note  The default password for global restrictions is Rodney (this is case sensitive). Circuit restrictions do not have a default password.

3. From the restrictions dialog box that appears, click Password. The Change Password dialog box appears.
4. If you are choosing a password for the first time, leave the Old password field blank.
5. If you are changing a password, enter the old password in the Old password field.
6. Enter your (new) password by entering it again in the Confirm password field.
7. Click OK to return to the dialog box, or Cancel to begin again.

   Note  If you want to change global or circuit restrictions, you will need to enter the respective password. Be sure to keep your passwords for both the Global restrictions and Circuit restrictions dialogs written down and in a safe place, as you will not be able to retrieve them from the program or circuit files, where they are stored in encrypted form.

   Note  A circuit password is not automatically transferred to a new circuit when you go to set circuit restrictions for it, so you will need to recreate the password every time you create circuit restrictions that you want to keep secure.

Link to Education Resources

   Note  This function is hidden when the simplified version option is selected. Refer to the Simplified Version section for more information.

To go to the National Instruments Academic website, click the Educational Website button or select Tools»Education Web Page.
This chapter describes Multisim’s breadboarding feature.

Some of the described features may not be available in your edition of Multisim. Refer to the NI Circuit Design Suite Release Notes for a description of the features available in your edition.

**Breadboarding Overview**

The **Breadboarding** feature provides a technical aid for educators who wish to illustrate breadboarding as a means of prototyping circuit designs. It also gives students exposure to the breadboarding process, and shows in 3D what the resulting breadboard will look like when completed.

**Breadboard Settings**

The default breadboard is shown in the screen capture below. If you wish to change the default settings, use the following procedure.

Complete the following steps to change the breadboard’s settings:

1. Select **Tools»Show Breadboard** from the main Multisim menu. The **Breadboard View** displays. The default breadboard appears as shown below.
As shown in the figure above, the default breadboard contains: one slat with two rows (1); one left strip (2); one bottom strip (3); one right strip (4); one top strip (5).

2. Select **Options > Breadboard Settings** to display the **Breadboard Settings** dialog box.

3. Enter the desired parameters for the breadboard:
   - **Number of Slats**—The number of slats to appear on the breadboard.
   - **Rows in a Slat**—The number of rows in each slat.
   - **Top Strip** checkbox—Select to include a top strip on the breadboard.
   - **Bottom Strip** checkbox—Select to include a bottom strip on the breadboard.
   - **Left Strip** checkbox—Select to include a left strip on the breadboard.
   - **Right Strip** checkbox—Select to include a right strip on the breadboard.

   **Note** Refer to the figure in step 1 for an illustration of the above parts of the breadboard.

4. Click **OK**. The view of the breadboard changes to reflect your settings.
3D Options

The 3D viewing options for the Breadboard View are set in the 3D Options tab of the Global Preferences dialog box.

Complete the following steps to change the 3D options:

1. Select Options » Global Preferences and click on the 3D Options tab.
2. Optionally, click on Background color to display a standard Color dialog box where you can adjust the background color as desired.
3. In the Info Box area:
   - Info Box — Disable this checkbox if you do not wish to see the box at the top of the Breadboard View that shows components information.
   - Left — Select to place the components information box at the top-left of the Breadboard View.
   - Center — Select to place the components information box at the top-center of the Breadboard View.
   - Right — Select to place the components information box at the top-right of the Breadboard View.
4. Disable the Show Target Holes checkbox if you do not wish to see where the targets for jumper wires are when placing them. Refer to the Placing a Jumper section for more information.
5. Disable the Show Completion Feedback checkbox if you do not wish components and wires on the schematic to change color as they are placed and wired on the breadboard.
6. In the 3D Performance box:
   - Move the slider as desired to improve graphic performance. More Details cause a slower screen refresh rate.
   - Enable the User Defined checkbox and disable the 3D features that you do not wish to see (Show Breadboard Numbers, Show Lights, Show Reflections, Show Transparent Indicators).

Tip  Disabling Show Breadboard Numbers will result in a much quicker refresh rate.
Placing Components on the Breadboard

Complete the following steps to place components on a breadboard:

1. Create a schematic diagram of the desired circuit in the usual manner.
2. Select **Tools»Show Breadboard** from the main Multisim menu. The **Breadboard View** displays similar to the following example.

3. Click on a component in the **Place Component Bar** and drag it to the desired location on the breadboard. As the component passes over the breadboard, sockets change color as shown below.
Tip  Select <Ctrl-R> to rotate a selected component 90 degrees clockwise or <Ctrl-Shift-R> to rotate it 90 degrees counter-clockwise.

4. Release the mouse button to place the component. Notice that the colored (red and green) sockets on the breadboard no longer appear.

5. Return to the schematic view and note that the color of the placed component has changed as shown in the example below (R1).
6. Continue placing the circuit’s components on the breadboard. When all the components have been placed, the **Place Component Bar** collapses as shown below.

**Tip** Where pins of components are connected on the schematic, you can place them in connected sockets on the breadboard as shown below. This technique can reduce the number of jumper wires required. Refer to the **Placing a Jumper** section for more information about jumpers.

**Appearance of 3D Components**

The appearance of the 3D component is dependant on the footprint that is selected from the **Select a Component** browser during schematic capture in the **Footprint manufacturer/Type** list.

Some virtual components have a default 3D view that appears as a blue 3D rectangle or cube. “Real” components that have pin pitch (spacing) that does not fit the pin pitch on the breadboard will also appear as 3D rectangles or cubes, with properly spaced pins—see below.
Note  Certain virtual components, including 3D components, also appear as 3D rectangles or cubes.

To view footprint information, hover the cursor over the desired component. Refer to the Viewing Component Information section for more information.

Wiring Placed Components

By placing component pins that are connected on the schematic into sockets that are internally connected, much of the “wiring” can be done at the same time components are placed. However, in most circuits, it will also be necessary to place jumpers to complete the wiring of the placed components.

Placing a Jumper

Complete the following steps to place a jumper wire:

1. Click on a socket connected to the pin where you wish to start the jumper and begin moving the cursor. Legitimate “target” pins display as shown below.
2. Click to place the jumper in the desired socket.

3. Return to the schematic view and note that the color of the wire connecting the two pins has changed to green to indicate a connection has been made, as shown in the figure below, between pin 2 of U2, and pin 1 of U3.

Note If a net contains more than two connections, all must be connected before any of the wires in the net change color.

4. Continue placing jumpers until all schematic connections have been made.

Tip Run a Design Rules Check and Connectivity Check to see if there are any errors in your breadboard. Refer to the DRC and Connectivity Check section for more information.
Changing Jumper Wire Color

Complete the following steps to change jumper wire color:

1. Select Edit->Breadboard Wire Color.
2. Select the desired color from the Colors dialog box that appears.

Note  The color of previously placed wires is not affected. The new color will be applied to any subsequently placed wires.

Viewing Component Information

Complete the following steps to view information about a specific component:

1. Hover the cursor over the component. The information box is populated as shown below.
Complete the following steps to see pin information:

1. Hover the cursor over the “metal” part of the desired pin. The information box now includes the pin name and the schematic net to which the pin should be connected.

**Note** This only works for placed components.

Two-terminal Components

Two-terminal non-directional components like resistors have symbol pin names (1 and 2) that automatically swap if they are connected the “wrong way” according to the pin name that is on the schematic.

Complete the following steps to view the pin names for all devices on the schematic:

1. Select **Options»Sheet Properties** and click the **Circuit** tab of the **Sheet Properties** dialog box.
2. Click the **Symbol Pin Names** checkbox until the checkbox contains a checkmark instead of a solid color.
3. Click **OK** to close the dialog.
In the above example, if Pin 1 is connected to a pin that should be connected to Pin 2, the pin names automatically swap. (Pin 1 becomes Pin 2 and vice versa.)

**Manipulating the Breadboard View**

You can manipulate the view of the breadboard in a number of ways.

To make the breadboard appear larger, select **View»Zoom in**.

To make the breadboard appear smaller, select **View»Zoom out**.

**Tip** Use your mouse’s center wheel to zoom in or out. (This must be set up in the **General** tab of the **Global Preferences** dialog box. For details, refer to the **Multisim Help**.)

To view the entire breadboard, select **View»Zoom Full**.

To rotate the breadboard 180 degrees, select **View»Rotate the View 180 Degrees**.

*Or*

Press <Shift-R> on your keyboard.

**Tip** Rotate the breadboard in any direction by dragging the mouse from a blank area of the **Breadboard View**.
To pan the breadboard, press <Shift> and use any of the arrow keys.

Or

Press <Ctrl-Shift> and drag the mouse.

Or

Hold down your mouse-wheel and drag the mouse.

**Breadboard Netlist dialog box**

Complete the following steps to display a netlist for the placed components and jumpers:

1. Select **Tools»Show Breadboard Netlist**. The **Breadboard Netlist** dialog box appears.

2. Optionally, click **Save** to save the breadboard netlist as a .txt or .csv file.

**Note** These nets are breadboard connections, and are not necessarily numbered in correspondence to the schematic nets.
DRC and Connectivity Check

You can run a **Design Rules and Connectivity Check** to see if there are any errors on your breadboard.

To run a DRC and Connectivity Check, select **Tools»DRC and Connectivity Check**. The results appear in the **Results** tab of the **Spreadsheet View**.

**Design Rule Errors**—Indicate connections that are on the breadboard that are not on the schematic.

**Connectivity Errors**—Indicate component pins that are connected to schematic nets whose connections are not all completed.
Virtual NI ELVIS

This chapter describes Multisim’s virtual NI ELVIS feature.

Some of the described features may not be available in your edition of Multisim. Refer to the *NI Circuit Design Suite Release Notes* for a description of the features available in your edition.

Overview

Virtual NI ELVIS emulates much of the behavior of its real-world counter-part, the NI Educational Laboratory Virtual Instrumentation Suite (NI ELVIS). Planning, prototyping and testing of instructors’ projects can be carried out on students’ PCs before moving on to the real NI ELVIS I or NI ELVIS II workstation in the lab.

Multisim emulates the original NI ELVIS I and NI ELVIS II. NI ELVIS II contains more instruments than the original. However, you should use whichever version you have in your lab. For details, refer to *The Virtual NI ELVIS I Schematic* and *The Virtual NI ELVIS II Schematic* sections.

The Virtual NI ELVIS I Schematic

A virtual NI ELVIS I schematic contains a number of items that correspond to elements of the real-world NI ELVIS workstation. The connection and control of these elements is described in this section.

**Note**  This section describes the behavior of Multisim’s original NI ELVIS I schematic. Refer to *The Virtual NI ELVIS II Schematic* section for information on Multisim’s NI ELVIS II functionality.
Complete the following steps to create a new virtual NI ELVIS I schematic:

1. Select **File»New»NI ELVIS I Design**. The schematic appears as shown below:

   ![Virtual NI ELVIS I schematic](image)

   **Note** The ground connector that appears at the bottom left of the diagram is the reference point for measurements taken during simulation, and must not be removed.

2. Place and wire components in the virtual NI ELVIS I schematic in the same manner as other Multisim schematics. For details, refer to the **Multisim Help**.

   The prototyping board rails (see 1 in the figure above) found to the left and right of the main workspace correspond to rails on the prototyping board of the real-world version of NI ELVIS, and are labelled in the same manner.

   Rows on the rails that are shown with green labels are not enabled for simulation in Multisim. However, they can be used for schematic capture and viewing of the completed virtual NI ELVIS I schematic in the 3D view.

   Unlike other Multisim components, these rails cannot be moved to other places on the workspace.
Chapter 3  Virtual NI ELVIS

LEDs
Connections to the eight LEDs on the right side of the NI ELVIS I schematic are found in the lower-right prototyping rail, as shown in the figure below (2). Any of these LEDs (1) that are correctly driven light during simulation.
Complete the following to connect to an LED:

1. Place a wire from one of the LED rows (LED 0 through LED 7) to the desired point in your schematic.

There are also three power supply LEDs in the lower-left section of any virtual NI ELVIS I schematic, as shown in the figure below (1).

During simulation, these LEDs light whether or not connections have been made to their corresponding pins in the prototyping rail. They indicate that power is available to the respective connections.

**NI ELVIS I Instruments**

One instance of each of the following NI ELVIS instruments is found in the virtual NI ELVIS I schematic:

- **Oscilloscope**—This instrument is a two-channel oscilloscope.
- **IV Analyzer and Multimeter**—This instrument can be enabled as either an IV analyzer, or a digital multimeter.
- **Function Generator**—This instrument generates sine, square or triangle waves.
- **Power Supplies**—This device is a variable power supply.
Oscilloscope

The connections to the virtual NI ELVIS oscilloscope are found in the upper-left prototyping rail.

To connect the oscilloscope, place wires from the points in your schematic that you wish to measure to any of the pins on the CH A+, CH A–, CH B+, CH B– or TRIGGER rows beside Oscilloscope. These rows correspond to the terminals of the oscilloscope.

- **CH A+** — Positive input of channel A.
- **CH A–** — Negative input of channel A.
- **CH B+** — Positive input of channel B.
- **CH B–** — Negative input of channel B.
- **TRIGGER** — Trigger input signal.

Complete the following steps to access the oscilloscope’s controls:

1. Double-click on the the Oscilloscope label in the upper-left prototyping rail. The instrument face for the Multisim virtual oscilloscope displays.
2. Refer to the Multisim Help for details on the use of this instrument.
When a new virtual NI ELVIS I schematic is opened, the IV Analyzer is disabled, and the Ammeter is enabled as shown in the above figure.

To disable the Ammeter and enable the IV Analyzer, double-click where indicated on the virtual NI ELVIS I schematic.

To disable the IV Analyzer and enable the Ammeter, double-click again.

Note When the IV Analyzer is enabled, there is a slight delay when simulation is started while a DC Sweep is performed. If the Ammeter is enabled, there is no delay.
Complete the following to connect the **IV Analyzer**:

1. Place wires from the component you wish to measure to the pins on the **3-WIRE, CURRENT HI** and **CURRENT LO** rows. These rows correspond to the inputs of the **IV Analyzer**. Refer to the figure below for connections for a diode (1); PNP BJT (2); NPN BJT (3); NMOS FET (4); PMOS FET (5).

2. Disconnect any other wires from the DMM terminals.

---

Complete the following to connect the **Ammeter/Ohmmeter**:

1. Place wires from the points in the circuit you wish to measure to the pins on the **CURRENT HI** and **CURRENT LO** rows. **CURRENT HI** corresponds to the + terminal of the meter and **CURRENT LO** corresponds to the – terminal.

2. Disconnect any other wires from the DMM terminals.

Complete the following steps to access the controls for the enabled instrument:

1. Double-click just above the **DMM** label. If you have enabled the **IV Analyzer** as described earlier, that instrument’s face appears. If you have enabled the **Ammeter**, an instrument containing the **Ammeter** and **Ohmmeter** functions of a multimeter appears.

2. Refer to the **Multisim Help** for details on the use of these instruments.
Complete the following to connect the **Voltmeter**:

1. Place wires from the points in the circuit you wish to measure to the pins on the **VOLTAGE HI** and **VOLTAGE LO** rows.  
   
   **VOLTAGE HI** corresponds to the + terminal of the meter and **VOLTAGE LO** corresponds to the – terminal.

2. Disconnect any other wires from the DMM terminals.

Complete the following steps to access the controls for the **Voltmeter**:

1. Double-click just below the DMM label. An instrument containing the **Voltmeter** function of a multimeter appears.

2. Refer to the *Multisim Help* for details on the use of this instrument.

**Function Generator**

Complete the following to connect the **Function Generator**:

1. Place wires from the pins on the **FUNC OUT, SYNC OUT, AM IN** and **FM IN** rows to the desired points in your schematic.
   
   - **FUNC OUT**—Output signal.
   - **SYNC OUT**—Outputs a TTL-compatible clock signal of the same frequency as the output waveform.
   - **AM IN**—A signal input here controls the amplitude of the signal at **FUNC OUT**.
   - **FM IN**—A signal input here controls the frequency of the signal at **FUNC OUT** and **SYNC OUT**.

Complete the following steps to access the controls for the **Function Generator**:

1. Double-click on the **Function Generator** label. The properties dialog for the **NI ELVIS Function Generator** appears.

2. Click on the **Value** tab and enter the desired output parameters.

3. Click **OK** to close the **Function Generator**’s properties dialog box.

**Note** Refer to the *Component Reference Help* for information about the user-settable parameters.

**Note** This instrument can be used for transient analysis only. It does not function for frequency-domain analyses. To run a frequency-domain analysis, use an AC source from the Multisim **Master database**. For more information on analyses, refer to the *Multisim Help*. 
Power Supplies

The lower-left prototyping rail contains the following fixed DC power supplies:

- +15 V
- –15 V
- +5 V (also found in the lower-right prototyping rail).

Variable Power Supplies are also available:

- SUPPLY + (+12 V max)
- SUPPLY – (–12 V max).

To connect to any of the power supplies, place wires from the pin on the corresponding row to the desired point in the circuit.

Complete the following steps to access the controls for the variable power supply:

1. Double-click on Variable Power Supplies. The properties dialog box for the NI ELVIS power supply appears.
2. Click on the Value tab and enter the desired parameters.
3. Click OK to close the properties dialog box.

Note Refer to the Component Reference Help for information about the user-settable parameters.

The Virtual NI ELVIS II Schematic

A virtual NI ELVIS II schematic contains a number of items that correspond to elements of the real-world NI ELVIS II workstation. The connection and control of these elements is described in this section.

Note This section describes the behavior of Multisim’s NI ELVIS II schematic. Refer to The Virtual NI ELVIS I Schematic section for information on Multisim’s original NI ELVIS I functionality.

Note During NI Circuit Design Suite (NI CDS) installation, the installer prompts you for the NI ELVISmx installation CD, which is included in your NI CDS package. NI ELVISmx enables the NI ELVIS II functionality in Multisim. If you do not install this software, the NI ELVIS II functionality will be disabled in Multisim.
Complete the following steps to create a new virtual NI ELVIS II schematic:

1. Select **File»New»NI ELVIS II Design**. When first opened, a virtual NI ELVIS II schematic appears as shown below.

![Diagram of virtual NI ELVIS II schematic]

**Note** The ground connector that appears at the bottom left of the diagram is the reference point for measurements taken during simulation, and must not be removed.

2. Place and wire components in the virtual NI ELVIS II schematic in the same manner as other Multisim schematics. For details, refer to the *Multisim Help*.

The prototyping board rails (see 1 in the figure above) found to the left and right of the main workspace correspond to rails on the prototyping board of the real-world version of NI ELVIS II, and are labelled in the same manner. At the top in the control panel sections (see 2 and 3 in the figure above),
there are icons for connecting to the oscilloscope, dynamic signal analyzer, bode analyzer and digital multimeter. These instruments are isolated and are not available in the rails of the prototyping board. They are found on the main real-world NI ELVIS II unit.

Rows on the rails that are shown with green labels are not enabled for simulation in Multisim. However, they can be used for schematic capture and viewing of the completed virtual NI ELVIS II schematic in the 3D view.

Unlike other Multisim components, these rails and instrument icons cannot be moved to other places on the workspace.

**LEDs**

Connections to the eight LEDs on the right side of the NI ELVIS II schematic are found in the NI ELVIS II Right-Bottom Rail Section, as shown in the figure below (2). During simulation, any of these LEDs (1) that are correctly driven will light.
Complete the following to connect to an LED:

1. Place a wire from one of the LED rows (LED 0 through LED 7) to the desired point in your schematic.

There are also three power supply LEDs in the lower-left section of any virtual NI ELVIS II schematic, as shown in the figure below (1):

During simulation, these LEDs will light whether or not connections have been made to their corresponding pins in the prototyping rail. They indicate that power is available to the respective connections.

**Enabling NI ELVIS II Schematic Instruments for Simulation**

NI ELVISmx instruments on the NI ELVIS II schematic can be enabled or disabled for simulation on an individual basis. Each enabled instrument consumes system resources, so setting unused instruments to disabled improves simulation speed.

When an NI ELVISmx instrument is disabled, a small red “X” appears next to the upper-right corner of the instrument icon on the schematic, as shown in the figure below (1). By default, all instruments in a new NI ELVIS II schematic begin as disabled.

**Note** NI ELVISmx instruments that are placed directly onto a workspace from the NI ELVISmx Instruments toolbar cannot be disabled for simulation. Refer to the *NI ELVISmx Instruments Toolbar* section for more information.
NI ELVISmx instruments’ enabled state for simulation may be modified in any one of three ways:

- Double-click on a disabled instrument to display its SFP. If simulation is running, a warning displays advising you to stop simulation before you enable the instrument.
- Right-click on the instrument to display a context menu that includes the item **NI ELVIS II Instrument Enabled in Simulation**. Select this menu item to toggle its check mark and switch the instrument from enabled to disabled and back again. This command is unavailable during simulation.
- Select **Simulate»NI ELVIS II Simulation Settings** to display the **NI ELVIS II Simulation Settings** dialog box. This lists the NI ELVIS instruments on the rails and platform control panel, with a check box next to each one. Check/uncheck the instrument name to enable/disable the instrument on the schematic. This menu item disabled during simulation.

**Note** This menu item is only active when an NI ELVIS II schematic is selected as the active workspace.

After enabling the desired instruments, run the simulation in the usual manner.

**Note** Refer to the *Multisim Help* for information about simulation.

### NI ELVIS II Instruments

The following NI ELVIS II instruments are available in Multisim:

- **Oscilloscope**—This instrument is a two-channel oscilloscope.
- **Dynamic Signal Analyzer**—This instrument computes and displays the RMS averaged power spectrum of a single channel.
- **Bode Analyzer**—This instrument measures the gain and phase shift versus frequency for passive or active linear circuits.
- **Digital Multimeter**—This instrument is a digital multimeter.
- **Arbitrary Waveform Generator**—This instrument generates user-specified waveforms.
- **Function Generator**—This instrument generates sine, square or triangle waves.
- **Variable Power Supply**—This device is a variable DC power supply.
- **Digital Reader**—This instrument reads digital data.
- **Digital Writer**—This instrument updates the digital output on the NI ELVIS II Prototyping Board with user-specific digital patterns.
There are three ways to access NI ELVIS II instruments:

- Use the pre-placed icons found on the NI ELVIS II schematic rails and platform control panel sections.
- Place them from the menu onto any Multisim workspace using Simulate»Instruments»NI ELVISmx Instruments»<instrument>.
- Place them from the NI ELVISmx Instruments toolbar onto any Multisim workspace. Refer to the NI ELVISmx Instruments Toolbar section for more information.

An NI ELVIS II instrument soft front panel (SFP) is where you find that instrument’s controls. To access any NI ELVIS II instrument’s SFP, double-click on its icon.

For information about any of the NI ELVIS II instruments, click the Help button on the instrument’s SFP to display the NI ELVISmx Help.

**Oscilloscope**

This instrument is a two-channel oscilloscope.

In NI ELVIS II schematics, this instrument’s pre-placed icon is located in the NI ELVIS II Platform Control Panel Scope Section of the NI ELVIS II schematic, as shown in the figure below (1).

![Oscilloscope Icon](image)

Complete the following step to connect the instrument:

1. Place wires from the desired points in your schematic to the pins on the NI ELVIS II Platform Control Panel Scope Section described below:
   - **TRIG**—Trigger input.
   - **CH 0 +** —Positive input of channel 0.
   - **CH 0 -** —Negative input of channel 0.
   - **CH 1+** —Positive input of channel 1.
   - **CH 1-** —Negative input of channel 1.
Complete the following steps to access the SFP:

1. Double-click the instrument’s icon, shown in the figure above (1). The SFP appears.
2. Change the settings in the SFP as desired.

Complete the following steps to place this instrument directly onto any Multisim workspace:

1. Select **Simulate»Instruments»NI ELVISmx Instruments»NI ELVISmx Oscilloscope**.
2. Click to place the instrument icon in the desired location on the workspace.
3. Wire in the same manner as any other Multisim instrument.

**Note**  You can also use the **NI ELVISmx Instruments** toolbar to place this instrument. Refer to the **NI ELVISmx Instruments Toolbar** section for more information.

For information about using this instrument, click the **Help** button on its SFP to display the **NI ELVISmx Help**.

**Dynamic Signal Analyzer**

The **NI ELVIS Dynamic Signal Analyzer** computes and displays the RMS averaged power spectrum of a single channel. A variety of windowing and averaging modes can be applied to the signal. It also detects the peak frequency component and estimates the actual frequency and power.

In NI ELVIS II schematics, this instrument’s icon is located in the NI ELVIS II Platform Control Panel Scope Section of the NI ELVIS II schematic, as shown in the figure below (1).

![Dynamic Signal Analyzer Icon](image)
Complete the following step to connect the instrument:
1. Place wires from the desired points in your schematic to the pins on the
   NI ELVIS II Platform Control Panel Scope Section described below:
   • TRIG—Trigger input.
   • CH 0+—Positive input of channel 0.
   • CH 0−—Negative input of channel 0.

Note CH 1+ and CH 1− are not used for this device.

Complete the following steps to access the SFP:
1. Double-click the instrument’s icon, shown in the figure above (1). The
   SFP appears.
2. Change the settings in the SFP as desired.

Complete the following steps to place this instrument directly onto any
Multisim workspace:
1. Select Simulate»Instruments»NI ELVISmx Instruments»
   NI ELVISmx Dynamic Signal Analyzer.
2. Click to place the instrument icon in the desired location on the
   workspace.
3. Wire in the same manner as any other Multisim instrument.

Note You can also use the NI ELVISmx Instruments toolbar to place this instrument. Refer to the
NI ELVISmx Instruments Toolbar section for more information.

For information about using this instrument, click the Help button on its
SFP to display the NI ELVISmx Help.
**Bode Analyzer**

The **NI ELVISmx Bode Analyzer** measures the gain and phase shift versus frequency for passive or active linear circuits.

In NI ELVIS II schematics, this instrument’s icon is located in the NI ELVIS II Platform Control Panel Scope Section of the NI ELVIS II schematic, as shown in the figure below (1).

Complete the following step to connect the instrument:

1. Place wires from the desired points in your schematic to the pins on the NI ELVIS II Platform Control Panel Scope Section described below:
   - **CH 0 +** — Positive Stimulus.
   - **CH 0 –** — Negative Stimulus.
   - **CH 1+** — Positive Response.
   - **CH 1–** — Negative Response.

Complete the following steps to access the SFP:

1. Double-click the instrument’s icon, shown in the figure above (1). The SFP appears.
2. Change the settings in the SFP as desired.

Complete the following steps to place this instrument directly onto any Multisim workspace:

1. Select `Simulate»Instruments»NI ELVISmx Instruments»NI ELVISmx Bode Analyzer`.
2. Click to place the instrument icon in the desired location on the workspace.
3. Wire in the same manner as any other Multisim instrument.

**Note** You can also use the **NI ELVISmx Instruments** toolbar to place this instrument. Refer to the **NI ELVISmx Instruments Toolbar** section for more information.

For information about using this instrument, click the **Help** button on its SFP to display the **NI ELVISmx Help**.
Digital Multimeter

This instrument is a digital multimeter (DMM).

In NI ELVIS II schematics, this instrument’s icon is located in the NI ELVIS II Platform Control Panel DMM Section of the NI ELVIS II schematic, as shown in the figure below (1).

Complete the following step to connect the instrument:

1. Place wires from the desired points in your schematic to the pins on the NI ELVIS II Platform Control Panel DMM Section described below:
   - V—Voltmeter input.
   - COM—Common input.
   - A—Ammeter input.

Complete the following steps to access the SFP:

1. Double-click the instrument’s icon, shown in the figure above (1). The SFP appears.
2. Change the settings in the SFP as desired.

Complete the following steps to place this instrument directly onto any Multisim workspace:

1. Select Simulate»Instruments»NI ELVISmx Instruments»NI ELVISmx Digital Multimeter.
2. Click to place the instrument icon in the desired location on the workspace.
3. Wire in the same manner as any other Multisim instrument.

Note  You can also use the NI ELVISmx Instruments toolbar to place this instrument. Refer to the NI ELVISmx Instruments Toolbar section for more information.

For information about using this instrument, click the Help button on its SFP to display the NI ELVISmx Help.
Arbitrary Waveform Generator

This instrument generates user-specified waveforms.

In NI ELVIS II schematics, this instrument’s icon is located in the NI ELVIS II Left-Bottom Rail Section of the NI ELVIS II schematic, as shown in the figure below (1).

Complete the following step to connect the instrument:

1. Place wires from the desired points in your schematic to the pins on the NI ELVIS II Left-Bottom Rail Section described below:
   - **AO 0**—Output pin 0.
   - **AO 1**—Output pin 1.

Complete the following steps to access the SFP:

1. Double-click the instrument’s icon, shown in the figure above (1). The SFP appears.
2. Change the settings in the SFP as desired.
Complete the following steps to place this instrument directly onto any Multisim workspace:

1. Select **Simulate»Instruments»NI ELVISmx Instruments»NI ELVISmx Arbitrary Waveform Generator**.
2. Click to place the instrument icon in the desired location on the workspace.
3. Wire in the same manner as any other Multisim instrument.

**Note** You can also use the **NI ELVISmx Instruments** toolbar to place this instrument. Refer to the **NI ELVISmx Instruments Toolbar** section for more information.

For information about using this instrument, click the **Help** button on its SFP to display the **NI ELVISmx Help**.

**Function Generator**

This instrument generates sine, square or triangle waves.

In NI ELVIS II schematics, this instrument’s icon is located in the NI ELVIS II Left-Bottom Rail Section of the NI ELVIS II schematic, as shown in the figure below (1).

![Function Generator Icon](image)

1 Function Generator Icon
Complete the following step to connect the instrument:
1. Place wires from the desired points in your schematic to the pin on the NI ELVIS II Left-Bottom Rail Section described below:
   • **FGEN**—Output from the device.

Complete the following steps to access the SFP:
1. Double-click the instrument’s icon, shown in the figure above (1). The SFP appears.
2. Change the settings in the SFP as desired.

Complete the following steps to place this instrument directly onto any Multisim workspace:
1. Select **Simulate»Instruments»NI ELVISmx Instruments»NI ELVISmx Function Generator**.
2. Click to place the instrument icon in the desired location on the workspace.
3. Wire in the same manner as any other Multisim instrument.

**Note** You can also use the **NI ELVISmx Instruments** toolbar to place this instrument. Refer to the **NI ELVISmx Instruments Toolbar** section for more information.

For information about using this instrument, click the **Help** button on its SFP to display the **NI ELVISmx Help**.
Variable Power Supply

This device is a variable DC power supply.

In NI ELVIS II schematics, this instrument’s icon is located in the NI ELVIS II Left-Bottom Rail Section of the NI ELVIS II schematic, as shown in the figure below (1).

Complete the following step to connect the device:

1. Place wires from the desired points in your schematic to the pins on the NI ELVIS II Left-Bottom Rail Section described below:
   - **SUPPLY +** — Positive output.
   - **SUPPLY –** — Negative output.

Complete the following steps to access the SFP:

1. Double-click the instrument’s icon, shown in the figure above (1). The SFP appears.
2. Change the settings in the SFP as desired.
Complete the following steps to place this instrument directly onto any Multisim workspace:

2. Click to place the instrument icon in the desired location on the workspace.
3. Wire in the same manner as any other Multisim instrument.

**Note** You can also use the NI ELVISmx Instruments toolbar to place this instrument. Refer to the NI ELVISmx Instruments Toolbar section for more information.

For information about using this instrument, click the Help button on its SFP to display the NI ELVISmx Help.

The left-bottom rail also contains the following fixed DC power supplies:
- $+15\,\text{V}$
- $-15\,\text{V}$
- $+5\,\text{V}$
Digital Reader

This instrument reads digital data.

In NI ELVIS II schematics, this instrument’s icon is located in the NI ELVIS II Right-Top Rail Section of the NI ELVIS II schematic, as shown in the figure below (1).

Complete the following step to connect the instrument:

1. Place wires from the desired points in your schematic to the pins on the NI ELVIS II Right-Top Rail Section described below:
   - DIO 8 – DIO 15—The inputs for the device.

Complete the following steps to access the SFP:

1. Double-click the instrument’s icon, shown in the figure above (1). The SFP appears.

2. Change the settings in the SFP as desired.
Complete the following steps to place this instrument directly onto any Multisim workspace:

2. Click to place the instrument icon in the desired location on the workspace.
3. Wire in the same manner as any other Multisim instrument.

**Note** You can also use the **NI ELVISmx Instruments** toolbar to place this instrument. Refer to the **NI ELVISmx Instruments Toolbar** section for more information.

For information about using this instrument, click the **Help** button on its SFP to display the **NI ELVISmx Help**.
Digital Writer

This instrument updates the digital output on the NI ELVIS Prototyping Board with user-specific digital patterns.

In NI ELVIS II schematics, this instrument’s icon is located in the NI ELVIS II Right-Top Rail Section of the NI ELVIS II schematic, as shown in the figure below (1).

Complete the following step to connect the instrument:

1. Place wires from the desired points in your schematic to the pins on the NI ELVIS II Right-Top Rail Section described below:
   - **DIO 0 – DIO 7**—The outputs for the device.

Complete the following steps to access the SFP:

1. Double-click the instrument’s icon, shown in the figure above (1). The SFP appears.
2. Change the settings in the SFP as desired.
Complete the following steps to place this instrument directly onto any Multisim workspace:

2. Click to place the instrument icon in the desired location on the workspace.
3. Wire in the same manner as any other Multisim instrument.

Note You can also use the NI ELVISmx Instruments toolbar to place this instrument. Refer to the NI ELVISmx Instruments Toolbar section for more information.

For information about using this instrument, click the Help button on its SFP to display the NI ELVISmx Help.

NI ELVISmx Instruments Toolbar

The buttons in the NI ELVISmx Instruments toolbar are described below. In each case, the button places a specific NI ELVISmx instrument on the workspace.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>NI ELVISmx Arbitrary Waveform Generator button. Places an NI ELVISmx arbitrary waveform generator on the workspace. Refer to the Arbitrary Waveform Generator section for more information.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>NI ELVISmx Digital Reader button. Places an NI ELVISmx digital reader on the workspace. Refer to the Digital Reader section for more information.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>NI ELVISmx Digital Writer button. Places an NI ELVISmx digital writer on the workspace. Refer to the Digital Writer section for more information.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>NI ELVISmx Digital Multimeter button. Places an NI ELVISmx digital multimeter on the workspace. Refer to the Digital Multimeter section for more information.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>NI ELVISmx Dynamic Signal Analyzer button. Places an NI ELVISmx dynamic signal analyzer on the workspace. Refer to the Dynamic Signal Analyzer section for more information.</td>
</tr>
</tbody>
</table>
### NI ELVISmx Function Generator button
Placed an NI ELVISmx function generator on the workspace. Refer to the Function Generator section for more information.

### NI ELVISmx Oscilloscope button
Placed an NI ELVISmx oscilloscope on the workspace. Refer to the Oscilloscope section for more information.

### NI ELVISmx Variable Power Supply button
Placed an NI ELVISmx variable power supply on the workspace. Refer to the Variable Power Supply section for more information.

### NI ELVISmx Bode Analyzer button
Placed an NI ELVISmx bode analyzer on the workspace. Refer to the Bode Analyzer section for more information.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt=" NI ELVISmx Function Generator button" /></td>
<td><strong>NI ELVISmx Function Generator</strong> button. Places an NI ELVISmx function generator on the workspace. Refer to the <a href="#">Function Generator</a> section for more information.</td>
</tr>
<tr>
<td><img src="image" alt=" NI ELVISmx Oscilloscope button" /></td>
<td><strong>NI ELVISmx Oscilloscope</strong> button. Places an NI ELVISmx oscilloscope on the workspace. Refer to the <a href="#">Oscilloscope</a> section for more information.</td>
</tr>
<tr>
<td><img src="image" alt=" NI ELVISmx Variable Power Supply button" /></td>
<td><strong>NI ELVISmx Variable Power Supply</strong> button. Places an NI ELVISmx variable power supply on the workspace. Refer to the <a href="#">Variable Power Supply</a> section for more information.</td>
</tr>
<tr>
<td><img src="image" alt=" NI ELVISmx Bode Analyzer button" /></td>
<td><strong>NI ELVISmx Bode Analyzer</strong> button. Places an NI ELVISmx bode analyzer on the workspace. Refer to the <a href="#">Bode Analyzer</a> section for more information.</td>
</tr>
</tbody>
</table>
NI ELVIS Prototyping Boards

Once you have completed the virtual NI ELVIS I or NI ELVIS II schematic, you are ready to place the components on the 3D rendering of the prototyping board.

The figure below shows the virtual NI ELVIS I 3D prototyping board (1) and platform (2) with no placed components.
The figure below shows the virtual NI ELVIS II 3D prototyping board (1) and platform (2) with no placed components.

**Note** The controls that appear on the NI ELVIS I and the NI ELVIS II 3D platforms are inactive. Interactive simulation is accomplished via the schematic view. For details on simulation, refer to the *Multisim Help*.

**Tip** For information about changing the 3D view, refer to the *Manipulating the Breadboard View* section of Chapter 2, *Breadboarding*. 
Complete the following steps to place components on the 3D prototyping board:

1. Select **Tools»Show Breadboard** from the main Multisim menu.

For NI ELVIS I designs, the 3D prototyping board appears similar to the example shown in the figure below:
For NI ELVIS II designs, the 3D prototyping board appears similar to the example shown in the figure below:

1. Component Description
2. Place Component Bar
3. Scroll Arrows

Note The Place Component Bar, shown in the figures above (2), is where components waiting to be placed on the prototyping board appear. To view other components, click the scroll arrows (3). To see a description of a component (for example, (1) in the above figure), hover the cursor over the component. 3D viewing options are set in the Global Preferences dialog box. Refer to the 3D Options section of Chapter 2, Breadboarding, for more information.

2. Click on a component in the Place Component Bar and drag it to the desired location on the board. As the component passes over the board, sockets change color as shown in the figure below.
Red sockets (1) indicate where the component’s pins will be placed when the mouse button is released. Green (2) indicates sockets that are internally connected to the red socket in the same row on the board.

**Tip** Select <Ctrl-R> to rotate a selected component 90 degrees clockwise or <Ctrl-Shift-R> to rotate it 90 degrees counter-clockwise.

3. Release the mouse button to place the component. The colored (red and green) sockets on the board no longer appear.

4. Return to the schematic view and note that the color of the placed component has changed as shown in the example below (R1).

5. Continue placing the circuit’s components on the board. When all the components have been placed, the **Place Component Bar** collapses.

**Tip** Where pins of components are connected on the schematic, you can place them in connected sockets as circled in the figure below. This technique can reduce the number of jumper wires required.
By placing component pins that are connected on the schematic into sockets on the 3D prototyping board that are internally connected, much of the “wiring” can be done at the same time components are placed. However, in most circuits, it will also be necessary to place jumpers on the 3D prototyping board to complete the wiring of the placed components.

Complete the following steps to place a jumper wire:

1. Click on a socket connected to the pin where you wish to start the jumper and begin moving the cursor. Legitimate “target” pins (green) display as you move the cursor.
2. Click to place the jumper in the desired socket.
3. Return to the schematic view and note that the color of the wire connecting the two pins has changed to green to indicate a connection has been made, as shown in the figure below, between pin 2 of U2, and pin 1 of U3.
Note: If a net contains multiple connections, all must be connected before any of the wires in the net change color.

4. Continue placing jumpers until all schematic connections have been made.

Tip: Run a Design Rules and Connectivity Check from the 3D prototyping view to see if there are any errors in your board. Refer to the DRC and Connectivity Check section of Chapter 2, Breadboarding, for more information.

Note: You may also wish to refer to the Viewing Component Information and Breadboard Netlist dialog box sections of Chapter 2, Breadboarding.
The following sections describe how to graphically define the internal structure of a PLD (programmable logic device), and how to export the PLD design to a VHDL file.

Some of the described features may not be available in your edition of Multisim. Refer to the *NI Circuit Design Suite Release Notes* for a description of the features available in your edition.

**Overview**

A PLD schematic defines the internal logical behavior of a PLD and the interface to external logical connections. PLD schematics can be exported to VHDL for use in other applications.

A PLD schematic contains specialized components that define the operation of the individual logic blocks of the PLD.

These PLD components include both SPICE models and VHDL export data. This allows the components to be simulated in Multisim, and then exported with VHDL-only data. Refer to the *Editing a Component’s VHDL Export Data* section for information about the VHDL export data.

**Note**  The PLD components are not compatible with older MultiVHDL components and models. If you have a legacy copy of MultiVHDL, you can continue to use it. However, co-simulation has been discontinued with version 11 of Circuit Design Suite.

Some additional diagnostic components such as digital probes and Multisim instruments can also be placed on a PLD schematic. These components do not change the PLD topology and are not exported when an *Export PLD to VHDL* command is executed.

The PLD schematic:

- restricts the components that can be placed to those that can be mapped for VHDL export, and to special diagnostic components.
- has special port connectors that map the external nets to internal signals and identify the signal modes.
- enables export to VHDL.
Components

On a special category of components are allowed for PLD schematic-based designs. Valid components include exportable and diagnostic devices. They are located in the PLD Logic Group and Sources Group of the database.

When a PLD schematic is active, the Select a Component dialog box name changes to Select a Component (PLD Mode). Only valid components appear in the dialog.

In the Select a Component dialog, the Model manufacturer/ID field displays the SPICE model manufacturer, and the VHDL export manufacturer/Name displays the source of the VHDL model.

Search functionality from the Select a Component dialog box additionally allows searching for VHDL export data and only finds valid PLD components. Titles on all search dialogs are appended with PLD Mode.

Refer to the Multisim Help for more information.

Port Connectors

Port connectors represent the FPGA pins that are used by the PLD circuit. You must define how the logic connects to the device pins by wiring the internal circuit to the port connectors.

When creating a PLD, you can define the port connectors (name and properties) that will be used in your design before creating the design (see the Port Connectors Tab section). This is particularly useful if you know in advance how VHDL signal names will be mapped to pins. Unlike undefined connectors, defined connectors retain their properties and can be exported even when not placed on the schematic.

You cannot place global connectors on a PLD schematic. In general, external nets cannot be connected directly to internal PLD schematic nets. They must go through port connectors.

A connector can be set to input, output, or bidirectional mode. The mode defines the behaviors in simulation and VHDL export. Input and output modes allow input or output to the PLD, respectively. The bidirectional mode may act as either an input or output, depending on the state of the control pin. When the signal on the control pin is high, the connector acts as an output from the PLD. When the signal on the control pin is low, the connector acts as an input to the PLD.
A connector’s symbol changes based on its mode, as shown in the figure below.

![Connector Symbols](image)

### PLD Toolbar

The table below describes the buttons found in the **PLD** toolbar.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Input Connector" /></td>
<td><strong>Place Input Connector</strong> button. Displays the <strong>Input Connector</strong> dialog box. Use this to place an input connector on a PLD schematic. Refer to the <em>Adding Port Connectors to a PLD Schematic</em> section for more information.</td>
</tr>
<tr>
<td><img src="image" alt="Output Connector" /></td>
<td><strong>Place Output Connector</strong> button. Displays the <strong>Output Connector</strong> dialog box. Use this to place an output connector on a PLD schematic. Refer to the <em>Adding Port Connectors to a PLD Schematic</em> section for more information.</td>
</tr>
<tr>
<td><img src="image" alt="Bidirectional Connector" /></td>
<td><strong>Place Bidirectional Connector</strong> button. Displays the <strong>Bidirectional Connector</strong> dialog box. Use this to place a bidirectional connector on a PLD schematic. Refer to the <em>Adding Port Connectors to a PLD Schematic</em> section for more information.</td>
</tr>
</tbody>
</table>
### PLD Components Toolbar

The table below describes the buttons found in the PLD Components toolbar. Refer to the Adding Components to a PLD Schematic section for more information.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="PLD Settings" /></td>
<td><strong>PLD Settings</strong> button. Displays the <strong>PLD Settings</strong> dialog box. Refer to the <strong>PLD Settings Dialog Box</strong> section for more information.</td>
</tr>
<tr>
<td><img src="image" alt="PLD Topology Check" /></td>
<td><strong>PLD Topology Check</strong> button. Runs a topology check on the selected PLD circuit. Refer to the <strong>Running a Topology Check</strong> section for more information.</td>
</tr>
<tr>
<td><img src="image" alt="Export PLD to VHDL" /></td>
<td><strong>Export PLD to VHDL</strong> button. Displays the <strong>Export PLD to VHDL</strong> dialog box. Refer to the <strong>Exporting to VHDL</strong> section for more information.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Place Logic Gate" /></td>
<td><strong>Place Logic Gate</strong> button. Displays the <strong>Select a Component (PLD Mode)</strong> dialog box with the <strong>Logic Gates Family</strong> selected. Select the desired logic gate in the <strong>Component</strong> list and click <strong>OK</strong> to place it on the PLD schematic.</td>
</tr>
<tr>
<td><img src="image" alt="Place Buffer" /></td>
<td><strong>Place Buffer</strong> button. Displays the <strong>Select a Component (PLD Mode)</strong> dialog box with the <strong>Buffers Family</strong> selected. Select the desired buffer in the <strong>Component</strong> list and click <strong>OK</strong> to place it on the PLD schematic.</td>
</tr>
<tr>
<td><img src="image" alt="Place Latch" /></td>
<td><strong>Place Latch</strong> button. Displays the <strong>Select a Component (PLD Mode)</strong> dialog box with the <strong>Latches Family</strong> selected. Select the desired latch in the <strong>Component</strong> list and click <strong>OK</strong> to place it on the PLD schematic.</td>
</tr>
<tr>
<td><img src="image" alt="Place Flip-Flop" /></td>
<td><strong>Place Flip-Flop</strong> button. Displays the <strong>Select a Component (PLD Mode)</strong> dialog box with the <strong>Flip-Flops Family</strong> selected. Select the desired flip-flop in the <strong>Component</strong> list and click <strong>OK</strong> to place it on the PLD schematic.</td>
</tr>
<tr>
<td><img src="image" alt="Place Encoder" /></td>
<td><strong>Place Encoder</strong> button. Displays the <strong>Select a Component (PLD Mode)</strong> dialog box with the <strong>Encoders Family</strong> selected. Select the desired encoder in the <strong>Component</strong> list and click <strong>OK</strong> to place it on the PLD schematic.</td>
</tr>
<tr>
<td>Button</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Place Decoder</td>
<td>Displays the Select a Component (PLD Mode) dialog box with the Decoders Family selected. Select the desired decoder in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
<tr>
<td>Place Counter</td>
<td>Displays the Select a Component (PLD Mode) dialog box with the Counters Family selected. Select the desired counter in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
<tr>
<td>Place Adder</td>
<td>Displays the Select a Component (PLD Mode) dialog box with the Adders Family selected. Select the desired adder in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
<tr>
<td>Place Comparator</td>
<td>Displays the Select a Component (PLD Mode) dialog box with the Comparators Family selected. Select the desired comparator in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
<tr>
<td>Place Multiplexer</td>
<td>Displays the Select a Component (PLD Mode) dialog box with the Multiplexers Family selected. Select the desired multiplexer in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
<tr>
<td>Place Demultiplexer</td>
<td>Displays the Select a Component (PLD Mode) dialog box with the Demultiplexers Family selected. Select the desired demultiplexer in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
<tr>
<td>Place Shift Register</td>
<td>Displays the Select a Component (PLD Mode) dialog box with the Shift Registers Family selected. Select the desired shift register in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
<tr>
<td>Place Generator</td>
<td>Displays the Select a Component (PLD Mode) dialog box with the Generators Family selected. Select the desired generator in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
</tbody>
</table>
Chapter 4  PLD Schematics

Creating a PLD Schematic

The PLD Wizard guides you through the steps of creating and configuring the PLD schematic. You can create a PLD schematic as an independent document, as a subcircuit, or as a hierarchical block in a standard schematic.

Complete the following steps to create a new PLD schematic:

1. Select File→New→PLD Design.  
   Or  
   Select Place→New PLD Subcircuit.  
   Or  
   Select Place→New PLD Hierarchical Block.

   Refer to the Placing PLDs as Subcircuits and Hierarchical Blocks section for more information.

   With any of the above actions, step 1 of the PLD Wizard appears.

2. Select one of the following as desired:
   • Use standard configuration—Select one of the following from the drop-down list: Digital Electronics FPGA Board, Digital Electronics FPGA Board (7 segment). Select one of the standard configuration files if you want to use Multisim with the NI Digital Electronics FPGA board. Refer to the PLD Configuration File section for more information.
   • Use custom configuration file—Select if you wish to use a non-standard configuration file.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Place Digital Source" /></td>
<td>Display the Select a Component (PLD Mode) dialog box with the Digital Sources Family selected. Select the desired digital source in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
<tr>
<td><img src="image" alt="Place Probe" /></td>
<td>Display the Select a Component (PLD Mode) dialog box with the Probe Family selected. Select the desired probe in the Component list and click OK to place it on the PLD schematic.</td>
</tr>
</tbody>
</table>
Create empty PLD—Select if you wish to create a PLD using saved default settings (will contain no defined connectors), or if you wish to define connectors after creating the schematic.

Note Refer to the PLD Configuration File section for more information about the choices available in this step.

3. Click Next to display step 2 of the PLD Wizard.

4. Complete the following as desired:
   - **PLD schematic name or PLD subcircuit name or Choose a file name**—Defaults to Programmable Logic Device 1, Programmable Logic Device 2, and so on. Edit as desired.
   - **Part number (optional)**—Defaults to the FPGA named in the configuration file that is referenced in step 1. If there is no referenced configuration file, or the file has no part number named, this field defaults to the last value selected. Edit to specify the part number to show in the Bill of Materials report.

5. Click Next to display step 3 of the PLD Wizard.

   Or

   Click Finish to close the PLD Wizard and open the new PLD schematic without modifying Default operating voltages or changing the defined connectors.

6. If you clicked Next, step 3 of the PLD Wizard displays. Edit the following in the Default operating voltages box as desired:
   - **Input connector**—The operating voltage for all new undefined input connectors in the PLD.
   - **Output connector**—The operating voltage for all new undefined output connectors in the PLD.
   - **Bidirectional connector**—The operating voltage for all new undefined bidirectional connectors in the PLD.

7. If you selected either Use standard configuration or Use custom configuration file in step 1 of the wizard, the Select the defined connectors to place on the PLD list also displays in step 3 of the wizard. Use the checkboxes to select which defined connectors to place on the PLD.

8. Click Finish to close the PLD Wizard and open the new PLD schematic.
Subcircuits and Hierarchical Blocks

You can place PLD subcircuits (SCs) and hierarchical blocks (HBs) inside a Multisim schematic. You can also use these blocks in a standard Multisim schematic design, or place them in an existing PLD schematic.

Refer to the figure below for some examples.

1. PLD schematic with no subcircuit or hierarchical block
2. Subcircuit in PLD schematic
3. Hierarchical block in PLD schematic
4. PLD subcircuit in Multisim schematic
5. PLD hierarchical block in Multisim schematic

Input and output connectors in nested PLD schematics do not graphically indicate their mode. In this case, the connectors have no effect on simulation.

1. Input or output connector in nested block
2. Bidirectional connector in nested block
Placing PLDs as Subcircuits and Hierarchical Blocks

You can create hierarchical designs to capture the PLD’s logic. Subsheets nested in a PLD do not define additional PLDs. Rather, they define reusable blocks in the PLD.

Refer to the Multisim Help for more information about hierarchical blocks and subcircuits.

Placing a New PLD as a Subcircuit

Complete the following steps to place a new PLD as a subcircuit in a standard Multisim schematic:

1. Open a new or existing Multisim schematic capture file.
2. Select Place> New PLD Subcircuit. Step 1 of the PLD Wizard appears.
3. Use the wizard to create the PLD subcircuit, as detailed in the Creating a PLD Schematic section.

When you click Finish in either step 2 or step 3 of the wizard, a ghost image of the PLD appears on the cursor.
4. Click to place the PLD on the workspace.

Placing a New PLD as a Hierarchical Block

Complete the following steps to place a new PLD as a hierarchical block in a standard Multisim schematic:

1. Open a new or existing Multisim schematic capture file.
2. Select Place> New PLD Hierarchical Block. Step 1 of the PLD Wizard appears.
3. Use the wizard to create the PLD subcircuit, as detailed in the Creating a PLD Schematic section.

When you click Finish in either step 2 or step 3 of the wizard, a ghost image of the PLD appears on the cursor.
4. Click to place the PLD on the workspace.

Placing a New PLD Subcircuit in a PLD Schematic

Complete the following steps to place a new PLD subcircuit in a PLD schematic:

1. Open a new or existing PLD schematic file.
2. Select Place> New Subcircuit. The Subcircuit Name dialog box appears.
3. Enter a Subcircuit Name and click OK to place the subcircuit on the PLD schematic.
Placing a New PLD Hierarchical Block in a PLD Schematic
Complete the following steps to place a new PLD hierarchical block in a PLD schematic:

1. Open a new or existing PLD schematic file.
2. Select **Place»New Hierarchical Block**. The **Hierarchical Block Properties** dialog box appears.
3. Enter the **File name of hierarchical block**, **Number of input pins**, **Number of output pins**, and click **OK** to place the hierarchical block on the PLD schematic.

Placing an Existing PLD Schematic as a Hierarchical Block in a PLD Schematic
Complete the following steps to place an existing PLD schematic as a hierarchical block in a PLD schematic:

1. Open a new or existing PLD schematic file.
2. Select **Place»Hierarchical Block from File**. A standard **Open** dialog box appears.
3. Select the desired file and click Open. A ghost image of the hierarchical block appears on the cursor.

   **Note** Only a PLD schematic may be placed in a PLD schematic as a hierarchical block.

4. Click to place it on the workspace.

Adding Components to a PLD Schematic
Complete the following steps to add a component to a PLD schematic:

1. Open or create a PLD schematic.
2. Select **Place»Component** to display the **Select a Component (PLD Mode)** dialog box.
   The components that display in this dialog are limited to those that can be placed on a PLD schematic.
3. Select the desired **Family** and **Component**, and click to place the component on the workspace.

Refer to the *Creating a PLD Schematic* and *Components* sections for more information.
PLD Configuration File

PLD configuration files describe general properties of a PLD and the connections you can make to the PLD.

Standard PLD configuration files are installed at `<Program Files>\National Instruments\Circuit Design Suite 11.0\pldconfig`. The standard files are accessed from the **Use standard configuration** drop-down list in step 1 of the **PLD Wizard**.

You can add your own PLD configuration files to this directory. These files become available in the **Use standard configuration** drop-down list. Refer to the **Creating a PLD Schematic** section for more information.

The files with extension `.mspc` are Multisim PLD configuration files. This folder also contains `PLDConfigurationSchema.xsd`, which describes the format of `.mspc` files and how you can create PLD configuration files.

To create a new `.mspc` file, you can:

- create a PLD schematic with the desired PLD connectors, and export it as a `.mspc` file. (This is the recommended method.) From a PLD, select **Transfer»Export to PLD Configuration**.
- create the PLD configuration in another application and save the file with a `.mspc` extension. See `PLDConfigurationSchema.xsd`, above.

Once you have created a `.mspc` file, you can select it in the **Use custom configuration file** field in step 1 of the **PLD Wizard**. Refer to the **Creating a PLD Schematic** section for more information.

Adding Port Connectors to a PLD Schematic

Complete the following steps to add an input, output, or bidirectional port connector to a PLD schematic:

1. Select **Place»Connectors»Input Connector**.
   
   Or
   
   Select **Place»Connectors»Output Connector**.
   
   Or
   
   Select **Place»Connectors»Bidirectional Connector**.

   **Note** Refer to the *PLD Configuration File* section for information on pre-defined port connectors.
2. If port connectors are defined, the associated dialog box appears, otherwise, skip to step 4.
   Select one of the following radio buttons:
   - **Create defined connector**—This button is active if there are defined connectors that have not been placed. Select one of these connectors from the list below the radio button.
   - **Create default connector**—Select to place a new, undefined connector on the PLD schematic.

3. Click **OK** to close the dialog.

4. A ghost image of the connector appears on the cursor.

5. Click in the desired location to place the connector.

### Port Connector Dialog Box

Complete the following steps to change the properties of a placed port connector:

1. Double-click on the placed connector to display the **Port Connector** dialog box. The **Value** tab displays.

2. Select a new **RefDes** from the drop-down list. This list displays all available defined reference designators.
   
   Or

   Type a new value in the **RefDes** field. The **RefDes** defines the name of the signal in exported VHDL.

3. Select one of **Input**, **Output**, or **Bidirectional** from the **Mode** drop-down list.

4. Change the **Operating voltage** as desired. This value is used for simulation only. It is not exported to VHDL.

   **Note** In simulation, a signal is interpreted as low when the voltage level is less than half of the operating voltage, and high when it is above half of the operating voltage.

5. Click **OK** to close the dialog box.

   **Note** You can set the default values for the operating voltages of all undefined PLD connectors in the **General** tab of the **PLD Settings** dialog box. Refer to the **General Tab** section for more information.
PLD Settings Dialog Box

Use the **PLD Settings** dialog box to adjust port connector and general settings for your PLD schematic.

**Port Connectors Tab**

Complete the following steps to make changes to the port connector settings of a PLD schematic:

1. Select the desired PLD schematic.
2. Select **Options** ➤ **PLD Settings** to display the **PLD Settings** dialog box.
3. Select the **Port connectors** tab. The following columns are for information only, and cannot be edited.
   - **Defined**—A green indicator in this column means that the corresponding port connector is defined for the PLD schematic. If you place a default connector as described in the *Adding Port Connectors to a PLD Schematic* section, the indicator does not appear.
   - **In Use**—A green indicator in this column means that the corresponding port connector is on the PLD schematic.
4. Edit the following as desired:
   - **RefDes**—The name the connector has on the PLD schematic. The **RefDes** also defines the name of the signal in exported VHDL.
   - **Mode** drop-down list—Select **Input**, **Output**, or **Bidirectional**.
   - **General purpose** checkbox—Select if you wish this connector to be able to assume any mode during placement. This may only be specified for defined connectors.
   - **Operating voltage**—The operating voltage of the connector.
   - **Always export** checkbox—Select to export a connector when an **Export PLD to VHDL** command is executed, whether or not it is **In Use**. This may only be specified for defined connectors. Refer to the *Exporting to VHDL* section for more information.
5. Optionally, in the **Defined port connectors** box:
   - **Add** button—Click to display the **Add Defined Connector** dialog box. Refer to the *Add Defined Connector dialog box* section for details.
   - **Delete** button—Click to delete the selected port connector. You cannot delete a connector that is **In Use**.

**Note** The **Set as default** checkbox applies to the **General** tab only. Refer to the **General Tab** section for more information.
Add Defined Connector dialog box

The Add Defined Connector dialog box displays when you click the Add button in the Port connectors tab of the PLD Settings dialog box. Refer to the Port Connectors Tab section for more information.

Complete the following steps to add a defined port connector to a PLD design:
1. Select Options»PLD Settings to display the PLD Settings dialog box.
2. Select the Port connectors tab.
3. Click Add. The Add Defined Connector dialog box displays.
4. Set the following as desired:
   - RefDes—Edit as desired.
   - Mode drop-down list—Select Input, Output, or Bidirectional.
   - Operating voltage—The operating voltage of the connector.
   - General purpose checkbox—Select to allow the connector to assume any mode. When selected, the connector appears in the Input Connector, Output Connector, and Bidirectional Connector dialog boxes. Refer to the Adding Port Connectors to a PLD Schematic section for information.
   - Always export checkbox—Select to export the connector, even if it is not used in the design.
5. Click Add. The new connector appears in the Port connectors tab.
6. Continue adding connectors as described above, or click Done to close the Add Defined Connector dialog box.

General Tab

Complete the following steps to make changes to the general settings of a top-level PLD schematic:
1. Select the desired PLD schematic.

Note Changes made in the following steps apply only to the top level of the selected PLD schematic. Settings in subsheets such as hierarchical blocks are not changed.

2. Select Options»PLD Settings to display the PLD Settings dialog box.
3. Select the General tab.
4. Edit the **Part number** to specify the part number shown in the **Bill of Materials**. This is the **Part number** selected in step 2 of the **PLD Wizard**.

5. Set the following in the **Default operating voltages** box as desired:
   - **Input connector**—The operating voltage of all new undefined input connectors in the PLD schematic.
   - **Output connector**—The operating voltage of all new undefined output connectors in the PLD schematic.
   - **Bidirectional connector**—The operating voltage of all new undefined bidirectional connectors in the PLD schematic.

6. Select the following checkboxes in the **Port connectors** box as desired:
   - **Lock port connector names**—Select to display a warning when you attempt to rename a port connector.
   - **Unconnected port connectors generate warning in topology check**—Refer to the **Running a Topology Check** section for more information.
   - **Unconnected output pins generate warning in topology check**—Refer to the **Running a Topology Check** section for more information.
   - **Export unconnected port connectors**—Placed, unconnected port connectors will be exported when an **Export PLD to VHDL** command is executed.
   - **Export unplaced defined port connectors**—Select to export port connectors that are defined in the PLD schematic file, but have not been placed on the PLD schematic.
   - **Export port connector buffers automatically**—Select to connect buffers from all input and output connectors to the internal PLD circuit logic when an **Export PLD to VHDL** command is executed. This prevents some errors from occurring when you synthesize the exported VHDL.

   **Note** Refer to the **Exporting to VHDL** section for more information.

7. Set the following in the **Advanced** box as desired:
   - **Source Library**—Component export data is added to the source library. This must be the name of the source library (normally **work**) in your VHDL synthesizer where you will add the exported VHDL file.
8. Optionally, select the **Set as default** checkbox.
   This checkbox applies to the **General** tab only. If you referenced a PLD configuration file when you created the PLD schematic, this file may have operating voltages and port connector locking preset. When creating a new PLD using a configuration file that defines these, the values in the configuration file take precedence. These settings take precedence over the selection made in the **General** tab of the **PLD Settings** dialog box.

### Exporting to VHDL

After you have completed your design, you can export the PLD device to VHDL for use in another application.

The export to VHDL command:

1. Checks the PLD circuit for errors using a **Topology Check**.

**Note** Refer to the **Running a Topology Check** and the **Export PLD to VHDL dialog box** sections for information.

Multisim exports two VHDL files—a design file and a package file.

The design file (for example, `ProgrammableLogicDevice1.vhd`) defines the top level for the design. The package file contains the component definitions for the PLD device. By default, these files are saved to the same directory as the Multisim design.

The package file (for example, `ProgrammableLogicDevice1_pkg.vhd`) is assumed to be in the library **work**—the default library for most synthesizers. If this is incorrect, you can change it in the **PLD Settings** dialog box. You can specify VHDL export options in the **General** tab. Refer to the **General Tab** section for details.

Multisim uses the RefDes of port connectors to generate top-level signal names. To prevent conflicts, and to ensure valid VHDL, the signal and entity names in the exported files may not always match the names in the design. For example, a net may have the name 1, which is not valid in VHDL. It is renamed to a similar but valid name, for example, `\1`.
Export PLD to VHDL dialog box

Complete the following steps to export the PLD design to VHDL:

1. Select Transfer→Export PLD to VHDL to run a Topology Check and display the Export PLD to VHDL dialog box.
   Results of the Topology Check appear in the Results tab of the Spreadsheet View.

   Note You can also manually run a manual Topology Check at any time. Refer to the Running a Topology Check section for information.

2. Optionally, type a new file path and file name in the Design file field, or click Browse and navigate to the desired location for the design file.
   The design file contains the topology of the PLD schematic.

   Note If port connectors are not locked, Multisim will prompt you to lock them.

3. Select the Use default package checkbox if you wish to automatically generate a name for the package file on export.
   Or
   Deselect the Use default package checkbox if you wish to enter your own file path and file name for the package file. Type a new file path and file name in the Package file field, or click Browse and navigate to the desired location.
   The package file contains definitions of all components in the PLD schematic.

4. Click OK to export the two files.

   Tip Right-click in the Design file or Package file field and select Show on Disk to go to the created files.

Running a Topology Check

A Topology Check generates errors and warnings.

Errors:
- verify that there is at least one used port connector in the design.
- verify that port connectors are not directly connected to another port connector.
Warnings:

- verify that all pins on a PLD component are connected to other PLD components or to a port connector. Unconnected pins are marked open in the VHDL netlist.
- check for unconnected port connectors. To disable this warning, uncheck **Unconnected port connectors generate warning in topology check** in the **General** tab of the **PLD Settings dialog** box.
- check for unconnected output pins. To disable this warning, uncheck **Unconnected output pins generate warning in topology check** in the **General** tab of the **PLD Settings dialog** box.
- identify components that are not exportable such as diagnostic components.
- check that all nets have at least one input and one output pin.

Complete the following steps to run a manual **Topology Check**:

1. Select **Tools»PLD Topology Check**.
   Any errors and warnings display in the **Results** tab of the **Spreadsheet View** with appropriate descriptive text.
2. Right-click on an error or warning and select **Go to** from the context menu that appears. Depending on the error, the source of the selected error or warning is highlighted on the workspace.

**Editing a Component’s VHDL Export Data**

Each PLD component includes VHDL export data as well as a standard SPICE model.

You can edit the VHDL export data from the **VHDL export** tab of the **Component Properties** dialog box. This tab is only available for PLD components.

**Note**  PLD components do not have footprints or electronic parameters. Consequently, the **Footprint** and **Electronic param** tabs in the **Component Properties** dialog box do not display for PLD components. Refer to the *Multisim Help* for more information about the **Component Properties** dialog box.

Complete the following steps to display a placed component’s export properties:

1. Double-click on the placed component to display its properties dialog box.
2. Click the **Value** tab.
3. Click Edit component in DB. The Component Properties dialog box appears.

4. Click the VHDL export tab. The following appear in this tab:

- **VHDL export name** area—Displays a list of VHDL export models associated with the selected component. This field cannot be edited.
- **VHDL export data** area—Displays the VHDL export model data of the selected component. This field cannot be edited.
- **Symbol pins** column—Found in the Pin mapping table. Displays the names of the pins associated with the symbol.
- **VHDL export ports** column—Found in the Pin mapping table. Use to map the component’s Symbol pins to its VHDL export ports. Edit with care.
- **Add from comp** button—Click to select a component, whose VHDL export model you wish to use, from the existing Multisim database.
- **Add/Edit** button—Use to add or edit a new or existing VHDL export model in the Multisim database.
- **Delete export data** button—Clears the contents of the tab.
- **Show Template** button—Use to display the Symbol to port mapping table. Edit with care.
This chapter describes Multisim’s ladder diagram functionality.

Some of the described features may not be available in your edition of Multisim. Refer to the NI Circuit Design Suite Release Notes for a description of the features available in your edition.

Overview

You can use the Education edition of Multisim to create and simulate **Ladder Diagrams**. These diagrams are electrically based, as opposed to the binary/digital representations employed by ladder logic. Diagrams of this type are used extensively for industrial motor control circuits.

**Ladder Diagrams** are able to drive output devices or take input data from regular schematics and embed the instructions on how input states affect output states. This can be done in either the same schematic or separate hierarchical blocks or subcircuits that contain the **Ladder Diagram**.

**Note** Refer to the *Multisim Help* for a complete description of hierarchical blocks and subcircuits.

Creating a Ladder Diagram

This section describes the steps required to make a simple **Ladder Diagram**. You should understand the concepts described here before reviewing the more complex circuits found in this chapter.

This section describes how to build the **Ladder Diagram** that is used in the **AND Rungs and OR Rungs** section.
Notes about the above circuit:

- The relays (X1-X4) are normally open relays. When their controlling coils (M1 or M2) are energized they close. The controlling coils are set in the Value tab of each relay’s properties dialog box.
- Both X1 AND X2 must be closed for the lamp in the AND rung (X5) to light up.
- Either X3 OR X4 must be closed for the lamp in the OR rung (X6) to light up.
- Coil M1 controls the relays with M1 as their reference. (X1 and X3.)
- Coil M2 controls the relays with M2 as their reference. (X2 and X4.)
- Use keys 1 and 2 on your keyboard to open and close switches J1 and J2, or hover your cursor over the desired switch and click on the button that appears.
Complete the following steps to add the diagram’s rungs:

1. Select Place»Ladder Rungs. The cursor appears with the rung’s left and right terminators attached.

2. Click to place the first rung and continue clicking and placing until you have placed four rungs as shown below. Right-click to stop placing rungs.

Complete the following steps to add components to the rungs:

1. Select Place»Component, navigate to the Normally Open Relay Contact (RELAY_CONTACT_NO) and click OK.

   **Note** This device is found in the Ladder Diagrams Group - Ladder Contacts Family.
Chapter 5  Ladder Diagrams

2. Drop the relay contact directly onto the first rung.

3. Continue in this manner until all relay contacts have been placed. (X4 must be placed and then wired separately.)

4. Place the lamps (Group - Indicators; Family - Lamp).
5. Place relay coils M1 and M2 on the third and fourth rungs (Group - Ladder Diagrams; Family - Ladder Relay Coils).

6. Place switches J1 and J2.

7. Double-click on each switch, select the Value tab, and change the key for J1 to 1 and the key for J2 to 2.

Complete the following steps to change the controlling device reference for X2 and X4:
1. Double-click on X2 and click the Value tab.
2. Enter M2 in the Controlling Device Reference field and click OK.
Repeat for X4. The completed **Ladder Diagram** appears as shown below.
AND Rungs and OR Rungs

This section illustrates the difference between AND rungs and OR rungs that are found in Ladder Diagrams. You should understand the concepts described here before reviewing the more complex circuits found in this chapter.

![Diagram](image_url)
Chapter 5  Ladder Diagrams

Complete the following steps to activate the lamp in the OR rung:

1. Select **Simulate»Run** to start simulation of the circuit.
2. Press <1> on your keyboard to close J1 (or hover your cursor over J1 and click the button that appears). Lamp X6 lights as described below.

If you press <2> on your keyboard (or hover your cursor over J2 and click the button that appears), J2 closes which activates coil M2. X6 lights because X4 is energized.
Complete the following steps to activate the lamp in the AND rung:

1. Select **Simulate»Run** to start simulation of the circuit.
2. Press <1> and <2> on your keyboard to close J1 and J2. Lamps X5 and X6 light as described below.
Sample Circuits

Holding Tank

This section contains an example of a logic diagram that drives a circuit that fills and then empties a fluid holding tank.

Note Refer to the Component Reference Help for information about the user-settable parameters for the Holding Tank, Input Module and Output Module.
Complete the following steps to activate this circuit:

1. Select **Simulate»Run** to begin simulation.
2. Press <P> on your keyboard to activate the Power temporary switch (or hover your cursor over the Power switch and click the button that appears). This sends 5 V to pin IN4 of Input Module U2 (**Input Module Base Address** = 100) which in turn energizes Input Contact X1 in the Power Lock-up Rung of the ladder diagram. Relay Coil M1 is energized, causing all Relay Contacts with **Relay Device Reference** = M1 to energize.
Complete the following steps to run the holding tank circuit:

1. Activate the circuit as described above.
2. Press <R> on your keyboard (or hover your cursor over the Run switch and click the button that appears) to activate the Run temporary switch.

Tip Select **Window»Tile Vertical** to view the ladder diagram and the circuit at the same time. Observe the interaction between the ladder diagram and the circuit as the simulation proceeds.
As the simulation proceeds, the tank begins to fill.
When the level of the fluid in the tank gets to the **Set Point**, fluid stops being pumped.
Chapter 5  Ladder Diagrams

After a delay of five seconds, the tank begins to empty.

When the tank is empty, the flow stops.
Complete the following to turn off the power at any point in the simulation:

1. Press <K> on your keyboard (or hover your cursor over the Kill switch and click the button that appears) to activate the Kill temporary switch. This sends 5 V to pin IN3 of Input Module U2 (Input Module Base Address = 100) which in turn energizes Input Contact X2 (the contact opens). The continuity in the Power Lock-up Rung is broken and Relay Coil M1 is de-energized, which in turn switches off all Relay Contacts with Relay Device Reference = M1.

When you press <K>, X20 is also temporarily energized, which in turn temporarily energizes Output Coil Y2, which sends a pulse to pin Out3 of Output Module U3. This is wired to the Stop pin of the holding tank, so the tank stops filling or emptying (depending on which is currently occurring).
Conveyor Belt

This section contains an example of a Ladder Diagram that drives a conveyor belt.

Note  Refer to the Component Reference Help for information about the user-settable parameters for the Conveyor Belt, Input Module and Output Module.
Complete the following steps to activate this circuit:

1. Select Simulate » Run to begin simulation.
2. Press <P> on your keyboard (or hover your cursor over the Power switch and click the button that appears) to activate the Power temporary switch. This sends 5 V to pin IN2 of Input Module U4 (Input Module Base Address = 101) which in turn energizes Input Contact X1 in the Power Lock-up Rung of the ladder diagram. Relay Coil M1 is energized, causing all Relay Contacts with Relay Device Reference = M1 to energize.
Complete the following steps to run the conveyor belt:

1. Activate the circuit as described earlier.
2. Press <R> on your keyboard (or hover your cursor over the Run switch and click the button that pops up) to activate the Run temporary switch.

Tip  Select Window»Tile Vertical to view the ladder diagram and the circuit at the same time. Observe the interaction between the ladder diagram and the circuit as the simulation proceeds.
Chapter 5  Ladder Diagrams

As the simulation proceeds, the box moves along the conveyor belt to Position Sensor 2 (PS2). The box stops moving and balls begin dropping from the hopper into the box.
When five balls have dropped into the box (counted by Count sensor and C1), the hopper stops dropping balls.
The conveyor continues moving and stops when the box gets to Position Sensor 3 (PS3).

Complete the following to turn off the power at any point in the simulation:

1. Press <K> on your keyboard (or hover your cursor over the Kill switch and click the button that appears) to activate the Kill temporary switch. This sends 5 V to pin IN3 of Input Module U4 (Input Module Base Address = 101) which in turn energizes Input Contact X3 (the contact opens). The continuity in the Power Lock-up Rung is broken and Relay Coil M1 is de-energized, which in turn switches off all Relay Contacts with Relay Device Reference = M1.

When you press <K>, X19 is also temporarily energized, which in turn temporarily energizes Output Coil Y2, which sends a pulse to pin Out3 of Output Module U2. This is wired to the Stop pin of the conveyor belt, so the belt stops.
Traffic Light

The ladder diagram in this section runs two traffic lights.
Note The ladder diagram is contained in a separate hierarchical block called TrafficLightLogic. For details on hierarchical blocks, refer to the Multisim Help.

Complete the following steps to run the traffic lights:

1. Select Simulate>Run.
2. Press <P> on your keyboard (or hover your cursor over the Power switch and click the button that pops up) to activate the Power momentary switch.

Tip Select Windows>Tile Vertical to view the ladder diagram and the circuit at the same time. Observe the interaction between the ladder diagram and the circuit as the simulation proceeds.
The red and green lights in traffic lights U1 and U3 light as shown below.

After 15 seconds, the green lights turn amber.
After 5 more seconds, the amber lights turn red and the red lights turn green.

After 15 seconds, the green lights turn amber.
After 5 more seconds, the amber lights turn red and the red lights turn green.

3. The cycle continues in this way until you stop the simulation, or press <K> (or hover your cursor over the Kill switch and click the button that appears) to activate the Kill momentary switch.
Technical Support and Professional Services

Visit the following sections of the award-winning National Instruments Web site at ni.com for technical support and professional services:

- **Support**—Technical support at ni.com/support includes the following resources:
  - **Self-Help Technical Resources**—For answers and solutions, visit ni.com/support for software drivers and updates, a searchable KnowledgeBase, product manuals, step-by-step troubleshooting wizards, thousands of example programs, tutorials, application notes, instrument drivers, and so on. Registered users also receive access to the NI Discussion Forums at ni.com/forums. NI Applications Engineers make sure every question submitted online receives an answer.
  - **Standard Service Program Membership**—This program entitles members to direct access to NI Applications Engineers via phone and email for one-to-one technical support as well as exclusive access to on demand training modules via the Services Resource Center. NI offers complementary membership for a full year after purchase, after which you may renew to continue your benefits.

    For information about other technical support options in your area, visit ni.com/services, or contact your local office at ni.com/contact.

- **Training and Certification**—Visit ni.com/training for self-paced training, eLearning virtual classrooms, interactive CDs, and Certification program information. You also can register for instructor-led, hands-on courses at locations around the world.

- **System Integration**—If you have time constraints, limited in-house technical resources, or other project challenges, National Instruments Alliance Partner members can help. To learn more, call your local NI office or visit ni.com/alliance.
If you searched ni.com and could not find the answers you need, contact your local office or NI corporate headquarters. Phone numbers for our worldwide offices are listed at the front of this manual. You also can visit the Worldwide Offices section of ni.com/niglobal to access the branch office Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.
Index

B
Breadboard Netlist dialog box, 2-12
Breadboard Settings, 2-1

C
Circuit restrictions, setting, 1-5
Conventions used in the manual, v

D
Defined Port Connector dialog box, 4-14
diagnostic tools (NI resources), A-1
documentation
   Conventions used in the manual, v
   NI resources, A-1
drivers (NI resources), A-1

E
Examples (NI resources), A-1
Export PLD to VHDL dialog box, 4-17
Exporting to VHDL, 4-16, 4-17

G
Global restrictions
   Passwords, 1-7
   Setting, 1-2

H
Help, technical support, A-1

I
Instrument drivers (NI resources), A-1

K
KnowledgeBase, A-1

L
Ladder diagrams, 5-1
   AND rungs, OR rungs, 5-7
   Creating, 5-1
   Sample circuits, 5-10

N
National Instruments support and services, A-1
NI ELVIS II Simulation Settings dialog box, 3-12
NI ELVISmx Instruments toolbar, 3-27
NI support and services, A-1

P
Passwords, creating/changing, 1-7
PLD Components toolbar, 4-4
PLD configuration file, 4-11
PLD schematic
   adding bidirectional connectors, 4-11
   Adding components, 4-10
   Adding input connectors, 4-11
   Adding output connectors, 4-11
   Adding port connectors, 4-11
   Components, 4-2
   Creating, 4-6
   Editing VHDL export data, 4-18
   Exporting to VHDL, 4-16, 4-17
   Overview, 4-1
   Placing hierarchical blocks, 4-9
   Placing subcircuits, 4-9
   PLD Components toolbar, 4-4
Index

PLD configuration file, 4-11
PLD toolbar, 4-3
PLD Wizard, 4-6
Port Connector dialog box, 4-12
port connectors, 4-2
subcircuits and hierarchical blocks, 4-8
topology check, 4-17
VHDL export tab, 4-18
PLD Settings dialog, 4-13
General tab, 4-14
Port Connectors tab, 4-13
PLD toolbar, 4-3
PLD Wizard, 4-6
port connectors, 4-2
programming examples (NI resources), A-1

V
VHDL export tab, 4-18
Virtual NI ELVIS I
3D prototyping board, 3-29
ammeter, 3-6
function generator, 3-8
instruments, 3-4
IV Analyzer, 3-6
oscilloscope, 3-5
power supplies, 3-9
prototyping board LEDs, 3-1
schematic, 3-1
Volt/Ohmmeter, 3-6
wiring placed components in 3D, 3-34

Virtual NI ELVIS II
3D prototyping board, 3-29
arbitrary waveform generator, 3-19
bode analyzer, 3-17
digital multimeter, 3-18
digital reader, 3-24
digital writer, 3-26
dynamic signal analyzer, 3-15
function generator, 3-20
instruments, 3-13
oscilloscope, 3-14
prototyping board LEDs, 3-9
schematic, 3-9
simulation settings, 3-12
variable power supply, 3-22

Virtual NI ELVIS II Instruments
setting instruments to simulate, 3-12

Virtual NI ELVIS, overview, 3-1

W
Web resources, A-1

V
VHDL export tab, 4-18

R
restrictions
about, 1-2
setting circuit, 1-5
setting global, 1-2

S
setting circuit restrictions, 1-5
setting global restrictions, 1-2
Simplified Version, 1-2
software (NI resources), A-1
support, technical, A-1

T
technical support, A-1
training and certification (NI resources), A-1
troubleshooting (NI resources), A-1

Web resources, A-1