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About This Manual

You can use this manual to familiarize yourself with the DataFinder Server 
Edition features and how to use them.

The first chapter shows you how to create a DataFinder server in a few easy 
steps and how to connect clients to this DataFinder server. The exercises do 
not take long, and they make it easier for you to get started with the 
DataFinder Server Edition.

The second chapter describes the Server Manager and shows you how to 
configure DataFinder servers. 

The third chapter describes how you must configure your firewall to allow 
DataFinder clients such as DIAdem, which are outside the firewall, to 
connect to a server that is inside the firewall. The chapter also outlines the 
integration of the DataFinder server into archiving systems, to enable you 
to identify and to find archived data.

Conventions
The following conventions are used in this manual:

<> Angles brackets indicate a key you press to perform a function, for 
example, <Ctrl> for the control key.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. If you read Settings»Global Options»DataPlugins, you 
must open the Settings menu, select the Global Options item, and then 
select the DataPlugins item.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Parameters are also bolded.

italic Italic text denotes a cross-reference.

monospace Text in this font denotes text or characters that you enter from the keyboard, 
such as dialog box entries and filenames. This font is also used for the 
names of drives, paths, folders, filenames, and filename extensions.
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monospace bold Bold text in this font denotes the settings and messages that the computer 
displays on the screen. 

Related Documentation
For more detailed information on the DataFinder Server Edition, refer to 
the following documentation:

• DataFinder Server Edition help files, which you open by selecting 
Help»Contents, or by pressing <F1>.

• DIAdem: Data Mining, Analysis, and Report Generation

DIAdem is the interactive National Instruments software for finding 
and managing technical data, mathematically and graphically 
analyzing the data, and presenting the data in reports. Chapter 2, 
Finding and Managing Data, describes how to make search entries in 
DIAdem to find data. DIAdem can access DataFinder servers as a 
client.
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1
Creating and Connecting 
DataFinder Servers

A DataFinder server is a search engine that you install on a server. The 
DataFinder server browses specified folders on computers in a network for 
files that contain technical data. The DataFinder server indexes data files to 
provide the clients with the data properties. The DataFinder server indexes 
files for which DataPlugins are registered in the Server Manager.

You can define several DataFinder servers in the Server Manager to provide 
different data for different work groups. Clients, such as DIAdem, 
communicate with the DataFinder servers to browse the indexed data and 
to load search results. 

Note The license specifies how many DataFinder servers you can create and how many 
users can access the DataFinder server simultaneously. For further information on 
licensing refer to the section on the NI License Manager.

Creating DataFinder Servers
When you start the DataFinder Server Edition, the Server Manager opens. 
In the Server Manager you create and configure DataFinder servers and test 
the functionality of the DataFinder servers. To create a DataFinder server, 
complete the following steps:

1. To start the DataFinder Server Edition, select Start»All Programs»
National Instruments»DataFinder Server Edition 2.0»DataFinder 
Manager. 

Because the Server Manager does not have any DataFinder servers 
when you install it, the New DataFinder Server dialog box opens 
automatically the first time you launch the Server Manager.

2. Enter TestRig as the name of the DataFinder server. 

3. Click Add Search Area to specify a search area. Search areas are the 
file system folders that clients can browse for data files. 
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4. Enter My_Data as the alias name for the search area.

5. Click Choose a Folder. 

a. Select the folder that you want the DataFinder server to provide 
for client access in a search. 

b. Click OK to close the dialog box.

6. Click Share Folder. 

The Server Manager opens the Windows share dialog box, where you 
share folders with other users on the network. You must share the 
folders in the search area so the clients can not only read the descriptive 
information, but also load the files found in the search.

7. Click OK to close the Windows share dialog box. 

8. Open the list in the Client path textbox and select the shared network 
path. The Add Search Area dialog box displays the path of the shared 
folder as shown in the following figure. 

Figure 1-1.  Defining a Search Area

9. Click OK to close the dialog box. 

The dialog box displays the new search area My_Data as shown in the 
following figure. 
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Figure 1-2.  Creating a New DataFinder Server

You can now define more search areas where clients can search for 
data. Click Exclude Subfolder to exclude subfolders of a search area 
from the search.

10. Click Finish to close the dialog box.

The Server Manager displays the new DataFinder server as shown in 
the following figure.

 

Figure 1-3.  Server Manager with Enabled DataFinder Server
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Exporting Client Configurations
For clients to execute queries on the server and to load data, you must 
connect the clients to a DataFinder server. You can export the required 
connection settings in the Server Manager, save the settings in a file, and 
then execute the settings on the client. To export a client configuration, 
complete the following steps.

1. Select the TestRig DataFinder server in the Server Manager. 

2. Click Export on the toolbar.

3. Accept the suggested name for the export file TestRig@Computer. 
The name consists of the name of the DataFinder server and the name 
of the server that the DataFinder Server Edition is installed on.

4. Select the Include DataPlugins in client configuration checkbox to 
save all the DataPlugins to the export file, as shown in the following 
figure. 

When you export the DataPlugins, you provide the client with all the 
DataPlugins for loading the files that the DataFinder server TestRig 
indexes and finds.

 

Figure 1-4.  Exporting a Client Configuration

Click OK to open the Save As dialog box.

5. Click Save to save the client configuration. The Server Manager saves 
the connection parameters in a file that has the extension .urf.                 
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Connecting Clients to DataFinder Servers
For a client, such as DIAdem, to use the DataFinder server TestRig, you 
must import the connection configuration to the client computer.

1. Copy the TestRig@Computer.urf file to the client computer.

2. Double-click the TestRig@Computer.urf file to register the 
connection parameters and the DataPlugins on the client computer. 

If you use the URF file to import DataPlugins that are already 
registered on this computer, you can specify whether, in the future, 
the client uses the imported DataPlugins or the DataPlugins that are 
already on the computer. 

A message indicates that the client configuration and the new 
DataPlugins are registered.

3. Open DIAdem. 

4. Select DIAdem NAVIGATOR.

5. Select Settings»Remote DataFinder. 

The following figure shows the dialog box with all the remote 
DataFinders that are registered in DIAdem.

Figure 1-5.  Remote DataFinders Registered in DIAdem

DIAdem can use any DataFinder server that is connected to the 
DIAdem computer on a network, as a remote DataFinder. You can use 
the security settings to limit clients’ access rights to DataFinder 
servers.

Note To load a URF file, you also can click Import Remote DataFinder in the DIAdem 
remote DataFinder settings. After you import the file, click Properties to open the client 
configuration settings. Click Test to check the connection to the DataFinder server.
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6. Click Open to open the DataFinder server in DIAdem NAVIGATOR. 

The file browser in the following figure shows a tree view of the search 
areas of the DataFinder server. If the associated DataPlugin allows, 
you can navigate to channel level in the files.

Figure 1-6.  Navigating in Search Areas of the DataFinder Server
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2
Configuring DataFinder Servers

Use the Server Manager to create, to edit, to duplicate, or to delete 
DataFinder servers. In the Server Manager you also can make general 
settings, export the settings for connecting clients to a DataFinder server, 
optimize custom properties, and open the search areas of a DataFinder 
server in a browser view.

Server Manager
The following figure shows the Server Manager, which provides an 
overview of the most important settings of all the DataFinder servers. The 
version number identifies the version of the DataFinder server. The Server 
Manager displays the version number only if you open the View menu and 
select Display all Versions. The status shows whether a DataFinder server 
is activated. The remote access shows whether clients can access the 
DataFinder server. The index frequency and the indexer start time show 
when the regular indexing of the data files starts. If you disable regular 
indexing, the entry Never appears here.

Figure 2-1.  The Server Manager Displays All DataFinder Servers
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The properties window at the bottom of the Server Manager shows other 
properties of the DataFinder server that is selected in the overview. The 
Autostart property shows, for example, whether the DataFinder server 
launches automatically when the computer starts. The Observe File 
System property shows whether the DataFinder server automatically 
indexes new files and modified files.

If you want to interrupt data file indexing, select a DataFinder server in the 
Server Manager and click Pause Indexing on the toolbar. If you want to 
close the selected DataFinder server, click Stop. If you close a DataFinder 
server, you not only interrupt indexing, you also interrupt the connection to 
the client. Click Start to reactivate a DataFinder server. Clients can now 
browse in the indexed files again. 

You can open the shortcut menu of each activated DataFinder server, 
independently of the Server Manager, in the information area on the 
Windows task bar. Select About My DataFinder to see when the last 
complete indexing was executed and how many files, groups, and channels 
are indexed. You also can use the shortcut menu to stop the indexing and to 
configure, start, and close the DataFinder server. You also can select 
DataFinder»Statistics in the Server Manager for information about 
indexing data.

Specifying the Start Options of DataFinder Servers
You do not need to open the Server Manager to start a DataFinder server. 
Select a DataFinder server in the overview, select Settings»Start Options, 
and select the Enable autostart checkbox. The DataFinder server now 
launches automatically every time the operating system starts. This setting 
also guarantees that the DataFinder server is automatically available when 
you restart the computer after the server computer was down.

In the Start Options dialog box, the setting Run as service specifies 
whether the operating system executes a DataFinder server as a Windows 
service the next time the operating system starts. A service is a Windows 
application that starts automatically when Windows starts and runs in the 
background until you shut down Windows. You only can run a DataFinder 
server as a Windows service if you are logged on as an administrator on 
Windows. In Windows Vista you must start the application explicitly as an 
administrator because the operating system generally starts applications 
with default rights.



Chapter 2 Configuring DataFinder Servers

© National Instruments Ireland Resources Limited 2-3 NI DataFinder Server Edition

Duplicating a DataFinder Server Configuration
Duplicate a DataFinder server configuration to create a new DataFinder 
server with the same configuration. To duplicate a configuration, select a 
DataFinder server in the Server Manager and select File»Duplicate. In the 
dialog box that opens, specify the name and the index location of the new 
DataFinder server. Use a different index location for each DataFinder 
server, because the Server Manager creates a separate index file for each 
DataFinder server. When you duplicate a DataFinder server configuration, 
the Server Manager does not copy the start options of the DataFinder 
server.

If you duplicate an earlier version of a DataFinder server, the Server 
Manager automatically upgrades the duplicated DataFinder server to the 
current version. 

Upgrading an Earlier DataFinder Server
You can upgrade a DataFinder server that was created with an earlier 
version of the DataFinder Server Edition. If you select View»Display all 
Versions, the Server Manager also displays the DataFinder servers from 
previous versions. Select Upgrade from the shortcut menu of the 
DataFinder server you want to update. The Server Manager executes the 
upgrade, converts the DataFinder server to the current version, and updates 
the version number. Do not interrupt the conversion. The conversion may 
take quite some time, and you cannot use the DataFinder server during this 
time. You cannot undo a DataFinder server upgrade. 

You also can upgrade the DataFinder server of an earlier version by 
duplicating the DataFinder server. The Server Manager automatically 
upgrades the duplicated DataFinder server. You then delete the previous 
DataFinder and rename the new DataFinder server. 

Defining Global Settings
Select Settings»Global Options»General and specify the default settings 
for new DataFinder servers, in the dialog box that opens. You specify 
whether a new DataFinder server automatically starts with the operating 
system, whether the DataFinder server is operated as a Windows service, 
whether the security settings are activated, and whether a DataFinder server 
is given a desktop shortcut. The settings in this dialog box apply for all the 
DataFinder servers that you create subsequently.



Chapter 2 Configuring DataFinder Servers

NI DataFinder Server Edition 2-4 ni.com

Configuring DataFinder Servers
To configure a DataFinder server, double-click the DataFinder server in the 
Server Manager. In the configuration of the DataFinder server you specify 
the search areas and the indexing of the data files. You also see which file 
types the DataFinder server includes in the search.

Defining Search Areas
On the Search Areas tab you select folders that the DataFinder server 
indexes for the search. You can edit and delete search areas and specify the 
order in which the DataFinder server indexes the search areas and displays 
the search areas in the browser. You can exclude subfolders of a search area 
from indexing. A plus sign in front of a search area indicates that the search 
area contains subfolders that the DataFinder server does not index. 

To enable clients to load files from the search areas, you must share each 
search area using the Windows share settings. You define the share mode 
when you create a search area or edit an existing search area. Click Share 
Folder to open the Windows system dialog box that has the Sharing tab. 
In the Windows sharing settings you specify which users, and how many 
simultaneous users, have read and write access. You can enter individual 
users and user groups that are defined in a network, for example, to provide 
access rights for an entire group. Refer to the Microsoft Windows program 
Help for more information about sharing folders.

You must define the search areas of the DataFinder server with path names 
that are unique within the network. If you click Edit Search Area, 
the Client path entry is the path for client access to files, for example, 
\\Testrig4a\NewCar\DATA.

To block remote access to all the search areas of a DataFinder server, clear 
the Allow remote access to this computer checkbox on the General tab. 
Now no clients can access the DataFinder server. All the share settings are 
hidden in the configuration dialog boxes.

Reading File Types with DataPlugins 
DataFinder servers decide which files to index according to the filename 
extension. The File Extensions tab has two lists that contain all the 
filename extensions that the DataFinder server recognizes. 

The Indexable extensions list shows all the indexable file types that 
correspond to the TDM data model. In indexable files the DataFinder server 
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can search for properties of data sets, groups, and channels. Clients can 
navigate to channel level in indexed files. Click a filename extension to see 
which DataPlugins the DataFinder server uses to index these files.

The Non-indexable extensions list shows all the non-indexable file 
types. These file types do not correspond to the TDM data model. In non-
indexable files, the DataFinder server cannot search for properties of 
groups or channels. The DataFinder server only can search for properties 
that the file system provides, such as the filename and the creation date. 

The registered DataPlugins define which file types the DataFinder server 
can index. A DataPlugin is a VBScript that analyzes files of a specific 
file type and provides this information to the DataFinder server. The 
DataPlugins tab shows you which DataPlugins the DataFinder uses for 
indexing. 

To add DataPlugins, select Settings»Global Options»DataPlugins. In this 
dialog box you can define, import, export, and delete DataPlugins. If you 
change the properties of a DataPlugin, these changes apply for all the 
DataFinder servers. 

Refer to ni.com/dataplugins for DataPlugins for various data formats, 
written and tested by programmers and by users. The site also provides 
assistance for programming DataPlugins, including a description of the 
objects, properties, and methods, and many examples. 

Planning Indexing
When indexing, the DataFinder server reads properties from data files and 
saves this information. When clients search for data files, the DataFinder 
server browses the index for the properties.

Click the Indexer tab to specify when and how often the DataFinder server 
indexes the search areas. To immediately start indexing a DataFinder server 
that is selected in the Server Manager, click the Start Now button. Depen-
ding on the amount of data, it can take quite a while to index a search area 
for the first time. 

Select the checkbox Update index immediately when files are created or 
modified to ensure that clients always search current data. The Idle time 
specifies the time that the DataFinder server waits after the last keyboard 
entry or mouse movement, before the indexing process continues. You limit 
the time that the DataFinder server spends indexing a specific file, for 
example, to prevent the DataFinder server from continually trying to index 
a file that cannot be read. 
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You can use the Scheduler to start indexing regularly. For example, the 
DataFinder server can browse the search areas every midnight, when no 
changes to the search areas and no client queries are expected. 

On the General tab, the Index location displays the folder where the 
DataFinder server saves the index. Generally, you should not change the 
index location that is created during installation. However, if the drive with 
the index has less than 20 MB free memory space, the DataFinder server 
stops indexing and displays an error message. You must then either delete 
files to make more space available, or change the index path. If you change 
the index path, the DataFinder server reindexes the search areas. To avoid 
changing the index path during the working process, install the DataFinder 
Server Edition on a server that has sufficient hard disk memory space.

Optimizing Custom Properties
You can optimize the search for custom properties for a DataFinder server 
so that the client finds these custom properties faster. Custom properties are 
user-defined properties that you can create for data sets, groups, and 
channels of the data that is saved in the TDM data model. Custom 
properties give data additional characteristics that are not included in the 
standard data model. 

To speed up the search for custom properties, select a DataFinder server in 
the Server Manager and select Settings»Optimize Custom Properties. On 
the tabs File, Group, and Channel you select custom properties that are to 
be optimized. Do not optimize more than 100 custom properties per file, 
group, or channel. If you click Suggest, the Server Manager makes a 
suggestion for optimizing the custom properties. When you close the dialog 
box, the DataFinder server optimizes the selected custom properties. The 
DataFinder server always optimizes custom properties for the data type that 
the DataFinder server used most frequently to index the custom property. 
Optimizing custom properties can take quite a long time. You cannot 
interrupt the optimizing process and during this process you cannot work 
with the DataFinder server.

In a client, such as DIAdem, you select the custom properties from the 
properties in the Advanced Search. If you select an optimized custom 
property, you can click the button shown on the left, which is at the end 
of the entry field, to include a suggested value in the search. Which 
operators you can use for a query depends on the data type of the 
property searched for. 
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Note You only can search for date type custom properties if the DataFinder server has 
optimized these custom properties.

Security Settings
You can use security settings to limit clients’ access rights on DataFinder 
servers. If you do not enable the security settings, a client can browse and 
search in all existing search areas. An error message only appears when a 
client tries to load data from a search area that is not shared. If you enable 
the security settings, the client only can search, browse, and load data from 
the shared search areas. To connect to a DataFinder server, the client must 
have read rights in at least one search area. 

You enable the security settings for a DataFinder server in the New 
DataFinder Server dialog box or on the General tab in the configuration 
dialog box of the DataFinder server. To use the security settings, select the 
Enable security checkbox in these dialog boxes. To use the security 
settings, you require a network with a specified domain.

You specify the client rights in the Windows dialog boxes for sharing and 
security, on the server. If you change access rights for sharing or for folders 
or create new users or groups, select Settings»Update Access Rights for 
the DataFinder to update rights without the server having to restart. 

Note To index the search areas completely, the user that executes the DataFinder server 
must have read rights for all search areas.

Note Even if the security settings are enabled, the data is transferred unencrypted between 
client and server.

Exporting Client Configurations
To export the settings for a client connection to a DataFinder server that you 
have selected in the Server Manager, click Export on the toolbar. You also 
can export the DataPlugins of the DataFinder server together with the client 
configuration, to provide the client with all the DataPlugins for loading the 
indexed files.

In the export dialog box you also can set connection parameters. You can 
limit the amount of time that the clients may take to connect to the 
DataFinder server, and the maximum time that the clients wait for the 
results of a search. When the Server Manager exports the client 
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configuration, it saves the connection parameters and the DataPlugins in a 
file that has the extension .urf.

To provide the connection settings for a client such as DIAdem, you copy 
the URF file to the DIAdem computer. Double-click the URF file to register 
the settings and the DataPlugins on the client computer. If the URF file 
imports DataPlugins that are already registered, you can specify whether 
you want the client to use the imported DataPlugins in the future. 

Then start DIAdem and select DIAdem NAVIGATOR. Select File»Open 
DataFinder. Select the new remote DataFinder that you have registered 
and click OK. DIAdem opens the search areas of the remote DataFinder in 
the file browser. You can navigate in the search areas of the remote 
DataFinder and load data.

To modify the connection parameters in DIAdem, select Settings»Remote 
DataFinder and click Properties. Click Test to check the connection to 
the server.

Browsing in Search Areas
The Server Manager provides a browser view of the search areas of the 
DataFinder servers. If the DataPlugin that is associated with the selected 
file type allows, you can navigate to channel level in the folders of the 
search areas and in the indexed files. 

Select a DataFinder server in the Server Manager and click Open in 
Browser on the toolbar. The Server Manager opens a tab with a tree view 
of the search areas of the selected DataFinder server. 

The properties window at the bottom displays the properties of the file, of 
the channel group, or of the channel, that is selected in the tree view. Click 
one of the indexed files to view the file properties as shown in the following 
figure. In the properties window, the Server Manager displays file 
properties such as the filename, path, creation date, name, and author. Drag 
up the top edge of the properties window to view the entire properties list.
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Figure 2-2.  Browsing in the Search Areas of a DataFinder Server

In the browser view you can open the shortcut menu to define other folders 
as search areas, and to edit and to delete existing search areas. You also can 
exclude subfolders from indexing.

In the browser view, if you select Client View from the shortcut menu or 
if you select View»Client View on the menu bar, the Server Manager 
displays the selected DataFinder server in the view that the client sees. In 
the client view, the Server Manager displays only the search areas and hides 
the MyComputer path.

Note Depending on the security settings, the view of the client can differ from the client 
view of the Server Manager.
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NI License Manager
The NI License Manager helps you manage your NI software product 
licenses. To work with the DataFinder Server Edition after your Evaluation 
version expires, select Start»All Programs»National Instruments»
NI License Manager and enter your serial number. 

The NI License Manager limits the number of active clients that can access 
the DataFinder server simultaneously. To increase the number of clients, 
you must purchase a license that allows more connections. Then select 
Help»Activate License in the Server Manager, click Next, and enter the 
new serial number.

The NI License Manager limits the number of DataFinder servers that you 
can create in the Server Manager. If you need more than one DataFinder 
server, you must purchase a license that allows multiple DataFinder 
servers.
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3
Integrating the DataFinder Server 
into the Work Environment

This chapter describes how you must configure your firewall to allow 
DataFinder clients such as DIAdem, which are outside the firewall, to 
connect to a server that is inside the firewall. The chapter also outlines the 
integration of the DataFinder server into archiving systems, to enable you 
to identify and to find archived data.

Configuring Firewalls and Network Address Translating 
Routers for DataFinder Servers

DataFinder servers use the UDP port 2343 and a range of UDP ports 
beginning with port 6000. The number of UDP ports above 6000 that the 
DataFinder servers use depends on the number of servers running on the 
computer. DataFinder clients, such as DIAdem, use a range of UDP ports 
beginning with port 5000. The number of UDP ports above 5000 that the 
DataFinder clients use depends on the number of clients running on the 
computer.

Firewalls
Complete the following steps to allow DIAdem or other DataFinder clients 
outside a firewall to connect to a DataFinder server inside a firewall. The 
exact steps for configuring the firewall depend on which specific firewall 
you use. Refer to the documentation on the firewall for specific instructions 
about opening UDP ports.

1. Open the UDP port 2343 for incoming and outgoing packets. 

2. Open the UDP port range from 6000 to 6010 for incoming packets. 

You also can allow clients inside a firewall to connect to a DataFinder 
server outside the firewall. Some firewalls automatically transmit incoming 
packets without any configuration. If the firewall does not open the ports 
automatically, open the UDP port range from 5000 to 5010 for incoming 
packets.
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Network Address Translating Routers
Complete the following steps to allow clients outside a NAT router to 
connect to a DataFinder server inside the router. The exact steps for 
configuring the router depend on the specific router you use. Refer to the 
documentation on the router for specific instructions about forwarding 
ports. Inside the router, only one computer can function as a server.

1. Forward the UDP port 2343 to the computer with the DataFinder 
server. 

2. Forward the UDP port range from 6000 to 6010 to the computer with 
the DataFinder server. 

You also can allow clients inside a NAT router to connect to a server outside 
the router. Some routers automatically forward UDP ports without any 
configuration. If the router does not forward the UDP ports automatically, 
forward the UDP port range from 5000 to 5010 to the computer with the 
client (DIAdem).

Note If you install the DataFinder Server Edition on a Windows machine with an 
enabled Windows firewall, you must add the programs ..\National Instruments\
DataFinder Server Edition 2.0\DataFinderSE.exe and ..\Windows\
System32\lkads.exe to the Windows firewall exception list. 

Note If a client (DIAdem) installed on a Windows machine with an enabled Windows 
firewall wants to access a DataFinder server, you must add the ..\Windows\System32\
lkads.exe program to the Windows firewall exception list. 

Support for Archiving Systems
Many factors such as powerful multicore processors, increased memory, 
fast hard drives, and increasing sampling rates, are leading to increasing 
amounts of data. For easy and economic management of these amounts of 
data you need a backup system or archiving system. 

Solutions
In a backup system the data that is no longer needed is stored on an 
inexpensive storage medium with a high storage capacity, usually magnetic 
tapes. The data must be stored and recovered manually. 

Archiving systems provide better management of large amounts of data. In 
archiving systems, automated and rule-based background processes move 
the files into the archive. A file with the same name and the same file 
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attributes but without any contents remains at the original position in the 
file system. 

DataFinder Server Edition
The DataFinder Server Edition integrates smoothly into archiving systems. 
The DataFinder server recognizes archived files and saves the archiving 
flag together with the descriptive TDM and TDMS file data, in the 
DataFinder index. If you navigate or mine data, the DataFinder server 
handles archived data the same as all other data. This means that you can 
browse and search in files that are only stored in an archive, not located in 
the search areas. The related file symbol denotes whether the file is in the 
archive. When you access the file it is automatically restored from the 
archive.

Note The process of connecting the DataFinder Server Edition to archiving systems was 
developed in cooperation with the company S.E.R.
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A
Technical Support and 
Professional Services

Visit the Support section of the National Instruments Web site at ni.com 
for technical support and professional services. Online technical support 
resources at ni.com/support include the following:

• Self-Help Technical Resources—For answers and solutions, visit 
ni.com/support for software drivers and updates, a searchable 
KnowledgeBase, product manuals, step-by-step troubleshooting 
wizards, thousands of example programs, tutorials, application notes, 
instrument drivers, and so on. Registered users also receive access to 
the NI Discussion Forums at ni.com/forums. NI Applications 
Engineers make sure every question submitted online receives 
an answer.

• Standard Service Program Membership—This program entitles 
members to direct access to NI Applications Engineers via phone and 
email for one-to-one technical support as well as exclusive access to on 
demand training modules via the Services Resource Center. NI offers 
complementary membership for a full year after purchase, after which 
you may renew to continue your benefits. 

For information about other technical support options in your area, visit 
ni.com/services or contact your local office at ni.com/contact. 
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