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About This Manual

You can use this manual to familiarize yourself with the DataFinder Server 
Edition features and how to use them.

The first chapter shows you how to create a DataFinder server in a few easy 
steps and how to connect clients to this DataFinder server. The exercises do 
not take long, and they make it easier for you to get started with the 
DataFinder Server Edition.

The second chapter describes the Server Manager and shows you how to 
configure DataFinder servers. 

The third chapter describes how you must configure your firewall to allow 
DataFinder clients such as DIAdem, which are outside the firewall, to 
connect to a server that is inside the firewall.

Conventions
The following conventions are used in this manual:

<> Angles brackets indicate a key you press to perform a function, for 
example, <Ctrl> for the control key.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. If you read Settings»Global Options»DataPlugins, you 
must open the Settings menu, select the Global Options item, and then 
select the DataPlugins item.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Parameters are also bolded.

italic Italic text denotes a cross-reference.

monospace Text in this font denotes text or characters that you enter from the keyboard, 
such as dialog box entries and filenames. This font is also used for the 
names of drives, paths, folders, filenames, and filename extensions.

monospace bold Bold text in this font denotes the settings and messages that the computer 
displays on the screen. 
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Related Documentation
For more detailed information on the DataFinder Server Edition, refer to 
the following documentation:

• DataFinder Server Edition help files, which you open by selecting 
Help»Contents, or by pressing <F1>.

• DIAdem: Data Mining, Analysis, and Report Generation

Chapter 2, Finding and Managing Data, describes how to make search 
entries in DIAdem to find data. DIAdem can access DataFinder servers 
as a client.
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1
Creating and Connecting 
DataFinder Servers

A DataFinder server is a search engine that you install on a server. The 
DataFinder server browses computers in a network for files that contain 
technical data. The DataFinder server indexes data files to provide the 
clients with the data properties. The DataFinder server indexes files that are 
the same types as the DataPlugins that are registered in the Server Manager.

You can define several DataFinder servers in the Server Manager to provide 
different data for different work groups. Clients, such as DIAdem, 
communicate with the DataFinder servers to browse the indexed data and 
to load the search results. 

Note The license specifies how many DataFinder servers you can create and how many 
users can access the DataFinder server simultaneously. For further information on 
licensing refer to the section on the NI License Manager.

Creating DataFinder Servers
When you start the DataFinder Server Edition the Server Manager appears. 
In the Server Manager you create and configure DataFinder servers and test 
the functionality of the DataFinder servers. Complete the following steps 
to create a DataFinder server:

1. To start the DataFinder Server Edition, select Start»All Programs» 
National Instruments»DataFinder Server Edition 1.1»DataFinder 
Manager. 

Because the Server Manager does not have any DataFinder servers 
when you install Server Manager, Step 1 of the wizard for creating a 
DataFinder server appears automatically the first time you launch the 
Server Manager.

2. Enter TestRig as the name of the DataFinder server.

3. Click Add search area to specify a search area. Search areas are the 
file system folders that a client can browse for data files. 

4. Enter My_Data as the alias name for the search area.
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5. Click Choose a folder. 

a. Select the folder that you want the DataFinder server to share with 
the client for a search. 

b. Click OK to close the dialog box.

6. Click Share folder. 

The DataFinder Manager opens the Windows share dialog box, where 
you share folders with other users on the network. You must share the 
folders in the search area so the clients see the descriptive information 
and can load the files found.

7. Click OK to close the Windows share dialog box. The Add search 
area dialog box displays the path of the shared folder as shown in the 
following figure. 

Figure 1-1.  Defining a Search Area

8. Click OK to close the dialog box. 
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The first step in the wizard displays the new search area My_Data as 
shown in the following figure. 

Figure 1-2.  Step 1 of the Wizard

You can now define more search areas where a client can search for 
data. Click Exclude subfolder to exclude subfolders of a search area 
from the search.

9. Click Next to open Step 2 of the wizard. 

10. If you select Enable autostart, Windows launches the DataFinder 
server automatically every time the operating system starts. 

11. Select the Create shortcut on the desktop checkbox to create an icon 
for the DataFinder server TestRig on the desktop. 

You can then double-click the icon to start the DataFinder server 
TestRig without opening the Server Manager. The following figure 
shows the second step of the wizard.
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Figure 1-3.  Step 2 of the Wizard

12. Click Finish to conclude the definition of the DataFinder server. 

The Server Manager immediately starts to index the data files in the 
search areas. 

13. The Server Manager displays the new TestRig DataFinder server as 
shown in the following figure. 

 

Figure 1-4.  Server Manager with Enabled DataFinder Server
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If you want to create another DataFinder server, click New DataFinder on 
the toolbar. You only can create more DataFinder servers if your license 
allows multiple DataFinder servers.

Exporting Client Configurations
For clients to execute queries on the server and to load data, you must 
connect the clients to a DataFinder server. You can export the required 
settings in the Server Manager, save the settings in a file, and then execute 
the settings on the client. Complete the following steps to export a client 
configuration.

1. Select the TestRig DataFinder server in the Server Manager. 

2. Click Export on the toolbar.

3. Accept the suggested name for the export file TestRig@computer. 
The name consists of the name of the DataFinder server and the name 
of the server that the DataFinder Server Edition is installed on.

4. Select the Include DataPlugins in client configuration checkbox to 
save all the DataPlugins to the export file, as shown in the following 
figure.

When you export the DataPlugins, you provide the client with all the 
DataPlugins for loading the files that the DataFinder server TestRig 
indexes and finds.

 

Figure 1-5.  Exporting a Client Configuration

Click OK to open the Save as dialog box.

5. Click Save to save the client configuration. The Server Manager saves 
the connection parameters in a file that has the extension urf.



Chapter 1 Creating and Connecting DataFinder Servers

NI DataFinder Server Edition 1-6 ni.com

Connecting Clients to DataFinder Servers
For a client, such as DIAdem, to use the DataFinder server TestRig, you 
must enable the client configuration on the client computer.

1. Copy the TestRig@computer.urf file to the client computer.

2. Double-click the TestRig@computer.urf file to register the 
connection parameters and the DataPlugins on the client computer. 

If you use the URF file to import DataPlugins that are already 
registered on this computer, you can specify whether, in the future, 
the client uses the imported DataPlugins or the DataPlugins that are 
already on the computer. 

A message indicates that the client configuration and the new 
DataPlugins are registered.

3. Open DIAdem. 

4. Select DIAdem NAVIGATOR.

5. Select Settings»Remote DataFinder. 

The following figure shows the dialog box with all the remote 
DataFinders that are registered in DIAdem.

 

Figure 1-6.  Remote DataFinders Registered in DIAdem

DIAdem can use any DataFinder server that is connected to the 
DIAdem computer on a network, as a remote DataFinder. 

Note To load a URF file, you also can click Import remote DataFinder in the DIAdem 
remote DataFinder settings. After you import the file, click Properties to open the client 
configuration settings. Click Test to check the connection to the DataFinder server. 
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6. Click Open to open the DataFinder server in DIAdem NAVIGATOR. 

The file browser in the following figure shows a tree view of the search 
areas of the DataFinder server. If the associated DataPlugin allows, 
you can navigate to channel level in the files.

Figure 1-7.  Navigating in Search Areas of the DataFinder Server

If you want to open the search areas of the DataFinder server TestRig 
by default in the file browser when you launch DIAdem, select Settings»
Options»NAVIGATOR. Select the radio button Start behavior»Exter-
nal data»DataFinder, click Browse, and select the DataFinder server 
TestRig. Save the modified program settings when you close DIAdem.

To access the search areas of various DataFinder servers faster in DIAdem, 
you can assign DataFinder servers to the buttons on the DataFinder 
function bar. To do this, select Default setting from the shortcut menu of 
a button on the function bar.
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2
Configuring DataFinder Servers

Use the Server Manager to create, to edit, to duplicate, or to delete your 
DataFinder server. In the Server Manager you also can make general 
settings, export the settings for connecting a client to a DataFinder server, 
optimize custom properties, and open the search areas of a DataFinder 
server in a browser.

Server Manager
The following figure shows the Server Manager, which provides an 
overview of the most important settings of all the DataFinder servers. 
The version number identifies the DataFinder server. The Server Manager 
displays the version number only if you open the View menu and select 
Display all versions. The status shows whether a DataFinder server is 
activated. The remote access shows whether clients can access the 
DataFinder server. The index frequency and the indexer start time show 
when the regular indexing of the data files starts. If you disable regular 
indexing, the entry Never appears here.

 

Figure 2-1.  The Server Manager Displays all DataFinder Servers
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The properties window at the bottom of the Server Manager shows other 
properties of the DataFinder server that is selected in the overview. The 
Autostart property shows, for example, whether the DataFinder server 
launches automatically when the computer starts. The Observe file 
system property shows, for example, whether the DataFinder server 
automatically indexes each new file and each modified file.

If you want to interrupt data file indexing, select a DataFinder server in 
the DataFinder Manager and click Pause indexing on the toolbar. If you 
want to close the selected DataFinder server, click Stop. If you close a 
DataFinder server, you not only interrupt indexing, you also interrupt the 
connection to the client. Click Start to reactivate a DataFinder server. 
Clients can now browse in the indexed files again. 

You can open the shortcut menu of each activated DataFinder server from 
the information area on the Windows task bar. Select About to see when 
the last complete indexing was executed and how many files, groups, and 
channels are indexed. You also can stop the indexing here and configure, 
start, and close the DataFinder server. You also can select DataFinder» 
Statistics in the Server Manager for information about indexing data.

Specifying the Start Options of DataFinder Servers
You do not need to open the Server Manager to start a DataFinder server. 
Select a DataFinder server in the overview, select Settings»Start options, 
and select the Enable autostart checkbox. The DataFinder server now 
launches automatically every time the operating system starts. This setting 
guarantees that the DataFinder server is automatically available when you 
restart the computer after the server computer was down.

In the Start options dialog box, the setting Run as service specifies 
whether the operating system executes a DataFinder server as a Windows 
service the next time the server starts. A service is a Windows applications 
that starts automatically when Windows starts and runs in the background 
until you shut down Windows. You only can run a DataFinder server as a 
Windows service if you are logged on as an administrator under Windows. 
In Windows Vista you must start the application explicitly as an 
administrator because the operating system starts applications with default 
rights.
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Duplicating a DataFinder Server Configuration
Duplicate a DataFinder server configuration to create a new DataFinder 
server with the same configuration. To duplicate a configuration, select the 
DataFinder server that you want to duplicate in the Server Manager and 
select File»Duplicate. In the dialog box that opens, specify the name and 
the index location of the new DataFinder server. If you do not change the 
name of the new DataFinder server, the Server Manager automatically adds 
a number to the name. Use a different index path for each DataFinder 
server. When you duplicate a DataFinder server configuration, the Server 
Manager does not copy the start options of the DataFinder server.

If you duplicate an earlier version of a DataFinder server, the Server 
Manager automatically upgrades the duplicated DataFinder server to 
the current version. 

Upgrading an Earlier DataFinder Server
You can upgrade a DataFinder server from an earlier version of the 
DataFinder server edition. If you select View»Display all versions, the 
Server Manager displays the previous DataFinder server versions. Select 
Upgrade from the shortcut menu of the DataFinder server you want to 
update. The Server Manager runs the upgrade and refreshes the version 
number of the selected DataFinder server. If you upgrade a DataFinder 
server, the Server Manager must reindex all the data of the search areas. 
Data indexing may take some time. You cannot undo a DataFinder server 
upgrade. 

You also can upgrade the DataFinder server of an earlier version if you 
duplicate the DataFinder server. The Server Manager automatically runs 
an upgrade of the duplicated DataFinder server. Delete the previous 
DataFinder and rename the new DataFinder server. 

Defining Global Settings
In the dialog box that opens when you select Settings»Global options» 
General, you can specify the default settings that the Server Manager uses 
to create new DataFinder servers. You specify whether a new DataFinder 
server automatically starts with the operating system, whether the 
DataFinder server is operated as a Windows service, and whether a 
DataFinder server is given a desktop shortcut. The settings in this dialog 
box apply for all the DataFinder servers that you create subsequently.
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Configuring DataFinder Servers
To configure a DataFinder server, double-click the DataFinder server in the 
Server Manager. In the configuration of the DataFinder server you specify 
the search areas and the indexing of the data files. You also can see which 
file types the DataFinder server includes in the search.

Defining Search Areas
On the Search areas tab you select folders that the DataFinder server 
browses. You can edit and delete search areas and specify the order in 
which the DataFinder server indexes the search areas and displays the 
search areas in the browser. You can exclude subfolders of a search area 
from the search. A plus sign in front of a search area indicates that the 
search area contains subfolders that the DataFinder server excludes from 
the search. 

You must share each search area using the Windows share settings, to 
enable clients to load files from the search areas. You define share mode 
when you create a search area or edit an existing search area. Click Share 
folder to open the Windows system dialog box with the Sharing tab. In 
the Windows sharing settings you specify which users, and how many 
simultaneous users, have read and write access. You can enter individual 
users and user groups that are defined in a network, for example, to provide 
access rights for an entire group. Refer to the Microsoft Windows program 
help for more information about sharing folders.

You must define the search areas of the DataFinder server with path names 
that are unique within the network. If you click Edit search area, the 
Client path entry is the path for client access to files, for example, 
\\Testrig4a\NewCar\DATA.

To block remote access to all the search areas of a DataFinder server, clear 
the Allow remote access to this computer checkbox on the General tab. 
Clients can no longer access the DataFinder server and all the share settings 
are hidden in the configuration dialog boxes.

Reading File Types with DataPlugins 
DataFinder servers decide which files to index according to the filename 
extension. The File extensions tab has two lists that contain all the filename 
extensions that each DataFinder server recognizes. 
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The Indexable extensions list shows all the indexable file types, 
which correspond to the TDM data model. In indexable files the 
DataFinder server can search for properties of data sets, groups, and 
channels. Clients can navigate to channel level in indexed files. Click 
a filename extension to see which DataPlugins the DataFinder server uses 
to index these files.

The Non-indexable extensions list shows all the non-indexable file 
types. These file types do not correspond to the TDM data model. In non-
indexable files, the DataFinder server cannot search for properties of 
groups or channels. The DataFinder server only can search for properties 
that the file system provides, such as the filename and the creation date. 

The registered DataPlugins determine which file types the DataFinder 
server can index. A DataPlugin is a VBScript that analyzes files of a 
specific file type and provides this information to the DataFinder server. 
The DataPlugins tab shows which filename extensions are assigned to 
which DataPlugin. 

To add DataPlugins, select Settings»Global options»DataPlugins. In this 
dialog box you can define, import, export, and delete DataPlugins. When 
you define a new DataPlugin, you can edit the associated VBScript. If you 
change the properties of a DataPlugin, these changes apply for all the 
DataFinder servers. 

The National Instruments internet site ni.com/dataplugins offers 
DataPlugins for various data formats, written and tested by programmers 
and by users. The site also provides assistance for programming 
DataPlugins, including a description of the objects, properties, and 
methods, and many examples. 

Planning Indexing
When indexing, the DataFinder server reads properties from data files and 
saves this information. When clients search for data files, the DataFinder 
server browses the index for the properties.

Click the Indexer tab to specify when and how often the DataFinder server 
indexes the search areas. To immediately start indexing a DataFinder server 
that is activated in the Server Manager, click the Start now button. 
Depending on the amount of data, it can take quite a while to index a search 
area for the first time. 
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Select the checkbox Update index immediately when files are created or 
modified to ensure that clients always search current data. The Idle time 
specifies the time that the DataFinder server waits after the last keyboard 
entry or mouse movement, before the indexing process continues. You limit 
the time that the DataFinder server spends indexing a specific file, for 
example, to prevent the DataFinder server from continually trying to index 
a file that cannot be read. 

You can use the Scheduler to start indexing regularly. For example, the 
DataFinder server can browse the search areas at 12 AM daily, when no 
changes to the search areas and no client queries are expected. 

If you shut down the computer during a scheduled indexing process or 
while an indexing process is running, the DataFinder server starts indexing 
at the next scheduled time, after you restart the computer. 

On the General tab, the Index location displays the folder where the 
DataFinder server saves the index. Generally, you should not change the 
index location that is created during installation. However, if the drive with 
the index has less than 20 MB free memory space, the DataFinder server 
stops indexing and displays an error message. You must then either delete 
files to make more space available, or change the index path. If you change 
the index path, the DataFinder server reindexes the search areas. To avoid 
changing the index path during the working process, install the DataFinder 
Server Edition on a server that has sufficient hard disk memory space.

Optimizing Custom Properties
You can optimize the search for custom properties for a DataFinder server 
so that the DataFinder server finds these custom properties faster. Custom 
properties are user-defined properties that you can create for data sets, 
groups, and channels of the data that is saved in the TDM data model. 
Custom properties give data additional characteristics that are not included 
in the standard data model. 

To speed up the search for custom properties, select a DataFinder server in 
the Server Manager and select Settings»Optimize custom properties. On 
the tabs File, Group, and Channel you select custom properties that are to 
be optimized. Do not optimize more than 100 custom properties per file, 
group, or channel. If you click Suggest, the Server Manager makes a 
suggestion for optimizing the custom properties. When you close the dialog 
box, the DataFinder server optimizes the selected custom properties. 
Optimizing custom properties can take quite a long time. You cannot 
interrupt the optimizing process and during this process you cannot work 
with the DataFinder server.
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In a client, such as DIAdem, select the custom properties from the 
properties in the Advanced search. If you select an optimized custom 
property, you can click the button shown on the left, which is at the end of 
the entry field, to apply a suggested value in the search. Which operators 
you can use for a search entry depends on the data type of the property 
searched for. The DataFinder server always optimizes custom properties 
for the data type that the DataFinder server used most frequently to index 
the custom property. 

Note You only can search for date type custom properties if the DataFinder server has 
optimized these custom properties.

Exporting a Client Configuration
To export the settings for a client connection to a DataFinder server that you 
have selected in the Server Manager, click Export on the toolbar. You also 
can export the DataPlugins of the DataFinder server together with the client 
configuration, to provide the client with all the DataPlugins for loading the 
indexed files.

In the export dialog box you also can set connection parameters. You 
can limit the amount of time that the clients may take to connect to the 
DataFinder server, and the maximum time that the clients wait for 
the results of a search. When the Server Manager exports the client 
configuration, it saves the connection parameters and the DataPlugins in 
a file that has the extension urf.

To provide the connection settings for a client such as DIAdem, you copy 
the URF file to the DIAdem computer. Double-click the URF file to register 
the settings and the DataPlugins on the client computer. If you use the URF 
file to import DataPlugins that are already registered, you can specify 
whether you want the client to use the imported DataPlugins in the future. 

Then start DIAdem and open DIAdem NAVIGATOR. Select File»Open 
DataFinder. Select the new remote DataFinder that you have registered 
and click OK. DIAdem opens the search areas of the remote DataFinder 
in the file browser. You can navigate in the search areas of the remote 
DataFinder and load data.

To modify the connection parameters in DIAdem, select Settings»Remote 
DataFinder and click Properties. Click Test to check the connection to 
the DataFinder server.
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Browsing in Search Areas
The Server Manager provides a tree view of the search areas of the 
DataFinder servers. If the DataPlugin allows, you can navigate to channel 
level in the folders of the search areas and in the indexed files. 

Select a DataFinder server in the Server Manager and click Open in 
browser on the toolbar. The Server Manager opens a tab with a tree view 
of the search areas of the selected DataFinder server. 

The properties window at the bottom displays the properties of the file, 
of the channel group, or of the channel, that is selected in the tree view. 
Click one of the indexed files to view the file properties as shown in the 
following figure. In the properties window, the Server Manager displays 
file properties such as the filename, path, creation date, name, and author. 
Drag the top edge of the properties window up to view the entire properties 
list.

 

Figure 2-2.  Browsing in the Search Areas of a DataFinder Server

In the tree view you can open the shortcut menu to define other folders as 
search areas, and to edit and to delete existing search areas. You also can 
exclude subfolders from indexing.

To display the selected DataFinder server as the client sees the DataFinder 
server, select View»Client view. In the client view, the Server Manager 
displays all the search areas and hides the path MyComputer.
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NI License Manager
The NI License Manager helps you manage your NI software product 
licenses. To work with the DataFinder Server Edition after your Evaluation 
version expires, select Start»All Programs»National Instruments»
NI License Manager and enter your serial number. 

The NI License Manager limits the number of active clients that can access 
the DataFinder server simultaneously. To increase the number of clients, 
you must purchase a license that allows more connections. Then select 
Help»Activate license in the Server Manager, click Next, and enter the 
new serial number.

The NI License Manager limits the number of DataFinder servers that you 
can create in the Server Manager. If you need more than one DataFinder 
server, you must purchase a license that allows multiple DataFinder 
servers.
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3
Configuring Firewalls and Network 
Address Translating Routers for 
DataFinder Servers

DataFinder servers use the UDP port 2343 and a range of UDP ports 
beginning with port 6000. The number of UDP ports above 6000 that the 
DataFinder servers use depends on the number of servers running on the 
computer. DataFinder clients, such as DIAdem, use a range of UDP ports 
beginning with port 5000. The number of UDP ports above 5000 that the 
DataFinder clients use depends on the number of clients running on the 
computer.

Firewalls 
Complete the following steps to allow DIAdem or other DataFinder clients 
outside a firewall to connect to a DataFinder server inside a firewall. The 
exact steps for configuring the firewall depend on which specific firewall 
you use. Refer to the documentation on the firewall for specific instructions 
about opening UDP ports.

1. Open the UDP port 2343 for incoming and outgoing packets. 

2. Open the UDP port range 6000 to 6010 for incoming packets. 

You also can allow clients inside a firewall to connect to a DataFinder 
server outside the firewall. Some firewalls automatically transmit incoming 
packets without any configuration. If the firewall does not open the ports 
automatically, open the UDP port range from 5000 to 5010 for incoming 
packets.
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Network Address Translating Routers
Complete the following steps to allow clients outside a NAT router to 
connect to a DataFinder server inside the router. The exact steps for config-
uring the router depend on the specific router you use. Refer to the 
documentation on the router for specific instructions about forwarding 
ports. Only one computer inside the router can function as a server.

1. Forward the UDP port 2343 to the computer with the DataFinder 
server. 

2. Forward the UDP port range 6000 to 6010 to the computer with the 
DataFinder server. 

You also can allow clients inside a NAT router to connect to a server outside 
the router. Some routers automatically forward UDP ports without any con-
figuration. If the router does not forward the UDP ports automatically, 
forward the UDP port range from 5000 to 5010 to the computer with the 
client (DIAdem).

Note If you installed the DataFinder Server Edition on a Windows machine with an 
enabled Windows firewall, you must add the programs ..\National Instruments\
DataFinder Server Edition 1.1\DataFinderSE.exe and ..\Windows\
System32\lkads.exe to the Windows firewall exception list. 

Note If a client (DIAdem) installed on a Windows machine with an enabled Windows 
firewall wants to access a DataFinder server, you must add ..\Windows\System32\
lkads.exe to the Windows firewall exception list. 
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A
Technical Support and 
Professional Services

Visit the Support section of the National Instruments Web site at ni.com 
for technical support and professional services. Online technical support 
resources at ni.com/support include the following:

• Self-Help Resources—For answers and solutions, visit the 
award-winning National Instruments Web site for software drivers and 
updates, a searchable KnowledgeBase, product manuals, step-by-step 
troubleshooting wizards, thousands of example programs, tutorials, 
application notes, instrument drivers, and so on.

• Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application Engineers 
worldwide in the NI Discussion Forums at ni.com/forums. National 
Instruments Application Engineers make sure every question receives 
an answer.

For information about other technical support options in your area, visit 
ni.com/services or contact your local office at ni.com/contact. 
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