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About This Manual

You can use this manual to familiarize yourself with the DataFinder Server 
Edition features and how to use them.

The first chapter shows you how to create a DataFinder server in a few easy 
steps and how to connect clients to this DataFinder server. The exercises do 
not take long, and they make it easier for you to get started with the 
DataFinder Server Edition.

The second chapter describes the DataFinder Manager and shows you how 
to configure DataFinder servers. 

Writing Conventions
The following conventions are used in this manual:

<> Angles brackets indicate a key you press to perform a function, for 
example, <Ctrl> for the control key.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. If you read Settings»Options»DataPlugins, you must 
open the Settings menu, select the Options item, and then select the 
DataPlugins item.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Parameters are also bolded.

italic Italic text denotes a cross reference.

monospace Text in this font denotes text or characters that you enter from the keyboard, 
such as dialog box entries and filenames. This font is also used for the 
names of drives, paths, folders, filenames, and filename extensions.

monospace bold Bold text in this font denotes the settings and messages that the computer 
displays on the screen. 
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Related Documentation
For more detailed information on the DataFinder Server Edition, refer to 
the following documentation:

• DataFinder Server Edition help files, which you open by selecting 
Help»Contents, or by pressing <F1>.

• DIAdem: Finding, Analyzing, and Documenting Data

Chapter 2, Finding and Managing Data, describes how to make search 
entries in DIAdem to find data. DIAdem can access DataFinder servers 
as a client.
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1
Creating and Connecting 
DataFinder Servers

A DataFinder server is a search engine that you install on a server. The 
DataFinder server browses computers in a network for files that contain 
technical data. The DataFinder server indexes data files to provide clients 
with the data properties. The DataFinder server indexes the file types of the 
DataPlugins that are registered in the DataFinder Manager.

You can define several DataFinder servers in the DataFinder Manager to 
provide different data for different work groups. Clients, such as DIAdem, 
communicate with the DataFinder servers to browse and to load the data 
that has been found and indexed. 

Note The license specifies how many DataFinder servers you can create and how many 
users can access the DataFinder server simultaneously. Refer to the section on the 
NI License Manager in Chapter 2, Configuring DataFinder Servers, for more information 
about licensing.

Creating DataFinder Servers
When you start the DataFinder Server Edition the DataFinder Manager 
appears. In the DataFinder Manager you create and configure DataFinder 
servers and test the functionality of the individual DataFinder servers. 
Complete the following steps to create a DataFinder server:

1. To start the DataFinder Server Edition, select Start»All Programs»
National Instruments»DataFinder Server Edition 1.0»DataFinder 
Manager. 

When you install the DataFinder Manager, it does not contain any 
DataFinder servers. Therefore, the dialog box where you define 
DataFinder servers opens automatically.

2. Enter DFServer_TestRig as the DataFinder name. 

3. Click Add search area to specify a search area. Search areas are the 
folders of the file system in which the DataFinder server searches for 
data files. 



Chapter 1 Creating and Connecting DataFinder Servers

NI DataFinder Server Edition 1-2 ni.com

4. Enter My_Data as the alias name for the search area. 

5. Click Choose a folder next to the path entry. 

a. Select the folder that you want the DataFinder server to browse, 
including the subfolders. 

b. Click OK to close the dialog box.

6. Click Share folder to specify that the files in the selected folder are 
accessible in the network. 

The DataFinder Manager opens the Windows system dialog box, 
where you share folders with other users in the network. You must 
share the folders of the search area so that clients can load the files 
found.

If you do not share the folders, clients can display the descriptive 
information of the data files, but cannot actually load the data.

7. Click OK to close the Windows system dialog box for sharing. The 
DataFinder Manager displays the path of the shared folder as shown in 
the following figure.

Figure 1-1.  Defining a Search Area

8. Click OK to close the dialog box. 

The definition dialog box of the new DataFinder displays the My_Data 
search area you created as shown in the following figure.
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Figure 1-2.  Defining a DataFinder Server

You can define other search areas to extend the index of the DataFinder 
server. Click Exclude subfolder to exclude subfolders in a search area 
from the search.

9. Select the Create shortcut on the desktop checkbox to create an icon 
for the DataFinder server DFServer_TestRig on the desktop. 

You can then double-click the icon to start the DataFinder server 
DFServer_TestRig without opening the DataFinder Manager. 

The Enable autostart checkbox is selected by default, which means 
that the DataFinder server starts when this definition dialog box closes, 
and that the DataFinder server starts automatically when Windows 
starts.

10. Click OK to conclude the definition of the DataFinder server. 

The DataFinder server immediately starts to browse the search areas 
for data files and to index the files found. 

The DataFinder Manager now contains the created DataFinder server 
DFServer_TestRig as shown in the following figure. 
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Figure 1-3.  DataFinder Manager with Enabled DataFinder Server

If you want to create another DataFinder server, click New on the toolbar. 
You only can create more DataFinder servers if your license allows 
multiple DataFinder servers.

Exporting a Client Configuration
For clients to execute queries on the server and to load data, you must 
connect the clients to a DataFinder server. You can export the required 
settings in the DataFinder Manager and save the settings to a file. Complete 
the following steps to create a client configuration.

1. Select the DataFinder server DFServer_TestRig in the DataFinder 
Manager. 

2. Click Export on the toolbar.

3. Enter DFServer_TestRig as the name of the export file.

4. Select the Include DataPlugins in client configuration checkbox to 
save all the DataPlugins to the export file. 

When you export the DataPlugins, you provide the client with all 
the DataPlugins for loading the files that the DataFinder server 
DFServer_TestRig finds and indexes.
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Figure 1-4.  Exporting a Client Configuration

Click OK to open the Save as dialog box.

5. Click Save to save the client configuration. The DataFinder Manager 
saves the connection parameters in a file that has the extension urf. 

Connecting Clients to DataFinder Servers
When you save the client configuration, a client such as DIAdem can read 
the settings. DIAdem uses the settings from the client configuration to 
establish the connection to the DataFinder server DFServer_TestRig. 

1. Copy the DFServer_TestRig.urf file to the client computer.

2. Double-click the DFServer_TestRig.urf file to register the settings 
and the DataPlugins on the client computer.

If you use the URF file to import DataPlugins that are already 
registered, you can specify whether you want the client to use the 
imported DataPlugins in the future. 

A message indicates that the client configuration and the new 
DataPlugins are registered.

3. Open DIAdem.

4. Select DIAdem NAVIGATOR.

5. Select Settings»Remote DataFinder. 

The following figure shows the dialog box with all the remote 
DataFinders that are registered in DIAdem.
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Figure 1-5.  Remote DataFinders Registered in DIAdem

DIAdem can use any DataFinder that is connected to the DIAdem 
computer in a network, as a remote DataFinder. 

Note To load a URF file, you also can click Import remote DataFinder in the DIAdem 
remote DataFinder settings. After you import the file, click Properties to open the client 
configuration settings. Click Test to check the connection to the DataFinder server. 

6. Click Open to open the DataFinder server in DIAdem NAVIGATOR.

The file browser in the following figure shows a tree view of the search 
areas of the DataFinder server. In the files you can navigate to channel 
level.

Figure 1-6.  Navigating in Search Areas of the DataFinder Server
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If you want to open the search areas of the DataFinder server 
DFServer_TestRig by default in the file browser when you start 
DIAdem, select Settings»Options»NAVIGATOR. Select the checkbox 
Start behavior»External data»DataFinder, click Browse, and select the 
DataFinder server DFServer_TestRig. Save the modified program 
settings when you close DIAdem.

When you access the search areas of various DataFinder servers in 
DIAdem, you can assign DataFinder servers to the DataFinder function 
bar. To do this, select Default setting from the shortcut menu of a button 
on the function bar.



© National Instruments Ireland Resources Limited 2-1 NI DataFinder Server Edition

2
Configuring DataFinder Servers

To edit or to delete a DataFinder server, or to create another DataFinder 
server, open the DataFinder Manager. In the DataFinder Manager you can 
export the settings for connecting a client to a DataFinder server and you 
can open the search areas of a DataFinder server in a browser.

DataFinder Manager
The DataFinder Manager provides an overview of the most important 
settings of all the defined DataFinder servers. The status shows whether a 
DataFinder server is activated. The remote access shows whether clients 
can access the search areas. The index frequency and the indexer start time 
show when the regular indexing of the data files starts. If you disable 
regular indexing, the entry Never appears here.

Figure 2-1.  The DataFinder Manager Displays all DataFinder Servers

The properties window at the bottom of the DataFinder Manager shows 
other properties of the DataFinder server that is selected in the overview. If 
you select Enable Autostart, the DataFinder server starts automatically 
when the computer starts. If you enable Observe file system, the 
DataFinder server automatically indexes each new file and each modified 
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file. Index status shows the time of the last indexing, and Index 
location shows where the DataFinder server stores its index. Select 
Settings»Configure to modify the displayed settings.

If you want to interrupt data file indexing, select a DataFinder server in 
the DataFinder Manager and click Pause indexing on the toolbar. If you 
want to close the selected DataFinder server, click Stop. If you close a 
DataFinder server, you not only interrupt indexing, you also interrupt the 
connection to the clients. Click Start to reactivate a DataFinder server. 
Clients can now browse in the indexed files again. 

You do not need to open the DataFinder Manager to start a DataFinder 
server. To start a DataFinder server automatically every time you start the 
operating system, select Settings»Configure»General»Enable autostart. 
This setting guarantees that even if the server computer has been down, the 
DataFinder server is available when you restart the computer and log in the 
user. 

If you want to manually start a DataFinder server, double-click the icon on 
the computer desktop. To create the desktop shortcut in the definition 
dialog box of a DataFinder server, you must select the Create shortcut on 
the desktop checkbox.

You can open the shortcut menu of each activated DataFinder server from 
the information area on the Windows task bar. Select About to see when 
the last complete indexing was executed and how many files, groups, and 
channels are indexed. You also can pause indexing, and restart or stop the 
DataFinder server from the shortcut menu. 

Configuring DataFinder Servers
To configure a DataFinder server, double-click a DataFinder server in the 
DataFinder Manager. In the configuration of the DataFinder server you 
specify the search areas and the indexing of the data files. You also can see 
which file types the DataFinder server includes in the search.

Defining Search Areas
On the Search areas tab you select other folders that the DataFinder server 
browses. You can edit and delete search areas and specify the order in 
which the DataFinder indexes the search areas and displays them in the file 
browser. You can exclude subfolders of a search area from the search. A 
plus sign in front of a search area indicates that the search area contains 
subfolders that the DataFinder server excludes from the search. 
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You must share each search area to enable clients to load files from the 
search areas. You define the share when you create a search area or edit an 
existing search area. Click Share folder to open the Windows system 
dialog box with the Sharing tab. In the Windows sharing settings you 
specify which users, and how many simultaneous users, have read and write 
access. You can enter individual users, and you can enter user groups that 
are defined in a network, for example, to provide access rights for an entire 
group. Refer to the MS Windows program help for more information about 
sharing folders.

The search areas of the DataFinder server must be defined with path names 
that are unique within the network. If you click Edit search area, the 
Client path entry is the path for client access to files, for example, 
\\Testrig4a\NewCar\DATA.

To block the remote access to all the search areas of a DataFinder server, 
clear the Allow remote access to this computer checkbox on the General 
tab. Clients can no longer access the DataFinder server and all the share 
settings are hidden in the configuration dialog boxes.

Reading File Types with DataPlugins 
DataFinder servers read or ignore files according to the filename extension. 
The File extensions tab has two lists that contain all the filename 
extensions that each DataFinder server recognizes. 

One of the lists shows all the indexable file types, which correspond to the 
TDM data model. In indexable files the DataFinder server can search for 
properties of data sets, groups, and channels. Clients can navigate to 
channel level in indexed files. Click a filename extension to see which 
DataPlugins the DataFinder server uses to index these files.

The other list shows all the non-indexable file types, which do not 
correspond to the TDM data model. In non-indexable files, the DataFinder 
server cannot search for properties of groups or channels. The DataFinder 
server only can search for properties that the file system provides, such as 
the filename and the creation date. 

Which file types the DataFinder server can index depends on the registered 
DataPlugins. A DataPlugin is a VBScript that analyzes files of a specific 
file type and provides this information to the DataFinder server. The 
DataPlugins tab shows which filename extensions are assigned to which 
DataPlugin. 
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To add DataPlugins, select Settings»Options»DataPlugins. In this dialog 
box you can define, import, export, and delete DataPlugins. When you 
define a new DataPlugin, you can edit the associated VBScript. If you 
change the properties of a DataPlugin, these changes apply for all the 
DataFinder servers. 

The National Instruments Internet site ni.com/dataplugins offers 
DataPlugins for various data formats, written and tested by programmers 
and by users. The site also provides assistance for programming 
DataPlugins, including a description of the objects, properties, and 
methods, and many examples. 

Planning Indexing
During indexing, the DataFinder server reads properties from data files and 
saves this information. When clients search for data files, the DataFinder 
server browses the indexing data for the entered properties.

Click the Indexer tab to specify when and how often the DataFinder server 
indexes the search areas. To immediately start indexing a DataFinder server 
that is activated in the DataFinder Manager, click the Start now button. 
Depending on the amount of data, it can take quite a while to index a search 
area for the first time. 

Select the checkbox Update index immediately when files are created or 
modified to ensure that clients always search current data. The Idle time 
specifies the time that the DataFinder server waits after the last keyboard 
entry or mouse movement, before the indexing process continues. You limit 
the time that the DataFinder server spends indexing a specific file, for 
example, to prevent the DataFinder server from continually trying to index 
a file that cannot be read. 

You can use the Scheduler to start indexing regularly. For example, the 
DataFinder server can browse the search areas at 12 pm daily, when no 
changes to the search areas and no client queries are expected. 

If you shut down the computer during a scheduled indexing process or 
while an indexing process is running, the DataFinder server starts indexing 
at the next scheduled time, after you restart the computer. 

The Index location displays the folder where the DataFinder server saves 
the index. Generally, you should not change the index path that is created 
during installation. However, if the drive with the index has less than 
20 MB free memory space, the DataFinder server stops indexing and 
displays an error message. You must then either delete files to make more 
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space available, or change the index path. If you change the index path, the 
DataFinder server reindexes the search areas. To avoid changing the index 
path during the working process, install the DataFinder Server Edition on a 
server that has sufficient hard disk memory space. 

Optimizing Custom Properties
You can optimize the search for custom properties for a DataFinder server 
so that the DataFinder server finds these custom properties faster. Custom 
properties are user-defined properties that you can create for data sets, 
groups, and channels of the data that is saved in the TDM data model. 
Custom properties give data additional characteristics that are not included 
in the standard data model. 

To speed up the search for custom properties, select a DataFinder server 
in the DataFinder Manager and select Settings»Optimize custom 
properties. On the tabs File, Group, and Channel you select custom 
properties that are to be optimized. Do not optimize more than 100 custom 
properties per file, group, or channel. When you close the dialog box, the 
DataFinder server optimizes the selected custom properties. Optimizing 
custom properties can take quite a long time. You cannot interrupt the 
optimizing process and during this process you cannot work with the 
DataFinder server.

In a client, such as DIAdem, the custom properties are shown in the 
properties list of the Advanced search. If you select an optimized custom 
property, you can click the button shown on the left for a list of suggested 
values that you can apply in your search. The button is at the end of the 
search input area. Which operators you can use for a search entry depends 
on the data type of the property to be searched for. The DataFinder server 
always optimizes custom properties for the data type that the DataFinder 
server used most frequently to index the custom property. 

Note You only can search for date type custom properties if these custom properties have 
been optimized.
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Exporting a Client Configuration
To export the settings for a client connection to a DataFinder server that you 
have selected in the DataFinder Manager, click Export on the toolbar. You 
also can export the DataPlugins of the DataFinder server together with the 
client configuration, to provide the client with all the DataPlugins for 
loading the indexed files.

In the export dialog box you also can set connection parameters. You can 
limit the amount of time that the clients may take to connect to the 
DataFinder server, and the maximum time that the clients wait for the 
results of a search. When the DataFinder Manager exports the client 
configuration, it saves the connection parameters and the DataPlugins in a 
file that has the extension urf.

To provide the connection settings for a client such as DIAdem, you copy 
the URF file to the DIAdem computer. Double-click the URF file to 
automatically register the settings and the DataPlugins on the client 
computer. If you use the URF file to import DataPlugins that are already 
registered, you can specify whether you want the client to use the imported 
DataPlugins in the future. 

Then start DIAdem and open DIAdem NAVIGATOR. Select File»Open 
DataFinder. Select the new remote DataFinder that you have registered 
and click OK. DIAdem opens the search areas of the remote DataFinder in 
the file browser. You can navigate in the search areas of the remote 
DataFinder and load data.

To modify the connection parameters in DIAdem, select Settings»Remote 
DataFinder and click Properties. Click Test to check the connection to 
the DataFinder server.

Browsing in Search Areas
The DataFinder Manager provides a tree view of the search areas of the 
DataFinder server. If the DataPlugin allows, you can navigate to channel 
level in the folders of the search areas and in the indexed files. 

Select a DataFinder server in the DataFinder Manager and click Open in 
browser on the toolbar. The DataFinder Manager opens a tab with a tree 
view of the search areas of the selected DataFinder server. 
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The properties window at the bottom displays the properties of the file, the 
channel group, or the channel, that is selected in the tree view. Click one of 
the files to view the file properties. In the properties window, the 
DataFinder Manager displays file properties such as the filename, path, 
creation date, name, and author. Drag the top edge of the properties window 
up to view the entire properties list.

Figure 2-2.  Browsing in the Search Areas of a DataFinder Server

In the tree view you can open the shortcut menu to define other folders as 
search areas, and to edit and to delete existing search areas. You also can 
exclude subfolders from indexing.

To display the selected DataFinder server as the client sees the DataFinder 
server, select View»Client view. In the client view, the DataFinder 
Manager displays all the search areas and hides the path MyComputer.

NI License Manager
The National Instruments License Manager manages your user licenses for 
NI software products. To work with the DataFinder Server Edition after 
your Evaluation version expires, select Start»All Programs»National 
Instruments»NI License Manager and enter your serial number. 

The NI License Manager limits the number of active clients that can access 
the DataFinder server simultaneously. To increase the number of clients, 
you must purchase a license that allows more connections. Then select 
Help»Activate license in the DataFinder Manager, click Next, and enter 
the new serial number.
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The NI License Manager limits the number of DataFinder servers that you 
can create in the DataFinder Manager. If you need more than one 
DataFinder server, you must purchase a license that allows multiple 
DataFinder servers.
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3
Configuring Firewalls and 
Network Address Translating 
Routers for DataFinder Servers

DataFinder servers use the UDP port 2343 and a range of UDP ports 
beginning with port 6000. The number of UDP ports above 6000 that the 
DataFinder servers use depends on the number of servers running on the 
computer. DataFinder clients, such as DIAdem, use a range of UDP ports 
beginning with port 5000. The number of UDP ports above 5000 that the 
DataFinder clients use depends on the number of clients running on the 
computer.

Firewalls 
Complete the following steps to allow DIAdem or other DataFinder clients 
outside a firewall to connect to a DataFinder server inside a firewall. The 
exact steps for configuring the firewall depend on which specific firewall 
you use. Refer to the documentation on the firewall for specific instructions 
about opening UDP ports.

1. Open UDP port 2343 for incoming and outgoing packets. 

2. Open the UDP port range 6000 to 6010 for incoming packets. 

You also can allow clients inside a firewall to connect to a DataFinder 
server outside the firewall. Some firewalls automatically transmit incoming 
packets without any configuration. If the firewall does not open the ports 
automatically, open the UDP port range from 5000 to 5010 for incoming 
packets.
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Network Address Translating Routers
Complete the following steps to allow clients outside a NAT router to 
connect to a DataFinder server inside the router. The exact steps for 
configuring the router depend on the specific router you use. Refer to the 
documentation for the router for specific instructions about forwarding 
ports. Only one computer inside the router can function as a server.

1. Forward UDP port 2343 to the computer with the DataFinder server. 

2. Forward the UDP port range 6000 to 6010 to the computer with the 
DataFinder server. 

You also can allow clients inside a NAT router to connect to a server outside 
the router. Some routers automatically forward UDP ports without any 
configuration. If the router does not forward the UDP ports automatically, 
forward the UDP port range from 5000 to 5010 to the computer with the 
client (DIAdem).

Note If you installed the DataFinder Server Edition on a Windows machine with an 
enabled Windows firewall, you must add the programs ..\National Instruments\
DataFinder Server Edition 1.0\DataFinderSE.exe and ..\Windows\
System32\lkads.exe to the Windows firewall exception list. 

Note If a client (DIAdem) installed on a Windows machine with an enabled 
Windows firewall wants to access a DataFinder server, you must add the program 
..\Windows\System32\lkads.exe to the Windows firewall exception list. 
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A
Technical Support and 
Professional Services

Visit the Support section of the National Instruments Web site at ni.com 
for technical support and professional services. Online technical support 
resources at ni.com/support include the following:

• Self-Help Resources—For answers and solutions, visit the 
award-winning National Instruments Web site for software drivers and 
updates, a searchable KnowledgeBase, product manuals, step-by-step 
troubleshooting wizards, thousands of example programs, tutorials, 
application notes, instrument drivers, and so on.

• Free Technical Support—All registered users receive free Basic 
Service, which includes access to hundreds of Application Engineers 
worldwide in the NI Discussion Forums at ni.com/forums. National 
Instruments Application Engineers make sure every question receives 
an answer.

For information about other technical support options in your area, visit 
ni.com/services or contact your local office at ni.com/contact. 
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