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必ずお読みください

保証
NIのソフトウェア製品が記録されている媒体は、素材および製造技術上の欠陥によるプログラミング上の問題に対して、受領書
などの書面によって示される出荷日から90日間保証致します。NIは、保証期間中にこのような欠陥の通知を受け取った場合、
弊社の裁量により、プログラミングの指示どおりに実行できないソフトウェア媒体を修理、交換致します。NIは、ソフトウェア
の操作が中断されないこと、および欠陥のないことを保証致しません。

お客様は、保証の対象となる製品をNIに返却する前に、返品確認 (RMA: Return Material Authorization)番号をNIから取得
し、パッケージ外に明記する必要があります。NIは、保証が及んでいる部品をお客様に返却する輸送費を負担いたします。

本書の内容については万全を期しており、技術的内容に関するチェックも入念に行っております。技術的な誤りまたは誤植が
あった場合、NIは、本書を所有するお客様への事前の通告なく、本書の次の版を改訂する権利を有します。誤りと思われる個所
がありましたら、NIへご連絡ください。NIは、本書およびその内容により、またはそれに関連して発生した損害に対して、一
切責任を負いません。

NIは、ここに記載された以外、明示または黙示の保証は致しません。特に、商品性または特定用途への適合性に関する保証は致
しません。NI側の過失または不注意により発生した損害に対するお客様の賠償請求権は、お客様が製品に支払われた金額を上限
とします。NIは、データの消失、利益の損失、製品の使用による損失、付随的または間接的損害に対して、その損害が発生する
可能性を通知されていた場合でも、一切の責任を負いません。NIの限定保証は、訴訟方式、契約上の責任または不法行為に対す
る責任を問わず、過失責任を含め、適用されます。NIに対する訴訟は、訴訟原因の発生から1年以内に提起する必要があります。
NIは、NIの合理的に管理可能な範囲を超えた原因により発生した履行遅延に関しては一切の責任を負いません。所有者がインス
トール、操作、保守に関するNIの指示書に従わなかったため、所有者による製品の改造、乱用、誤用、または不注意な行動、さ
らに停電、サージ、火災、洪水、事故、第三者の行為、その他の合理的に管理可能な範囲を超えた事象により発生した損害、欠
陥、動作不良またはサービスの問題については、本書に定める保証の対象となりません。

著作権
著作権法に基づき、National Instruments Corporation（米国ナショナルインスツルメンツ社）の書面による事前の許可なく、
本書のすべてまたは一部を写真複写、記録、情報検索システムへの保存、および翻訳を含め、電子的または機械的ないかなる形
式によっても複製または転載することを禁止します。

National Instrumentsは他者の知的財産を尊重しており、お客様も同様の方針に従われますようお願いいたします。NIソフト
ウェアは著作権法その他知的財産権に関する法律により保護されています。NIソフトウェアを用いて他者に帰属するソフトウェ
アその他のマテリアルを複製することは、適用あるライセンスの条件その他の法的規制に従ってそのマテリアルを複製できる場
合に限り可能であるものとします。

商標
National Instruments、NI、ni.com、および LabVIEWはNational Instruments Corporation（米国ナショナルインスツルメ
ンツ社）の商標です。National Instrumentsの商標の詳細については、ni.com/legalの「Term of Use」セクションを参照し
てください。

Tektronix®および Tekは Tektronix, Inc.の商標です。その他の製品名および企業名は、それぞれの企業の商標または商号です。 

ナショナルインスツルメンツ・アライアンスパートナー・プログラムのメンバーはナショナルインスツルメンツより独立してい
る事業体であり、ナショナルインスツルメンツと何ら代理店、パートナーシップまたはジョイント・ベンチャーの関係にありま
せん。

特許
National Instrumentsの製品を保護する特許については、ソフトウェアに含まれている特許情報（ヘルプ→特許情報）、CDに
含まれているpatents.txtファイル、またはni.com/patentsのうち、該当するリソースから参照してください。

National Instruments Corporation製品を使用する際の警告
(1) National Instruments Corporation（以下「NI」という）の製品は、外科移植またはそれに関連する使用に適した機器の備
わった製品として、または動作不良により人体に深刻な障害を及ぼすおそれのある生命維持装置の重要な機器として設計されて
おらず、その信頼性があるかどうかの試験も実行されていません。

(2) 上記を含むさまざまな用途において、不適切な要因によってソフトウェア製品の操作の信頼性が損なわれるおそれがありま
す。これには、電力供給の変動、コンピュータハードウェアの誤作動、コンピュータのオペレーティングシステムソフトウェア
の適合性、アプリケーション開発に使用したコンパイラや開発用ソフトウェアの適合性、インストール時の間違い、ソフトウェ
アとハードウェアの互換性の問題、電子監視・制御機器の誤作動または故障、システム（ハードウェアおよび /またはソフト
ウェア）の一時的な障害、予期せぬ使用または誤用、ユーザまたはアプリケーション設計者の側のミスなどがありますが、これ
に限定されません（以下、このような不適切な要因を総称して「システム故障」という）。システム故障が財産または人体に危
害を及ぼす可能性（身体の損傷および死亡の危険を含む）のある用途の場合は、システム故障の危険があるため、1つの形式の
システムにのみ依存すべきではありません。損害、損傷または死亡といった事態を避けるため、ユーザまたはアプリケーション



設計者は、適正で慎重なシステム故障防止策を取る必要があります。これには、システムのバックアップまたは停止が含まれ
ますが、これに限定されません。各エンドユーザのシステムはカスタマイズされ、NIのテスト用プラットフォームとは異なる
ため、そしてユーザまたはアプリケーション設計者が、NIの評価したことのない、または予期していない方法で、NI製品を他
の製品と組み合わせて使用する可能性があるため、NI製品をシステムまたはアプリケーションに統合する場合は、ユーザまた
はアプリケーション設計者が、NI製品の適合性を検証、確認する責任を負うものとします。これには、このようなシステムま
たはアプリケーションの適切な設計、プロセス、安全レベルが含まれますが、これに限定されません。



表記規則

このマニュアルで使用する表記規則は、以下の通りです。 

<> AO <3..0>のように、山括弧内の数字間にある省略符号は、ビットまたは
信号名に関連する値の範囲を示します。

[ ] [対応 ]のような場合の角括弧内は、オプション項目を示します。

→ 矢印（ →）は、ネストされたメニュー項目やダイアログボックスのオプ
ションをたどっていくと目的の操作を選択できることを意味します。 たと
えば、ファイル→ページ設定→オプションという順番の場合は、まずファ

イルメニューをプルダウンし、次にページ設定項目を選択して、最後にダ

イアログボックスからオプションを選択します。

このアイコンは、注意すべき重要な情報があることを示します。

太字 太字のテキストは、メニュー項目およびダイアログボックスオプションな

ど、ソフトウェアで選択またはクリックする必要のある項目を表します。 
また、パラメータ名も太字で示します。

斜体 斜体のテキストは変数、強調、または重要な概念の説明のほか、入力する

必要がある語または値のプレースホルダを示します。2重括弧は、相互参
照を示 します。

monospace このフォントのテキストは、キーボードから入力するテキストや文字、

コードの一部、プログラミング例、構文例を示します。 また、ディスクド
ライブ名、パス名、ディレクトリ名、プログラム名、サブプログラム名、

サブルーチン名、デバイス名、関数名、操作名、変数名、ファイル名と拡

張子にも使用します。
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1
NI SignalExpress Tektronix 
Editionの概要

ナショナルインスツルメンツでは、業界標準のコンピュータとプラット

フォームを使用した自動計測システムを構築するための革新的なソリュー

ションを科学者やエンジニアのために提供しています。 当社では、グラ
フィカルプログラミングが可能な LabVIEW、ANCI Cプログラミング対
応の LabWindowsTM/CVITM、Microsoft Visual Studioプログラミング
対応のMeasurement Studioなど、ロバストで業界最先端の自動計測シ
ステム用プログラミング環境を開発しています。 これらのプログラミング
ツールを弊社の計測ハードウェアや従来の計測器へのインタフェースとと

もに使用すれば、カスタム仕様の高機能な計測システムを構築することが

可能です。

NI SignalExpress Tektronix Edition は、プログラミングが不要な対話式
計測環境を提供しています。 この NI SignalExpress Tektronix Editionで
は、信号の集録、生成、解析、比較、インポート、保存を対話式に行うこ

とができます。 また、設計データと計測データの比較を 1 つのステップで
行えます。 NI SignalExpress Tektronix Editionを使用すれば、信号の集録
や解析が必要な際にプログラミングしなくても、Virtual 
Instrumentationの使いやすさと性能を活用できます。 また、LabVIEW 
で作成したカスタムプログラムのインポートや、NI SignalExpress 
Tektronix Edition プロジェクトを LabVIEWプログラムに変換すること
により、NI SignalExpress Tektronix Edition の機能拡張が可能です。

NI SignalExpress Tektronix Edition（設計ラボ用）
テクトロニクス社と弊社は、オシロスコープとコンピュータの業界一シー

ムレスな接続性のあるソリューションによって、ユーザの生産性向上に貢

献するためのパートナー提携を結びました。 NI SignalExpress Tektronix 
Edition は、計測 /集録、解析およびドキュメント用の対話式ソフトウェ
アです。 また、業界初の USB プラグアンドプレイ対応の自動構成および接
続機能が搭載されています。 この NI SignalExpress Tektronix Edition で
利用できる機能は、以下の通りです。

� 業界初の USBプラグアンドプレイ対応の接続機能による、テクトロ
ニクス製計測器への接続および構成機能

� プログラミングが必要ない直観的なドラッグアンドドロップユーザイ

ンタフェース
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� 計測の設定や波形、画面上の画像のキャプチャ機能、転送機能、保存

機能

� シミュレート結果の迅速なインポート機能と実際の計測値との比較機

能

� リアルタイムで実行する 200以上の計測、処理、解析およびレポー
ト生成機能

また、サポートされている計測器は、以下の通りです。

� Tektronix DPO4000/TDS3000 シリーズオシロスコープ

� Tektronix AFG3000 シリーズ任意 /関数発生器 

� 300以上の標準のスタンドアロン型計測器

NI SignalExpress Tektronix Editionのプロジェク
トを LabVIEWで機能拡張する

LabVIEW で作成した VI を NI SignalExpress Tektronix Edition にイン
ポートし、内蔵計測オプションを拡張すると、NI SignalExpress 
Tektronix Editionの機能を拡張することができます。 

LabVIEWの VIをインポートする方法については、7章
「NI SignalExpress Tektronix Editionのプロジェクトを LabVIEWで機能
拡張する」を参照してください。
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2
NI SignalExpress Tektronix 
Editionをお使いになる前に

本章では、NI SignalExpress Tektronix Editionのシステム要件およびイ
ンストール方法、バージョン情報、入手できるライセンスオプションにつ

いて説明します。

NI SignalExpress Tektronix Editionをインストー
ルする

本マニュアルの演習問題を行う前に、お使いのコンピュータに

NI SignalExpress Tektronix Editionをインストールしてください。 
NI SignalExpress Tektronix Editionは、セットアッププログラムにより、
10分程でインストールされます。

最小システム要件
NI SignalExpress Tektronix Editionを実行するためのシステム要件（推
奨）は、以下の通りです。

� 256 MBのメモリ（最小 128 MB）

� Pentium 4もしくは同等の性能のプロセッサ（最小 Pentium III/
Celeron 600 MHz）

インストールの手順
NI SignalExpress Tektronix EditionをWindows 2000/XP上にインス
トールするには、以下の手順に従ってください。

1. NI SignalExpress Tektronix Editionのインストーラを実行する前に、
すべてのプログラムを終了します。 バックグラウンドでウィルスス
キャンユーティリティなどのアプリケーションを実行していると、イ

ンストールの完了に時間がかかることがあります。

2. 管理者または管理者権限のあるユーザとしてログオンします。

3. NI SignalExpress Tektronix Edition CDを挿入し、画面上の指示に
従います。

メモ インストール中に別の場所を指定しない限り、ファイルは、NI SignalExpress 
Tektronix Edition インストールプログラムにより、
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<Program Files>¥National Instruments¥SignalExpressTekEdディレク

トリにコピーされます。

4. インストールが済んだら、一時的に無効にしたウィルス検出プログラ

ムを有効にし、ハードディスクにウィルスがないことを確認します。

本マニュアルで使用するサンプルプロジェクトは、<Program 
Files>¥National Instruments¥SignalExpressTekEd¥

Examples¥Tutorialにあります。 各演習問題の回答は、<Program 
Files>¥National Instruments¥SignalExpressTekEd¥

Examples¥Tutorial¥Solutionsにあります。

NI SignalExpress Tektronix Editionのバージョン
情報

NI SignalExpress Tektronix Editionには、プロフェッショナル版とベー
ス版があります。 それぞれで使用可能な機能については、以下の表を参照
してください。 

メモ NI SignalExpress Tektronix Edition ベース版に搭載されていない機能の有効期
間は、ソフトウェアの使用開始日を含め 30日間のみです。 30日経過後にこれら
の機能を使用した場合には、NI SignalExpress Tektronix Editionは 10分後に実
行が停止し、プロジェクトを保存することもできません。 Tektronix特有のス
テップのみをプロジェクトで使用する場合には、ソフトウェアは正常に動作し

ます。

表 2-1 NI SignalExpress Tektronix Editionのプロフェッショナル版とベース版の違いについて

プロフェッショナル版 ベース版

対応する計測器

DPO4000（デジタル・フォス
ファ・オシロスコープ）

✓ ✓

AFG3000 任意 /関数発生器 ✓ ✓

TDS3000B（デジタル・フォス
ファ・オシロスコープ）

✓ ✓

300以上の標準スタンドアロン型
計測器

✓ —
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視覚化 /文書化

カスタマイズ可能なグラフ生成 ✓ ✓

対話式カーソル ✓ ✓

信号のファイルへの保存 ✓ ✓

グラフのエクスポートと印刷 ✓ ✓

データのMicrosoft Excelや
Word、WordPadへのドラッグア
ンドドロップ

✓ ✓

自動データ収集 ✓ —

信号処理

ソフトウェアフィルタ ✓ —

スカラおよび波形演算処理 ✓ —

デジタルおよびアナログ変換 ✓ —

対話式の信号比較 ✓ —

PSPICE、Multisim などの SPICE
パッケージからのシミュレーショ
ンデータのロード

✓ —

時間 /周波数計測

振幅とレベル ✓ —

タイミングと遷移 ✓ —

パワースペクトル ✓ —

周波数応答 ✓ —

歪み測定 ✓ —

トーン抽出 ✓ —

表 2-1 NI SignalExpress Tektronix Editionのプロフェッショナル版とベース版の違いについて（続き）

プロフェッショナル版 ベース版
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NI SignalExpress Tektronix Editionのライセンス
オプション

このセクションでは、NI Signal Express Tektronix Editionのライセンス
ポリシーの情報を掲載します。 これは、弊社のソフトウェア使用許諾契約
に代わるものではありません。参考としてお使いください。

NI SignalExpress Tektronix Edition ベース版のライセンス
NI SignalExpress Tektronix Editionの非ライセンスバージョンでは、
表 2-1にある全機能の使用有効期間は 30日間です。 この期間を過ぎると、
NI SignalExpress Tektronix Editionは非ライセンスモードで実行します。 
有効なライセンスを 30日以内にアクティブ化しないと、作成したプロ
ジェクトにライセンスステップが含まれている場合には、以下のようにな

ります。

メモ Tektronix特有のステップは、ライセンスで保護されていません。 

� ライセンスで保護されているステップもしくは Tektronix特有ではな
いステップをドロップするたびに、ソフトウェアをアクティブ化する

よう促すプロンプトが表示される。 

� プロジェクトが保存できない。

� 10分経過するとプロジェクトが閉じる。

NI SignalExpress Tektronix Edition プロフェッショナル版の詳細と購入
については、弊社ウェブサイト、ni.com/tek（英語）をご覧ください。

NI Signal Express Tektronix Edition プロフェッショナル版のラ
イセンス

プロフェッショナル版のライセンスでは、表 2-1にある全機能を使用する
ことができます。 NI SignalExpress Tektronix Editionプロフェッショナル
版は、弊社の License Managerもしくは NI SignalExpress Tektronix 
Editionのインストーラを使用し、アクティブ化することができます。

計測オートメーション

スイープ機能 ✓ —

リミットテスト ✓ —

表 2-1 NI SignalExpress Tektronix Editionのプロフェッショナル版とベース版の違いについて（続き）

プロフェッショナル版 ベース版



© National Instruments Corporation 3-1 NI SignalExpress 入門 Tektronix 版

3
計測器の接続と制御

NI SignalExpress Tektronix Editionは、Tektronix DPO4000/TDS3000
シリーズオシロスコープおよび AFG3000シリーズ信号発生器に対応して
います。 計測器を PC に接続する方法と NI SignalExpress Tektronix 
Edition で行う信号生成および集録について説明します。

NI SignalExpress Tektronix Editionは、テクトロニクス社製のオシロス
コープや信号発生器の製品ラインにある多くの計測器をはじめ、300以上
の標準的なスタンドアロン型計測器をサポートしています。 この他の計測
器の制御については、8章「「詳細情報」」の「他の計測器を
NI SignalExpress Tektronix Editionで使用することに関する説明」をご
覧ください。

Tektronix DPO4000 シリーズオシロスコープ

USBで接続する
NI SignalExpress Tektronix Editionは、Windows XPの内蔵 USBプラグ
アンドプレイ機能を使用し、Tektronix DPO4000シリーズオシロスコー
プが PCに接続されるとそれを自動的に検出し、オシロスコープの制御と
オシロスコープからの信号集録を可能にします。 Tektronix DPO4000シ
リーズオシロスコープを接続するには、以下の手順に従ってください。

1. Tektronix DPO4000シリーズオシロスコープの電源を入れます。
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2. 図 3-1のように、USBデバイスケーブルを使用し、デバイス側のタイ
プ Bコネクタを Tektronix DPO4000シリーズオシロスコープの背面
にある USBデバイスポートに接続します。 ホスト側のタイプ Aコネ
クタをコンピュータに接続します。 

図 3-1 DPO4000の USB接続

接続が完了すると、Windows が新しいデバイスを検出し、
Tektronix DPO4000シリーズオシロスコープのドライバをインス
トールするよう促すプロンプトが表示されます。 

3. いくつか続くダイアログボックスの Nextボタンをクリックし、
Tektronix DPO4000 シリーズオシロスコープのドライバのインス
トールを完了します。

メモ 手順 3は、Tektronix DPO4000シリーズオシロスコープをコンピュータに初め
て接続するときのみ行う必要があります。 次回の接続からは、手順 4で説明する
ダイアログボックスが即座に表示されます。 
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4. 図 3-2のように、Windowsにより Tektronix DPO4000シリーズオ
シロスコープが検出されたことを示すダイアログボックスが表示さ

れ、次に行う操作のプロンプトが表示されます。 Control Instrument 
using NI SignalExpress - Tektronix Editionが選択されていない場
合にはクリックし、OKボタンをクリックします。 

 

図 3-2 USB Plug-and-Playダイアログボックス



第 3章 計測器の接続と制御

NI SignalExpress 入門 Tektronix 版 3-4 ni.com/jp

5. NI SignalExpress Tektronix Edition が起動して、図 3-3のような
Tektronix DPO4000 シリーズオシロスコープで集録しているデータ
が NI SignalExpress Tektronix Edition の画面に表示されます。

 

図 3-3 Tektronix DPO4000 シリーズオシロスコープでリアルタイムの集録を行っ
ている状態

イーサネットで接続する
このセクションをお読みになる前に、『DPO4000シリーズ　ユーザ・マ
ニュアル　デジタル・フォスファ・オシロスコープ』を参照し、イーサ

ネットを介した通信のための Tektronix DPO4000シリーズ オシロスコー
プの接続と構成を正しく行ってください。 オシロスコープの接続と構成が
完了したら、以下の手順に従って、NI SignalExpress Tektronix Edition
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内から Tektronix DPO4000シリーズオシロスコープにアクセスしてくだ
さい。

1. スタート→すべてのプログラム→ National Instruments→
SignalExpress Tektronix Edition→ NI SignalExpress Tektronix 
Editionを選択し、NI SignalExpress Tektronix Editionを起動しま
す。

2. 左側にある Add Stepボタンをクリックし、Tektronix→ Acquire 
Signals→ Tek DPO4000を選択します。 図 3-4のような Tektronix 
DPO4000 シリーズオシロスコープの Step Setupダイアログボック
スが表示されます。 

 

図 3-4 Tektronix DPO4000 シリーズオシロスコープイーサネット接続の構成画面



第 3章 計測器の接続と制御

NI SignalExpress 入門 Tektronix 版 3-6 ni.com/jp

3. 接続された Tektronix DPO4000シリーズオシロスコープの IPアドレ
スを VISA Resourceタブ上の Select instrument to useドロップ
ダウンボックスに入力します。

IPアドレスが分からない場合には、VISA Resourceタブの
Autodetectボタンをクリックし、Tektronix DPO4000シリーズオ
シロスコープのローカルサブネットをスキャンしてください。 
Tektronix DPO4000シリーズオシロスコープが検出されると、計測
器アドレスが表示され、Tektronix DPO4000シリーズオシロスコー
プが接続され、波形が 1つ集録されます。

メモ 接続している Tektronix DPO4000シリーズオシロスコープがローカルサブネッ
ト上にない場合には、計測器アドレスを手動で入力してください。 Tektronix 
DPO4000シリーズオシロスコープに手動で接続する方法については、『NI 
Express Workbench Help』（英語）を参照してください。このドキュメント
は、Help→ Express Workbench Helpを選択し、検索タブをクリックし、
Tek DPO4000と入力すると表示されます。 

4. 左の Runボタンをクリックし、Tektronix DPO4000シリーズオシロ
スコープから信号を連続集録します。

Tektronix AFG3000 シリーズ任意 /関数発生器

USBで接続する
NI SignalExpress Tektronix Editionでは、内蔵 USBプラグアンドプレイ
接続機能を使用し、Tektronix AFG3000シリーズ任意 /関数発生器が PC
に接続されたことが自動的に検出され、信号の制御と生成を行えるように

なります。 Tektronix AFG3000シリーズ 任意 /関数発生器を USBで接続
するには、以下の手順に従ってください。

1. Tektronix AFG3000シリーズ任意 /関数発生器の電源を入れます。

2. USBデバイスケーブルを使用し、デバイス側のタイプ Bコネクタを
Tektronix AFG3000シリーズ任意 /関数発生器の背面にある USBデ
バイスポートに接続します。 ホスト側のタイプ Aコネクタをコン
ピュータに接続します。

接続が完了すると、Windows が新しいデバイスがコンピュータに接
続されたことを検出し、AFG3000のドライバをインストールするよ
う促すプロンプトが表示されます。 

3. 表示されたダイアログボックスの Nextボタンをクリックし、
Tektronix AFG3000シリーズ任意 /関数発生器のインストールを完
了します。
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メモ 手順 3は、Tektronix AFG3000シリーズ任意 /関数発生器をコンピュータに初
めて接続するときのみ行う必要があります。 次回の接続からは、手順 4で説明す
るダイアログボックスが即座に表示されます。 

4. 図 3-5のように、Windowsが Tektronix AFG3000 シリーズ任意 / 
関数発生器が検出したことを示すダイアログボックスが表示され、次

に行う操作のプロンプトが表示されます。 Control Instrument using 
NI SignalExpress - Tektronix Editionが選択されていない場合には
クリックし、OKボタンをクリックします。 

 

図 3-5 USB Plug-and-Playダイアログボックス
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5. 図 3-6のような Tektronix AFG3000 シリーズ任意 / 関数発生器の構
成画面が表示されます。 

 

図 3-6 NI SignalExpress Tektronix Editionの Tektronix AFG3000シリーズ任意 / 
関数発生器構成画面

イーサネットで接続する
このセクションをお読みになる前に、『AFG3000 Series Quick Start User 
Manual』（英語）を参照し、イーサネットを介した通信のための
Tektronix AFG3000シリーズ任意 /関数発生器の接続と構成を正しく
行ってください。 任意 /関数発生器の接続と構成が完了したら、以下の手
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順に従って、NI SignalExpress Tektronix Edition内から Tektronix 
AFG3000シリーズ任意 /関数発生器にアクセスしてください。

1. スタート→すべてのプログラム→ National Instruments→
SignalExpress Tektronix Edition→ NI SignalExpress Tektronix 
Editionを選択し、NI SignalExpress Tektronix Editionを起動しま
す。

2. 左の Add Stepボタンをクリックし、Tektronix→Generate 
Signals→ Tek AFG3000を選択します。 図 3-7のような Tektronix 
AFG3000シリーズ任意 /関数発生器の Step Setupダイアログボッ
クスが表示されます。 

 

図 3-7 Tektronix AFG3000 シリーズ任意 / 関数発生器イーサネット接続の構成画面



第 3章 計測器の接続と制御

NI SignalExpress 入門 Tektronix 版 3-10 ni.com/jp

3. VISA Resourceタブの Autodetectボタンをクリックし、接続され
ている Tektronix AFG3000シリーズ任意 /関数発生器のローカルサ
ブネットをスキャンします。 Tektronix AFG3000シリーズ任意 /関数
発生器がローカルサブネット上に検出されると、計測器アドレスが表

示され、NI SignalExpress Tektronix Editionは Tektronix AFG3000
シリーズ任意 /関数発生器に接続されます。

メモ 接続している Tektronix AFG3000シリーズ任意 /関数発生器がローカルサブ
ネット上にない場合には、計測器アドレスを手動で入力してください。 
Tektronix AFG3000シリーズ任意 /関数発生器に手動で接続する方法について
は、『NI Express Workbench Help』を参照してください。このドキュメント
は、Help→ Express Workbench Helpを選択し、検索タブをクリックし、
Tek AFG3000と入力すると表示されます。 

4. 左の Run ボタンをクリックし、Tektronix AFG3000シリーズ /関数
発生器を使用して信号生成を開始します。

GPIBで接続する
GPIBケーブルで Tektronix AFG3000シリーズ任意 /関数発生器の接続
と制御を行うには、以下の手順に従ってください。

1. GPIBケーブルを使用し、Tektronix AFG3000シリーズ任意 /関数発
生器をコンピュータに接続します。

2. スタート→すべてのプログラム→ National Instruments→
SignalExpress Tektronix Edition→ NI SignalExpress Tektronix 
Editionを選択し、NI SignalExpress Tektronix Editionを起動しま
す。

3. 左の Add Stepボタンをクリックし、Tektronix→Generate 
Signals→ Tek AFG3000を選択します。 図 3-8のような Tektronix 
AFG3000シリーズ任意 /関数発生器の Step Setupダイアログボッ
クスが表示されます。 
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図 3-8 Tektronix TDS3000 シリーズオシロスコープイーサネット接続の構成画面

4. VISA Resourceタブの Autodetectボタンをクリックし、Tektronix 
AFG3000シリーズ任意 /関数発生器の検出と接続を行います。 

5. 左の Run ボタンをクリックし、Tektronix AFG3000シリーズ /関数
発生器を使用して信号生成を開始します。

Tektronix TDS3000 シリーズオシロスコープ

イーサネットで接続する 
このセクションをお読みになる前に、『TDS3000 シリーズ ユーザ・マニュ
アル』を参照し、イーサネットを介した通信のための Tektronix TDS3000
シリーズ オシロスコープの接続と構成を正しく行ってください。 オシロス
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コープの接続と構成が完了したら、以下の手順に従って、

NI SignalExpress Tektronix Edition内から Tektronix TDS3000シリーズ
オシロスコープにアクセスしてください。

1. スタート→すべてのプログラム→ National Instruments→
SignalExpress Tektronix Edition→ NI SignalExpress Tektronix 
Editionを選択し、NI SignalExpress Tektronix Editionを起動しま
す。

2. 左の Add Stepボタンをクリックし、Tektronix→ Acquire 
Signals→ Tek TDS3000を選択します。 図 3-9のような Tektronix 
TDS3000シリーズオシロスコープの Step Setup ダイアログボック
スが表示されます。 

 

図 3-9 Tektronix AFG3000 シリーズ任意 / 関数発生器GPIB接続の構成画面
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3. 接続された Tektronix TDS3000シリーズオシロスコープの IPアドレ
スを VISA Resourceタブ上の Select instrument to useドロップ
ダウンボックスに入力します。

IPアドレスがわからない場合には、Autodetectボタンをクリック
し、接続されている Tektronix TDS3000シリーズオシロスコープの
ローカルサブネットワークをスキャンします。 ローカルサブネットに
Tektronix TDS3000シリーズオシロスコープが検出されたら、計測器
のアドレスが表示され、Tektronix TDS3000シリーズオシロスコープ
が接続され、波形が 1つ集録されます。

メモ 接続している Tektronix TDS3000シリーズオシロスコープがローカルサブネッ
ト上にない場合には、計測器アドレスを手動で入力してください。 Tektronix 
TDS3000シリーズオシロスコープに手動で接続する方法については、
『NI Express Workbench Help』を参照してください。このドキュメントは、
Help→ Express Workbench Helpを選択し、検索タブをクリックし、
Tek TDS3000と入力すると表示されます。 

4. 左の Runボタンをクリックし、Tektronix TDS3000シリーズオシロ
スコープから続けて集録します。

GPIBで接続する
GPIBで Tektronix TDS3000シリーズオシロスコープの接続と制御を行う
には、以下の手順に従ってください。

1. GPIBケーブルを使用し、Tektronix TDS3000シリーズオシロスコー
プをコンピュータに接続します。

2. スタート→すべてのプログラム→ National Instruments→
SignalExpress Tektronix Edition→ NI SignalExpress Tektronix 
Editionを選択し、NI SignalExpress Tektronix Editionを起動しま
す。

3. 左の Add Stepボタンをクリックし、Tektronix→ Acquire 
Signals→ Tek TDS3000を選択します。 図 3-10のように、Tektronix 
TDS3000シリーズオシロスコープの Step Setupダイアログボック
スが表示されます。 
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図 3-10 Tektronix TDS3000シリーズオシロスコープGPIB接続の構成画面

4. VISA Resourceタブの Autodetectボタンをクリックし、Tektronix 
TDS3000シリーズオシロスコープの検出と接続を行います。 

5. 左の Runボタンをクリックし、Tektronix TDS3000シリーズオシロ
スコープで信号集録を開始します。
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4
プロジェクトの操作

NI SignalExpress Tektronix Editionでは、対話式計測環境でステップの
追加や構成を行い、計測処理を定義することができます。 ステップとは、
信号の集録や生成、解析、ロード、保存を行う機能のことで、それぞれ構

成することが可能です。 ステップにより、入力信号が処理され、出力信号
が生成されます。 Step Setupダイアログボックスに数値を指定すると、
ステップの操作を構成することができます。 構成されたステップのシーケ
ンスを保存したものが NI SignalExpress Tektronix Editionのプロジェク
トです。 本章では、NI SignalExpress Tektronix Editionの基本機能につい
て説明します。 既存のプロジェクトのロードや実行を行う方法、プロジェ
クトのステップを構成する方法を習得してください。

プロジェクトをロードする

NI SignalExpress Tektronix Editionにサンプルプロジェクトをロードす
るには、以下の手順に従ってください。

1. スタート→すべてのプログラム→ National Instruments→
SignalExpress Tektronix Edition→ NI SignalExpress Tektronix 
Editionを選択し、NI SignalExpress Tektronix Editionを起動しま
す。

2. File→Open Projectを選択し、<SignalExpressTekEd>¥
Examples¥Tutorialディレクトリを選択したら、First 

Project.wbpをダブルクリックします。 Workbenchプロジェクト
とは、NI SignalExpress Tektronix Editionを含む Express 
Workbenchのフレームワークのことです。

3. 図 4-1のようなダイアログボックスが表示されたら、
NI SignalExpress Tektronix Editionの様々なコンポーネントを確認
してください。
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図 4-1 First Project.wbp

左側のペーンがプロジェクトビューで、プロジェクトの操作順やス

テップを表示します。 右のペーンがデータビューで、プロジェクトが
生成および解析した信号がここに表示されます。

プロジェクトの実行と信号の表示

NI SignalExpress Tektronix Editionでは、 「Run」と「Run Once」の
2つの実行モードがあります。 Runボタンをクリックすると、プロジェク
トのステップがすべて連続して実行されます。Stopボタンを押すと実行
は停止されます。 プロジェクトの実行中は、Runボタンは押せなくなり、
Stopボタンは押せるようになります。 プロジェクトのステップが実行し
ている間にも、データビューは更新され続けます。 プロジェクトの実行中
に計測の構成を変更したり、計測結果を即座に表示したりすることができ

ます。 プロジェクトの実行中にステップの構成を変更した場合、

1 実行制御ボタン

2 ステップ
3 入力

4 出力
5 プロジェクトビュー

6 データビュー

3

2

4

1

6

5
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変更は NI SignalExpress Tektronix Editionに直ちに適用されます。 Run 
Onceボタンをクリックすると、プロジェクトのステップがすべて１回
実行されます。

 

図 4-2 NI SignalExpress Tektronix Edition のプロジェクトとデータビュー

ステップを構成する

ステップとは、信号の集録や生成、解析、ロード、保存を行う機能のこと

で、それぞれ構成することが可能です。 ステップにより、入力信号が処理
され、出力信号が生成されます。 ステップの動作は、そのステップの
Step Setupダイアログボックスの値を指定することで構成することがで
きます。 プロジェクトの実行中でも、ステップの構成を変更して変更が適
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用された結果を表示したり、必要な計測結果が得られるまで計測を調整す

ることができます。

Distortionステップおよび Amplitude and Levelsステップを構成する
には、以下の手順に従ってください。

1. プロジェクトビューの Distortionステップをダブルクリックします。 
図 4-3のようなDistortionステップの Step Setupダイアログボック
スが表示されます。 Step Setupダイアログボックスが組み込まれて
いる場合には、ツールバーの左にある Dock ボタンをクリックし、
Step Setupダイアログボックスが別のウィンドウになるようにして
ください。

 

図 4-3 Distortionステップの Step Setupダイアログボックス
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Configuration タブ上のこの設定では、Distortionステップは時間
軸の信号を入力として受け取り、信号に対してパワースペクトルを計

算して周波数領域に変換し、この信号の全高調波歪み（THD）と基本
周波数を計算します。 Distortionステップにより、時間領域波形入力
信号のスペクトルと THD、基本周波数の 3種類の計測が 出力として
生成されます。

2. 詳細ヘルプが Step Setupダイアログボックスの右側に表示されてい
ない場合には、左の Show Helpボタンをクリックし、ステップに関
する参照情報を表示してください。 
詳細ヘルプの上方にはステップについての情報、そして下方には項目

について（項目の上にカーソルを移動させることで表示）の情報が表

示されます。

3. Configurationタブ上で、Export signals (THD)プルダウンメ
ニューから Fundamental Toneを選択します。 入力信号の全周波数
領域スペクトルが表示されていたステップに、入力信号の基本トーン

の周波数スペクトルのみが表示されます。 Step Setupダイアログ
ボックスの上半分に表示されている信号は、変更に基づいて更新され

ます。

4. Export signals (THD)プルダウンメニューから Harmonics Onlyを
選択します。 このステップは、入力信号から高調波信号のスペクトル
のみがエクスポートされるよう変更されます。 Distortionステップの
出力信号とデータビューのグラフは両方とも、変更に基づいてアップ

デートされます。

5. プロジェクトビューの Amplitude and Levelsステップをクリック
します。 Distortionステップの構成が表示されていた Step Setupダ
イアログボックスに、Amplitude and Levelsステップの構成が表示
されます。 

6. Input/Outputタブをクリックし、図 4-4で表すようにこのステップ
で選択できる入出力リストを表示します。
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図 4-4 Amplitude and Levelsステップの Step Setupダイアログボックス

7. Export +peak value、Export -peak value、Export peak-peak 
valueの各チェックボックスを有効にして Amplitude and Levels
ステップを構成し、追加した 3つの計測を返します。 追加された 3つ
の出力は、プロジェクトビューに表示されています。

8. Step Setupダイアログボックスの左側にあるCloseボタンをクリッ
クし、Amplitude and Levelsステップの Step Setupダイアログ
ボックスを閉じます。

9. プロジェクトビューの +peak、-peak、peak-peakの 3つの新し
い出力をデータビューにドラッグし、それぞれの計測結果を表示しま

す。
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10. 左の Stopボタンをクリックし、プロジェクトを停止します。

Stopボタンをクリックすると、すべてのステップが完了した後でプ
ロジェクトの実行は停止されます。 Abortボタンをクリックするとプ
ロジェクトは完全に緊急停止し、残りのステップは実行されません。

11. File→ Save Project Asを選択し、プロジェクトを My First 

Project.wbpという名前で <SignalExpressTekEd>¥Examples¥

Tutorialディレクトリに保存します。

12. File→ Close Project を選択し、プロジェクトを閉じます。

ステップの移動と削除

NI SignalExpress Tektronix Editionのプロジェクトのステップは、入力
データによって異なります。つまり、各ステップが利用できるのは、プロ

ジェクトビューにある以前のステップからエクスポートされたデータのみ

です。 ステップの Step Setupダイアログボックスの Input signalプルダ
ウンメニューをクリックすると、以前のステップからエクスポートされた

対応信号のみがメニューに表示されます。 ステップの出力が別のステップ
の入力になると、その 2 つのステップは互いに依存するようになり、順
次に実行されます。 最初のステップによって生成された出力信号は、2 つ
目のステップの入力として受信され、実行が開始されます。

プロジェクトビューでステップを上下にドラッグすることで、プロジェク

ト内でステップを移動することができます。 また、プロジェクトビューで
ステップを右クリックし、ショートカットメニューから Deleteを選択す
ることで、ステップを削除することができます。 ただし、ステップの移動
や削除を行った場合には、プロジェクトの信号のステータスが変更されま

す。 たとえば、出力信号を生成するステップを削除した場合に、削除され
た出力信号のいずれかが他のステップの入力になっているとプロジェクト

の動作は中断され、プロジェクトビューにエラーが表示されます。 ステッ
プをプロジェクトの下方に移動すると、ステップの出力信号は以前のス

テップの入力として使用できません。

また、プロジェクト内でステップの切り取り、コピー、貼り付けを行うに

は、<Ctrl-X>、<Ctrl-C>、<Ctrl-V>のそれぞれのキーを押すか、プロジェ
クトビューのステップを右クリックしてショートカットメニューから

Cut、Copy、Paste Beforeまたは Paste Afterを選択します。
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エラーと警告の処理

プロジェクトの実行中にエラーが発生した場合には、エラーが発生したス

テップの左側にあるエラー表示器がプロジェクトビューに表示されます。 
エラーが発生したステップをダブルクリックし、エラーの説明を Step 
Setupダイアログボックスの下全体に表示します。 エラーの説明の右にあ
る Detailsボタンをクリックすると、エラーの全説明が表示されます。 

エラーおよび警告はすべて、プロジェクトの実行中にイベントログに記録

されます。 イベントログを表示するには、View→ Event Logを選択し、
データビューの Event Logタブをクリックします。 エラーと警告につい
ての詳細は、『NI Express Workbench Help』を参照してください。この
ドキュメントは、Help→ Express Workbench Helpを選択し、Search
タブをクリックし、errorsと入力すると表示されます。
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5
信号を操作する

NI SignalExpress Tektronix Editionでは、信号の生成および解析を行い、
プログラミングを行わずに設計を評価することができます。 本章では、信
号をグラフにプロットする方法、信号をファイルからインポートする方

法、2つの信号を対話式に揃えて比較する方法、信号をファイルに保存す
る方法といった NI SignalExpress Tektronix Editionにおける信号の操作
方法について説明します。

信号をグラフ化する

サンプルプロジェクトの信号をプロットし、カーソルを使用して視覚的に

検査するには、以下の手順に従ってください。

1. File→Open Projectを選択し、<SignalExpressTekEd>¥

Examples¥Tutorialディレクトリを選択したら、Signals.wbpを

ダブルクリックします。 このプロジェクトでは、方形波を生成する
Create Signalステップと、ローパスバタワースフィルタでフィルタ
処理を行う Filterステップが構成されています。

2. Create Signalステップの step signal出力をデータビューにドラッ
グします。

3. Filterステップの filtered step出力をデータビューにドラッグしま
す。 
信号タイプが同じ信号は、同一のグラフにプロットすることができま

す。 ステップの信号とフィルタ処理済みのステップの信号は、両方と
も時間領域信号であるため、同じグラフに表示されます。 異なるタイ
プの信号をプロットする場合には、信号を同一のグラフにドラッグす

ると、新しいグラフが作成されます。

4. ツールバーの左側にある Add Displayボタンをクリックし、新しい
グラフを作成します。

5. Filterステップの filtered step出力を新しいグラフにドラッグしま
す。

6. 新しいグラフを右クリックし、ショートカットメニューから Cursors
を選択し、図 5-1にあるような対話式カーソルを 2つ表示します。



第 5章 信号を操作する

NI SignalExpress 入門 Tektronix 版 5-2 ni.com/jp

 

図 5-1 Signals.wbp

カーソルをドラッグするたびに、カーソルの x値と y値が更新され、
データビューの下方のカーソルの表に表示されます。

7. グラフを右クリックし、ショートカットメニューにある他の操作を表

示します。 

1 つのグラフに複数の信号があり、ある信号が他の信号の影になり
はっきり見えない場合には、信号の並び順を変更することができま

す。 プロジェクトを連続実行する際にデータを特定の実行反復から表
示したい場合には、データビューを右クリックし、ショートカットメ

ニューから Display Updateを選択し、 Always Updateを選択して
隣にあるチェックマークを外すことで、表示機能を一時停止すること

ができます。 また、表示や信号は、追加もしくは削除することもでき
ます。
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8. File→ Save Project Asを選択し、プロジェクトを
My Signals.wbpという名前で <SignalExpressTekEd>¥
Examples¥Tutorialディレクトリに保存します。 

信号をファイルからインポートする 
信号は、ASCII、コンマ区切りもしくはタブ区切りのファイル、
LabVIEW 計測データファイル（.lvm）などの標準的なファイル形式から

インポートすることができます。 また、SPICE シミュレータなどの EDA
ツールのシミュレーション結果からも信号をインポートすることができま

す。

信号をファイルからインポートするには、以下の手順に従ってください。

1. プロジェクトビューを右クリックし、ショートカットメニューから

Analog→ Load/Save Signals→ Load from ASCIIを選択します。 
2. 左の、Step Setupダイアログボックスの Browseボタンをクリック
し、<Program Files>¥National Instruments¥

SignalExpressTekEd¥Examples¥Tutorialディレクトリを参照

し、Step Response.txtをダブルクリックします。 このステップに
より、ASCII形式のファイルが読み込まれ、データが表示されます。

File preview セクションのColumn 1 はタイムスタンプデータ、
Column 2は信号の実際の電圧値を示します。

3. Import Signalsタブをクリックし、ファイルにある使用可能な信号
を表示します。

4. Column 2チェックボックスを有効にして信号をインポートし、
Column 1チェックボックスを無効にします。 Step Setupダイアロ
グボックスの Imported Signalセクションに信号のプレビューが表
示されます。

5. Input X valuesプルダウンメニューから Column 1を選択し、波形
の x軸データを適切な値に設定します。

6. Closeボタンをクリックし、Step Setupダイアログボックスを閉じ
ます。

7. プロジェクトビューの Column 2出力を右クリックし、ショート
カットメニューから Renameを選択します。

8. step responseと入力し、<Enter>キーを押して出力名を変更しま
す。

9. Load from ASCIIの step response出力を下のグラフにドラッグし
ます。 2つの信号はソースと実行速度が異なるため、ダイアログボッ
クスが表示されます。
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10. Yesボタンをクリックし、両方の信号を同じグラフに表示します。 
図 5-2のように、フィルタ処理ステップの信号は、ステップ応答出力
の立ち上がりエッジと類似しています。

 

図 5-2 My Signals.wbpの信号

11. File→ Save Projectを選択し、プロジェクトを保存します。

信号の整列と比較

フィルタ処理ステップの信号とステップ応答の出力の両方に、立ち上がり

エッジでオーバーシュートが見られますが、信号ソースが異なることや振

幅やタイミングに違いがあるため、この 2つの信号は類似点を判定しに
くいという状況にあります。 ただし、Interactive Alignmentステップを
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使用すれば 2 つの信号を整列・比較できるため、プロジェクト内で使用
する情報を選択することができます。

My Signals.wbpプロジェクトの 2つの信号を整列するには、以下の手
順に従ってください。

1. step response出力を右クリックし、ショートカットメニューから
Send To→ Analog→ Processing→ Interactive Alignment選択
し、ステップ応答信号を ASCIIからロードステップから対話式アラ
イメントステップへ渡します。

図 5-3のように、ロジェクトで最後に使用された 2つの信号が入力
として選択され、Step Setupダイアログボックスのグラフにそれら
の信号が表示されます。

 

図 5-3 Interactive Alignmentステップの Step Setupダイアログボックス
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ステップをプロジェクトに追加すると、ステップが受け入れることの

可能な信号タイプに基いて入力信号が選択されます。 例えば、
Interactive Alignmentステップでは、時間領域信号のみを扱うこと
ができます。 したがって、プロジェクトで作成された信号のうち最後
の 2 つの時間領域信号が入力となります。 ステップの入力信号を変更
するには、Step Setup ダイアログボックスの Input/Output タブに
ある対応信号のプルダウンメニューから、別の信号を選択します。

2. 赤い信号をクリックし、グラフ内でドラッグします。 グラフ上の信号
は、ドラッグ、拡張、縮小を行うことができます。

3. グラフ内で信号をドラッグすることで、2つの信号の立ち上がりエッ
ジを整列してみます。 信号をクリックしてアンカーポイントを設定
し、<Alt>キーを押したまま信号をクリックしてアンカーポイントの
周りにドラッグします。 これにより、信号は x方向および y方向に伸
びます。

Step Setupダイアログボックスの Alignmentタブ上では、信号を
ドラッグするたびに、ステップによりアライメント仕様を満たすのに

必要なｘ軸とｙ軸のゲインおよびｘ軸とｙ軸のオフセット値が計

算され、表示されます。

4. Modeプルダウンメニューから Auto - Stepを選択し、信号を整列
します。 このアライメントモードは、内蔵アルゴリズムに基づいてい
ます。

Step Setupダイアログボックスの下方のグラフには、2つの信号に
おける相違が表示されます。

5. Input/Outputタブの Export aligned signalsチェックボックスを
有効にし、信号をステップの出力に追加します。

6. Closeボタンをクリックし、Step Setupダイアログボックスを閉じ
ます。

7. 左の Add Displayボタンをクリックし、3つ目のグラフを作成しま
す。

8. Interactive Alignmentステップの aligned reference出力と
aligned test出力を新しいグラフにドラッグし、整列された信号を
表示します。

9. File→ Save Projectを選択し、プロジェクトを保存します。 

NI SignalExpress Tektronix Editionの信号タイプ 
ステップの中には、Arithmeticステップなど、様々な信号タイプを使用
できるステップがあります。 たとえば、Arithmeticステップでは、時間
領域または周波数領域の波形を処理することができます。 この
Arithmeticステップでは、そのステップで選択した入力信号のタイプに
よって動作が異なります。 たとえば、2つの時間領域信号を追加すると、
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その振幅のみが追加されます。 これに対し、2つの周波数領域位相信号を
追加すると、位相が適切にシフトされます。

詳細は、『NI Express Workbench Help』（英語）を参照してください。
このヘルプは、Help→ Express Workbench Helpを選択し、Search
タブをクリックし、signal typesと入力すると表示されます。

信号のエクスポートと印刷

NI SignalExpress Tektronix Editionでは、様々な文書化機能が備えられ
ているため、Microsoft Excelや NI DIAdemのレポート生成ツールなど、
別のソフトウェアアプリケーションで解析を続けることができます。 これ
らの機能は、NI SignalExpress Tektronix Editionのデータをレポート形
式で文書化する際に便利です。

Microsoft Excelへ信号をエクスポートする
Microsoft Excelへ信号データをエクスポートするには、Microsoft 
Excelを起動し、ステップの出力信号をMicrosoft Excelのスプレッド
シートへドラッグします。

信号を印刷する
グラフの画像を印刷するには、データビューを右クリックし、ショート

カットメニューから Export→ Print Displayを選択します。

信号を画像として保存する
グラフの画像を .pngファイルに保存するには、データビューを右クリッ

クし、ショートカットメニューから Export→ Save as Imageを選択し
ます。 .pngファイルは、Microsoft Wordなどのあらゆる文書化ツールに
インポートすることができます。

Tektronix Scopeの画像を保存する
オシロスコープの画像を .pngファイルに保存するには、Step Setupダ
イアログボックスの Utilitiesメニューをクリックし、Save Imageを選
択します。 .pngファイルは、Microsoft Wordなどのあらゆる文書化ツー
ルにインポートすることができます。
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データをファイルにロギングする
信号のグラフを印刷したり、信号データをエクスポートもしくは保存して

スプレッドシートアプリケーションに表示したりすることができます。

信号をファイルへ保存するには、以下の手順に従ってください。

1. Add Stepボタンをクリックし、Analog→ Load/Save Signals→
Save to ASCII/LVMを選択します。

2. Step Setupダイアログボックスの Signalsタブをクリックし、
Input Dataプルダウンメニューから filtered stepを選択します。

3. If file already existsプルダウンメニューからOverwriteを選択し
ます。

4. Export file typeプルダウンメニューからGeneric ASCII (.txt) を選
択します。 プロジェクトが実行されるたびに、信号をロード / 保存ス
テップを使用し、データをファイルへ保存します。

5. File Settingsタブ上で、ファイルを <SignalExpressTekEd>¥ 

Examples¥Tutorial¥filtered signal.txtへ保存します。

6. Closeボタンをクリックし、Step Setupダイアログボックスを閉じ
ます。

7. File→ Save Projectを選択し、プロジェクトを保存します。

8. File→ Close Project を選択し、プロジェクトを閉じます。
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スイープ計測を行う

NI SignalExpress Tektronix Edition では、スイープ操作により計測を自
動化し、特性評価や設計検証を行うことができます。 広範な条件でスイー
プ測定を使用して設計からデータを収集し、その設計性能を文書化するこ

とができます。 たとえば、特性評価のための計測を実行中に、スイープ操
作を使用して刺激信号の周波数や電源の電圧レベルを変化させることがで

きます。

本章では、NI SignalExpress Tektronix Edition の Sweepステップを使
用したスイープ操作の設定方法について説明します。 周波数スイープを行
い、フィルタ出力の測定を行うことで、フィルタの性能を評価 する方法
と、 スイープ結果の表示方法と、より複雑な計測のための多次元掃引（ス
イープ）の実行方法についても説明します。

スイープの範囲と出力を定義する

Sweepステップでは、複雑で反復的なスイープ操作でも、これを定義す
ることにより計測を自動的に行うことができます。

サンプルプロジェクトで周波数範囲を定義し、フィルタを介してスイープ

操作を行うには、以下の手順に従ってください。

1. File→Open Projectを選択し、<SignalExpressTekEd>

¥Examples¥Tutorialディレクトリを選択したら、Sweep.wbpをダ

ブルクリックします。

2. 左の Runボタンをクリックし、プロジェクトを実行します。 
このプロジェクトでは、Create Signalステップにより正弦波の刺激
信号が生成されます。この信号は、Filterステップにより楕円バンド
パスフィルタを介して渡され、Amplitude and Levels ステップによ
りフィルタ出力の RMS（実効値）が計測され、Formula ステップに
よりデシベル（dB）に変換されます。 Filter ステップはシミュレート
された検査対象（UUT）として動作するため、計測器は使用しませ
ん。 ただし、Tektronix 製の信号発生器により生成される実際の信号
をスイープすることはできます。

3. 左の Add Stepボタンをクリックし、Operations→ Sweepを選択
します。
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4. 図 6-1のように、Step Setupダイアログボックスの Addボタンを
クリックし、プロジェクトの各ステップのスイープパラメータのリス

トを表示します。

図 6-1 Sweep Parameter Selectionダイアログボックス

5. Create Signal: stimulus signal (sinewave)にある Frequency 
(Hz) パラメータを選択し、OKボタンをクリックします。

6. Sweep Configurationタブの Typeプルダウンメニューから
Exponentialを選択します。

7. Start Frequency (Hz)制御器に 1kと入力し、Stop Frequency (Hz)
制御器に 40kと入力します。

8. Number of points制御器に 150と入力します。

図 6-2のような Sweep Configurationタブが表示されます。
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図 6-2 Sweepステップの Step Setupダイアログボックス

Sweepステップを使用し、Create Signal ステップの周波数（Hz）、
（信号の周波数）をスイープさせる範囲を設定します。 Create Signal 
ステップでは、定義された周波数範囲を元に、各周波数で正弦波を生

成します。 周波数以外のパラメータをスイープさせることも可能で
す。

9. Sweep Outputタブをクリックします。

10. Addボタンをクリックし、プロジェクトの各ステップの出力リスト
を表示します。

11. Formula (Scalar)から response amplitude in dB出力を選択し、
OKボタンをクリックし、スイープされた周波数（Hz）パラメータに
対してこの計測をプロットします。
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12. 左の Closeボタンをクリックし、Step Setupダイアログボックスを
閉じます。

スイープ操作で使用するステップをすべて含めるため、Sweep ステップ
はループを作成してプロジェクトの全ステップを囲みます。

スイープの結果をプロットする

スイープ計測を実行するには、以下の手順に従ってください。

1. 左の Run Once ボタンをクリックし、スイープ計測を実行します。

グラフ上の刺激信号の出力は、指定された周波数で繰り返し出力され

ます。

2. Sweepループの下の response amplitude in dB vs. Frequency 
(Hz)信号をデータビューにドラッグし、スイープの出力を表示しま
す。

新しいグラフが作成されます。 図 6-3のように、スイープ操作のデー
タは、XYグラフで表示されます。
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図 6-3 スイープ操作からのグラフ出力

3. Run Onceボタンをもう一度クリックし、実行します。 新たに作成さ
れた XYグラフに Filterステップの周波数応答（振幅（dB）対周波
数）がプロットされます。 周波数に対するデシベルで表される振幅の
出力、またはフィルタの転送関数がグラフに表示されます。

4. Filterステップをダブルクリックし、Step Setupダイアログボック
スを表示します。 Filter Magnitude Response (dB)のグラフにある
フィルタの周波数応答が、データビューのグラフと一致します。

5. Closeボタンをクリックし、Step Setupダイアログボックスを閉じ
ます。

6. File→ Save Project Asを選択し、プロジェクトを My Sweep.wbp

という名前で <SignalExpressTekEd>¥Examples¥Tutorialディ

レクトリに保存します。 
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Sweep Step Setupダイアログボックスの Sweep Configuration
タブに別のパラメータを追加することで、Sweepステップを使用
し、複数のパラメータを同時にスイープすることができます。   たと
えば、刺激信号の振幅と周波数を両方スイープさせることが可能で

す。 また、信号レベルを変更するたびに Tektronix 社製オシロスコー
プの入力範囲を変更することで、集録の精度を最適化させることがで

きます。 信号レベルが上昇したら、計測デバイスの入力範囲を広げれ
ば、その計測に測定器がもつ分解能がフルに活かすことができます。

多次元掃引を実行する

多次元（ネスト化した）スイープを使用し 2つのパラメータを順番にス
イープさせることが可能です。 たとえば、刺激信号の周波数を様々な振幅
でスイープする場合には、ネスト化されたスイープを実行します。

振幅をレベル 1に設定して様々な周波数でスイープし、今度は振幅をレ
ベル 2に設定して様々な周波数でスイープする、といったことができま
す。 ネスト化されたスイープは、プロジェクトの Sweepステップを右ク
リックし、ショートカットメニューから Add Dimensionを選択し、別
のスイープループを追加することで作成できます。

ネスト化されたスイープのサンプルプロジェクトを実行するには、以下の

手順に従ってください。

1. File→Openを選択し、<SignalExpressTekEd>¥Examples¥
Tutorialディレクトリを選択したら、Nested Sweep.wbpをダブ

ルクリックします。

2. 左の Runボタンをクリックし、プロジェクトを実行します。
内側のスイープループは刺激信号の周波数をスイープさせます。 外側
のスイープループは、Filter ステップのカットオフ周波数の上限と下
限を変化させます。 図 6-4のように、まず上のグラフに実行中のス
イープがリアルタイムに表示されます。下のグラフには、各カットオ

フ周波数設定のスイープがすべて表示されます。
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図 6-4 Nested Sweep.wpb

3. 左の Stopボタンをクリックし、プロジェクトを停止します。
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NI SignalExpress Tektronix 
Editionのプロジェクトを
LabVIEWで機能拡張する

NI SignalExpress Tektronix Editionでは、信号の集録や生成、解析用の 
内蔵ステップを使用し、プログラミングせずに自動計測を定義す ること
ができます。 また、LabVIEWでユーザ定義のステップ（VI）を作成し、
VIを NI SignalExpress Tektronix Editionにインポートして使用可能なス
テップ数を追加したりすることで、機能を拡張することができます。

メモ この章の演習問題には、LabVIEW 7.1以降のバージョンが必要です。

LabVIEWの VIを NI SignalExpress Tektronix 
Editionにインポートし、ステップとして使用する

NI SignalExpress Tektronix Editionのユーザ定義ステップを使用すれば、
カスタム仕様の LabVIEW VI の呼び出しを行うことができます。
NI SignalExpress Tektronix Edition から LabVIEW VI を呼び出すことに
より、以下のようなことを行えます。

� スタンドアロン型の計測器を制御する

� 多様なファイル形式のデータを読み書きする

� 操作の説明をポップアップダイアログボックスに表示する

� 測定アルゴリズムを定義する

ユーザ定義ステップを含む VI を LabVIEW からインポートするには、以
下の手順に従ってください。

1. File→Open Projectを選択し、<SignalExpressTekEd>¥
Examples¥Tutorialディレクトリを選択したら、User Step.wbp

をダブルクリックします。 このプロジェクトでは、Create Signalス
テップを使用して、信号を生成します。

2. Add Stepボタンをクリックし、User-Defined Stepを選択します。
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3. Step Setupダイアログボックスの参照ボタンをクリックし、
<SignalExpressTekEd>¥Examples¥Tutorialディレクトリにある
Limiter.viを選択します。 Limiter VIは時間領域波形を入力として
受け取り、Step Setupダイアログボックスで指定した信号の範囲の
上限を超えたデータと下限を下回ったデータをクリップし、クリップ

した波形を出力信号として返します。

LabVIEW VIをインポートする際、VIの入力はパラメータとして、
そして出力は出力信号としてマップされます。

入力は、入力信号として LabVIEW上で定義すれば、ステップの入力
としてプロジェクトビューに表示することができ、NI SignalExpress 
Tektronix Editionのステップの入力パラメータとして使えます。 この
プロジェクトでは、入力信号 Time waveform in が VI に含まれてい
ます。

4. Outputsリストから Clipped waveform outを選択し、Strict Type 
of Output Dataプルダウンメニューから Time Waveform, Realを
選択し、Clipped waveform outを時間領域波形と指定します。 
図 7-1のような Step Setupダイアログボックスが表示されます。
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図 7-1 Limiter VIステップの Step Setupダイアログボックス

5. 左の Closeボタンをクリックし、Step Setupダイアログボックスを
閉じます。

6. 左の Runボタンをクリックし、プロジェクトを実行します。

7. Limiter.viステップから Clipped waveform out出力信号をデータ
ビューにドラッグします。

8. Limiter.viステップをダブルクリックし、Step Setupダイアログ
ボックスを表示します。

9. Configure VIタブをクリックし、VIのフロントパネルを表示しま
す。
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10. Upper limitおよび Lower limitフィールドに新しい値を入力します。 
たとえば、図 7-2のように、Upper limit制御器に 100 と入力しま
す。

 

図 7-2 Configure VIタブ

11. Closeボタンをクリックし、Step Setupダイアログボックスを閉じ
ます。 指定した変更の通りに、データビューの Clipped waveform 
out出力信号が変更されます。

NI SignalExpress Tektronix Edition における LabVIEW VI の使用方法や、
NI SignalExpress Tektronix Edition と正しく動作する VI の開発方法につ
いての詳細は、『NI Express Workbench Help』（英語）を参照してくだ
さい。
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詳細情報

NI SignalExpress Tektronix Editionについてさらに詳しい情報を入手す
るには、以下の資料を参照してください。

NI SignalExpress Tektronix Edition のサンプルプ
ロジェクト

NI SignalExpress Tektronix Editionには、多くの機能を搭載した様々な
サンプルプロジェクトが付属しています。 これらのプロジェクトは、
<SignalExpressTekEd>¥Examplesディレクトリにあります。 これらの
サンプルを参照すれば、さらに多くの機能について習得することや、要求

に近いプロジェクトで作業を開始することができます。

他の計測器をNI SignalExpress Tektronix Edition
で使用することに関する説明

Tektronix DPO4000/TDS3000/AFG3000シリーズの計測器など、
NI SignalExpress Tektronix Editionは 400以上の普及しているスタンド
アロン型やプラグイン計測器に対応しています。 他の計測器で
NI SignalExpress Tektronix Editionを使用することについての詳細は、
『NI Express Workbench Help』（英語）を参照してください。このド
キュメントは、Help→ Express Workbench Helpを選択すると表示さ
れます。

関連文書

信号の集録と解析に使用する基本機能を習得するには、『Getting 
Started with SignalExpress』（英語）を参照してください。 このマニュア
ルには、SignalExpressで作業を開始する際に役立つ演習問題などが含ま
れています。

『Getting Started with SignalExpress』は、PDFファイルです。 PDF
ファイルを表示するには、Adobe Readerが必要です。 Adobe Reader
をダウンロードするには、アドビシステムズ社のウェブサイトを参照して

ください。 また、最新のドキュメントは、ni.com/jp/manualsの製品マ

ニュアルのライブラリをご覧ください。
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関連ウェブサイト

サンプルプロジェクト、技術関連文書、NI SignalExpress Tektronix 
Editionで使用する LabVIEW VIについては、弊社ウェブサイト、
ni.com/jp/signalexpress を参照してください。
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技術サポートおよびプロフェッ
ショナルサービス

技術サポートおよびその他のサービスについては、ナショナルインスツル

メンツのウェブサイト（ni.com/jp）の下記のセクションを参照してく

ださい。

� サポート―オンライン技術サポート（ni.com/support/ja）には以

下のリソースがあります。

� セルフヘルプリソース―質問に対する回答やソリューションが必
要な場合は、ナショナルインスツルメンツのウェブサイトをご参
照ください。ソフトウェアドライバとアップデート、検索可能な
技術サポートデータベース、製品マニュアル、トラブルシュー
ティングウィザード、種類豊富なサンプルプログラム、チュート
リアル、アプリケーションノート、計測器ドライバなどをご利用
いただけます。

� 技術サポート―ユーザ登録をされますと、基本的なサービスを無
償でご利用いただくことができます。ni.com/jp/dforumから
アクセスできる NIディスカッションフォーラムでは、アプリ
ケーションエンジニアに対するご質問を承ります。 お尋ねいただ
きましたご質問には、ナショナルインスツルメンツのアプリケー
ションエンジニアが必ず回答いたします。

ご利用の地域のその他の技術サポートオプションについては、
ni.com/jp/servicesをご覧いただくか、または ni.com/jp/
contactから最寄りの営業所までお問い合わせください。 

� トレーニングと認定―自習形式のコースキットやインストラクタによ

る実践コースなどのトレーニングおよび認定プログラムについては、

ni.com/jp/training 参照してください。

� システムインテグレーション―時間の制約がある場合や社内で技術リ

ソースが不足されている場合、または、プロジェクトで簡単には解消

しない問題がある場合などは、ナショナルインスツルメンツのアライ

アンスパートナーによるサービスをご利用いただけます。 詳しくは、
最寄りの NI営業所にお電話いただくか、ni.com/jp/allianceを

ご覧ください。

NIのウェブサイト（ni.com/jp）を検索しても問題が解決しない場合は、

最寄りの営業所またはナショナルインスツルメンツ本社までお問い合わせ

ください。世界各地の弊社営業所の連絡先は、本書の巻頭に掲載されてい

ます。ni.com/niglobal（英語）にあるWorldwide Officesのセク
ションから、各支社のウェブサイトへアクセスすることもできます。この
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ウェブサイトでは、お問い合わせ情報、サポートの電話番号、Eメールア
ドレス、および現行のイベント等に関する最新情報をご案内しています。
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