RELEASE AND UPGRADE NOTES

LabVIEW™ Datalogging and Supervisory Control Module

Version 2013

This document describes the system requirements and the process of installing the LabVIEW 2013 Datalogging and Supervisory Control (DSC) Module and the DSC Module Run-Time System. This document also describes the new features available with version 2013 and compatibility and upgrade issues you might encounter when you use version 2013.

Contents

System Requirements ............................................................................................................... 1
• Supported Operating Systems .......................................................................................... 2
• Installing the DSC Module ............................................................................................... 2
  • Activating the DSC Module .......................................................................................... 3
• DSC Module 2013 Features and Changes ........................................................................ 3
  • Supervisory Control and Data Acquisition System Sample Project ......................... 3
  • New VIs ......................................................................................................................... 3
  • Behavior Changes ......................................................................................................... 4
• Upgrade and Compatibility Issues .................................................................................... 5
  • Upgrading from the DSC Module 2012 ...................................................................... 5
  • Upgrading from the DSC Module 8.2 ......................................................................... 5
  • Upgrading from the DSC Module 7.x .......................................................................... 5
• DSC Module Run-Time System ....................................................................................... 5
  • Installing the DSC Module Run-Time System .............................................................. 5
• Configuring the Microsoft SQL Server ............................................................................. 6
  • Upgrading from the Microsoft SQL Server 2000 Desktop Engine .............................. 7
  • Upgrading from the Microsoft SQL Server 2005 Express Edition ............................... 8
• Where to Go from Here ..................................................................................................... 8
• Known Issues .................................................................................................................... 8

System Requirements

To use the DSC Module, the computer must meet the following minimum system requirements:

• 800 MB free disk space.
• 512 MB of RAM. National Instruments recommends 1 GB of RAM.
• LabVIEW 2013 Base, Full, or Professional Development System (32-bit). Refer to the LabVIEW Help for information about the LabVIEW development system.
• Internet Explorer 6 Service Pack 1 or later.
Supported Operating Systems

The DSC Module supports the following operating systems:

- Windows 8 (32-bit and 64-bit)
- Windows 7 (32-bit and 64-bit)
- Windows Vista (32-bit and 64-bit)
- Windows XP Service Pack 3 or later
- Windows Server 2003 R2 (32-bit)
- Windows Server 2008 R2 (64-bit)

The DSC Module does not support Windows NT/Me/2000/98/95 or the Windows Server non-R2 editions.

Note
Support for Windows Server 2003 R2 may require disabling physical address extensions (PAE). To learn how this might affect your use of Windows Server 2003 and what actions you might have to take, visit ni.com/info and enter the Info Code PAESupport.

Installing the DSC Module

This section includes information about installing the DSC Module on a development computer.

Complete the following steps to install the DSC Module.

1. Log in to the computer as an administrator or as a user with administrative privileges.
2. Disable any automatic virus detection programs before you install. Some virus detection programs interfere with installation.
3. Insert the LabVIEW Platform DVD Disc 1.
   
   Tip You also can double-click setup.exe from the media to launch the installer.

4. Follow the instructions for installing software.
5. When the Product List page appears, select Datalogging and Supervisory Control Module in the Industrial Monitoring folder.
6. Select Install to minimize user interaction. Selecting Custom install opens additional dialog boxes that require your input.
7. Follow the instructions to finish installing and activating the DSC Module.
8. After installation, enable any virus detection programs you disabled.
9. Refer to the Where to Go from Here section of this document for more information about getting started with and using the DSC Module.

Note By default, the NI Keyboard Filter Driver is not installed. The NI Keyboard Filter Driver activates special security features, including the ability to restrict users from switching between applications by pressing the <Alt-Tab> keys. This driver does not work on laptop computers or on computers with hibernation enabled.
Activating the DSC Module

The DSC Module relies on licensing activation. You have a temporary license for a 7-day evaluation period. When the evaluation period expires, you must activate a valid DSC Module license to continue using the DSC Module.

The NI OPC Servers application installed with the DSC Module provides a temporary license for a two-hour evaluation period. You must activate a valid license to continue using the NI OPC Servers application after the evaluation period expires.

You can use the NI License Manager, available by selecting Start»All Programs»National Instruments»NI License Manager, to activate National Instruments products. (Windows 8) Click NI Launcher and select NI License Manager in the window that appears. Refer to the National Instruments License Manager Help, available by selecting Help»Contents in the NI License Manager, for information about activating NI products.

Refer to ni.com/support if you encounter errors during installation.

DSC Module 2013 Features and Changes

The following sections describe the new features and changes in the DSC Module.

Supervisory Control and Data Acquisition System Sample Project

The Supervisory Control and Data Acquisition System sample project implements Supervisory Control and Data Acquisition (SCADA) for a simulated CompactRIO and PLC-based system. This sample project provides a scalable architecture for building systems with a large number of I/O points.

Access this sample project by selecting File»Create Project in LabVIEW.

New VIs

- **Register Server VI**—Use the Register Server VI to register the OPC UA server with the UA Local Discovery Server (LDS). This VI is located on the OPC UA Server palette.
- **Unregister Server VI**—Use the Unregister Server VI to unregister the OPC UA server with the UA Local Discovery Server (LDS). This VI is located on the OPC UA Server palette.
Behavior Changes

The DSC Module introduces the following behavior changes.

Variables & I/O Servers VIs

The following VIs on the Variables & I/O Servers palette include the new **reset when disabled?** input which specifies whether to reset the value you specify to the initial state when using this VI to disable a property.

- Configure Alarming
- Configure Initial Value
- Configure Logging
- Configure Scaling
- Configure Update Deadband

SharedVariableIO Properties

You can use the SharedVariableIO properties without enabling the Enabled property.

In the DSC Module 2012 or earlier, when you disable the Enabled property, LabVIEW resets the value you specify for the SharedVariableIO properties to the initial state. In the DSC Module 2013, when you disable the Enabled property, LabVIEW retains the value you specify for the SharedVariableIO properties.

Alarm Acknowledgement Type

- When you specify 1 for the AckType shared variable alarming data item, the acknowledgement type of the alarm is User.
- The following VIs, properties, dialog box option, and shared variable alarming data item include a new **Each Occurrence** value, which specifies that LabVIEW does not acknowledge an alarm until you acknowledge the alarm. LabVIEW generates a new alarm instance whenever the alarm changes from a normal state to an abnormal state.
  - The **ack type** input of the Configure Alarming VI.
  - The following SharedVariableIO properties:
    - Alarming:Bad Status:Acknowledgement Type
    - Alarming:Boolean:Acknowledgement Type
    - Alarming:Hi:Acknowledgement Type
    - Alarming:HiHi:Acknowledgement Type
    - Alarming:Lo:Acknowledgement Type
    - Alarming:LoLo:Acknowledgement Type
    - Alarming:Rate Of Change:Acknowledgement Type
    - Alarming:U32 Bit Field:Acknowledgement Type
  - The **Ack Type** option of the Alarming Page in the Shared Variable Properties dialog box.
  - The AckType shared variable alarming data item.
Upgrade and Compatibility Issues

Refer to the following section for upgrade and compatibility issues specific to different versions of the DSC Module.

Upgrading from the DSC Module 2012

In the DSC Module 2012 or earlier, a VI using the SharedVariableIO properties is unable to correctly read shared variable properties deployed in the DSC Module 2013.

Upgrading from the DSC Module 8.2

If you open a VI saved in the DSC Module 8.2 or earlier, the VI might be broken if the VI contains an indicator, constant, or control created from the shared variable value change notification output of the following VIs.

- Cancel Value Change Notifications
- Enable Value Change Notifications
- Request Value Change Notifications

To fix the broken VI, delete the indicator, constant, or control. Then create a new indicator, constant, or control from the shared variable value change notification output and wire it to the appropriate parameter.

Upgrading from the DSC Module 7.x

If you are upgrading from the DSC Module 7.x or earlier, refer to the Upgrading from the LabVIEW DSC Module 7.x section of the LabVIEW 8.2 Datalogging and Supervisory Control Module Release and Upgrade Notes for important upgrade information. Refer to the National Instruments website at ni.com/info and enter the Info Code dsc820 to access the LabVIEW 8.2 Datalogging and Supervisory Control Module Release and Upgrade Notes.

DSC Module Run-Time System

To run applications built with LabVIEW, the DSC Module, and the LabVIEW Application Builder on a computer without the DSC Module installed, you must install the DSC Module Run-Time System on that computer. The DSC Module Run-Time System contains components that enable the DSC Module features in the built applications. Refer to the National Instruments website at ni.com/info and enter the Info Code dscrts for information about the DSC Module Run-Time System.
To use the DSC Module Run-Time System, the computer must meet the following minimum system requirements:

- Depending on the components you choose to install, the computer must have the following amount of free disk space:
  - 1.0 GB free disk space if you install all components of the DSC Module Run-Time System except the Shared Variable Logging Support component
  - 1.3 GB free disk space if you install all components of the DSC Module Run-Time System

- 512 MB of RAM

The DSC Module Run-Time System supports the same operating systems as the DSC Module. Refer to the Supported Operating Systems section of this document for information about operating systems that the DSC Module Run-Time System supports.

### Installing the DSC Module Run-Time System

Complete the following steps to install the DSC Module Run-Time System.

1. Log in to the computer as an administrator or as a user with administrative privileges.
2. Install the DSC Module Run-Time System from the LabVIEW 2013 DSC Module Run-Time System installation media.
3. Follow the instructions that appear on the screen.

**Note** If you install the DSC Module Run-Time System on a Touch Panel computer, National Instruments recommends that you do not install the Shared Variable Logging Support component unless you need to log data to the Touch Panel computer. Logging data consumes resources, such as memory and disk space, that you may want to reserve for other uses. If you do not install the Shared Variable Logging Support component, you still can use the Touch Panel computer to view logged data on other computers.

4. Restart the computer.

### Configuring the Microsoft SQL Server

The DSC Module requires the Microsoft SQL Server 2008 R2 Express. This component is installed by default when you install the DSC Module. During the installation process, the DSC Module installer creates an instance of the Microsoft SQL Server 2008 R2 Express named CITADEL. To prevent unauthorized access to the Microsoft SQL Server 2008 R2 Express, the installer also generates a password for the default Microsoft SQL Server 2008 R2 Express administrator sa. The default password is the computer ID.

Complete the following steps to find the computer ID using the NI License Manager.

1. Launch the NI License Manager by selecting Start » All Programs » National Instruments » NI License Manager. (Windows 8) Click NI Launcher and select NI License Manager in the window that appears.
2. Click the **Display Computer Information** button on the toolbar.

The DSC Module installer enables a mixed security mode on existing SQL Servers. If the target computer does not have an SQL Server installed, the DSC Module installer installs the Microsoft SQL Server 2008 R2 Express in the mixed security mode.

Use the following command line prompt to change the default password for the `sa` user:

```
Sqlcmd -S"localhost\CITADEL" -U"sa" -P"COMPUTER_ID" -Q"sp_password 'COMPUTER_ID', 'NEW_PASSWORD', 'sa'"
```

If the mixed security mode is not acceptable, change both the Microsoft SQL Server 2008 R2 Express and Citadel login modes. You must set the registry DWORD values

```
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode
```

and

```
HKEY_LOCAL_MACHINE\SOFTWARE\National Instruments\Citadel\5.0\IntegratedSecurity
```

to 1.

National Instruments recommends that you change the login mode immediately after you install the DSC Module. Otherwise, you must relink all existing Citadel databases. Restart the Microsoft SQL Server 2008 R2 Express and Citadel services in order for changes to take effect. If you use integrated NT security, you might need to configure the server machine and all clients explicitly.

### Upgrading from the Microsoft SQL Server 2000 Desktop Engine

The DSC Module 8.2 uses Microsoft SQL Server 2000 Desktop Engine (MSDE 2000), not the Microsoft SQL Server 2008 R2 Express. If you are upgrading from the DSC Module 8.2, any existing databases continue to use MSDE 2000 for alarm logging, but new databases you create use the Microsoft SQL Server 2008 R2 Express. If you detach an existing database from the DSC Module and then reattach the database, the DSC Module migrates the database to the Microsoft SQL Server 2008 R2 Express.

You might want to uninstall MSDE 2000 after installing the DSC Module 2013. Complete the following steps to uninstall MSDE 2000.

1. Stop all running processes in the NI Distributed System Manager.
2. Open Measurement & Automation Explorer (MAX) and select **My System»Historical Data»Citadel 5 Universe** from the **Configuration** tree.
3. On the **Databases** page, detach all databases from the local computer.
4. Open the Windows **Control Panel** and uninstall MSDE 2000.
5. Restart the computer.
6. Open MAX and reattach all databases.
Upgrading from the Microsoft SQL Server 2005 Express Edition

From the DSC Module 8.5 to the DSC Module 2012, the DSC Module uses the Microsoft SQL Server 2005 Express Edition (SQL Express). If you are upgrading from any version of the DSC Module between the DSC Module 8.5 and the DSC Module 2012, the DSC Module automatically migrates any existing databases to the Microsoft SQL Server 2008 R2 Express.

Where to Go from Here

National Instruments provides many resources to help you succeed with your NI products. Use the following resources as you start exploring the DSC Module.

- **Getting Started with the LabVIEW Datalogging and Supervisory Control Module**—Use this manual, located in the `labview/manuals` directory, to familiarize yourself with some of the features that the DSC Module adds to LabVIEW.

- **DSC Module Examples**—Refer to the DSC Module examples, located in the `labview\examples\lvdsc` directory, for examples that demonstrate common tasks using the DSC Module. You also can access these examples in the NI Example Finder by selecting Help>Find Examples from LabVIEW and browsing or searching for the DSC Module examples.

- **LabVIEW Help**—Available by selecting Help>LabVIEW Help in LabVIEW. Browse the DSC Module book on the Contents tab for an overview of the DSC Module.

- Visit [ni.com/dsc](http://ni.com/dsc) for the latest NI Developer Zone articles, examples, and support information for the DSC Module.

- **DSC Module Training**—Refer to [ni.com/info](http://ni.com/info) and enter the Info Code dsctrn to access online training for the DSC Module.

Known Issues

You can access the software and documentation known issues list online. Refer to the National Instruments website at [ni.com/info](http://ni.com/info) and enter the Info Code LVDSC2013KI for an up-to-date list of known issues in the DSC Module and the DSC Module Run-Time System.