
RELEASE NOTES

LabWindows /CVI
Version 2013

These release notes introduce LabWindows™/CVI™ 2013. Refer to this document for system 
requirements, installation and activation instructions, and information about new features in 
LabWindows/CVI.
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LabWindows/CVI System Requirements
To run LabWindows/CVI, you must have the following:

• Personal computer using a Pentium 4/M or equivalent processor

• Microsoft operating systems:

– Windows 8 (32-bit and 64-bit)

– Windows 7 (32-bit and 64-bit), including Starter Edition 

– Windows Vista Service Pack 1 (32-bit and 64-bit)

– Windows XP Service Pack 3

– Windows Server 2008 R2 Service Pack 2 (64-bit)

– Windows Server 2003 R2 Service Pack 2 (32-bit)

Note LabWindows/CVI supports only R2 editions of Windows Server.

• 1024 × 768 resolution (or higher) video adapter

• Minimum of 512 MB of RAM, 2 GB recommended

• 1.4 GB free hard disk space for full installation, which includes the Interface to Win32 
Application Programmatic Interface (API); additional space needed for National 
Instruments Device Drivers and for the Microsoft .NET Framework 4.0

• Microsoft-compatible mouse

Installing LabWindows/CVI
The LabWindows/CVI Platform DVD includes LabWindows/CVI and the following modules 
and toolkits:

Modules
• Real-Time Module

• Vision Development Module

Toolkits
• Real-Time Execution Trace Toolkit

• SQL Toolkit

• Signal Processing Toolkit

• PID Toolkit

• Execution Profiler Toolkit

• ECU Measurement and Calibration Toolkit

• Automotive Diagnostic Command Set

If you purchased any of these modules or toolkits, you can install them using the 
LabWindows/CVI Platform DVD. If you want to evaluate any of these modules or toolkits 
before purchasing them, you can install these add-ons from the LabWindows/CVI Platform 
DVD.
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Before Installation
Keep the following points in mind before you install LabWindows/CVI:

• If you already have a different version of LabWindows/CVI installed on your computer, be 
sure to install version 2013 in a different directory. If you want to install to an existing 
directory, uninstall the other version before installing LabWindows/CVI 2013.

• You must have administrator privileges to install LabWindows/CVI.

Running the Installation
Complete the following steps to install LabWindows/CVI.

Caution Installing LabWindows/CVI 2013 replaces any previous version of the 
LabWindows/CVI Run-Time Engine with the LabWindows/CVI 2013 Run-Time 
Engine. To restore the previous Run-Time Engine, uninstall LabWindows/CVI 2013, 
the LabWindows/CVI 2013 Run-Time Engine, and any previous versions of 
LabWindows/CVI and the LabWindows/CVI Run-Time Engine on the computer. 
Then reinstall the LabWindows/CVI version you want to use, along with any 
additional National Instruments software you might have installed.

1. Insert the LabWindows/CVI media into the disk drive. If the media does not run 
automatically, open Windows Explorer, right-click the disk drive icon, and select 
AutoPlay.

2. On installation startup, the National Instruments LabWindows/CVI 2013 screen appears. 
Click Install LabWindows/CVI, Modules, and Toolkits.

3. Continue to follow the instructions on the screen.

Note If you have a serial number for the product you want to install, enter the 
number during installation when you are prompted. You also can activate the product 
after installation. For more information about finding serial numbers, refer to 
ni.com/info and enter SerialNumbers_en as the Info Code.

Each product on the LabWindows/CVI Platform DVD has a different serial number, 
with the possible exception of the LabWindows/CVI Execution Profiler Toolkit. The 
Execution Profiler Toolkit does not require a separate license if you have a 
LabWindows/CVI Full Development System license. If you have the 
LabWindows/CVI Base Package, you can install the Execution Profiler Toolkit for 
evaluation.

4. If you select Device Drivers in the Features panel, the LabWindows/CVI installer prompts 
you to insert the National Instruments Device Drivers media, which is available on 
ni.com. The NI Device Drivers media is required only if you want to upgrade existing 
driver software to the latest version. Otherwise, you can ignore this prompt.

5. To activate a National Instruments product, refer to the Activating LabWindows/CVI 
section of this document.
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Activating LabWindows/CVI
If you did not enter a serial number during installation, click Activate Products in the License 
Status dialog box to launch the NI Activation Wizard.

Once you choose your activation method and launch the NI Activation Wizard, follow the 
instructions on the screen to activate LabWindows/CVI. For more information about activation, 
refer to the Activating Your Software topic in the LabWindows/CVI Help.

Note If you are unable to activate LabWindows/CVI, refer to the web page at 
ni.com/activate.

What’s New in LabWindows/CVI?
This section includes information about changes and enhancements in LabWindows/CVI 2013.

Updated LabWindows/CVI Compiler and Build System
The LabWindows/CVI compiler is now using the LLVM compiler infrastructure with a Clang 
C front end. The updated compiler generates optimized code, meaning that you no longer need 
to use an external optimizing compiler for this purpose.

The updated build system provides the following features:

• Build source files in parallel

• Edit while building

• Clean and rebuild

• Specify project build dependencies

• Take advantage of faster build times

LabWindows/CVI Debugging Updates
Along with the updated LabWindows/CVI compiler, the LabWindows/CVI debugger is also 
updated. The new LabWindows/CVI debugger is implemented using the DWARF format. The 
LabWindows/CVI debugger produces debug information that consumes less space on disk, 
which increases performance.

The following general changes affect debugging in LabWindows/CVI 2013:

• You can create debuggable static libraries in LabWindows/CVI 2013.

• You can now detach the LabWindows/CVI debugger from a process to which it is attached 
by selecting from the following options:

– Detach from Process in the <<Running>> menu of an executing process. 

– Run»Detach from Process from a suspended application.

The following sections include information about changes and enhancements to debugging 
tools.
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Array Display
The String Display window is deprecated. You can view and edit string variables and 
one-dimensional and multidimensional string arrays in the Array Display window.

The Array Display window launches confined to the Debugging Region by default. You can 
release the window by right-clicking in the window and selecting Release Window from the 
context menu. In the Array Display window, the Options»Reset Indices option is renamed to 
Options»Change Data Slice.

Refer to the Using LabWindows/CVI»Debugging Tools»Using the Array Display Window»
Array Display Window topic in the LabWindows/CVI Help for more information about the Array 
Display window.

Graphical Array View
The Graphical Array View launches confined to the Debugging Region by default. You can 
release the window by right-clicking in the window and selecting Release Window from the 
context menu. The Interpret data as option is now the Interleaved Arrays option.

Refer to the Using LabWindows/CVI»Debugging Tools»Using the Array Display Window»
Graphical Array View topic in the LabWindows/CVI Help for more information about the 
Graphical Array View.

Variables and Call Stack Window
The Variables and Call Stack window, formerly called the Variables window, includes the 
following changes:

• The Run»Stack Trace menu item is no longer available. Use the Call Stack section of the 
Variables and Call Stack window to view the current call stack of functions in the program. 

Refer to the Using LabWindows/CVI»Debugging Tools»Using the Variables and Call Stack and 
Watch Windows»Variables and Call Stack Window topic in the LabWindows/CVI Help for more 
information about the Variables and Call Stack window.

Watch Window
The Watch Window and watch expressions include the following changes in 
LabWindows/CVI 2013:

• The Add/Edit Watch Expression dialog box is deprecated. Click a cell in the Watch window 
to put the cell in edit mode. You can then edit the value of the expression directly in the 
window.

• The Break On Change Watch expression option, formerly the Break when value changes 
option, can now be triggered as a result of changes in the memory address of a watch 
expression that happened outside of the scope of the original watch expression.



6 | ni.com | LabWindows/CVI Release Notes

• The Break On Change Watch expression option is available only when the expression you 
are watching represents the contents of a memory address in your program.

• Watch expressions can now reference variables defined inside of a block statement.

Refer to the Using LabWindows/CVI»Debugging Tools»Using the Variables and Call Stack and 
Watch Windows»Watch Window topic in the LabWindows/CVI Help for more information about 
the Watch window.

Debugging DLLs, Remote Debugging, and Debugging on 
Real-Time Systems
Several aspects of debugging DLLs, remote debugging, and debugging on real-time systems 
have changed.

• LabWindows/CVI no longer creates a .cdb file with debugging information for DLLs or 
EXEs. The debugging information is now included in the DLL or EXE.

• The remote debugging utility, ConfigureRemoteDebugger.exe, is now 
RemoteDebugger32bit.exe for 32-bit configurations or 
RemoteDebugger64bit.exe for 64-bit configurations.

• When debugging a real-time application via LabVIEW, LabWindows/CVI does not stop 
listening when the VI is unloaded, which means you do not have to restart debugging in 
LabWindows/CVI through multiple instances of running your VI. This behavior also 
increases stability. You can select either Disconnect or Abort and reboot from the 
<<Running>> menu when you are ready to stop debugging.

Miscellaneous
The following are miscellaneous debugging changes:

• The Command Line button of the Add Configuration dialog box and the Edit 
Configuration dialog box is now Executable and Arguments.

• The Set Next Statement option is not available when you are suspended inside a library 
function. For example, you cannot set the next statement while suspended in 
RunUserInterface or when you have hit a non-fatal run-time error. You must step out 
of the library function before you can set the next statement.

• The Run»Command Line command is deprecated. The Run»Specify Executable to 
Debug command is now Run»Specify Executable and Command Line, and you specify 
command line arguments in the associated dialog box. Also, the Specify Executable and 
Command Line dialog box includes an Environment options field where you can set 
environment options for your project.

• You can debug interactive statements in the Interactive Execution window while a project 
is suspended.



LabWindows/CVI Release Notes | © National Instruments | 7

Source Code Browsing Updates
LabWindows/CVI 2013 includes updated source code browsing through the updated 
LabWindows/CVI compiler.

Show Completions
The Edit»Show Completions option provides the following changes and enhancements:

• The drop-down list displays only identifiers that are appropriate for the function or block 
scope you are working within.

• The option displays an icon for each symbol in the drop-down list. The icon represents the 
type of symbol displayed.

• Macros appear in the drop-down list even when they have not been used.

Show Prototype
The Edit»Show Prototype option provides the following changes and enhancements:

• LabWindows/CVI displays function prototype tooltips for functions with no parameter list 
or a void parameter list.

• LabWindows/CVI does not display prototype tooltips for empty macros.

• LabWindows/CVI displays unnamed types as <type>_unknown.

Source Code Browse Information and Source Code Browser
Source code browse information and the Source Code Browser have the following changes and 
enhancements:

• The Generate source code browse information option has moved from the Build Options 
dialog box to the Environment dialog box and is called Generate browse information 
policy. You can choose to generate source code browse information while editing a file, 
when you save a file, or when you compile a file. This option no longer applies 
per-configuration-per-workspace, but is now global to LabWindows/CVI.

• Source code browse information is available in release and debug configurations.

• The Definitions item of the View column is now the Declarations item.

• LabWindows/CVI creates source code browse information for functions that are declared 
even if they are not called in the project.

• When LabWindows/CVI generates source code browse information, a message is 
displayed in the status bar indicating for which file the information is generating. 

• When you select Go to Source from the Referencing and Referenced from views, 
LabWindows/CVI highlights the import declaration of the function rather than the 
definition of the function.

Miscellaneous
The following are miscellaneous source code browsing changes:

• You can view and jump to functions available in a source file by using the pull-down list in 
the toolbar of the Source window.

• Use the keyboard shortcut <Ctrl-0> to go to the beginning of the next function in a file. Use 
the keyboard shortcut <Ctrl-9> to go to the beginning of the previous function in a file.
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• The Edit»Go to»Go to Next Reference command includes going to the next definition of 
an identifier.

• The Edit»Go to»Go to Definition command no longer highlights the forward declaration 
when one exists; LabWindows/CVI highlights the type from the parameter declaration 
instead. 

• LabWindows/CVI displays the value of a struct member, when you hover your mouse over 
the struct member.

Refer to the Using LabWindows/CVI»Writing Source Code»Browsing Source Code book in the 
LabWindows/CVI Help for more information about source code browse information in 
LabWindows/CVI.

Compiler Warning Levels
Use the Compiler Warnings dialog box to customize warnings that display in the Build Output 
window. To access this dialog box, select Options»Build Options and then select the ... button 
next to the Warning Level field.

Support for Soft Dependencies in Distributions
When you create a distribution, you can select or omit soft dependencies for any National 
Instruments installer components that include soft dependencies. A soft dependency of a product 
refers to a component that might or might not be required by the product, depending on the 
specific needs of your application. Use the Drivers & Components tab of the Edit Installer 
dialog box to include soft dependencies.

Refer to the Using LabWindows/CVI»Distributing Applications»Creating and Editing an 
Installer»National Instruments Dependencies in LabWindows/CVI Installers topic for more 
information and caveats to omitting any soft dependencies.

OpenMP Support
OpenMP, Open Multi-Processing, is a set of compiler directives and related clauses, an 
application programming interface (API), and environment variables that allow you to easily 
create applications that execute on multiple threads. The OpenMP model allows you to complete 
the following tasks:

• Define parallel regions of code and create teams of threads that execute the parallel regions. 

• Specify how to share work among the threads in the team. 

• Declare data that is shared among the threads and data that is private to each thread. 

• Synchronize threads, protect shared data from concurrent access, and define regions that 
execute by a single thread exclusively. 

You must enable OpenMP by selecting Enable OpenMP Support in the Build Options dialog 
box.

Refer to the Library Reference»OpenMP Runtime Library book in the LabWindows/CVI Help 
for more information about using OpenMP in LabWindows/CVI.
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Network Streams Library
Use functions in the Network Streams Library to exchange data between LabWindows/CVI 
applications. A network stream is a lossless, unidirectional, one-to-one communication channel 
that consists of a writer and a reader endpoint.

Refer to the Library Reference»Network Streams Library book in the LabWindows/CVI Help for 
more information about the Network Streams Library.

Advanced TDM Streaming Library Functions
LabWindows/CVI 2013 includes the following advanced TDM Streaming Library functions:

• TDMS_AdvancedAsyncRead 

• TDMS_AdvancedAsyncWrite 

• TDMS_AdvancedCloseFile 

• TDMS_AdvancedCreateFile 

• TDMS_AdvancedOpenFile 

• TDMS_AdvancedSyncRead 

• TDMS_AdvancedSyncWrite 

• TDMS_AllocateAlignedMemory 

• TDMS_ConfigureAsyncReads 

• TDMS_ConfigureAsyncWrites 

• TDMS_CreateLinearScalingInfo 

• TDMS_CreatePolynomialScalingInfo 

• TDMS_CreateReciprocalScalingInfo 

• TDMS_CreateRTDScalingInfo 

• TDMS_CreateStrainGageScalingInfo 

• TDMS_CreateTableScalingInfo 

• TDMS_CreateThermistorScalingInfo 

• TDMS_CreateThermocoupleScalingInfo 

• TDMS_FreeAlignedMemory 

• TDMS_GetAsyncReadStatus 

• TDMS_GetAsyncWriteStatus 

• TDMS_GetDataTypeSize 

• TDMS_ReserveFileSize 

• TDMS_SetChannelInfo 

• TDMS_SetNextReadPosition 

• TDMS_SetNextWritePosition 
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These functions add new advanced functionality to the library. Examples of the functionality 
include:

• Writing metadata and raw data separately

• (Windows) Reading and writing data asynchronously to increase streaming performance 
in some applications

• Overwriting a subset of data in a .tdms file

• Pre-allocating disk space for the data you want to write, which can prevent fragmentation 
and increase performance

• Add scaling information to channels in a .tdms file that will be applied when reading data 
from the file

Refer to the Library Reference»TDM Streaming Library book in the LabWindows/CVI Help for 
more information about using the new functions.

Batch Auto-Indent Support in the Source Window
You can auto-indent lines of text in LabWindows/CVI 2013. To auto-indent specified lines, 
select lines of text in the Source window, and select Edit»Format Selection. To auto-indent an 
entire file, select Edit»Format File. Select Options»Editor Preferences and then click the 
Formatting Options button to specify bracket style and indent options.

Additional LabWindows/CVI Enhancements
LabWindows/CVI 2013 includes the following additional enhancements.

Functions
The following functions are new for LabWindows/CVI 2013.

LabWindows/CVI ActiveX Server Interface
• SetEnvironmentOptions

• SetBrowseInformationPolicy 

• GetBrowseInformationPolicy 

• FormatFileSelection 

• SetFormattingOptions 

• GetFormattingOptions 

• DetachDebugger 

Programmer’s Toolbox (toolbox.fp)
• FP32_Compare 

Localize User Interface (localui.fp)
• LoadLocalizedPanelEx 

• LoadLocalizedMenuBarEx 
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Attributes
The following attributes are new in LabWindows/CVI 2013.

User Interface
• ATTR_GRID_STYLE 

• ATTR_PLOT_OPACITY 

• ATTR_TRACE_OPACITY 

• ATTR_NUM_DIGITS_FLOATING_POINT 

• ATTR_ROW_OFFSET

• ATTR_COLUMN_OFFSET 

• ATTR_TOOLTIP_HIDE_DELAY 

Events
• EVENT_RING_BEGIN_MENU 

Environment Changes
• Create subfolders under existing subfolders in the Project Tree. Right-click a project or 

folder and select Add Folder to create a subfolder.

• Rearrange folders in the Project Tree.

• The Build Errors windows is now the Build Output window.

• The Display status dialog during build option in the Build Options dialog is no longer 
available. You can view build status by selecting the Show Build Output window when 
build starts option in the Build Options dialog box.

• The Build menu includes new menu items to build, rebuild, and clean all projects in the 
workspace or a single project; cancel a build; and specify project dependencies.

• The Edit»Go to»Go to Definition, Go to Next Reference, and Go Back commands are 
valid for release configurations.

• The Batch Build dialog box includes a Clean button, which deletes files in the cvibuild 
folder for the project and all of its dependencies.

• The Menu Bar Editor includes a Delete button, which removes the selected item from the 
menu.

• Right-click any project in a workspace and select Build, even if that project is not the active 
project.

• The right-click menu of the Build Output window contains new options, Show Warnings 
and Hide Warnings.

• The Distributions Needed dialog box is now called the Select Source dialog box.

• The Force project files in Interactive window option in the Environment dialog box is 
now called Include project files in Interactive window.
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• The Force loaded instrument drivers into Interactive window option in the 
Environment dialog box is now called Include loaded instrument drivers in Interactive 
window.

• The Generate help from source option of the Target Settings dialog box is available in 
release and debug configurations.

Miscellaneous
• User Interface controls display up to 17 digits of floating point data in standard decimal 

notation. If more digits are required the number is displayed in scientific notation.

• LabWindows/CVI defines the _CVI_CONFIGURATION_NAME_ predefined macro, which 
is defined as the active configuration of the project.

• The pow function in the ANSI C Library sets the errno global variable to ERANGE for 
overflow and underflow conditions.

• Use <Ctrl-Shift-Backspace> and <Ctrl-Shift-Delete> to navigate in text and string controls; 
use <Ctrl-Home> and <Ctrl-End> to navigate in text box controls.

• LabWindows/CVI displays a list of user interface features that were not saved when you 
select a version of LabWindows/CVI in the Save as type option that does not include those 
user interface features. 

• If you specify a remote debugging target, you can attach the LabWindows/CVI debugger 
to a process on the remote target.

• The LabWindows/CVI evaluation period no longer includes restrictions. The evaluation 
period lasts for seven days, but you can increase the evaluation period to 45 days by 
creating a user profile on ni.com.

• Scrolling the mouse wheel includes built-in functionality for the following user interface 
controls:

– Numeric controls—Scrolling increments and decrements the value of the control.

– Ring controls—Scrolling cycles through the values in the ring control.

– Binary switches—Scrolling up turns the switch to the on state; scrolling down turns 
the switch to the off state.

– Combo box and numeric cells in table controls—When you put the cells in edit 
mode, scrolling updates the value of the cell.

• Starting with LabWindows/CVI 2013, rebuilding a project with no changes results in 
identical build output, such as .exe, .dll, and .lib files.

Bug Fixes
For a list of bugs fixed in LabWindows/CVI 2013, refer to the National Instruments web page 
at ni.com/info and enter the Info Code exmvwx.
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LabWindows/CVI Resources
How do I get started?

Read the Getting Started with LabWindows/CVI manual, which provides a tutorial for learning 
basic LabWindows/CVI program development techniques.

Are there known issues or late-breaking information?

Refer to the LabWindows/CVI Readme, which you can access from Start»All Programs»
National Instruments»LabWindows CVI 2013»LabWindows CVI 2013 Readme. The 
readme file contains information about known issues.

Where can I find reference information?

The LabWindows/CVI Help contains complete reference information. The help file includes the 
following sections:

• Using LabWindows/CVI describes the LabWindows/CVI development environment and 
features.

• Library Reference provides information about functions you can call in LabWindows/CVI.

• Programmer Reference provides information to help you develop applications.

• Tools Library provides information about the LabWindows/CVI Toolslib controls.

• LabWindows/CVI Real-Time Module Help includes an introduction to the 
LabWindows/CVI Real-Time Module, programming considerations for RT applications, 
and function reference information for the LabWindows/CVI Real-Time Utility Library. 
You must have the LabWindows/CVI Real-Time Module installed to view this help file.

Use the Search tab in the LabWindows/CVI Help to quickly locate specific information. For 
information about how to use the search functionality, refer to the Using Help»Searching Help 
topic of the LabWindows/CVI Help.

Where can I find examples?

Find examples with the NI Example Finder, which you can access by selecting Help»Find 
Examples.

LabWindows/CVI example programs are located in the following location on 
Windows 8/7/Vista/Server 2008: C:\Users\Public\Documents\National 
Instruments\CVI2013\samples. On Windows XP/Server 2003, example programs are 
located in the following location: C:\Documents and Settings\All Users\
Documents\National Instruments\CVI2013\samples.
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Is there a list of LabWindows/CVI documentation?

The Guide to LabWindows/CVI Documentation topic describes documentation available for new 
users and upgrade users. In addition, this topic provides links to LabWindows/CVI 
documentation, including manuals and web resources. You can access the Guide 
to LabWindows/CVI Documentation topic through the LabWindows/CVI Help.

Where else can I go for LabWindows/CVI information?

Visit the LabWindows/CVI Web site and NI Developer Zone at ni.com for the most up-to-date 
information about LabWindows/CVI.

http://www.ni.com
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