LabWindows™ /CVI™ Release Notes
Version 2010
These release notes introduce LabWindows™/CVI™ 2010. Refer to this document for system
requirements, installation and activation instructions, and information about new features in
LabWindows/CVI.
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Minimum System Requirements
To run LabWindows/CVI, you must have the following:
•

Personal computer using a Pentium 1 GHz or higher microprocessor

•

Microsoft operating systems:
–

Windows 7, including Starter Edition (32-bit and 64-bit)

–

Windows Vista (32-bit and 64-bit)

–

Windows XP (32-bit)

–

Windows Server 2008 R2 (64-bit)

–

Windows Server 2003 R2 (32-bit)

Note

LabWindows/CVI supports only Windows Server R2 editions.

•

1024 × 768 resolution (or higher) video adapter

•

Minimum of 128 MB of RAM, 512 MB recommended

•

1.1 GB free hard disk space for full installation, which includes the Interface to Win32 Application
Programmatic Interface (API)

•

Microsoft-compatible mouse

Installing LabWindows/CVI
The LabWindows/CVI Platform DVD includes LabWindows/CVI and the following modules and
toolkits.
Modules
•

Real-Time Module

•

Vision Development Module

Toolkits
•

Execution Profiler Toolkit

•

PID Toolkit

•

Real-Time Execution Trace Toolkit

•

Signal Processing Toolkit

•

SQL Toolkit

If you purchased any of these modules or toolkits, you can install them using the LabWindows/CVI
Platform DVD. If you want to evaluate any of these modules or toolkits before purchasing them, you
can install these add-ons from the LabWindows/CVI Platform DVD and try them for free for 30 days.
Caution Installing LabWindows/CVI 2010 replaces any previous version of the LabWindows/CVI
Run-Time Engine with the LabWindows/CVI 2010 Run-Time Engine. To restore the previous
Run-Time Engine, uninstall LabWindows/CVI 2010, the LabWindows/CVI 2010 Run-Time Engine,
and any previous versions of LabWindows/CVI and the LabWindows/CVI Run-Time Engine on the
computer. Then reinstall the LabWindows/CVI version you want to use, along with any additional
National Instruments software you might have installed.

1.

Insert the LabWindows/CVI media into the disk drive. If the media does not run automatically,
open Windows Explorer, right-click the disk drive icon, and select AutoPlay.
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2.

On installation startup, the National Instruments LabWindows/CVI 2010 screen appears.
Click Install LabWindows/CVI, Modules, and Toolkits.

3.

Continue to follow the instructions on the screen.
Notes If you have a serial number for the product you want to install, enter the number during
installation when you are prompted. If you do not enter a serial number during installation, you can
enter the number the first time that you launch LabWindows/CVI.

Each product on the LabWindows/CVI Platform DVD has a different serial number.
4.

If you selected Device Drivers in the Product List, the LabWindows/CVI installer prompts you
to insert the National Instruments Device Drivers DVD after you install LabWindows/CVI and any
selected modules and toolkits. Follow the instructions on the screen to install the device drivers.

5.

To activate a National Instruments product, refer to the Activating LabWindows/CVI section of this
document.

Activating LabWindows/CVI
If you entered a serial number during installation, LabWindows/CVI prompts you to confirm the
activation when you launch LabWindows/CVI for the first time. If you did not enter a serial number
during installation, click Activate Products in the License Status dialog box to launch the NI Activation
Wizard.
Once you choose your activation method and launch the NI Activation Wizard, follow the instructions
on the screen to activate LabWindows/CVI. For more information about activation, refer to the
Activating Your Software topic in the LabWindows/CVI Help.
Note If you are unable to activate LabWindows/CVI, refer to the NI License Activation Web page
at ni.com/activate.

What’s New in LabWindows/CVI?
This section includes information about changes and enhancements in LabWindows/CVI 2010.
Note

The Real-Time features require the LabWindows/CVI 2010 Real-Time Module.

Custom Build Configurations
In previous versions of LabWindows/CVI, project configurations were limited to predefined build
configurations (debug/release, 32-bit/64-bit). You now can create build configurations with customized
LabWindows/CVI build options. You can create multiple build configurations per project.
To create, edit, or remove a custom configuration, select Build»Configuration»Manage
Configurations.
For more information about creating custom build configurations, refer to the Using LabWindows/CVI»
Managing Projects»Setting the Project Configuration book in the LabWindows/CVI Help.

Attach the LabWindows/CVI Debugger to Programs
You can attach the LabWindows/CVI debugger to currently running programs, which allows you to start
debugging without restarting the program from the debugger. To receive the most useful debugging
information, build the DLL or EXE you want to debug in LabWindows/CVI 2010 or later and in debug
configuration.
To attach to a running process, select Run»Attach to Process.
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Additionally, you can debug crashed programs with the LabWindows/CVI just-in-time debugger, which
is installed and registered as the default just-in-time debugger when you install LabWindows/CVI.
If you later install software that registers a different just-in-time debugger, you can re-register the
LabWindows/CVI just-in-time debugger by selecting Tools»Register Just-In-Time Debugger.
For more information about attaching the LabWindows/CVI debugger to running processes, refer to the
Using LabWindows/CVI»Debugging Tools»Debugging Processes topic in the LabWindows/CVI Help.

Arrays of User Interface Controls
Arrays of controls provide convenient programmatic access to controls. For example, you can iterate
through each control in the array, perform batch operations on all controls in the array, and so on.
You can create arrays of controls programmatically and interactively.
For more information about arrays of controls, refer to the Library Reference»User Interface Library»
Control Arrays book in the LabWindows/CVI Help.

User Interface Browser
The User Interface Browser contains a tree view of the user interface objects, such as panels, controls,
and menu bars, related to the selected .uir. When you select or open a .uir file, the User Interface
Browser appears to the right of the User Interface Editor. Double-clicking a control or panel highlights
the object in the User Interface Editor and LabWindows/CVI displays the attributes of the object in the
Attribute Browser. If you double-click an array of controls, LabWindows/CVI highlights the controls in
the User Interface Browser and displays the common attributes of the controls in the array. The User
Interface Browser is the primary resource for interactively editing arrays of controls.
For more information about the User Interface Browser, refer to the Using LabWindows/CVI»
LabWindows/CVI Workspace»Workspace Window Overview»User Interface Browser topic in the
LabWindows/CVI Help.

Updated Win32 API
LabWindows/CVI 2010 includes the Windows 7 version of the Microsoft Interface to Win32
Application Programmatic Interface (API) headers and libraries. The Interface to Win32 API provides
programmatic access to all of the latest features of Microsoft Windows.

Distribution Patching
You can create patches for distributions that you create with LabWindows/CVI 2010 or later. With a
distribution patch, you can make minor updates to an existing distribution installation. Patches contain
only files that must be updated, making the patch smaller and more convenient to distribute. Patches do
not include NI drivers.
When you create a patch, you automatically can include files that have been updated since you built the
distribution on which you are basing the patch. You can specify most of the same options in a patch that
you specify in a new distribution. For example, you can include new files and modify and add registry
keys.
For more information about distribution patching, refer to Using LabWindows/CVI»Managing
Projects»Building a Project»Distributing Applications»Creating Patches for Distributions topic in
the LabWindows/CVI Help.
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FPGA Interface C API Generator
The Tools menu contains the FPGA Interface C API Generator item, which you can use to create a
C program that interacts with LabVIEW FPGA VIs without using LabVIEW. You must have the FPGA
Interface C API Generator, which is available on ni.com, installed to use this tool. The FPGA Interface
C API Generator is optimized for use with LabWindows/CVI.

Backing Up, Restoring, and Replicating RT Targets via USB Thumb Drive (Real-Time)
You can use RT target disk images to back up, restore, and replicate RT targets. An RT target disk image
is a copy of the primary RT target hard drive. You can use an RT Desktop PC Utility USB drive to create
and apply RT target disk images.

Web-Based Monitoring and Configuration (Real-Time)
The Real-Time Module includes support for NI Web-Based Monitoring and Configuration. When you
install NI Web-Based Monitoring and Configuration on an RT target, you can use a Web browser to
monitor and configure the RT target.

Lower CPU Overhead for Hard Drives in AHCI Mode (Real-Time)
The ETS AHCI driver now has lower CPU overhead because it uses Message Signaled Interrupts (MSIs)
instead of polling.

Improved Support for RT Desktop PC Targets (Real-Time)
The Real-Time Module 2010 includes the following improvements for RT desktop PC targets.
•

Expanded Support for IDE-Compatible Hard Drives—The ETS RTOS now detects all
IDE-compatible hard drive controllers. You now can use native IDE mode for SATA hard drive
controllers that do not support AHCI mode.

•

Improved Support for USB Booting—You now can boot an RT desktop PC target using a wider
range of USB drives.

•

Improved RT Desktop PC Evaluator Tool—The USB-based RT desktop PC Evaluator tool now
more accurately diagnoses potential hardware compatibility issues.

Additional LabWindows/CVI Enhancements
LabWindows/CVI 2010 includes the following additional enhancements. Refer to the LabWindows/CVI
Help for more information about these features.

Functions
The following functions are new in LabWindows/CVI 2010.
Advanced Analysis Library
•

CxMultipleToneInfo

•

CxMultipleToneSignal

•

CxSingleToneInfo

•

CxSingleToneSignal

•

MultipleToneInfo

•

MultipleToneSignal

•

SingleToneInfo

•

SingleToneSignal

•

ZeroPhaseFiltering
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Utility Library
•

CmtGetLockEx

•

CmtWaitForThreadPoolFunctionCompletionEx

LabWindows/CVI ActiveX Server Interface
•

AttachDebuggerToProcess

•

DetachDebugger

Attributes
The following attributes are new in LabWindows/CVI 2010.
User Interface
•

ATTR_CHART_HSCROLL_OFFSET

•

ATTR_HORIZONTAL_BAR_COLOR

Events
The following event is new in LabWindows/CVI 2010:
•

EVENT_CTRL_MENU

Menus and Context Menu Changes
•

In the Memory Display window, select a contiguous memory range, right-click and select Add
Memory Watch Expression from the shortcut menu to add a memory-specific expression to the
Watch window.

•

In the line icon area of the Source window, you can select the Disable Breakpoint and Edit
Breakpoint options.

•

Use the Root Drive context menu item in the Installation Files & Directories browser in the Edit
Installer dialog box to specify a drive letter as the base installation location for distributions.

•

The Editable Cell Tree custom control is no longer available in the Create menu of the User
Interface Editor. However, the Editable Cell Tree instrument driver (editableCellTree.fp) is
still installed. If you want to add a tree to your user interface, use the native LabWindows/CVI tree
control.

•

The Enable ‘O’ Option context menu item for source files in the Project Tree is now called
Enable .Obj Option.

•

The View»Library Tree/Attribute Browser menu item is now View»Library Tree. The
Attribute Browser is displayed when a .uir file is open.

•

The Specific Type context menu item for arrays in the Variables and Watch windows is now
Specific Type of Elements. Use this menu item to specify the conceptual type for all elements in
the array.

Dialog Box Changes
•

The Minimum Operating System Version option in the Advanced tab of the Edit Installer dialog
box no longer includes Windows 2000. The minimum operating system version you can specify is
Windows XP.

•

Select Windows Server 2003 or Windows Server 2008 as the minimum or maximum operating
system versions for distributions.

•

The Environment dialog box contains a new option for saving your projects, Save changes before
compiling.
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•

The options in the Build Options dialog box are divided among two tabs, Configuration Options
and Build Process Options.

•

The Save File As dialog box for .uir files includes an option to save a .uir file in
LabWindows/CVI 2010 format.

•

The Make ‘O’ option compatible with CVI 5.0.1 option in the Build Options dialog box has been
renamed to Make .obj option compatible with CVI 5.0.1.

•

The Auto hide Project Tree and Library Tree/Attribute Browser option in the Environment
dialog box is now the Auto Hide Project Tree and Library Tree option. The Attribute Browser
is displayed when a .uir file is open.

•

The Active Compiler option in the Build Options dialog box is replaced by two options: Active
32-bit compiler and Active 64-bit compiler.

•

The Release Configuration button in the Edit Project dialog box is replaced by two buttons: 32-Bit
Release Configurations and 64-bit Release Configurations.

Additional Features
•

Compile LabWindows/CVI code with Clang as the external optimizing compiler.

•

Specify a third-party compiler for 64-bit projects.

•

Use new special variables in build steps for distributions and projects:

•

–

%CVITARGETFILEVER% to specify the target file version

–

%CVITARGETPRODVER% to specify the product version

Use new predefined macros for versioning:
–

_TARGET_FILE_VERSION_, which is defined as the value in the File Version option in the

Version Info dialog box.
–

_TARGET_PRODUCT_VERSION_, which is defined as the value in the Product Version

option in the Version Info dialog box.
•

Use the %configname variable in the Version Info dialog box to specify a configuration for your
application.

•

Use the -config argument to specify a custom configuration in the command line interface.

•

LabWindows/CVI supports hexadecimal floating point literals per the C99 specification.

•

LabWindows/CVI supports the following math.h macros:

•

–

HUGE_VAL

–

HUGE_VALF

–

INFINITY

–

NAN

–

FP_INFINITE

–

FP_NAN

–

FP_NORMAL

–

FP_SUBNORMAL

–

FP_ZERO

The LabWindows/CVI compiler recognizes $ as a valid character in a symbol identifier.

•

The LabWindows/CVI compiler recognizes the ## token.

•

LabWindows/CVI supports empty parameter lists for variable argument macros.
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•

The command line interface for the LabWindows/CVI Real-Time File Copy Utility provides an
option to reboot the RT target.

•

The following white papers are no longer installed as PDFs with LabWindows/CVI. The content
for these white papers is integrated into the LabWindows/CVI Help.
White Paper

Table of Contents Path in LabWindows/CVI Help

Multithreading in LabWindows/CVI

Programmer Reference»Creating Multithreaded
Applications

Programming for Multibyte Character
Sets in LabWindows/CVI

Programmer Reference»Programming for Multibyte
Character Sets in LabWindows/CVI

Building ActiveX Servers in
LabWindows/CVI

Library Reference»ActiveX Library»Building ActiveX
Servers in LabWindows/CVI

Building Networked Applications
with the LabWindows/CVI TCP
Support Library

Library Reference»TCP Support Library»Building
Networked Applications with the LabWindows/CVI TCP
Support Library

Using LabWindows/CVI DLLs in
LabVIEW Real-Time Applications

Programmer Reference»Creating and Downloading DLLs
to Real-Time Targets»Creating and Downloading
Real-Time DLLs via LabVIEW

Deprecated Features
•

National Instruments no longer supports Windows 2000.

•

The Object File Format option in the Advanced Compiler Options dialog box is no longer
available because LabWindows/CVI no longer supports the Borland compatibility mode.

•

LabWindows/CVI no longer installs the help for the Interface to Win32 API. National Instruments
recommends that you view the latest version of this documentation at www.msdn.com. For more
information, visit ni.com/info and enter the Info Code msdn.

LabWindows/CVI Resources
How do I get started?
Read the Getting Started with LabWindows/CVI manual, which provides a tutorial for learning basic
LabWindows/CVI program development techniques.
Are there known issues or late-breaking information?
Refer to the LabWindows/CVI Readme, which you can access from Start»All Programs»
National Instruments»LabWindows CVI 2010»LabWindows CVI 2010 Readme. The readme file
contains information about known issues.
Where can I find reference information?
The LabWindows/CVI Help contains complete reference information. The help file includes the
following sections:
•

Using LabWindows/CVI describes the LabWindows/CVI development environment and features.

•

Library Reference provides information about functions you can call in LabWindows/CVI.

•

Programmer Reference provides information to help you develop applications.

•

Tools Library provides information about the LabWindows/CVI Toolslib controls.

LabWindows/CVI Release Notes

8

ni.com

•

LabWindows/CVI Real-Time Module Help includes an introduction to the LabWindows/CVI
Real-Time Module, programming considerations for RT applications, and function reference
information for the LabWindows/CVI Real-Time Utility Library. You must have the
LabWindows/CVI Real-Time Module installed to view this help file.

Use the Search tab in the LabWindows/CVI Help to quickly locate specific information. For information
about how to use the search functionality, refer to the Using Help»Searching Help topic of the
LabWindows/CVI Help.
Where can I find examples?
Find examples with the NI Example Finder, which you can access by selecting Help»Find Examples.
LabWindows/CVI example programs are located in the following location on Windows 7/Vista/Server
2008: C:\Users\Public\Documents\National Instruments\CVI2010\samples.
On Windows XP/Server 2003, example programs are located in the following location:
C:\Documents and Settings\All Users\Documents\National Instruments\
CVI2010\samples.

Is there a list of LabWindows/CVI documentation?
The Guide to LabWindows/CVI Documentation topic describes documentation available for new users
and upgrade users. In addition, this topic provides links to LabWindows/CVI documentation, including
manuals and web resources. You can access the Guide to LabWindows/CVI Documentation topic
through the LabWindows/CVI Help.
Where else can I go for LabWindows/CVI information?
Visit the LabWindows/CVI Web site and NI Developer Zone at ni.com for the most up-to-date
information about LabWindows/CVI.
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CVI, LabVIEW, National Instruments, NI, ni.com, the National Instruments corporate logo, and the
Eagle logo are trademarks of National Instruments Corporation. Refer to the Trademark Information at
ni.com/trademarks for other National Instruments trademarks. The mark LabWindows is used
under a license from Microsoft Corporation. Windows is a registered trademark of Microsoft
Corporation in the United States and other countries. Other product and company names mentioned
herein are trademarks or trade names of their respective companies. For patents covering
National Instruments products/technology, refer to the appropriate location: Help»Patents in your
software, the patents.txt file on your media, or the National Instruments Patent Notice at
ni.com/patents. For copyright notices, conditions, and disclaimers, including information
regarding certain third-party components used in LabWindows/CVI, refer to the Copyright topic of
the LabWindows/CVI Help.
© 2003–2010 National Instruments Corporation. All rights reserved.
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