
LabWindows /CVI  Release 
Notes 
Version 8.1

These release notes introduce LabWindows™/CVI™ 8.1. Refer to this document for system 
requirements, installation and activation instructions, and information about new features in 
LabWindows/CVI.
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Minimum System Requirements
To run LabWindows/CVI, you must have the following items:

• Personal computer using a Pentium 1 GHz or higher microprocessor

• Microsoft Windows 2000 Service Pack 3 or higher or Windows XP

• 1024 × 768 resolution (or higher) video adapter

• Minimum of 128 MB of RAM, 256 MB recommended

• 200 MB free hard disk space for full installation

• Microsoft-compatible mouse

Installation Instructions
Complete the following steps to install LabWindows/CVI 8.1:

Note If you already have a different version of LabWindows/CVI installed on your 
computer, be sure to install version 8.1 in a different directory or uninstall the other version 
before installing LabWindows/CVI 8.1.

1. Insert the LabWindows/CVI CD into the CD drive. If the CD does not run automatically, 
open Windows Explorer, right-click the CD drive icon, and select AutoPlay.

2. Select Install LabWindows/CVI on the National Instruments LabWindows/CVI screen.

3. LabWindows/CVI prompts you to enter your user information. Select one of the 
following options:

• Install this product using the following serial number

• Install this product for evaluation

If you choose to enter a serial number, enter the serial number found on your Certificate 
of Ownership card. LabWindows/CVI automatically uses this serial number when you 
run the NI Activation Wizard.

4. Continue to follow the instructions on the screen.

Activation Instructions
When the installation completes, you will be prompted to activate LabWindows/CVI. You can 
activate at this time, or you can activate when you launch LabWindows/CVI. If you want to 
activate at the end of the installation, click Next to launch the NI Activation Wizard. If you 
want to activate later, deselect the Activate this version of LabWindows/CVI now option. 
If you choose to activate later, you will see a dialog box requiring you to activate a 
LabWindows/CVI license or run in evaluation mode when you first launch 
LabWindows/CVI. Click Activate in this dialog box to launch the NI Activation Wizard.
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Complete the following steps to activate LabWindows/CVI:

1. Select the Automatically activate through a secure Internet connection option and 
click Next. Your computer must be connected to the Internet for this option to work. If 
you do not have Internet access on your computer, refer to the instructions following 
these steps.

2. The serial number should be automatically entered for you. If not, enter the serial number 
found on your Certificate of Ownership card and click Next.

3. Fill in the necessary information and click Next.

4. Check the option if you would like to receive a confirmation email of your activation and 
click Next.

5. After a brief moment, you should receive a message indicating whether 
LabWindows/CVI has been activated or not. Enter or verify your serial number. Click 
Next.

6. Continue to follow the instructions on the screen.

7. When you successfully activate LabWindows/CVI, click Finish. LabWindows/CVI will 
then display a window indicating when this license will expire.

If you do not have Internet access on the computer requiring activation, complete the 
following steps to activate LabWindows/CVI:

1. Select the Use a web browser, email client, telephone, or fax machine to acquire an 
activation code option to acquire an activation code. Click Next.

2. Select Use a Web browser on this or another computer. If you have multiple NI 
products installed on your computer, you may need to select the version of 
LabWindows/CVI you want to activate. Click Next.

3. Keep the default serial number, click Next, and click Save this information to save the 
serial number, computer ID, product, and version number in a text file.

4. Go to the NI License Activation Web page on ni.com/activate.

5. Select LabWindows/CVI as the Product to Activate and 8.1 as the Product Version. 
Fill out the form with the information required and click Continue. This step generates 
the activation code for you.

6. Go back to the LabWindows/CVI activation dialog box and enter that activation code to 
activate LabWindows/CVI.

7. If you are unable to activate LabWindows/CVI, refer to the NI License Activation Web 
page on ni.com/activate.

What’s New in LabWindows/CVI?
This section includes information about changes and enhancements in LabWindows/CVI 8.1.

Note Real-Time features require the LabWindows/CVI 8.1 Real-Time Module. The 
LabWindows/CVI 8.1 Real-Time Module will be available for purchase after the release of 
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LabWindows/CVI 8.1. For more information, contact your local NI branch office. Refer to 
the Technical Support and Professional Resources topic in the LabWindows/CVI Help for 
more information about contacting NI branch offices.

Network Variable Library
LabWindows/CVI 8.1 includes a new library, the Network Variable Library, to share data 
between applications running on the same or different computers. The Network Variable 
Library uses the NI Publish-Subscribe Protocol (NI-PSP).

With the Network Variable Library, you can communicate with LabVIEW shared variables 
and with Measurement Studio network variables. You also can use this library in your 
Real-Time (RT) applications.

Note This library supersedes the DataSocket Library and provides better performance and 
scalability.

For more information about the Network Variable Library, refer to the Library Reference»
Network Variable Library section in the LabWindows/CVI Help.

TDM Streaming Library
LabWindows/CVI 8.1 includes a new library, the TDM Streaming Library, to log large 
amounts of data quickly. This library uses the TDM Streaming file format. You can then use 
DIAdem to analyze the data you logged with the TDM Streaming Library.

For more information about the TDM Streaming Library, refer to the Library Reference»
TDM Streaming Library section of the LabWindows/CVI Help.

Enhancements to DIAdem Library
The DIAdem Library has been enhanced to provide support for custom properties, support for 
the new TDM Streaming file format, support for enumerating properties, checking for the 
existence of specific properties, and checking property types.

For more information about the DIAdem Library, refer to the Library Reference»DIAdem 
Connectivity Library section of the LabWindows/CVI Help.

Updated User Interface Control Appearance
User interface controls are updated to display based on the Theme setting in the Windows 
Display Properties dialog box. Updated user interface controls appear on Windows XP and 
later. 

You can enable and disable the Theme-based appearance with the 
ATTR_CONFORM_TO_SYSTEM_THEME and ATTR_DISABLE_PANEL_THEME panel attributes.
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For more information about Theme-based appearance for controls, refer to the Using 
LabWindows/CVI»Developing a Graphical User Interface»Setting User Interface Editor 
Preferences topic in the LabWindows/CVI Help.

RS-232 Library in Real-Time Applications
Use RS-232 Library functions to develop new RT applications that use serial communication. 
You also can port existing applications that use the RS-232 Library to an RT system.

For more information about RS-232 and RT applications, refer to the Library Reference»
RS-232 Library section and the Programmer Reference»Creating and Downloading DLLs to 
Real-Time Targets section of the LabWindows/CVI Help.

Asynchronous Timers in Real-Time Applications
Use the asynchronous timers instrument driver (asynctmr.fp) in your RT applications. 
You also can port existing applications that use asynchronous timers to an RT system. 
Asynchronous timers help you program recurring tasks.

For more information about asynchronous timers, refer to the Tools Library»Asynchronous 
Timers section of the LabWindows/CVI Help.

New User Interface Events
LabWindows/CVI 8.1 includes new events that give you more control over the user interface. 
The following table lists the new events:

For more information about the new and updated events, refer to the Library Reference»
User Interface Library»Events section of the LabWindows/CVI Help.

HTML Files from Function Panels
Generate HTML help files from function panel help. The Options»Generate 
Documentation feature creates one HTML file per function panel, an overview file, and 
alphabetical and hierarchical lists of the functions. You do not need to include HTML tags in 
your function panel help to generate HTML files.

EVENT_MOUSE_POINTER_MOVE

EVENT_LEFT_CLICK_UP

EVENT_RIGHT_CLICK_UP

EVENT_MOUSE_WHEEL_SCROLL

EVENT_PANEL_SIZING

EVENT_PANEL_MOVING

EVENT_RADIX_CHANGE

EVENT_ZOOM

EVENT_TABLE_ROW_COL_LABEL_CLICK

EVENT_INTERACTIVE_LEGEND
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For more information about generating HTML files, refer to the Using LabWindows/CVI»
Instrument Drivers»Building Instrument Drivers»Generating Documentation topic of the 
LabWindows/CVI Help.

ActiveX Server Interface Breakpoint Functions
LabWindows/CVI 8.1 includes new functions to programmatically control breakpoints as you 
debug your code through the LabWindows/CVI ActiveX server interface. Use the functions 
to create and configure breakpoints, line tags, and excluded lines.

For more information about the ActiveX server interface breakpoint functions, refer to the 
Using LabWindows/CVI»Accessing the LabWindows/CVI ActiveX Server Interface section of 
the LabWindows/CVI Help.

Support for .NET Generics
The LabWindows/CVI .NET Library now supports generics, a new feature in .NET 
Framework 2.0. .NET generics are similar to C++ templates. You can use functions in the 
.NET Library to call generic classes, call generic methods, and call members of generic 
interfaces.

For more information about generics, refer to the Library Reference».NET Library section of 
the LabWindows/CVI Help.

Project and File Templates
You can create projects and files using templates. Select File»New»Project from Template 
to create a project containing the settings configured in the template you select. Select 
File»New»File from Template to create a file containing the settings configured in the 
template you select.

You also can create your own projects and files to use as templates.

For more information about templates, refer to the Using LabWindows/CVI»Managing 
Projects»Creating Projects and Files from Templates section in the LabWindows/CVI Help.

.TIF Image Support
LabWindows/CVI supports .tif images. You can create a .tif file with the 
SaveBitmapToTIFFile function.

For more information about .tif files, refer to the Library Reference»User Interface 
Library»Overview»Common User Interface Objects»Using Bitmap Objects topic in the 
LabWindows/CVI Help.
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New Advanced Analysis Library Functions
The Advanced Analysis Library has been updated to include the following functions:

Note The Advanced Analysis Library is available in the LabWindows/CVI Full 
Development System only.

For more information about the updated Advanced Analysis Library, refer to the Library 
Reference»Advanced Analysis Library section of the LabWindows/CVI Help.

Edit Multiple Controls
You can select multiple user interface controls of the same type and edit them simultaneously. 
Select multiple controls and select Edit»Controls or double-click the controls to open the 
Edit Control dialog box.

For more information, refer to the Using LabWindows/CVI»Developing a Graphical User 
Interface»Editing a User Interface»Editing Controls topic in the LabWindows/CVI Help.

Source Code Color Printing
When you print source files to a color printer, LabWindows/CVI prints the files using the 
default syntax colors.

Windows BartHannWin
BohmanWin
ParzenWin
WelchWin

Signal Generation GaussModSine
GaussMonopulse
PeriodicSinc
UnsymmetricTriangle

Transform InvChirpZT

Filter FIRFiltering
FIRFiltering_CxInput
IIRFiltering_CxInput
SavitzkyGolayCoef
SavitzkyGolayFiltering
SavitzkyGolayFiltering_CxInput

Linear Algebra CxKronProduct
KronProduct

Time Series CxDecimate

Curve Fitting PolyFitWithWeight
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For more information about source code color printing, refer to the Using LabWindows/CVI»
Writing Source Code»Printing Source Files topic in the LabWindows/CVI Help.

Edit Graph Axes Interactively
You can edit graph axis values at run time. Double-click the minimum or maximum axis label 
value to edit it. When you modify the value, the axis range changes based on the new value.

For more information about editing graph axes interactively, refer to the Library Reference»
User Interface Library»Controls»Control Types»Graph Control section of the 
LabWindows/CVI Help.

LabWindows/CVI Resources
How do I get started?

Read the Getting Started with LabWindows/CVI manual, which provides a tutorial for 
learning basic LabWindows/CVI program development techniques.

Are there known issues or late-breaking information?

Refer to the LabWindows/CVI Readme, which you can access from Start»Programs»
National Instruments»LabWindows CVI 8.1»LabWindows CVI Readme. The readme 
file contains information about known issues.

Where can I find reference information?

The LabWindows/CVI Help contains complete reference information. The help file includes 
the following sections:

• Using LabWindows/CVI describes the LabWindows/CVI development environment and 
features.

• Library Reference provides information about functions you can call in 
LabWindows/CVI.

• Programmer Reference provides information to help you develop applications.

• Tools Library provides information about the LabWindows/CVI Toolslib controls.

Use the Search tab in the LabWindows/CVI Help to quickly locate specific information. For 
information about how to use the search functionality, refer to the Using Help»Searching 
Help topic in the LabWindows/CVI Help.

Where can I find examples?

Find examples with the NI Example Finder, which you can access by selecting Help»Find 
Examples.
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Is there a list of LabWindows/CVI documentation?

The Guide to LabWindows/CVI Documentation topic provides links to LabWindows/CVI 
documentation, including manuals, application notes, and white papers. You can access the 
Guide to LabWindows/CVI Documentation topic through the LabWindows/CVI Help.

Where else can I go for LabWindows/CVI information?

Visit the LabWindows/CVI Web site and NI Developer Zone at ni.com for the most 
up-to-date information about LabWindows/CVI.

http://www.ni.com
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