
LabWindows /CVI  Release Notes
Version 8.0.1

These release notes introduce LabWindows™/CVI™ 8.0.1. Refer to this document for system 
requirements, installation and activation instructions, and information about new features in 
LabWindows/CVI.
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Minimum System Requirements
To run LabWindows/CVI, you must have the following items:

• Personal computer using a Pentium 600 or higher microprocessor

• Windows 2000/XP

• 800 × 600 resolution (or higher) video adapter

• Minimum of 128 MB of RAM, 256 MB recommended

• 150 MB free hard disk space for full installation

• Microsoft-compatible mouse

Installation Instructions
Complete the following steps to install LabWindows/CVI 8.0.1:

Note If you have LabWindows/CVI 7.x or earlier installed on your computer, be sure to 
install version 8.0.1 in a different directory or uninstall the earlier version before installing 
version 8.0.1. If you have LabWindows/CVI 8.0 installed on your computer, you can install 
version 8.0.1 in the same directory. In this case, LabWindows/CVI 8.0.1 overwrites 
LabWindows/CVI 8.0.

1. Insert the LabWindows/CVI CD into the CD drive. If the CD does not run automatically, 
open Windows Explorer, right-click the CD drive icon, and select AutoPlay.

2. Select Install LabWindows/CVI on the National Instruments LabWindows/CVI screen. 

3. LabWindows/CVI prompts you to enter your user information. Select one of the 
following options:

• Install this product using the following serial number

• Install this product for evaluation

If you choose to enter a serial number, enter the serial number found on your Certificate 
of Ownership card. LabWindows/CVI automatically uses this serial number when you 
run the NI Activation Wizard.

4. Continue to follow the instructions on the screen.

Activation Instructions
Complete the following steps to activate LabWindows/CVI 8.0.1:

1. When you launch LabWindows/CVI for the first time after installation, 
LabWindows/CVI displays the Evaluation License dialog box. Click Activate to launch 
the NI Activation Wizard.
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2. In the NI Activation Wizard, select one of the following methods to acquire the activation 
code and click Next.

• Automatically activate through a secure Internet connection—Automatically 
receive an activation code.

• Use a Web browser, email client, telephone, or fax machine to acquire an 
activation code—Contact National Instruments to obtain an activation code. You 
will then enter the code in the NI Activation Wizard to activate LabWindows/CVI.

• Apply a 20-character activation code previously acquired for this 
computer—Enter a code you have obtained to activate LabWindows/CVI.

Note The remaining instructions assume you select the Automatically activate through 
a secure Internet connection option. If you select an alternate option, follow the 
instructions on the screen to complete product activation.

3. Enter or verify your serial number. Click Next.

4. Continue to follow the instructions on the screen.

5. When you successfully activate LabWindows/CVI, click Finish.

What’s New in LabWindows/CVI?
This section includes information about changes and enhancements in LabWindows/CVI.

Download LabWindows/CVI DLLs to Real-Time Targets
You can use LabWindows/CVI to create a DLL that you can download to an RT target directly 
from LabWindows/CVI. After LabWindows/CVI downloads the DLL, you can debug the 
DLL on the RT target or deploy the DLL to a production RT target. You must have the 
LabWindows/CVI 8.0 Real-Time Module installed on your computer to use this feature.

For more information about downloading DLLs, refer to the Programmer Reference»
Creating and Downloading DLLs to Real-Time Targets section of the LabWindows/CVI 
Help.

Create Visual Studio 2005 Projects That Use LabWindows/CVI Libraries
Use the LabWindows/CVI Application Wizard to create a new Visual C++ project that uses 
LabWindows/CVI libraries. You also can use the LabWindows/CVI Conversion Wizard to 
convert an existing LabWindows/CVI project to a Visual C++ project. To use these wizards, 
you must have installed Microsoft Visual Studio 2005 or later (Standard edition or higher).

For more information about creating Visual Studio 2005 projects that use LabWindows/CVI 
libraries, refer to the Using LabWindows/CVI»Wizards and Tools»Creating Visual Studio 
2005 Projects section of the LabWindows/CVI Help.
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Call .NET Assemblies
Use the .NET Library to call .NET assemblies. LabWindows/CVI also provides the Create 
LabWindows/CVI .NET Controller dialog box, which you can use to generate an instrument 
driver that serves as a wrapper for a .NET assembly.

For more information about using .NET assemblies in LabWindows/CVI, including sample 
code, refer to the Library Reference».NET Library section of the LabWindows/CVI Help.

Create Optimized Code
You can use an external optimizing compiler to compile LabWindows/CVI code from within 
the LabWindows/CVI environment. To compile your code using an external optimizing 
compiler, you must create a compiler configuration for that compiler. LabWindows/CVI 
provides configuration templates for Microsoft Visual C++, Borland, and Intel compilers.

For more information about creating optimized code, refer to the Programmer Reference»
Creating Optimized Code section of the LabWindows/CVI Help.

Add Tabs to Graphical User Interfaces
Use the tab control to organize user interface panels into multiple tabbed pages. As with all 
other LabWindows/CVI controls, you can create and modify tab controls programmatically 
or in the User Interface Editor.

For more information about the tab control, refer to the Library Reference»User Interface 
Library»Controls»Control Types»Tab Control section of the LabWindows/CVI Help.

Use Updated Graph Control Features
You can use the graph control features for the following tasks:

• Add annotations to specified data points

• Use absolute and relative time formats for graph axes

• Change plot settings interactively with the graph legend

• Convert pixels to graph units

• Use multi-line text in custom axis label text strings

For more information about the graph control features, refer to the Library Reference»User 
Interface Library»Controls»Control Types»Graph Control section of the LabWindows/CVI 
Help.

Distribute LabWindows/CVI Applications
LabWindows/CVI provides a redesigned way to distribute applications. You now can 
create a distribution that includes not only the LabWindows/CVI application but also its 
dependencies. Use the new distribution creation feature to include NI product drivers and 
custom merge modules in installers.
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For more information about the new distribution system, refer to the Using 
LabWindows/CVI»Managing Projects»Building a Project»Distributing Applications section 
of the LabWindows/CVI Help.

View the Source Code Browser in the Workspace Window
You can view and interact with the Source Code Browser from within the Workspace window. 
LabWindows/CVI displays the Source Code Browser at the bottom of the Workspace 
window.

Include New Cell Types in the Table Control
The table control now supports ring, combo box, and button cells. The table control continues 
to support numeric, picture, and string cells, as it has in previous versions.

For more information about the table control, refer to the Library Reference»User Interface 
Library»Controls»Control Types»Table Control section of the LabWindows/CVI Help.

Use New Advanced Analysis Library Functions
The Advanced Analysis Library has been improved to include new curve fitting and 
windowing functions, high-performance linear algebra functions, and enhancements to 
two-dimensional Fast Fourier Transform (FFT) analysis and other signal processing features.

Note The Advanced Analysis Library is available in the LabWindows/CVI Full 
Development System only.

For more information about the updated Advanced Analysis Library, refer to the Library 
Reference»Advanced Analysis Library section of the LabWindows/CVI Help.

Customize Menu Bars
You can customize menu bars by adding images to menu items and specifying a font for 
menu bars. For more information about customizing menu bars, refer to the Using 
LabWindows/CVI»Developing a Graphical User Interface»Creating a GUI»Menu Bars»
Creating a Menu Bar topic in the LabWindows/CVI Help.

Enhance Toolbars
You can add pull-down menus, string controls, and color numeric controls to the toolbar. You 
also can include multiple toolbars on a single panel. The updated toolbar instrument driver 
provides a move handle, which you can place on a toolbar to allow a user to dock and undock 
the toolbar and to move the toolbar from one panel to another.

For more information about the toolbar, refer to the Tools Library»Toolbar Control section 
of the LabWindows/CVI Help.
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Record Macros
You can record macros in the Source window to save and repeat a series of actions, such as 
keystrokes and menu selections. For more information about macros, refer to the Using 
LabWindows/CVI»Writing Source Code»Recording Macros topic in the LabWindows/CVI 
Help.

Auto-Indent Source Files
LabWindows/CVI automatically indents source code based on the bracket style preferences 
you specify. The auto-indent feature is turned on by default. You can set auto-indent options 
in the Editor Preferences dialog box.

Enable Documentation Tooltips for User-Defined Functions
You can add special tags to functions you define to make documentation for these functions 
available throughout your project. For more information about adding the documentation 
tags, refer to the Using LabWindows/CVI»Writing Source Code»Editing a Source File»
Documenting Source Code topic in the LabWindows/CVI Help.

Include Alpha-Channel Data in Image Files
You can set alpha-channel data in bitmaps you use in LabWindows/CVI to create partially 
transparent images. To set alpha-channel data, you must use the .png file format. 
LabWindows/CVI includes the following functions specifically for .png support:

• NewBitmapEx

• SetBitmapDataEx

• GetBitmapDataEx

• GetBitmapInfoEx

• AllocBitmapDataEx

• SaveBitmapToPNGFile

For more information about alpha-channel data and .png files, refer to the Library 
Reference»User Interface Library»Overview»Common User Interface Objects»Using 
Bitmap Objects topic in the LabWindows/CVI Help.

Experience Improved DIAdem Connectivity Library Performance
The updated DIAdem Connectivity Library now features improved performance for 
appending data to an existing file. For more information about the DIAdem Connectivity 
Library, refer to the Library Reference»DIAdem Connectivity Library section of the 
LabWindows/CVI Help.
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Use the Enhanced Instrument I/O Assistant
The Instrument I/O Assistant now features improved code generation capabilities. You also 
can configure instrument inputs at run time using the assistant. For more information about 
the Instrument I/O Assistant, refer to the Using LabWindows/CVI»Wizards and Tools»
Creating an Instrument I/O Task section of the LabWindows/CVI Help.

Create IVI Class Drivers with the IVI Custom Class Driver Wizard
Use the new IVI Custom Class Driver Wizard to help you create IVI class drivers for 
instrument classes not defined by the IVI Foundation. With custom class drivers, you can 
replace one instrument belonging to that class with another instrument without modifying 
your test applications. This new wizard automatically generates source (.c), include (.h), and 
function panel (.fp) files for your custom IVI class driver. 

For more information about the wizard, refer to the Using LabWindows/CVI»Wizards and 
Tools»Creating an IVI Custom Class Driver section of the LabWindows/CVI Help.

LabWindows/CVI Resources
How do I get started?

Read the Getting Started with LabWindows/CVI manual, which provides a tutorial for 
learning basic LabWindows/CVI program development techniques.

Are there known issues or late-breaking information?

Refer to the LabWindows/CVI Readme, which you can access from Start»Programs»
National Instruments»LabWindows CVI 8.0.1»LabWindows CVI Readme. The readme 
file contains information about known issues.

Where can I find reference information?

The LabWindows/CVI Help contains complete reference information. The help file includes 
the following sections:

• Using LabWindows/CVI describes the LabWindows/CVI development environment and 
features.

• Library Reference provides information about functions you can call in 
LabWindows/CVI.

• Programmer Reference provides information to help you develop applications.

• Tools Library provides information about the LabWindows/CVI Toolslib controls.

Use the Search tab in the LabWindows/CVI Help to quickly locate specific information. For 
information about how to use the search functionality, refer to the Using Help»Searching 
Help topic in the LabWindows/CVI Help.
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Where can I find examples?

Find examples with the NI Example Finder, which you can access by selecting Help»Find 
Examples.

Is there a list of LabWindows/CVI documentation?

The Guide to LabWindows/CVI Documentation topic provides links to LabWindows/CVI 
documentation, including manuals, application notes, and white papers. You can access the 
Guide to LabWindows/CVI Documentation topic through the LabWindows/CVI Help.

Where else can I go for LabWindows/CVI information?

Visit the LabWindows/CVI Web site and NI Developer Zone at ni.com for the most 
up-to-date information about LabWindows/CVI.

http://www.ni.com
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