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This document contains information about calibrating National
Instruments 9265 modules using NI-DAQmx. This calibration procedure is
intended for metrology labs.

This document does not discuss programming techniques or compiler
configuration. The NI-DAQmx driver contains online help files that have
compiler-specific instructions and detailed function explanations. You can
install these help files when you install NI-DAQmx on the calibration

computer.
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Conventions

»

bold

italic

monospace

monospace italic

Software

The following conventions appear in this manual:

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names and hardware labels.

Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

Monospace text denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

Ttalic text in this font denotes text that is a placeholder for a word or value
that you must supply.

Install NI-DAQmx 8.5 or later on the calibration computer. NI-DAQmx
includes high-level function calls to simplify the task of writing software to
calibrate devices. You must have the proper device driver installed on the
calibration system before calibrating the device.

@ Note NI recommends that you install the NI-DAQmx driver software before physically
installing the NI 9265. NI-DAQmx, available at ni . com/downloads, configures and
controls the NI 9265.

NI 9265 Calibration Procedure

NI-DAQmx supports a number of programming languages, including
LabVIEW, LabWindows™/CVI™, Microsoft Visual C++ 6.0, Microsoft
Visual Basic 6.0, Microsoft .NET, and Borland C++.
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You can access the NI-DAQmx header file, NIDAQmx . h, like any standard
library. You can find examples of how to use the NI-DAQmx driver in the
Program Files\National Instruments\NI-DAQ\Examples
directory.

Documentation

You might find the following documentation helpful as you write the
calibration procedure:

NI-DAQmx Help—This help file contains general information about
measurement concepts, key NI-DAQmzx concepts, and common
applications that apply to all programming environments. To access
this help file, select Start»All Programs»National Instruments»
NI-DAQ»NI-DAQmx Help.

NI-DAQmx C Reference Help—This help file contains C reference and
general information about measurement concepts. To access this help
file, select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

DAQ Getting Started Guide for NI-DAQ 8.0 or later—This guide
describes how to install NI-DAQmzx for Windows software and
NI-DAQmzx-supported DAQ devices, and how to confirm that your
device is operating properly. To access this guide, select Start»
All Programs»National Instruments»NI-DAQ»DAQ Getting
Started Guide.

@ Note The documents above are installed with NI-DAQmx. You can also download the
latest versions from the NI Web site at ni . com/manuals.

NI 9265 Operating Instructions and Specifications—This document
describes how to use the NI 9265 and includes specifications and
terminal assignments for the NI 9265. You can download the latest
version of this document from the NI Web site at ni . com/manuals.

Calibration Interval

The NI 9265 should be calibrated at a regular interval as defined by

the measurement accuracy requirements of your application. National
Instruments recommends that you routinely perform a complete calibration
at least once every year. You can shorten this interval based on the accuracy
demands of your application or requirements of your processes.

© National Instruments Corporation
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Test Equipment

National Instruments recommends that you use the following equipment
for calibrating the NI 9265.

Table 1. Recommended Equipment

Equipment Recommended Model Requirements

DMM NI 4070 DMM If this instrument is unavailable, use a
multiranging 6 1/2 digit DMM with a
DC current measurement accuracy of
400 ppm.

Chassis NI cDAQ-9172 —

Bench-top power supply — 9-36 VDC output voltage

Test Conditions

Follow these guidelines to optimize the connections and the environment:

*  Keep connections to the device as short as possible. Long cables and
wires act as antennae, picking up extra noise that can affect
measurements.

»  Use shielded copper wire for all cable connections to the device.
Use twisted-pair wire to eliminate noise and thermal offsets.

e Maintain an ambient temperature of 23 +5 °C. The device temperature
will be greater than the ambient temperature.

*  Keep relative humidity below 80%.

e Allow a warm-up time of at least 10 minutes to ensure that the
measurement circuitry is at a stable operating temperature.

Calibration Procedure

This section provides instructions for verifying the performance of the
NI 9265.

Calibration Process Overview
The calibration process consists of the following steps:
1. Initial Setup—Configure the device in NI-DAQmx.

2. Verification Procedure—Verify the existing operation of the device.
This step confirms whether the device is operating within its specified
range and whether it needs adjustment.
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3. Adjustment—If the device does not fall within the desired
specifications, submit the device to NI for a factory calibration to
adjust the calibration constants.

4. Verification Procedure—Perform another verification to ensure that
the device operates within its specifications after adjustment.

The first two steps are explained in the following sections.

Initial Setup

You must configure the device in Measurement & Automation Explorer
(MAX) to communicate with NI-DAQmx.

Complete the following steps to configure a device in MAX:
1. Install the NI-DAQmx driver software.

2. Make sure that no power is connected to the module terminals. If the
system is in a nonhazardous location, the chassis power can be on
when you install the module.

3. Insert the module into an available slot in the cDAQ-9172 chassis.
4. Launch MAX.

5. Right-click the device name and select Self-Test to ensure that the
device is working properly.

@ Note When a device is configured with MAX, it is assigned a device name. Each function
call uses this device name to determine which DAQ device to calibrate. This document uses
dev1 to refer to the device name. In the following procedures, use the device name as it
appears in MAX.

Verification Procedure

Verification determines how well the device is meeting its specifications.
By completing this procedure, you can see how the device has drifted over
time, which helps you determine the appropriate calibration interval for
your application. Table 3 in the Test Limits section shows all acceptable
settings for the device type. Throughout the verification process, use
Table 3 to determine if the device is operating within its specified range.

Complete the following steps to test the performance of the device:

1. Connect the negative lead of the bench-top power supply to Power
Supply COM, and the positive lead of the power supply to the supply
terminal, Vg,
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2. Connect the DMM to the channel you want to verify. Connect the
negative output of the DMM to COM and the positive output of the
DMM to AO. Refer to Figure 1 for the terminal assignments of the
NI 9265.

S
AOO (0]
COMO ]IS
AOT [2](|S)
comi 13](|S)
AO2 141
CcoM2 15](|S)
AO3 16 /IS
Ccom3 HiS
Vsup 18]I
Power Supply COM 9 (| [

S

|

Figure 1. NI 9265 Terminal Assignments

3. Set the output current of the selected channel of the NI 9265 to a
Test Point value indicated in Table 3.

4. Ifyouuse C function calls, create a task using DAQmxCreateTask, as
shown in the following table. If you use LabVIEW, skip this step. The
task is created in step 5 in LabVIEW.

LabVIEW Block Diagram NI-DAQmx Function Call

Call bAQmxCreateTask with
the following parameters:

LabVIEW does not require this step. taskName:

AQVerificationTask
taskHandle: staskHandle
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5. Create and configure an AO current channel using the DAQmx Create
Virtual Channel VI, as shown in the following table.

E Note Throughout the procedure, refer to the NI-DAQmx function parameters for the
LabVIEW input values. Refer to the block diagram images for the correct instance to use

for polymorphic VIs.
LabVIEW Block Diagram NI-DAQmx Function Call
Call
DAQmxCreateAOCurrentChan
with the following parameters:
| taskHandle: taskHandle
physicalChannel: dev1/aox”
r nameToAssignToChannel:
- kask out myCurrentChannel
phyysical channels S ;
| DAL= :
it B0 terminal Config
R DAQmx_Val_Cfg Default
ML minvako
Tecif AD Currenk ™ E=H :
maxVal: 0.02
units: DAQmx_Val_Amps
customScaleName: NULL
* X refers to the channel number.

6. Configure the timing properties for the current generation using the
DAQmzx Timing VI, as shown in the following table.

LabVIEW Block Diagram NI-DAQmx Function Call

Call DAQmxCfgSampClkTiming
with the following parameters:

karmples per channel

taskHandle: taskHandle
source: NULL
rate: 100000.0

H activeEdge:

0 kask ook gl. o
Wﬂ DAQmx_Val_Rising

sampleMode:

i L_ DAQOmx_Val_FiniteSamps
Sample Clock = Foas ] sampsPerChan: 10000

i
=
=
=]
=
=)

r
:
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7. Generate the current output using the DAQmx Write VI, as shown in
the following table.

LabVIEW Block Diagram NI-DAQmx Function Call
Call DAQmxWriteAnalogF64
with the following parameters:
askjchannels in
1/0 taskHandle: taskHandle
numSampsPerChan: 1
= TH autoStart: 1
sk out timeout: 10.0
W == datalLayout:
' LA DAQmx_Val_GroupByChannel
Analog DEL L writeArray: sdata
[Sauk 1Chan 15amp boen sampsPerChanWritten:
&samplesWritten
reserved: NULL
8. Compare the resulting values that the DMM shows to the Upper Limit
and Lower Limit values in Table 3. If the result is between these
values, the device passes the test.
9. Clear the generation using the DAQmx Clear Task VI, as shown in the
following table.
LabVIEW Block Diagram NI-DAQmx Function Call

Call bAQmxClearTask with the
following parameter:

taskHandle: taskHandle
— i3]

(5 beeeed

10. Repeat steps 3 through 9 for both Test Point values. NI recommends
that you verify all values, although you can save time by verifying only
the values used in your application.

11. Repeat steps 2 through 10 for all channels.
12. Disconnect the DMM from the device.
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Specifications

Test Limits

The values in the following table are based on calibrated scaling
coefficients, which are stored in the onboard EEPROM. The following
calibration specifications are for 23 +5 °C.

Table 2. NI 9265 Accuracy

Percent of Reading (Gain Error) | Percent of Range™ (Offset Error)

0.10% 0.12%

* Range equals 0 to 20.6 mA

Range

Test Point

1-Year Limits

Table 3 lists the specifications that the NI 9265 should meet if it has been
one year between calibrations. The following definitions describe how to
use the information from Table 3.

Range refers to the minimum or maximum current range of an output signal.

The Test Point is the current value that is output for verification purposes.
This value is broken down into two columns—Location and Value.
Location refers to where the test value fits within the test range. Value
refers to the current value to be verified. Max refers to the maximum value
and Min refers to the minimum value.

The I-Year Limits column contains the Upper Limits and Lower Limits for
the test point value. That is, when the device is within its 1-year calibration
interval, the test point value should fall between these upper and lower limit
values.

Table 3. NI 9265 Verification Test Limits

Range (mA) Test Point 1-Year Limits
Value Lower Limit Upper Limit
Minimum | Maximum Location (mA) (mA) (mA)
0 20 Min 1 0.9739 1.0261
0 20 Max 19 18.9559 19.0441
© National Instruments Corporation 9 NI 9265 Calibration Procedure




Where to Go for Support

The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at

11500 North Mopac Expressway, Austin, Texas, 78759-3504.

National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States,
create your service request at ni . com/support and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:

Australia 1800 300 800, Austria 43 662 457990-0,

Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,

Canada 800 433 3488, China 86 21 5050 9800,

Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,
Finland 358 (0) 9 725 72511, France 01 57 66 24 24,

Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737,
Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400,
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710,

Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,

New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60,

Poland 48 22 328 90 10, Portugal 351 210 311 210,

Russia 7 495 783 6851, Singapore 1800 226 5886,

Slovenia 386 3 425 42 00, South Africa 27 0 11 805 8197,

Spain 34 91 640 0085, Sweden 46 (0) 8 587 895 00,

Switzerland 41 56 2005151, Taiwan 886 02 2377 2222,

Thailand 662 278 6777, Turkey 90 212 279 3031,

United Kingdom 44 (0) 1635 523545

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni .com/1legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products/technology,
refer to the appropriate location: Help»Patents in your software, the patents. txt file on your
media, or the National Instruments Patent Notice at ni . com/patents.

© 2008 National Instruments Corporation. All rights reserved. 372667A-01 Dec08
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