
Lookout  Tutorial
This document provides a brief tutorial to help you become familiar with 
the basics of Lookout development. Refer to the Introduction to Lookout 
manual, available by navigating to the lookout\Documentation 
directory and opening the Lookout_Introduction.pdf file, for more 
information about using Lookout.
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Create a Server Process
In this exercise, you simulate connections to hardware. You will use this 
process as the server process in later exercises.

Note While server is a networking term, a Lookout server process does not necessarily 
need to be connected to a network.

This exercise shows how to create and configure Lookout objects, make 
and edit connections between those objects, and configure data for logging.

1. Start Lookout by selecting Start»All Programs»National 
Instruments»Lookout x.x»Lookout, where x.x is the version number 
of Lookout.

2. Browse the information offered in the default process by clicking the 
topic links.

3. Close the default process by selecting File»Close All. Click Yes to 
stop the process.

4. Select File»New to create a new Lookout process.

Notice that the status bar at the bottom of the Lookout workspace is 
now yellow. This signals that Lookout is in edit mode. If you have 
trouble completing any of the steps in this tutorial, check to see 
whether Lookout is in edit or run mode. You can change modes 
by pressing <Ctrl-Space> or selecting Edit»Edit Mode.

5. In the Create Process dialog box, name your process Server, 
as shown in the following figure. Leave the rest of the fields with their 
default settings.
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6. Click OK.

7. In the New Control Panel dialog box that appears, change the 
Title (not the Name) to Lookout Server Control Panel.

8. Click OK.

9. Select Object»Object Explorer.

Use the Lookout Object Explorer to examine Lookout processes 
running on any Lookout computer on your network, create new 
objects, arrange objects in hierarchical folders, make connections, 
edit data members, and register computers running Lookout on 
your network.

10. Arrange your Lookout workspace so that you can see both your control 
panel and the Object Explorer.
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Create a Server Modbus Slave Object

Note These exercises use the Modbus Slave driver object because it does not return errors 
if it cannot locate hardware connected to your serial port. You can use the Modbus Slave 
driver object as you would any PLC or RTU driver object, if your control hardware is not 
available. 

1. Right-click the Server process in the Object Explorer, and select 
New Object from the menu. The Select object dialog box appears.

2. Select the ModbusSlave object, which is in the Drivers folder if the 
objects are categorized. Notice that a description of this object appears 
in the field to the right of the list of objects.

3. Click OK. The New Modbus Slave dialog box appears, as shown in the 
following figure. For this example, accept the default values for the 
object ModbusSlave1 by clicking OK.

The Modbus Slave object, ModbusSlave1, appears under your 
Server process in the Object Explorer.

Create and Connect a Server Pot Object to Your Modbus Slave
Typically, you do not need to develop the user interface for a server 
process, except for perhaps a few displays to help you verify and 
troubleshoot connections to hardware. The following steps show how to 
add some simple displays. In the Create a Client Process section, you will 
construct a more detailed user interface.
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1. Expand the tree view of your newly created ModbusSlave1 object by 
clicking the + sign to the left of it in the Object Explorer, as shown in 
the following figure. You use the Object Explorer to view the data 
members available for you to use. 

A data member is a data source or sink associated with a Lookout 
object. In the following steps, you will display the 40001 data member 
of the Modbus Slave on your control panel. This data member might 
represent a particular hardware register.

2. Right-click the 40001-49999 data member range in Object Explorer 
and drag it to your control panel. Release the mouse button and select 
Create Control»Pot.

 

Tip Pot is an abbreviation for potentiometer. In Lookout, you use Pot objects to set or 
control analog outputs.
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3. The New potentiometer dialog box appears, as shown in the following 
figure. It is connected to 40001 because the first available data 
member is used by default when you select a range.

 

4. Accept the default values for Pot1 by clicking OK. The Insert Pot 
dialog box appears.

5. Select the vertical slider (top row, second graphic). Select the Use as 
Default checkbox, then click OK. You can position your object 
anywhere on the control panel.

6. To check that your connection works, place a digital display of the 
ModbusSlave1.40001 data member on your control panel by 
left-clicking 40001-49999 in the Object Explorer and dragging 
it to your control panel.

7. Use the sizing handles around the number to make the display large 
enough to show three digits.
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8. Right-click the control panel and select Insert Text/plate/inset and 
type a percent full label for your digital display with a transparent 
background, as shown in the following figure. Click OK and position 
the label next to the digital display.

 

9. View your process in action. Press <Ctrl-Space> to leave edit mode, 
then use your pointer to move the Pot slider up and down. Notice the 
number in the digital display changes as you move your Pot control, 
as shown in the following figure. The Pot slider object output is 
connected to the ModbusSlave1 data member 40001, and the value 
the Pot sets for that data member is shown in the digital display.
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10. Toggle back to edit mode by pressing <Ctrl-Space>.

11. Select Object»Connection Browser. In the Objects column, 
double-click your computer name, then Server, then Pot1 to see 
the Pot’s connection to the Modbus Slave 40001 data member in the 
Inputs column. Click Close.

The connection between your Pot control and the Modbus Slave driver is 
an example of a remote source connection. This two-way connection makes 
the Pot an indicator as well as a control. Refer to the Lookout Help, 
available by selecting Start»All Programs»National Instruments»
Lookout x.x»Lookout Help, for more information about the various types 
of connections.

The digital display is an example of an expression. To learn more, 
right-click the digital display, choose Object Properties, then click 
the Help button in the Revise expression dialog box that appears.

Configure Data for Logging, Scaling, and Alarms
The following steps show how to configure logging, scaling, alarms, and 
more for your data. You might want to show how many gallons of liquid 
the tank is holding, display information about the tank and its contents 
graphically, and trigger alarms when the tank is too full or almost empty. 
To keep track of this data and to make it easier to handle, Lookout uses the 
internal Citadel database. Each time you create a Lookout object, every one 
of its data members is a potential entry in Citadel.

Assume your tank holds 250,000 gallons. You can configure a Citadel entry 
for your tank to track how full the tank is (in gallons), convert the 
percentage measurement to a volume measurement, and handle your 
logging and alarming.

1. Right-click the ModbusSlave1 object in the Object Explorer. Select 
Edit Data Member Configuration. 

2. Using the following figure for help, enter these values in the dialog 
box.

a. Select the 40001 data member you connected your Pot object to 
by clicking 40001-49999 in the Native members list. Assign it 
an Alias of TankLevel.

b. In the Scaling section of the dialog box, set the Raw units at 0 for 
the Minimum and 100 for the Maximum. These are the raw 
numeric values connected to the 40001 data member, indicating 
what percentage of the tank is currently full. Set the Eng. units 
to 0 for the Minimum and 250000 for the Maximum.
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Lookout will now automatically scale the 0–100 input to a value 
between 0–250,000 that you can display using the alias value 
TankLevel.

c. Check Log to historical database, and set the Resolution to 0.

d. Set the Deviation to 1.5. (This will be used in the next exercise.)

e. Set your Alarm conditions as shown. Notice that Lookout lets 
you divide alarms into groups, called alarm areas. In this case, the 
alarm Area is Tanks.

f. Click the Save button (or the Update button if you saved earlier 
in the process), then click the Quit button to exit the dialog box.  

 

3. Expand the ModbusSlave1 object in the Object Explorer by clicking 
the +, and drag the scaled data member TankLevel to your control 
panel. This digital display reports the contents of your tank in gallons.

4. Select Insert»Text/Plate/Inset, and type a gallons label for this 
digital display, choose a transparent background, and click OK. 
Position the label next to the scaled tank level display.
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Your control panel should now look similar to the following figure.
 

5. Press <Ctrl-Space> to exit edit mode, then move the Pot slider up and 
down. Moving the Pot to the upper and lower limits of its range triggers 
the alarms you set for TankLevel in step 2e. Notice that the alarms 
appear in the Alarms Window. If you cannot see the Alarms Window, 
select Alarms»Show.

6. Right-click an alarm in the Alarms Window and select Acknowledge 
All to acknowledge the alarms. You can click OK without entering a 
comment.
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7. Save your server process by selecting File»Save. You will be accessing 
it with the client process you create next.

Tip If you want to change the size and location of the Alarms Window, select Alarms»
Display Options. To control what is displayed in the Alarms Window, select Alarms»
Filter Options. Refer to the Lookout Help for more information about alarms and 
alarming.

Review—Creating a Server Process
A Lookout server process runs on the computer that has direct or physical 
connections to your industrial automation hardware. You can configure the 
data for logging, alarms, scaling, and so on in the server process. A server 
process provides data for clients, and does not need an elaborate user 
interface.

Tip You can add network and local security to this server process. Refer to the Lookout 
Help for more information about using the Lookout security features.

Create a Client Process
In this exercise, you build a simple Lookout client process to interact with 
the server you built in the Create a Server Process exercise.

The instructions for this exercise assume you are developing your client 
process on the same computer that is running your server process. In the 
Use Networked Client Process section, you will have a chance to move the 
client to another computer, add a feature, and fix a simulated data quality 
problem.

1. If the Server process is not already running, launch Lookout and load 
it using the File»Open command.

If you did not save your server process from the previous example, you 
can use the Server sample process, found in the Examples folder 
installed with your copy of Lookout. 

2. Select File»New to create a Lookout client process.

3. In the Create Process dialog box that appears, name your new process 
Client. Click OK.

4. In the New Control Panel dialog box that appears, change the Title to 
Client Control Panel, and click OK.
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Configure the Panel to Activate Automatically
By default, Lookout control panels are minimized. The following steps 
show how to make your client control panel active and visible every time 
you load the process. 

1. Select Object»Edit Connections and navigate to the Panel object in 
your client process. Click OK. The Objectname connections dialog 
box appears. 

2. Select activate from the Writable members field and click the 
Select button. Type TRUE in the yellow expression field, and click 
Accept. Your client control panel will now activate when you first 
open the process. 

 

3. Click Quit.
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Set the Root
To work with your processes properly, you need to set the Object Explorer 
root to an appropriate folder. 

1. Select Object»Object Explorer. 

2. Select Universe from the combo box at the top of the Object Explorer 
window.

3. Expand your view so that you can see both the network presence of 
your computer and the local presence, as shown in the following 
figure.

Notice that the Network branch and local branch show both Server and 
Client processes.

Create a Client Pot Object
1. In the Network branch of Object Explorer under Server and 

ModbusSlave1, right-click and drag the 40001-49999 data member 
range to your Client control panel. Release the mouse button and 
select Create Control»Pot. This Pot will have a remote connection 
to the Modbus Slave object, defined by a URL.

The path shown in the green field of this dialog box will work no 
matter which computer on your network is running this client process.

2. Click OK in the New potentiometer dialog box, then select the 
vertical slider and click OK.
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3. Arrange panels so you can see both control panels. Operate the Pot 
control in the client process control panel. Notice that on the server 
process control panel, both the Pot control and digital displays 
respond.

4. Operate the Pot control in your server process. Notice that the Pot 
control in your client process changes to reflect movement of the 
server values.

Connect a Client Switch Object to Your Modbus Slave
1. In the client process, press <Ctrl-Space> to return to edit mode (the 

status bar at the bottom of the Lookout workspace should turn yellow).

2. Right-click your Client process in the local branch of the Object 
Explorer, and select New Object.

Note Lookout does not allow you to edit a process remotely. If you right-click the Client 
process in the Network branch of Object Explorer, you will not be able to access the New 
Object option.

3. Select Switch, which is in the Control category if the objects are 
categorized, and click OK. The New switch dialog box appears.

4. For Position Source, select the Remote option, and right-click in 
the green URL field. The URL Editor dialog box appears.

When you created your Pot object for your client, Lookout 
automatically used an absolute path mode to make sure the URL would 
work from any computer on your network. In this case you will create 
a computer-relative path that will later fail when you move the client 
process to another computer. This will demonstrate Lookout’s ability 
to alert you to data quality problems, and give you a chance to learn 
how to correct such problems.

5. Expand the Network node in the tree that appears, expand your 
computer under the Network node, then expand the Server process. 
Select the ModbusSlave1 object as shown in the following figure.
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6. Select the 1-9999 data member in the Contents list and click Paste to 
insert the URL string into the green URL field. The URL is an absolute 
path. 

7. In the green field, delete your computer name and substitute a period 
(.) to convert the absolute path to a computer-relative path. The final 
string should be the following:

\\.\Server\ModbusSlave1.1

Use computer-relative mode when you want to reference other 
processes running on the same computer. After you move the process 
with this Switch to a client computer, the Switch will attempt to find 
its remote source on that client computer.

8. Click OK.
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9. Click OK in the New switch dialog box to finish creating your Switch 
object.

10. Drag the Switch object from the Object Explorer to your client control 
panel. Select the standard switch on the far right as shown in the 
following figure, and click OK.

Create a Symbolic Link
So far you have created a Pot in your client process that has a remote source 
connection to the server, which will work no matter where you move the 
client process on your network. You also created a Switch that will work 
when the client process is running on the same computer as the server 
process. However, if you move your server process to a new computer, or 
otherwise change the server computer’s name, your connections will break. 
Repairing these broken connections becomes difficult if you have a large 
number of them. To make maintenance easier, you can use a Symbolic Link 
connection between a client and a server.

1. In the Object Explorer of Lookout running the client process, 
right-click the local branch of your Client process and select 
New Symbolic Link. The Create Symbolic Link dialog box appears. 
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2. Name the Symbolic Link Link_to_Server and enter the absolute 
path to your server process in the URL field, in the following form:

\\your_computername\Server
 

3. Click OK.

4. In the local branch of Object Explorer, expand the Symbolic Link you 
just made. Notice that all the objects in the server process are exposed 
in the Symbolic Link.
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5. Expand the ModbusSlave1 object under Link_to_Server. Drag 
and drop the 1-9999 data range to your client control panel to insert 
an LED display that will reflect operation of the Switch you made. 

6. Right-click the LED and select Object Properties to see that the 
expression is as follows:

[Link_to_Server]\ModbusSlave1.1

This indicator is now linked to the server process through the Symbolic 
Link. You can, in fact, make all your connections through the Symbolic 
Link, making your client more flexible, portable, and reusable. By 
editing the path in the Symbolic Link, you can change every 
connection in your process with one operation instead of changing 
connections one at a time.

7. Click OK. Save your client process.

Create a HyperTrend Object
In the Configure Data for Logging, Scaling, and Alarms section, you 
configured the TankLevel data member in your server process for scaling, 
and set it to be logged to Citadel. As long as your server process is running, 
Lookout is keeping track of this value in Citadel.

1. Make note of the current time on your computer, then switch to run 
mode and change the position of the Pot slider on your client or server 
process a number of times in large increments. Later, you will view the 
changes you made on the HyperTrend.

2. Press <Ctrl-Space> to return to edit mode.

3. In Object Explorer, right-click your computer in the local branch and 
select Make Root. You no longer need access to the Server process 
in the network view.

4. Right-click your Client process in the Object Explorer and choose 
New Object. Select HyperTrend, which is in the Logging folder if 
the objects are categorized, and click OK.
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5. In the Create HyperTrend dialog box, click the Add Group button. 
The following dialog box appears.

 

6. Name the group TankLevels. The default trend width is one minute; 
accept this and the other defaults.

7. Click OK. Lookout returns you to the Create HyperTrend dialog box. 
Make sure your new TankLevels group is highlighted, and then click 
the Add Item button. The following dialog box appears.

 

8. Right-click in the green URL field to activate the URL Editor. 

9. Ensure the Path Mode is Relative, then under your computer name 
in the left tree view, select the ModbusSlave1 object under 
Link_to_Server. Select the TankLevel data member in the 
Contents list. Click the Paste button. The path in the green field 
should be [Link_to_Server]\ModbusSlave1.TankLevel. 

10. Click OK.

11. Set Numeric maximum to 250000 to match the scaled value of the 
TankLevel data member.
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12. Click OK in the Add Item dialog box and again in the Create 
HyperTrend dialog box.

13. Drag your new HyperTrend object from the Object Explorer to your 
client process control panel. Use the sizing handles to adjust the size 
of the chart. Arrange your client process control panel to resemble 
the following figure. You can add the scale shown by selecting Insert»
Scale. You can add the Percentage full label by selecting Insert»
Text/Plate/Inset.

 

View Your HyperTrend Data
1. Press <Ctrl-Space> to toggle out of edit mode. Move the Pot slider up 

and down and notice the trace change on the graph.

2. Click the HyperCursor icon in the center of the top of the HyperTrend 
object. The HyperCursor icon is replaced by a solid line down the 
center of the chart, and the HyperTrend1 Cursor dialog box appears, 
as shown in the following figure.

1 Modbus Slave 1.1 Switch 2 Modbus Slave 1.1 LED Indicator 3 HyperTrend Cursor

2

1

3
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3. Use the Time control on the dialog box to scroll back to the time you 
noted when you changed the TankLevel value.

4. Select File»Save All from the Lookout menu to save both your 
processes. Make sure that your client process is saved in the Lookout 
folder, so that you can successfully export it as a Web Client.

Review—Creating a Client Process
A Lookout client process interacts with Lookout servers. The client process 
is capable of running on any Lookout computer on your network without 
modification. To ensure this portability, a Lookout client application 
should not include driver objects, and it should always use remote 
connections to a server process.
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Use Networked Client Process
If you have access to a second computer on your network, you can run your 
new client on that computer and try out Lookout’s easy-to-use networking. 
This exercise shows how a client process developed in a server computer 
can be distributed across any machine in a network. The client process 
works with absolutely no additional development.

1. Install Lookout on a client computer. 

2. Copy your client process files to the Lookout directory on the client 
computer. If you did not change the name of your process when saving, 
you should have the following four files that comprise your client 
process: Client.l4p, Client.l4t, Client.lks, and 
Client.lka.

Note Refer to the Lookout Help for more information about Lookout file types. 

3. On the client computer, launch Lookout, select File»Open, and open 
Client. 

4. Operate the Pot object slider on your client computer. The Pot controls 
in the server and client processes running on the first computer should 
respond.

5. Notice the red X over the switch, which indicates a data quality 
problem. This will be explained later in the Correct Problems with 
Data Quality section.

Note If you do not see any traces on your HyperTrend, you may need to synchronize your 
computers. This will be explained later in the Synchronize Computer Clocks section.

Register Your Network Computers
While Lookout processes can communicate with each other across the 
network without any special preparations, you may need to register other 
computers running Lookout in order to browse across the network for 
development purposes.

1. On the client computer, press <Ctrl-Space> to put Lookout in edit 
mode. Select Object»Object Explorer if the Object Explorer is not 
already running.

2. Click the name of your client computer in the window at the top of 
the Object Explorer, and select Universe from the pull-down list. 

You can now browse every computer registered as running Lookout on 
your network.
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3. Register your server computer (the one running your server process) 
by right-clicking Network and selecting Register computer.

 

4. In the Register Network Computer dialog box that appears, type 
the name of your server computer into the Computer name field, as 
shown. If you prefer, you can browse for your computer name in the 
network tree view available in the Entire Network field.

 

5. Click OK.

6. Expand the Network node of the tree view in the Object Explorer. You 
should see both your client computer (the computer you are currently 
working on) and the computer running your server process.
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Correct Problems with Data Quality
The red X superimposed on the client computer’s Switch object is an 
example of the Lookout data quality feature, which alerts you when your 
process is receiving data that has some problem. Complete the following 
steps to fix the data quality problem. 

1. Right-click the switch with the red X over it and select Object»
Properties.

2. Right-click in the green URL field to change the computer-relative 
path to an absolute path. 

3. In the URL Editor dialog box, navigate to your server computer 
under the Network branch. Expand the view to select ModbusSlave1 
under your server process.

4. In the Contents field, select 1-9999 and click Paste. The new path 
is an absolute path connection to that data member.

5. Click OK twice. The red X should be gone.

Synchronize Computer Clocks
You might notice some time lag in operating your Pot control and seeing 
the change in your HyperTrend chart on your server computer, which 
can happen when your networked computers do not have their clocks 
synchronized. To provide for accurate data logging, complete the following 
steps to have Lookout synchronize your computers.

1. On the client computer, select Options»Time Synchronization 
or click the date/time display in the status bar. The Time 
Synchronization Settings dialog box appears.

2. Click Add. The Add Time Server dialog box appears.

3. Enter the name of your server computer in the Computer name field. 
You can also browse for your computer in the Entire Network list.

4. Click OK. The Time Synchronization Settings dialog box reappears.

5. Set Sleep time to 10. With this setting, your computers resynchronize 
every 10 seconds.

6. Click OK. Your computers are now synchronized.

Show Networked Alarms and Events
If you operate your Pot slider on your server computer, you may notice that 
the alarms you trigger on your server computer do not appear in the Alarms 
window on your client computer. To monitor and acknowledge alarms 
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from a networked computer, you must select the processes you want to 
monitor as follows.

1. On your client computer, select Alarms»Select Processes. The 
following dialog box appears.

 

2. Expand the tree view to show the processes running on your server 
computer. Select the Server process, and click the Add button. 
Click OK.

Your client computer can now monitor alarms from your server computer.

Review—Networking
Networking a Lookout application is as easy as copying your client process 
files to any networked computer. Then you can resolve any data quality 
problems, synchronize your system clocks, register computers, and access 
alarm and event information.
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