NI 9264 Calibration Procedure

This document contains information about calibrating
National Instruments 9264 modules using NI-DAQmx.
This calibration procedure is intended for metrology labs.

This document does not discuss programming techniques or compiler
configuration. The NI-DAQmx driver contains online help files that have
compiler-specific instructions and detailed function explanations. You can
install these help files when you install NI-DAQmx on the calibration

computer.
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Conventions

»

bold

italic

monospace

Software

The following conventions appear in this manual:

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names and hardware labels.

Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

Monospace text denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

Install NI-DAQmzx 8.6 or later on the calibration computer. NI-DAQmx
includes high-level function calls to simplify the task of writing software to
calibrate devices. You must have the proper device driver installed on the
calibration system before calibrating the device.

@ Note NI recommends that you install the NI-DAQmx driver software before physically
installing the NI 9264. NI-DAQmx, available at ni . com/downloads, configures and
controls the NI 9264.

NI 9264 Calibration Procedure

NI-DAQmx supports a number of programming languages, including
LabVIEW, LabWindows™/CVI™, Microsoft Visual C++ 6.0, Microsoft
Visual Basic 6.0, Microsoft .NET, and Borland C++.

You can access the NI-DAQmx header file, NIDAQmx . h, like any standard
library. You can find examples of how to use the NI-DAQmx driver in the
Program Files\National Instruments\NI-DAQ\Examples
directory.
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Documentation

You might find the following documentation helpful as you write the
calibration procedure:

*  NI-DAQmx Help—This help file contains general information about
measurement concepts, key NI-DAQmzx concepts, and common
applications that apply to all programming environments. To access
this help file, select Start»All Programs»National Instruments»
NI-DAQ»NI-DAQmx Help.

*  NI-DAQmx C Reference Help—This help file contains C reference and
general information about measurement concepts. To access this help
file, select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

*  DAQ Getting Started Guide for NI-DAQ 8.0 or later—This guide
describes how to install NI-DAQmx for Windows software and
NI-DAQmzx-supported DAQ devices, and how to confirm that your
device is operating properly. To access this guide, select Start»
All Programs»National Instruments»NI-DAQ»DAQ Getting
Started Guide.

@ Note The documents above are installed with NI-DAQmx. You can also download the
latest versions from the NI Web site at ni . com/manuals.

* NI 9264 Operating Instructions and Specifications—This document
describes how to use the NI 9264 and includes specifications and pin
assignments for the NI 9264. The limits you use to verify the accuracy
of this device are based on the specifications found in this document.
You can download the latest version of this document from the
NI Web site at ni . com/manuals.

Calibration Interval

The NI 9264 should be calibrated at a regular interval as defined by

the measurement accuracy requirements of your application. National
Instruments recommends that you routinely perform a complete calibration
at least once every year. You can shorten this interval based on the accuracy
demands of your application or requirements of your processes.
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Test Equipment

National Instruments recommends that you use the following equipment
for calibrating the NI 9264.

Table 1. Recommended Equipment

Equipment Recommended Model Requirements

DMM NI 4070 DMM If this instrument is unavailable, use a
multiranging 6 1/2 digit DMM with an
accuracy of 40 ppm.

Chassis NI cDAQ-9172 —

Connection Accessory NI 9974 —

Test Conditions

Follow these guidelines to optimize the connections and the environment:

*  Keep connections to the device as short as possible. Long cables
and wires act as antennae, picking up extra noise that can affect
measurements.

*  Use shielded copper wire for all cable connections to the device.
Use twisted-pair wire to eliminate noise and thermal offsets.

*  Maintain an ambient temperature of 23 +10 °C. The device
temperature will be greater than the ambient temperature.

*  Keep relative humidity below 80%.

e Allow a warm-up time of at least 10 minutes to ensure that the
measurement circuitry is at a stable operating temperature.

Calibration Procedure

This section provides instructions for verifying the performance of the
NI 9264.

Calibration Process Overview
The calibration process consists of the following steps:
1. Initial Setup—Configure the device in NI-DAQmx.

2. Verification Procedure—Verify the existing operation of the device.
This step confirms whether the device was operating within its
specified range prior to calibration.
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Adjustment—If the device does not fall within the desired
specifications, submit the device to NI for a factory calibration
to adjust the calibration constants.

Verification Procedure— Perform another verification to ensure
that the device operates within its specifications after adjustment.

The first two steps are explained in the following sections.

Initial Setup

You must configure the device in Measurement & Automation Explorer
(MAX) to communicate with NI-DAQmx.

Complete the following steps to configure a device in MAX:

1.
2.

Install the NI-DAQmx driver software.

Make sure that no power is connected to the module terminals. If the
system is in a nonhazardous location, the chassis power can be on
when you install the module.

Insert the module into an available slot in the cDAQ-9172 chassis.
Launch MAX.

Right-click the device name and select Self-Test to ensure that the
device is working properly.

@ Note When a device is configured with MAX, it is assigned a device name. Each function
call uses this device name to determine which DAQ device to calibrate. This document uses
dev1 to refer to the device name. In the following procedures, use the device name as it

appears in MAX.

Verification Procedure

Verification determines how well the device is meeting its specifications.
By completing this procedure, you can see how the device has drifted over
time, which helps you determine the appropriate calibration interval for
your application. Table 3 in the Test Limits section shows all acceptable
settings for the device type. Throughout the verification process, use
Table 3 to determine if the device is operating within its specified range.

© National Instruments Corporation
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Complete the following steps to test the performance of the device:

1. Connect the positive output of the DMM to an AO terminal and the
negative output of the DMM to a COM terminal. Refer to Figure 1 for
the pin assignments of the NI 9264.

O
ACD 119 com
o1 | | |[2z]  com
AC2 [sf21]]| | |com
AO3 || ][4]22 com
204 [5lesl | | [com
AO5 | ] ][6]e4 com
06 7as] | | |com
ao7 | | |[8]2g] com
AO8 9[27]] | |com
a0 | | |[wofzs]  com
AO10 [11]29] | | |com
aot1 | | |[12[30 com
AO12 [13[31] | | [com
Ao13 | | | [14]z2 com
AO14 [15[33] | | |com
aots | | | [16][34] coMm
com [17]s]| | |com
com [18[36] com
O

Figure 1. NI 9264 Pin Assignments

2. If you use C function calls, create a task using DAQmxCreateTask,
as shown in the following table. If you use LabVIEW, skip this step.
The task is created in step 3 in LabVIEW.

LabVIEW Block Diagram NI-DAQmx Function Call

Call DAQmxCreateTask with
the following parameters:

LabVIEW does not require this step. taskName:

AQOVerificationTask
taskHandle: staskHandle
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3. Create and configure an AO voltage channel using the DAQmx Create
Virtual Channel VI, as shown in the following table. Use Table 3 to
determine the minimum and maximum values for the device.

E Note Throughout the procedure, refer to the NI-DAQmx function parameters for the
LabVIEW input values. Refer to the block diagram images for the correct instance to use

for polymorphic VIs.
LabVIEW Block Diagram NI-DAQmx Function Call
Call
DAQmxCreateAOVoltageChan

with the following parameters:

inirnurm value
taskHandle: taskHandle

physicalChannels: devl/ao00

\ 'I’

aximurn value nameToAssignToChannel:
myVoltageChannel
kask out .
- minVal: -10.0

phevsical channels|  mg-~r-eree--—~{fL0

170 e maxVal: 10.0

Arh E_E”E'r out units: DAQmx_val_volts

AC Volbage - - it customScaleName: NULL

P o W
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4. Generate the voltage output using the DAQmx Write VI, as shown in
the following table.

LabVIEW Block Diagram NI-DAQmzx Function Call

Call DAQOmxWriteAnalogF64

with the following parameters:
askjchannels in
taskHandle: taskHandle

/0
numSampsPerChan: 1
= TE autoStart: 1
fask out timeout: 10.0
W 1= dataLayout:
b Pt DAQmx_Val_GroupByChannel
Analog DBL L writeArray: sdata
B 1Chan 15amp = sampsPerChanWritten:
&samplesWritten

reserved: NULL

Wait 1 ms to ensure the output is settled.

6. Compare the resulting values that the DMM shows to the Upper Limit
and Lower Limit values in Table 3. If the result is between these
values, the device passes the test.

7. Clear the acquisition using the DAQmx Clear Task VI, as shown in the
following table.

LabVIEW Block Diagram NI-DAQmzx Function Call

Call bAQmxClearTask with the
following parameter:

taskHandle: taskHandle
. e

[ Heed

8. Repeat steps 2 through 7 for all channels and all values.
9. Disconnect the DMM from the device.
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Specifications

The values in the following table are based on calibrated scaling
coefficients, which are stored in the onboard EEPROM. The following
calibration specifications are for 23 +10 °C.

Table 2. NI 9264 Accuracy

Percent of Reading Percent of Range*
(Gain Error) (Offset Error)
0.05% 0.05%

“Range equals 10.5 V

Test Limits

Table 3 lists the specifications that the NI 9264 should meet if it has been
one year between calibrations. The following definitions describe how to
use the information from Table 3.

Range

Range refers to the minimum or maximum voltage range of an output
signal.

Test Point

The Test Point is the voltage value that is input or output for verification
purposes. This value is broken down into two columns—Location and
Value. Location refers to where the test value fits within the test range.
Value refers to the voltage value to be verified. Max refers to maximum
value, Min refers to minimum value, and Mid refers to mid-scale.

1-Year Limits

The I-Year Limits column contains the Upper Limits and Lower Limits for
the test point value. That is, when the device is within its 1-year calibration
interval, the test point value should fall between these upper and lower limit
values.
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Table 3. NI 9264 Verification Test Limits

Range (V) Test Point 1-Year Limits
Minimum | Maximum Location Value (V) Lower Limit (V) | Upper Limit (V)
—-10.000 10.000 Max 9.500000 9.490000 9.510000
-10.000 10.000 Mid 0.000000 -0.005250 0.005250
—-10.000 10.000 Min —9.500000 -9.510000 -9.490000
NI 9264 Calibration Procedure 10 ni.com



Where to Go for Support

The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at

11500 North Mopac Expressway, Austin, Texas, 78759-3504.

National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States,
create your service request at ni . com/support and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:

Australia 1800 300 800, Austria 43 662 457990-0,

Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,

Canada 800 433 3488, China 86 21 5050 9800,

Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,

Finland 358 (0) 9 725 72511, France 01 57 66 24 24,

Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737,
Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400,
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710,

Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,

New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60,

Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851,
Singapore 1800 226 5886, Slovenia 386 3 425 42 00,

South Africa 27 0 11 805 8197, Spain 34 91 640 0085,

Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151,

Taiwan 886 02 2377 2222, Thailand 662 278 6777,

Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni . com/legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products, refer to the
appropriate location: Help»Patents in your software, the patents . txt file on your CD, or
ni.com/patents.

© 2007 National Instruments Corporation. All rights reserved. 372403A-01 Oct07
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