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Overview of the Lesson Manager
The Lesson Manager window is an alternate interface for LabVIEW that 
an instructor can use to organize and present custom or example VIs to 
students or novice users. The Lesson Manager window replaces the 
Getting Started window in LabVIEW. 

The Lesson Manager window allows users to easily navigate through 
classroom laboratory examples (labs) using a three-tiered organizational 
structure. A lab consists at a minimum of a LabVIEW project file 
(.lvproj) and top-level VI, but a lab also can contain other LabVIEW and 
non-LabVIEW files.

The Lesson Manager window, shown in Figure 1, contains the following 
components. Refer to the LabVIEW Help for more information about the 
Lesson Manager window components.

™
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Figure 1.  The Lesson Manager Window for the SPEEDY-33 Target

• Open Lab section—Opens labs that the instructor provides or copies 
the lab and opens the copy. 

• New Custom Lab section—Creates labs for the default, 
non-Windows target device or the host computer. 

• Open Saved Lab section—Opens a dialog box to browse for labs that 
you save. Select My Labs in the pull-down menu to open the My Labs 
directory on the hard disk. Select Browse to Last Folder Opened in 
the pull-down menu to browse for LabVIEW projects in the last 
directory a user opened with LabVIEW. 

• Test My Hardware button—Runs a quick diagnostic to make sure 
that the host computer can connect to the target device and that the 
device is operating properly. 

• Quit button—Exits LabVIEW. Make sure to save any projects or labs 
you create or change before quitting LabVIEW.

• Help button—Opens the LabVIEW Help. 
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Before you can use the Lesson Manager window in a classroom setting, 
you must do the following:

1. Set up the default hardware target for new labs that students create 
through the New Custom Lab section of the Lesson Manager 
window. By default, the target is SPEEDY-33. Refer to the Setting the 
Default Target Hardware section for information about setting the 
default non-Windows hardware target.

2. Create a Windows shortcut to launch LabVIEW with the Lesson 
Manager window. By default, you can open the Lesson Manager 
window by double-clicking LessonManager.vi located in the 
labview\Targets\NI\DSP\LessonManager directory. Refer to 
the Creating a Windows Shortcut for the Lesson Manager section for 
information about creating a Windows shortcut for the Lesson 
Manager.

3. Create and organize the LabVIEW projects and VIs that you want 
to use as labs in the classroom. By default, the Lesson Manager 
window lists labs you store in the labview\Targets\NI\DSP\
LessonManager\Sample Labs directory. Refer to the Creating and 
Organizing Labs for the Lesson Manager section for information 
about organizing the student labs.

4. (Optional) Change the storage location of the labs that appear in the 
Lesson Manager window, the location of the My Labs directory, and 
the background image of the Lesson Manager window. Refer to the 
Customizing the Lesson Manager section for information about 
customizing the Lesson Manager window. 

Setting the Default Target Hardware
The Lesson Manager supports one non-Windows target when creating new 
labs through the New Custom Lab section of the Lesson Manager 
window. By default, this target is the SPEEDY-33. 

Complete the following steps to change the default non-Windows target for 
the Lesson Manager.

1. Log on as an administrator or as a user with administrator privileges.

2. Close LabVIEW if LabVIEW is running.

3. Open the LessonManager.ini file, located in the labview\
Targets\NI\DSP\LessonManager directory, in any text editor. For 
better readability, do not use word wrap features in the text editor when 
editing the LessonManager.ini file.
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4. Modify the following line in the LessonManager.ini file to specify 
the new default DSP target: 

Default Target=x

where x is the default non-Windows target.

Modify the line by replacing x with a target entry from the list of 
hardware devices in the following table. 

For example, change the line to Default Target=target1 so that 
the Lesson Manager uses the NI SPEEDY-33 by default.

Refer to ni.com/info and enter the info code changehw for the 
latest list of non-Windows targets that the Lesson Manager supports.

5. Save and close the LessonManager.ini file in a text-only format. 
Make sure that the text editor does not change the extension of the 
LessonManager.ini file.

The next time you open the Lesson Manager window, the default 
non-Windows target appears in the title bar.

Module Target Default Target Entry

DSP Module NI SPEEDY-33 target1

DSP Module Texas Instruments 6711 DSK target2

DSP Module Spectrum Digital 6713 DSK target3

DSP Module Spectrum Digital 6416 DSK target4

Embedded Module for 
Blackfin Processors

Analog Devices ADSP-BF531 target5

Embedded Module for 
Blackfin Processors

Analog Devices ADSP-BF532 target6

Embedded Module for 
Blackfin Processors

Analog Devices ADSP-BF533 target7

Embedded Module for 
Blackfin Processors

Analog Devices ADSP-BF534 target8

Embedded Module for 
Blackfin Processors

Analog Devices ADSP-BF536 target9

Embedded Module for 
Blackfin Processors

Analog Devices ADSP-BF537 target10

Embedded Module for 
Blackfin Processors

Analog Devices ADSP-BF538 target11

http://digital.ni.com/public.nsf/websearch/A438A513BCB2BFE6862572FA006B49D8?OpenDocument
www.ni.com/info
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Creating a Windows Shortcut for the Lesson Manager
You can launch LabVIEW with the Lesson Manager window or the 
Getting Started window. Create a desktop shortcut to launch 
LabVIEW with the Lesson Manager window. Otherwise, select 
Start»All Programs»National Instruments»LabVIEW»LabVIEW to 
launch LabVIEW with the default Getting Started window.

Complete the following steps to create a shortcut to the Lesson Manager on 
the desktop of a computer.

1. Log on as an administrator or as a user with administrator privileges.

2. Close LabVIEW if LabVIEW is running.

3. Browse to labview\Targets\NI\DSP\LessonManager using 
Windows Explorer.

4. Right-click the LessonManager.vi file and select Create Shortcut 
from the shortcut menu.

5. Drag the new shortcut to the Windows desktop.

6. Right-click the shortcut and select Rename from the shortcut menu.

7. Type a new name, such as LabVIEW for the Classroom, and press 
the <Enter> key to save the name.

Tip (Windows XP) You also can right-click the LessonManager.vi and select Send To»
Desktop (create shortcut) from the shortcut menu to create a shortcut.
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Creating and Organizing Labs for the Lesson Manager
You use LabVIEW projects and VIs to illustrate concepts and provide 
hands-on labs for students. These labs can help reinforce key concepts that 
you teach in class. 

After you create a set of labs for your curriculum, you must name, organize, 
and write-protect the project files and VIs to display the labs in the Lesson 
Manager window.

Naming Labs
Each lab has at least two associated files—a LabVIEW project file 
(.lvproj) and a LabVIEW VI (.vi).

The project and the top-level VI must have the same filename to be 
compatible with the Lesson Manager window. For example, when you 
create a new LabVIEW project and VI for the classroom, you must save 
both the project and the VI with the same filename as follows:

• VI (lab) filename: My Example.vi

• Project filename: My Example.lvproj

Note A project can contain more than one VI, but the top-level VI must have the same 
name as the project to work properly with the Lesson Manager window.

Similarly, if a student creates a new lab through the New Custom Lab 
section of the Lesson Manager window, the student needs to save the 
LabVIEW project and the top-level VI with the same name. The name of 
the LabVIEW project appears by default in the dialog box that the Open 
Saved Lab section of the Lesson Manager window displays.

Tip Select File»Save All in the Project Explorer window to save both the VI and the 
project when you finish making edits.
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Organizing and Storing Labs
The Lesson Manager window uses a file storage hierarchy to populate the 
Application, Topic, and Example column entries.You determine the items 
that appear in the columns in the Open Lab section of the Lesson 
Manager window by naming and organizing folders and files on disk as 
shown in Figure 2.

Figure 2.  Organizing Labs for the Lesson Manager Window

The default location of the Sample Labs folder is labview\Targets\
NI\DSP\LessonManager\Sample Labs, but you can change this 
location. Refer to the Changing the Location of the Lesson Manager Labs 
Directory section for information about changing the folder location.
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Keep the following in mind when you name and organize the folders and 
labs:

• Each folder located directly within the Sample Labs folder appears 
as an item in the Application column of the Lesson Manager window. 

• Each folder in the labs folder must contain at least one folder to 
populate the Topic column of the Lesson Manager window. 

• Finally, each folder at the Topic level must contain the LabVIEW 
project and VI files for the labs. These labs appear in the Example 
column of the Lesson Manager window.

Note The names of the items in the Application, Topic, and Example columns come 
directly from the names of the folders and files in the labs directory.

Write-Protecting Labs
After you save the project and VIs for the Lesson Manager labs, you need 
to protect the files from accidental editing or erasure by write-protecting 
the entire Lesson Manager labs directory. 

Complete the following steps to write-protect the Lesson Manager labs 
directory.

1. Log on as an administrator or as a user with administrator privileges.

2. Open Windows Explorer.

3. Navigate to the Lesson Manager labs directory. By default, the Lesson 
Manager labs directory is located at labview\Targets\NI\DSP\
LessonManager\Sample Labs.

4. Right-click the directory and select Properties from the shortcut 
menu.

5. Click the General Tab.

6. In the Attributes section, place a checkmark in the Read-only 
checkbox.

7. Click the Apply button.

8. Select Apply Changes to this folder, subfolder and files and click 
the OK button in the dialog box that appears. 

9. Click the OK button to close the Properties dialog box.

Note To delete a lab, first remove the read-only attribute of the file. Follow the above 
steps, but remove the checkmark in step 6. Now you can delete the VI and project files. 

Caution Make sure to reapply the read-only attribute to the labs directory when you finish 
making changes. If you do not make the directory read-only, students can delete or alter the 
labs.
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Customizing the Lesson Manager
You can change the following items to customize the Lesson Manager.

• The storage location of the labs that appear in the Lesson Manager 
window

• The default location of the My Labs directory where students can save 
custom labs

• The background graphic of the Lesson Manager window

Changing the Location of the Lesson Manager Labs Directory
The Lesson Manager window populates the Application, Topic, and 
Example columns with LabVIEW projects and VIs located in the labs 
directory. The Lesson Manager window automatically updates the lists 
every time you launch LabVIEW using the Lesson Manager. 

The default location of the Lesson Manager labs directory is 
labview\Targets\NI\DSP\LessonManager\Sample Labs. Refer to 
the Organizing and Storing Labs section for information about storing the 
labs within the Lesson Manager labs directory.

Complete the following steps to change the location of the Lesson Manager 
labs directory.

1. Log on as an administrator or as a user with administrator privileges.

2. Close LabVIEW if LabVIEW is running.

3. Open the LessonManager.ini file, located in the labview\
Targets\NI\DSP\LessonManager directory, in any text editor. For 
better readability, do not use word wrap features in the text editor when 
editing the LessonManager.ini file.

4. Add or modify the following line to the end of the file to specify the 
new default location:

Lab Location=x

where x is the path to the Lesson Manager lab directory. 

For example, change the line to Lab Location=C:\New Labs so that 
the Lesson Manager window searches the C:\New Labs directory 
for the directories and files containing the labs. Refer to the Organizing 
and Storing Labs section for information about the necessary directory 
structure of the labs directory. 

5. Save and close LessonManager.ini in a text-only format. Make 
sure that the text editor does not change the extension of the 
LessonManager.ini file.

Next time you launch LabVIEW with the Lesson Manager window, labs 
from the new location appear in the Open Lab section.
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Changing the Location of the My Labs Directory
The My Labs directory is the default location for saving labs that students 
modify using the Copy & Go button in the Open Lab section of the 
Lesson Manager window. A student can access the My Labs directory 
using the pull-down menu in the Open Saved Lab section of the Lesson 
Manager window. 

LabVIEW creates the My Labs directory in the C:\Documents and 
Settings\<user>\My Documents\LabVIEW Data\ directory by 
default, where <user> is the Windows account running LabVIEW. For 
example, if each student logs on to the classroom computer using a 
different login, LabVIEW creates a separate My Labs directory for each 
student. 

Complete the following steps to change the location of the My Labs 
directory.

1. Log on as an administrator or as a user with administrator privileges.

2. Close LabVIEW if LabVIEW is running.

3. Open the LessonManager.ini file, located in the 
labview\Targets\NI\DSP\LessonManager directory, in any text 
editor. For better readability, do not use word wrap features in the text 
editor when editing the LessonManager.ini file.

4. Add or modify the following line to the end of the file to specify the 
new default location:

My Labs Location=x

where x is the path to the My Labs directory.

For example, change the line to My Labs Location=Q: so that 
LabVIEW creates the My Labs directory on the Q: network drive.

5. Save and close LessonManager.ini in a text-only format. Make 
sure that the text editor does not change the extension of the 
LessonManager.ini file.
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Changing the Lesson Manager Window Background Image
You can change the background image of the Lesson Manager 
window. By default, the Lesson Manager window uses the 
LessonManager_658x471.bmp file, shown in Figure 3, located in the 
labview\Targets\NI\DSP\LessonManager directory.

Figure 3.  The LessonManager_658x471.bmp Image

Notice that the background image contains the titles for the different 
sections of the Lesson Manager window such as the Application, Topic, 
and Example list columns. You must include titles in the new image you 
create, so use the LessonManager_658x471.bmp file as a template to 
create a new background image for the Lesson Manager window. 

Complete the following steps to change the Lesson Manager window 
background image.

1. Open LessonManager_Edit.vi, located in the labview\
Targets\NI\DSP\LessonManager directory.

2. Switch to the block diagram and double-click the Lesson Manager VI 
to open the Lesson Manager VI without running the Lesson Manager.

3. Select Edit»Select All from the front panel window of the Lesson 
Manager VI.
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4. Click the Reorder button, shown at left, in the front panel window 
toolbar, and select Unlock to unlock the items on the front panel 
window.

5. Click the background image to select the object.

6. Press the <Delete> key to delete the background image.

7. Open the new background image in an image editor program and copy 
the image to the Windows clipboard.

8. Select Edit»Paste to paste the new background image in the Lesson 
Manager VI.

9. Click the Reorder button and select Move To Back to move the new 
background image behind all the other objects in the front panel 
window.

10. Align the background image with the controls on the front panel.

11. Select Edit»Select All.

12. Click the Reorder button and select Lock to lock the items on the front 
panel window.

13. Save and close the Lesson Manager VI. The new image appears as the 
background graphic the next time you use the Lesson Manager VI to 
launch LabVIEW.

Where to Go from Here
National Instruments provides many resources to help you succeed with 
your NI products. Use the following resources as you start exploring 
LabVIEW and the Lesson Manager.

Refer to the LabVIEW Help for information about LabVIEW and the 
LabVIEW Lesson Manager, and refer to the Context Help window for 
information about using controls, VIs, and functions.

• LabVIEW Help—Available by selecting Help»Search the LabVIEW 
Help in LabVIEW. Click the Index tab and enter lesson manager 
window for topics describing the Lesson Manager. 

• Context Help window—Available by selecting Help»Show Context 
Help or by pressing the <Ctrl-H> keys.

Visit ni.com/academic for other academic and training resources. 

http://www.ni.com/academic
www.ni.com/academic
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Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 662 457990-0, 
Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 5050 9800, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 (0) 9 725 72511, France 01 57 66 24 24, 
Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737, 
Italy 39 02 413091, Japan 81 3 5472 2970, Korea 82 02 3451 3400, 
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, 
Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466, 
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851, 
Singapore 1800 226 5886, Slovenia 386 3 425 42 00, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

http://www.ni.com/support
www.ni.com/support
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