NI 9201/9221 Calibration
Procedure

This document contains information about calibrating National
Instruments 9201/9221 modules using NI-DAQmx. This calibration
procedure is intended for metrology labs.

This document does not discuss programming techniques or compiler
configuration. The NI-DAQmx driver contains online help files that have
compiler-specific instructions and detailed function explanations. You can
install these help files when you install NI-DAQmx on the calibration

computer.
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NI 9201/9221

Software

The following conventions appear in this manual:

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names and hardware labels.

Ttalic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

Monospace text denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

NI 9201/9221 refers to the NI 9201 and NI 9221.

Install NI-DAQmx 8.5 or later on the calibration computer. NI-DAQmx
includes high-level function calls to simplify the task of writing software to
calibrate devices. You must have the proper device driver installed on the
calibration system before calibrating the device.

@ Note NI recommends that you install the NI-DAQmx driver software before physically
installing the NI 9201/9221. NI-DAQmx, available at ni . com/downloads, configures
and controls the NI 9201/9221.

NI-DAQmx supports a number of programming languages, including
LabVIEW, LabWindows™/CVI™, Microsoft Visual C++ 6.0, Microsoft
Visual Basic 6.0, Microsoft .NET, and Borland C++.

You can access the NI-DAQmx header file, NIDAQmx . h, like any standard
library. You can find examples of how to use the NI-DAQmx driver in the
Program Files\National Instruments\NI-DAQ\Examples
directory.
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Documentation

You might find the following documentation helpful as you write the
calibration procedure:

*  NI-DAQmx Help—This help file contains general information about
measurement concepts, key NI-DAQmx concepts, and common
applications that apply to all programming environments. To access
this help file, select Start»All Programs»National Instruments»
NI-DAQ»NI-DAQmx Help.

*  NI-DAQmx C Reference Help—This help file contains C reference and
general information about measurement concepts. To access this help
file, select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

*  DAQ Getting Started Guide for NI-DAQ 8.0 or later—This guide
describes how to install NI-DAQmx for Windows software and
NI-DAQmzx-supported DAQ devices, and how to confirm that your
device is operating properly. To access this guide, select Start»
All Programs»National Instruments»NI-DAQ»DAQ Getting
Started Guide.

@ Note The documents above are installed with NI-DAQmx. You can also download the
latest versions from the NI Web site at ni . com/manuals.

* NI 9201 Operating Instructions/NI 9221 Operating Instructions—
These documents contain information about specific device features.
The limits you use to verify the accuracy of the devices are based on
the specifications found in these documents. You can download the
latest versions of these documents from the NI Web site at ni . com/
manuals.

Calibration Interval

The NI 9201/9221 should be calibrated at a regular interval as defined by
the measurement accuracy requirements of your application. National
Instruments recommends that you routinely perform a complete calibration
at least once every year. You can shorten this interval based on the accuracy
demands of your application or requirements of your processes. Adjusting
the calibration constants must be done by a factory calibration at NI.
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Test Equipment

National Instruments recommends that you use the following equipment
for calibrating the NI 9201/9221.

Table 1. Recommended Equipment

Equipment Recommended Model Requirements

Calibrator Fluke 5700A If this instrument is unavailable, use a
high-precision voltage source with an
accuracy of at least 10 ppm and an
output impedance of less than or equal
to 50 Q.

Chassis NI cDAQ-9172 —

Connection accessory NI 9932 or NI 9934 Use the NI 9932 connector kit for the
NI 9201/9221 with screw terminal.
Use the NI 9934 connector kit for the
NI 9201/9221 with DSUB.

Test Conditions

Follow these guidelines to optimize the connections and the environment:

e Keep connections to the device as short as possible. Long cables
and wires act as antennae, picking up extra noise that can affect
measurements.

e Use shielded copper wire for all cable connections to the device.
Use twisted-pair wire to eliminate noise and thermal offsets.

e  Maintain an ambient temperature of 23 +10 °C. The device
temperature will be greater than the ambient temperature.

e Keep relative humidity below 80%.

*  Allow a warm-up time of at least 10 minutes to ensure that the
measurement circuitry is at a stable operating temperature.
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Calibration Procedure

This section provides instructions for verifying the NI 9201/9221.

Calibration Process Overview

The calibration process consists of the following steps:

1.
2.

Initial Setup—Configure the device in NI-DAQmx.

Verification Procedure—Verify the existing operation of the device.
This step confirms whether the device was operating within its
specified range prior to calibration.

Adjustment—Submit the device to NI for a factory calibration to adjust
the calibration constants.

Verification Procedure—Perform another verification to ensure that
the device operates within its specifications after adjustment.

The first two steps are explained in the following sections.

Initial Setup

You must configure the device in Measurement & Automation Explorer
(MAX) to communicate with NI-DAQmx.

Complete the following steps to configure a device in MAX:

1. Install the NI-DAQmx driver software.

2. Make sure that no power is connected to the module terminals. If the
system is in a nonhazardous location, the chassis power can be on
when you install the module.

3. Insert the module into an available slot in the cDAQ-9172 chassis.
Launch MAX.

5. Right-click the device name and select Self-Test to ensure that the
device is working properly.

@ Note When a device is configured with MAX, it is assigned a device name. Each function

call uses this device name to determine which DAQ device to calibrate. This document uses
devl to refer to the device name. In the following procedures, use the device name as it

appears in MAX.

© National Instruments Corporation
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Verification Procedure

Verification determines how well the device is meeting its specifications.
By completing this procedure, you can see how the device has drifted over
time, which helps you determine the appropriate calibration interval for

your application. Tables 4 and 5 in the Test Limits section show all

acceptable settings for the device type. Throughout the verification process,

use Tables 4 and 5 to determine if the device is operating within its

specified range prior to calibration. You must perform verification on all

analog input channels.

Complete the following steps to test the performance of the device:

1. Connect the positive output of the calibrator to AI0 and the negative
output of the calibrator to COM. If the calibrator has a guard
connection, connect that terminal to COM as well. Refer to Table 2 for
the terminal assignments of the NI 9201/9221 with screw terminal.
Refer to Figure 1 for the pin assignments of the NI 9201/9221 with

DSUB.

Table 2. Terminal Assignments for the NI 9201/9221 with Screw Terminal

Module Terminal Signal
0 AIO

S
1 All

i 2 AI2
ST

0 & S| 3 Al3

1 S

2 N 4 Al4

3 S

4 N 5 Al5

5 S

6|4 6 Al6

7 S

9 S

(S]] 8 No Connection
I D 9 COM
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Figure 1. Pin Assignments for the NI 9201/9221 with DSUB

2. Set the calibrator voltage to the Test Point value indicated in Tables 4
and 5. NI recommends that you verify all values, although you can
save time by verifying only the values used in your application.

3. If you use C function calls, create a task using DAQmxCreateTask,
as shown in the following table. If you use LabVIEW, skip this step.
The task is created in step 4 in LabVIEW.

LabVIEW Block Diagram NI-DAQmx Function Call

Call DAQmxCreateTask with
the following parameters:

LabVIEW does not require this step. taskName:

AlVerificationTask
taskHandle: staskHandle
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4. Create and configure an Al voltage channel using the DAQmx Create
Virtual Channel VI, as shown in the following table. Use Tables 4
and 5 to determine the minimum and maximum values for the device.

Note Throughout the procedure, refer to the NI-DAQmx function parameters for the

LabVIEW input values.

LabVIEW Block Diagram

NI-DAQmx Function Call

efault -

inirum value

aximunm walue

[
- -

hysical channels

kask ouk

Dricn: S [V

Call
DAQmxCreateAIVoltageChan
with the following parameters:

taskHandle: taskHandle
physicalChannel: dev1/ai0
nameToAssignToChannel:
myVoltageChannel
terminal Config:
DAQmx_Val_Cfg_Default

== ue minVal (NI 9201): -10.0
At maxVal (NI 9201): 10.0

Error in Al Yolkage ~ | minVal (NI 9221): -60.0
T o o maxVal (NI 9221): 60.0

units: DAQmx_Val_Volts

customScaleName: NULL

5. Configure the timing properties for the voltage acquisition using the
DAQmx Timing VI, as shown in the following table.
LabVIEW Block Diagram NI-DAQmx Function Call

samples per channel

[T32%

Finite Samples *

askichannels in
170

ake

Zm o K

Fi]
y - ror ouk
Sample Clock 'I L_ =

kask ouk
r

Call DAQmxCfgSampClkTiming
with the following parameters:

taskHandle: taskHandle
source: NULL

rate: 25000

activeEdge:
DAQmx_Val_Rising
sampleMode:
DAQmx_Val_FiniteSamps
sampsPerChan: 10000
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6. Start the acquisition using the DAQmx Start Task VI, as shown in the

following table.
LabVIEW Block Diagram NI-DAQmx Function Call
Call DAQmxStartTask with the
bask out following parameter:
(B A8 taskHandle: taskHandle
[Sstk F ot
7. Acquire 10,000 points of voltage data using the DAQmx Read VI,
as shown in the following table.
LabVIEW Block Diagram NI-DAQmx Function Call

askjchannels in kask ouk
s | 3 A1)
irmeouk
B —mm—
(LA
Frorin Analog 1D DEL _ rrufur ouk
o ket | ] Chan MSamp iy | 21

Call DAQmxReadAnalogF64 with
the following parameters:

taskHandle: taskHandle
numSampsPerChan: -1
timeout: 10.0

fillMode:
DAQmx_Val_GroupByChannel
readArray: data
arraySizeInSamples: 10000
sampsPerChanRead: sread
reserved: NULL

®©

Average the voltage values that you acquired for the channel. Compare

the resulting average to the Upper Limit and Lower Limit values listed
in Tables 4 and 5 per channel. If the result is between these values, the
device passes the test.

e

following table.

Clear the acquisition using the DAQmzx Clear Task VI, as shown in the

LabVIEW Block Diagram

NI-DAQmx Function Call

Call DAQmxClearTask with the
following parameter:

taskHandle: taskHandle
2 SH|
[Ea bmj
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Specifications

10. Repeat steps 3 through 9 for all channels and all values.

11. Disconnect the calibrator from the device.

Test Limits

The values in the following table are based on calibrated scaling
coefficients, which are stored in the onboard EEPROM. The following
calibration specifications are for 23 +10 °C.

Table 3. NI 9201/9221 Accuracy

Module Gain Error Offset Error
NI 9201 0.05% 12 mV
NI 9221 0.05% 71 mV

Using the Tables

Tables 4 and 5 list the specifications that the NI 9201/9221 meets if it has
been two years between calibrations.

The following definitions describe how to use the information from
Tables 4 and 5.

Range

Range refers to the minimum or maximum voltage range of an input signal.

Test Point

The Test Point is the voltage value that is input or output for verification
purposes. This value is broken down into two columns—Location and
Value. Location refers to where the test value fits within the test range.
Value refers to the voltage value to be verified. Max refers to maximum
value, Min refers to minimum value, and Mid refers to mid-scale.

1-Year Limits

The I-Year Limits column contains the Upper Limits and Lower Limits for
the test point value. That is, when the device is within its 1-year calibration
interval, the test point value should fall between these upper and lower limit
values.

NI 9201/9221 Calibration Procedure 10 ni.com



Table 4. NI 9201 Analog Input Values

Range (V) Test Point 1-Year Limits
Minimum | Maximum Location Value (V) | Lower Limit (V) | Upper Limit (V)
—-10.000 10.000 Max 9.500000 9.483250 9.516750
-10.000 10.000 Mid 0.000000 —-0.012000 0.012000
-10.000 10.000 Min -9.500000 -9.516750 -9.483250
Table 5. NI 9221 Analog Input Values
Range (V) Test Point 1-Year Limits
Minimum | Maximum Location Value (V) | Lower Limit (V) | Upper Limit (V)
—60.000 60.000 Max 57.000000 56.900500 57.099500
—60.000 60.000 Mid 0.000000 —-0.071000 0.071000
—60.000 60.000 Min —-57.000000 —57.099500 -56.900500
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Where to Go for Support

The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at

11500 North Mopac Expressway, Austin, Texas, 78759-3504.

National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States,
create your service request at ni . com/support and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:

Australia 1800 300 800, Austria 43 662 457990-0,

Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599,

Canada 800 433 3488, China 86 21 5050 9800,

Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,

Finland 385 (0) 9 725 72511, France 33 (0) 1 48 14 24 24,

Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737,
Italy 39 02 413091, Japan 81 3 5472 2970, Korea 82 02 3451 3400,
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710,

Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466,

New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60,

Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851,
Singapore 1800 226 5886, Slovenia 386 3 425 42 00,

South Africa 27 0 11 805 8197, Spain 34 91 640 0085,

Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151,

Taiwan 886 02 2377 2222, Thailand 662 278 6777,

Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section onni . com/legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products, refer to the
appropriate location: Help»Patents in your software, the patents. txt file on your CD, or
ni.com/patents.

© 2007 National Instruments Corporation. All rights reserved. 372204A-01 Feb07



	NI 9201/9221 Calibration Procedure
	Contents
	Conventions
	Software
	Documentation
	Calibration Interval
	Test Equipment
	Table 1. Recommended Equipment

	Test Conditions
	Calibration Procedure
	Calibration Process Overview
	Initial Setup
	Verification Procedure
	Table 2. Terminal Assignments for the NI 9201/9221 with Screw Terminal
	Figure 1. Pin Assignments for the NI 9201/9221 with DSUB


	Specifications
	Table 3. NI 9201/9221 Accuracy

	Test Limits
	Using the Tables
	Range
	Test Point
	1-Year Limits
	Table 4. NI 9201 Analog Input Values
	Table 5. NI 9221 Analog Input Values


	Where to Go for Support



