NI 9263 Calibration Procedure

This document contains information about calibrating the National
Instruments 9263 module using NI-DAQmzx. This calibration procedure
is intended for metrology labs.

This document does not discuss programming techniques or compiler
configuration. The NI-DAQmx driver contains online help files that have
compiler-specific instructions and detailed function explanations. You can
install these help files when you install NI-DAQmx on the calibration
computer.

The NI 9263 should be calibrated at a regular interval as defined by

the measurement accuracy requirements of your application. National
Instruments recommends that you routinely perform a complete calibration
at least once every year. You can shorten this interval based on the accuracy
demands of your application or requirements of your processes. Adjusting
the calibration constants must be done by a factory calibration at NI.
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Conventions

»

bold

italic

monospace

The following conventions appear in this manual:

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names and hardware labels.

Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

Monospace text denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

Software and Documentation Requirements

Software

This section describes the software and documentation required for
calibration.

Install NI-DAQmx 8.1 or later on the calibration computer. NI-DAQmx
includes high-level function calls to simplify the task of writing software to
calibrate devices. You must have the proper device driver installed on the
calibration system before calibrating the device.

@ Note NI recommends that you install the NI-DAQmx driver software before physically
installing the NI 9263. NI-DAQmx, available at ni . com/downloads, configures and
controls the NI 9263.

NI 9263 Calibration Procedure

NI-DAQmx supports a number of programming languages, including
LabVIEW, LabWindows™/CVI™, Microsoft Visual C++ 6.0, Microsoft
Visual Basic 6.0, Microsoft .NET, and Borland C++.
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You can access the NI-DAQmx header file, NIDAQmx . h, like any standard
library. You can find examples of how to use the NI-DAQmx driver in

the Program Files\National Instruments\NI-DAQ\Examples
directory.

Documentation

You might find the following documentation helpful as you write the
calibration procedure:

NI-DAQmx Help—This help file contains general information about
measurement concepts, key NI-DAQmx concepts, and common
applications that apply to all programming environments. To access
this help file, select Start»All Programs»National Instruments»
NI-DAQ»NI-DAQmx Help.

NI-DAQmx C Reference Help—This help file contains C reference and
general information about measurement concepts. To access this help
file, select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

DAQ Getting Started Guide for NI-DAQ 8.0 or later—This guide
describes how to install NI-DAQmx for Windows software and
NI-DAQmzx-supported DAQ devices, and how to confirm that your
device is operating properly. To access this guide, select Start»
All Programs»National Instruments»NI-DAQ»DAQ Getting
Started Guide.

Note The documents above are installed with NI-DAQmx. You can also download the
latest versions from the NI Web site at ni . com/manuals.

NI 9263 Operating Instructions— This document contains
information about specific device features. You can download the
latest version of this document from the NI Web site at
ni.com/manuals.

Calibration Requirements

Test Equipment

National Instruments recommends that you use the following equipment
for calibrating the NI 9263:
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NI 4070 DMM. If that instrument is unavailable, use a multiranging
6 1/2 digit DMM with an accuracy of 40 ppm.

NI cDAQ-9172 chassis.
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Test Conditions

Follow these guidelines to optimize the connections and the environment:

Keep connections to the device as short as possible. Long cables and
wires act as antennae, picking up extra noise that can affect
measurements.

Use shielded copper wire for all cable connections to the device.
Use twisted-pair wire to eliminate noise and thermal offsets.

Maintain an ambient temperature of 23 +10 °C. The device
temperature will be greater than the ambient temperature.

Keep relative humidity below 80%.

Allow a warm-up time of at least 10 minutes to ensure that the
measurement circuitry is at a stable operating temperature.

Calibration Process

This section provides instructions for verifying the NI 9263.

Calibration Process Overview

The calibration process consists of the following steps:

Initial Setup

NI 9263 Calibration Procedure

1.
2.

Initial Setup—Configure the device in NI-DAQmx.

Verification Procedure—Verify the existing operation of the device.
This step confirms whether the device was operating within its
specified range prior to calibration.

Adjustment—Submit the device to NI for a factory calibration to
adjust the calibration constants.

The first two steps are explained in the following sections.

You must configure the device in Measurement & Automation Explorer
(MAX) to communicate with NI-DAQmx.

Complete the following steps to configure a device in MAX:

1.
2.

Install the NI-DAQmzx driver software.

Make sure that no power is connected to the module terminals. If the
system is in a nonhazardous location, the chassis power can be on
when you install the module.

Insert the module into an available slot in the cDAQ-9172 chassis.
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4. Launch MAX.

5. Right-click the device name and select Self-Test to ensure that the
device is working properly.

@ Note When a device is configured with MAX it is assigned a device name. Each function
call uses this device name to determine which DAQ device to calibrate. This document uses
devl to refer to the device name. In the following procedures, use the device name as it
appears in MAX.

Verification Procedure

Verification determines how well the device is meeting its specifications.
By completing this procedure, you can see how the device has drifted over
time, which helps you determine the appropriate calibration interval for
your application. Tables 4 and 5 in the Device Test Limits section show
all acceptable settings for the device type. Throughout the verification
process, use Tables 4 and 5 to determine if the device is operating within
its specified range prior to calibration. You must perform verification on all
analog output channels.

Complete the following steps to test the performance of the device:

1. Refer to Table 1 for a list of the NI connection accessories for the
NI 9263 and instructions on connecting the DMM to the device.

Table 1. NI Connection Accessories

Device Connection Accessory Connection Instructions
NI 9263 NI 9932 Strain relief & high Connect the positive output of the DMM to a
voltage screw terminal positive terminal and the negative output of the
connector DMM to a COM terminal. Refer to Table 2 to
determine which terminals to connect to the
DMM for each channel.

Table 2. Terminal Connections

Module Channel | Positive DMM Output | Negative DMM Output
0 AOQO (terminal 0) COM (terminal 1)
1 AO1 (terminal 2) COM (terminal 3)
2 AQO2 (terminal 4) COM (terminal 5)
3 AO3 (terminal 6) COM (terminal 7)
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2. If you use C function calls, create a task using DAQmxCreateTask,
as shown in the following table. If you use LabVIEW, skip this step.
The task is created in step 3 in LabVIEW.

NI-DAQmx Function Call

LabVIEW Block Diagram

Call DAQmxCreateTask with
the following parameters:

taskName:
AQVerificationTask
taskHandle: staskHandle

LabVIEW does not require this step.

3. Create and configure an AO voltage channel through NI-DAQmx
using DAQmxCreateAOVoltageChan (DAQmx Create Virtual
Channel VI), as shown in the following table. Use Tables 4 and S to
determine the minimum and maximum values for the device.

NI-DAQmx Function Call

LabVIEW Block Diagram

Call
DAQmxCreateAOVoltageChan
with the following parameters:

taskHandle: taskHandle
physicalChannels: devl/ao0
nameToAssignToChannel:
myVoltageChannel

minVal: -10.0

maxVal: 10.0

units: DAQmx_Val_Volts
customScaleName: NULL

Differential *

inimum value

aximum wvalue
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4. Start the generation using DAQmxStartTask (DAQmx Start Task VI),
as shown in the following table.

NI-DAQmx Function Call

LabVIEW Block Diagram

Call DAQmxStartTask with
the following parameter:

taskHandle: taskHandle
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5. Generate the voltage output using DAQmxWriteAnalogF64 (DAQmx
Write VI), as shown in the following table.

NI-DAQmx Function Call LabVIEW Block Diagram

Call DAQmxWriteAnalogF64 with the

following parameters:
askichannels in

taskHandle: taskHandle
numSampsPerChan: 1
autoStart: 1

timeout: 10.0

10
’

dataLayout:
]

kask ouk
170

S

DAQmx_Val_GroupByChannel
writeArray: &data
sampsPerChanWritten:
&samplesWritten

reserved: NULL

fnalog DEL L

1Chan 15amp =T

6. Compare the resulting value that the DMM shows to the Upper Limit
and Lower Limit values listed in Tables 4 and 5. If the result is between

these values, the device passes the test.
7. Clear the acquisition using DAQmxClearTask (DAQmx Clear Task
VI), as shown in the following table.

NI-DAQmx Function Call LabVIEW Block Diagram

Call DAQmxClearTask with the following
parameter:

taskHandle: taskHandle

— —
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8. Repeat steps 2 through 7 for all channels and all values.
9. Disconnect the DMM from the device.
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Specifications

The values in the following table are based on calibrated scaling
coefficients, which are stored in the onboard EEPROM. The following
calibration specifications are for 23 +10 °C.

E Note The accuracy and test limits of the NI 9263 vary depending on whether you use
Revision D or Revision E of the module. To determine which revision of the module you
are using, refer to the Part No. on the sticker on the back of the module. The Part No.
includes a letter that indicates the revision of the module.

Table 3. NI 9263 Accuracy

Percent of Reading

Percent of Range*

Device Error (Gain Error) (Offset Error)
NI 9263 Revision D Calibrated, max 0.10% 0.28%
NI 9263 Revision E Calibrated, max 0.08% 0.09%

“Range equals £10.7 V

Device Test Limits

Using the Tables

NI 9263 Calibration Procedure

Tables 4 and 5 list the specifications that the NI 9263 meets if it has been
one year between calibrations.

The following definitions describe how to use the information from

Tables 4 and 5.

Range

Range refers to the minimum or maximum voltage range of an output

signal.

Test Point

The Test Point is the voltage value that is input or output for verification
purposes. This value is broken down into two columns—Location and
Value. Location refers to where the test value fits within the test range.
Value refers to the voltage value to be verified. Max refers to maximum
value, Min refers to minimum value, and Mid refers to mid-scale.
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1-Year Limits

The I-Year Limits column contains the Upper Limits and Lower Limits for
the test point value. That is, when the device is within its 1-year calibration
interval, the test point value should fall between these upper and lower limit
values.

Table 4. NI 9263 Revision D Analog Output Values

Range (V) Test Point 1-Year Limits
Minimum | Maximum Location Value (V) Lower Limit (V) | Upper Limit (V)
-10.000 10.000 Max 9.500000 9.460540 9.539460
—-10.000 10.000 Mid 0.000000 —0.029960 0.029960
—-10.000 10.000 Min —9.500000 —9.539460 -9.460540
Table 5. NI 9263 Revision E Analog Output Values
Range (V) Test Point 1-Year Limits
Minimum | Maximum Location Value (V) Lower Limit (V) | Upper Limit (V)
-10.000 10.000 Max 9.500000 9.482770 9.517230
-10.000 10.000 Mid 0.000000 —0.009630 0.009630
—-10.000 10.000 Min —9.500000 -9.517230 -9.482770
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Where to Go for Support

The National Instruments Web site is your complete resource for technical
support. At ni.com/support you have access to everything from
troubleshooting and application development self-help resources to email
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at

11500 North Mopac Expressway, Austin, Texas, 78759-3504.

National Instruments also has offices located around the world to help
address your support needs. For telephone support in the United States,
create your service request at ni . com/support and follow the calling
instructions or dial 512 795 8248. For telephone support outside the United
States, contact your local branch office:

Australia 1800 300 800, Austria 43 0 662 45 79 90 0,
Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599,

Canada 800 433 3488, China 86 21 6555 7838,

Czech Republic 420 224 235 774, Denmark 45 45 76 26 00,
Finland 385 09 725 725 11, France 33 0 1 48 14 24 24,
Germany 49 0 89 741 31 30, India 91 80 41190000,

Israel 972 0 3 6393737, Ttaly 39 02 413091, Japan 81 3 5472 2970,
Korea 82 02 3451 3400, Lebanon 961 0 1 33 28 28,
Malaysia 1800 887710, Mexico 01 800 010 0793,
Netherlands 31 0 348 433 466, New Zealand 0800 553 322,
Norway 47 0 66 90 76 60, Poland 48 22 3390150,

Portugal 351 210 311 210, Russia 7 495 783 68 51,
Singapore 1800 226 5886, Slovenia 386 3 425 42 00,

South Africa 27 0 11 805 8197, Spain 34 91 640 0085,
Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51,
Taiwan 886 02 2377 2222, Thailand 662 278 6777,

Turkey 90 212 279 3031, United Kingdom 44 0 1635 523545

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation.
Refer to the Terms of Use section on ni . com/legal for more information about National
Instruments trademarks. Other product and company names mentioned herein are trademarks or trade
names of their respective companies. For patents covering National Instruments products, refer to the
appropriate location: Help»Patents in your software, the patents . txt file on your CD, or
ni.com/patents.

© 2006 National Instruments Corporation. All rights reserved. 372092A-01 Dec06
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