The LabVIEW Touch Panel Module extends the LabVIEW graphical development environment to Touch Panel devices so you can create human-machine interface (HMI) applications for Touch Panel devices running Windows CE or Windows XP Embedded. You can create custom touch panel displays to communicate with National Instruments embedded real-time platforms, such as Compact FieldPoint, CompactRIO, and Compact Vision System.

This manual contains new features for version 8.6, system requirements, installation instructions, and a tutorial that shows you how to create a LabVIEW project and build, run, deploy, and debug a Touch Panel application.

Contents

System Requirements.............................................................................. 3
Installing the Touch Panel Module.......................................................... 3
Installing Additional Tools ................................................................. 4
   NI TPC Service Support ................................................................. 4
   Windows CE Targets....................................................................... 4
   Third-Party XP Embedded Targets................................................. 5
   Shared Variable Support (Windows CE).......................................... 5
   Using ActiveSync/FTP................................................................... 5
   Using the NI TPC Service ............................................................... 5
   PNG Image Support (Windows CE)................................................ 6
   Using ActiveSync/FTP................................................................... 6
   Using the NI TPC Service ............................................................... 6
   NI-VISA Support (Windows CE)...................................................... 6
   x86 Target Support for Third Parties (Windows CE)......................... 7
Uninstalling the Touch Panel Module (Windows CE)............................ 7
What’s New ........................................................................................................... 7
Windows XP Embedded Support ........................................................................ 8
NI TPC-2512 Support ......................................................................................... 8
New Device Configuration Options .................................................................. 8
Fixed-Point Support .......................................................................................... 8
  Supported Numeric Functions ........................................................................ 8
  Conversion Functions ...................................................................................... 9
Data Conversion Functions ............................................................................... 9
LabVIEW Schema Functions ............................................................................ 9
String/Number Conversion Functions ................................................................ 10
New VI-Specific Code Generation Options ..................................................... 10
New Project-Level Code Generation Options .................................................. 10
New VIs and Functions ...................................................................................... 11
  In Place Element Structure Support ............................................................. 11
  Synchronization Functions Support ............................................................. 11
New Touch Panel Navigation VIs ................................................................. 12
New Front Panel Control ................................................................................. 12
Windows CE Tutorial ....................................................................................... 12
  Configuring the Windows CE Device to Use the NI TPC Service ................. 12
  Creating the LabVIEW Project ................................................................. 13
  Creating the Build Specification .................................................................. 17
Building the Touch Panel VI into an Application and Deploying .................... 22
  Using the Shortcut Menu ............................................................................. 22
  Using the Run Button .................................................................................. 22
Closing the Touch Panel Application ............................................................. 23
Debugging the Touch Panel Application ......................................................... 23
  Creating a Debugging Build Specification ............................................... 23
  Adding a Probe to the Touch Panel VI ...................................................... 25
  Deploying and Debugging a Touch Panel Application ................................ 26
XP Embedded Tutorial .................................................................................... 27
  Creating the LabVIEW Project .................................................................. 27
  Creating the Build Specification .................................................................. 32
Building the Touch Panel VI into an Application and Deploying .................... 36
  Using the Shortcut Menu ............................................................................. 36
  Using the Run Button .................................................................................. 36
Debugging the Touch Panel Application ......................................................... 37
  Creating a Debugging Build Specification ............................................... 37
  Adding a Probe to the Touch Panel VI ...................................................... 39
  Deploying and Debugging a Touch Panel Application ................................ 40
Related Documentation ............................................................................... 41
Where to Go for Support .............................................................................. 42
System Requirements

The Touch Panel Module has the following requirements:

- A computer with Windows Vista/XP or Windows 2000 with Service Pack 4.0 or later
- LabVIEW 8.6 Base, Full, or Professional Development System
- 2.5 GB available disk space
- (Windows CE) A Touch Panel device, such as the NI TPC-2006, running Windows CE 4.2 or 5.0
- (XP Embedded) A Touch Panel device, such as the NI TPC-2512, running Windows XP Embedded

Refer to the LabVIEW Release Notes, available by selecting Start»All Programs»National Instruments»LabVIEW»LabVIEW Manuals and opening LV_Release_Notes.pdf, for standard LabVIEW development system requirements.

Installing the Touch Panel Module

Complete the following steps to install the Touch Panel Module.

1. Log in as an administrator or as a user with administrator privileges.

2. Install LabVIEW 8.6, if not already installed. Refer to the LabVIEW Release Notes for standard LabVIEW installation instructions.

3. Install the Touch Panel Module. The Touch Panel Module includes Microsoft tools, such as Microsoft ActiveSync on Windows XP/2000. Some of these Microsoft tools might interfere with any existing installations of Visual Studio, Windows Embedded, or Windows CE toolkits.

   Note (Windows XP/2000) The Touch Panel Module installs ActiveSync 4.2 if you do not already have ActiveSync 4.2 or later installed. The Touch Panel Module works with ActiveSync 4.2 or later.


   You must activate the Touch Panel Module before you can build Touch Panel VIs into Touch Panel applications. The Touch Panel Module runs in evaluation mode if you do not activate it. In evaluation mode, you can create Touch Panel VIs, but any Touch Panel applications you build run only for five minutes. You have the option of activating the Touch Panel Module at the end of the installation. You also can use the NI License Manager, available by selecting Start»All Programs»National Instruments»NI License Manager, to activate National
Instruments products. Refer to the National Instruments License Manager Help, available by selecting Help » Contents in the NI License Manager, for more information about activating NI products.

5. Restart the computer when the installer completes.


7. Install the additional tools you need. Refer to the Installing Additional Tools section for more information about additional tools.

**Installing Additional Tools**

You must install additional tools on the target depending on the functionality you need.

**NI TPC Service Support**

The NI TPC Service is an Ethernet-based service that you can use to deploy, run, and debug Touch Panel applications. Use the NI TPC Service instead of ActiveSync if you are using Ethernet and need to deploy a Touch Panel application to multiple Touch Panel targets. If you are using the NI TPC-2006 or a third-party device, you must install the NI TPC Service on the Touch Panel target before you can use the NI TPC Service. The NI TPC-2012, NI TPC-2106, and NI TPC 2512 include the NI TPC Service by default.

**Windows CE Targets**

Complete the following steps to install support for the NI TPC Service on a Touch Panel target.

1. Depending on which type of target you are using, use FTP or an external storage device to copy NITPCService.cab from the labview\PDA\Utilities\NITPCService\ARM directory or labview\PDA\Utilities\NITPCService\x86 directory to any location on the Touch Panel device.

2. Run the .cab file on the Touch Panel device to install the NI TPC Service.

3. For NI TPC devices, use the default installation location. Tap the <Enter> key to accept the default installation location. For third-party devices, install the service in a non-volatile directory on the device.
Third-Party XP Embedded Targets

Install the NI TPC Service from `NI_TP_Service\NITPCService.msi`, which is located in the same directory as the `setup.exe` you used to install the Touch Panel Module.

Shared Variable Support (Windows CE)

To use front panel data binding and Shared Variable nodes in Touch Panel applications, you must install the latest version of shared variable support on the target.

*Note*  You do not need to install shared variable support if you are using NI TPC-2006 with the improved display driver, NI TPC-2012, or NI TPC-2106 because those devices already includes the latest version of shared variable support. Refer to National Instruments Web site at [ni.com/info](http://ni.com/info) and enter the info code `tpcdis` for more information about updating the display driver for the NI TPC-2006.

*Note*  Shared variables are not supported on Windows CE 4.x x86 Touch Panel targets. Shared variables are supported on Windows CE 5.0 and later x86 targets.

Using ActiveSync/FTP

Complete the following steps to install or uninstall support for shared variables on a Touch Panel target using ActiveSync/FTP.

1. Connect the Touch Panel device to the host computer using ActiveSync/FTP.
2. Navigate to and run `labview\PDA\Utilities\Variables\ARM\Setup.exe` or `labview\PDA\Utilities\Variables\x86\Setup.exe`, depending on which type of target you are using.
3. For NI TPC devices, use the default installation location. For third-party devices, install the service in a non-volatile directory on the device.

Using the NI TPC Service

Complete the following steps to install or uninstall support for shared variables on a Touch Panel target using the NI TPC Service.

1. In LabVIEW, right-click the Touch Panel target in the Project Explorer window and select Install>Support for Shared Variables (ARM) from the shortcut menu.
2. For NI TPC devices, use the default installation location. For third-party devices, install the service in a non-volatile directory on the device.
PNG Image Support (Windows CE)

You must install support for PNG images on the Touch Panel target if the Touch Panel VI contains PNG images on the user interface.

Note If you have an NI TPC-2006 device and you have already downloaded the updated PNG support from KnowledgeBase 40EAE6X1: Improved Display Driver for TPC-2006 Industrial Touch Panel Computer from the National Instruments Web site, you do not need to complete the following steps. NI TPC-2106 and NI TPC-2012 devices already include support for PNG images.

Using ActiveSync/FTP

Complete the following steps to install or uninstall support for PNG images on a Touch Panel target.

1. Connect the Touch Panel device to the host computer using ActiveSync/FTP.
2. Navigate to and run \labview\PDA\Utilities\LVPNG\ARM\Setup.exe or \labview\PDA\Utilities\LVPNG\x86\Setup.exe, depending on which type of target you are using.
3. For NI TPC devices, use the default installation location. For third-party devices, install the service in a non-volatile directory on the device.

Tip You also can right-click the Touch Panel target in the Project Explorer window in LabVIEW and select Install»Support for PNG Images (ARM) from the shortcut menu.

Using the NI TPC Service

Complete the following steps to install or uninstall support for PNG images on a Touch Panel target using the NI TPC Service.

1. In LabVIEW, right-click the Touch Panel target in the Project Explorer window and select Install»Support for PNG Images (ARM) from the shortcut menu.
2. For NI TPC devices, use the default installation location. For third-party devices, install the service in a non-volatile directory on the device.

NI-VISA Support (Windows CE)

You must install NI-VISA on the target to use VISA in Touch Panel applications. If you did not install NI-VISA when you installed the Touch Panel Module, select Start»All Programs»National Instruments»VISA and select Windows CE for ARM Driver Installation or Windows CE for x86 Driver Installation, depending on which type of target you are using.
Tip  You also can right-click the target in the Project Explorer window in LabVIEW and select Install»Support for NI-VISA (ARM) from the shortcut menu.

**x86 Target Support for Third Parties (Windows CE)**

The Touch Panel Module installs support for ARM Touch Panel targets and Windows CE 5.0 x86 Touch Panel targets. If you need support for x86 Touch Panel targets running Windows CE 4.2, install the following Microsoft eMbedded Visual Tools:

- Microsoft eMbedded Visual C++ 4.0
- Microsoft eMbedded Visual C++ SP 4 or later
- SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at [ni.com/info](http://ni.com/info) and enter the info code `tpcevc` for the most recent information about downloading and installing the Microsoft eMbedded Visual Tools.

**Uninstalling the Touch Panel Module (Windows CE)**

In addition to uninstalling the Touch Panel Module, you also must uninstall the following:

- *(Windows XP/2000)* Microsoft ActiveSync
- Microsoft Device Emulator version 1.0
- Microsoft Visual C++ 2005 Redistributable

**What’s New**

Refer to the *LabVIEW Upgrade Notes*, available by selecting Start»All Programs»National Instruments»LabVIEW»LabVIEW Manuals and opening `LV_Upgrade_Notes.pdf`, for more information about new features and changes in the LabVIEW development system.

Refer to the *Touch Panel Module* book on the Contents tab of the *LabVIEW Help*, available by selecting Help»Search the LabVIEW Help in LabVIEW, for more information specific to the Touch Panel Module and Touch Panel applications.

Refer to the *LabVIEW Touch Panel Module Readme*, available by selecting Start»All Programs»National Instruments»LabVIEW»Readme and opening `readme_TPC.html`, for known issues.

The LabVIEW 8.6 Touch Panel Module includes the following enhancements and features.
Windows XP Embedded Support

You can now create Touch Panel applications for XP Embedded targets. In the Touch Panel Project Wizard, select Windows XP Embedded Device or NI TPC-2512 Device from the Device type pull-down menu to create an XP Embedded target. Use the Application Properties dialog box to configure Touch Panel applications for XP Embedded targets.

NI TPC-2512 Support

The Touch Panel Module now supports the NI TPC-2512. In the Touch Panel Project Wizard, select NI TPC-2512 Device from the Device type pull-down menu to create an NI TPC-2512 target.

New Device Configuration Options

You now can use the Touch Panel Project Wizard to specify connection information for Touch Panel devices. Use the Configure device page to specify the device IP address and whether the target uses ActiveSync or the NI TPC Service to deploy, run, and debug applications.

Fixed-Point Support

The fixed-point data type has limited support.

Note: Overflow mode is supported, but overflow status is not supported.

Supported Numeric Functions

The following Numeric functions support the fixed-point data type:

- Absolute Value
- Add
- Decrement
- Increment
- Multiply
- Negate
- Round To Nearest
- Round Toward +Infinity
- Round Toward -Infinity
- Scale By Power Of 2 Function
- Sign
- Square
Conversion Functions
The following Conversion functions support the fixed-point data type:
- To Byte Integer
- To Double Precision Float
- To Extended Precision Float
- To Fixed-Point
- To Long Integer
- To Quad Integer
- To Single Precision Float
- To Unsigned Byte Integer
- To Unsigned Long Integer
- To Unsigned Quad Integer
- To Unsigned Word Integer
- To Word Integer

Data Conversion Functions
The following Data Manipulation functions support the fixed-point data type:
- Flatten To String
- Logical Shift
- Rotate Left With Carry
- Rotate Right With Carry
- Type Cast
- Unflatten From String

LabVIEW Schema Functions
The following LabVIEW Schema functions support the fixed-point data type:
- Flatten to XML
- Unflatten from XML
**String/Number Conversion Functions**

The following **String/Number Conversion** functions support the fixed-point data type:

- Decimal String To Number
- Fract/Exp String To Number
- Hexadecimal String To Number
- Number To Decimal String
- Number To Engineering String
- Number To Exponential String
- Number To Fractional String
- Number To Hexadecimal String
- Number To Octal String
- Octal String To Number

**New VI-Specific Code Generation Options**

You can now optimize subVI calls and inline subVIs into callers, which can eliminate overhead and increase code optimization.

- **Optimize subVI calls**—Generates C code for subVI calls with as little default data initialization as possible. You cannot debug a VI with optimized subVI calls.
- **Allow inlining**—Allows inlining of subVIs into callers. Inlining subVIs is most useful for small subVIs, VIs with many calls in a loop, or subVIs with only one call site. The default is True. This option only allows inlining. To actually inline a subVI, you must select True from the **Inline subVI** pull-down menu on the **Source File Settings** page in the **Build Specification** dialog box.

To set code generation options for a VI, select **File»VI Properties** from the front panel window or block diagram window to open the **VI Properties** dialog box. Select **C Code Generation Options** from the **Category** pull-down menu. You can select **From project**, **True**, or **False**. Select **True** to enable the option and **False** to disable it. The default is **From project**, so you only need to set the options in VI Properties if you want to override the code generation settings in the project.

**New Project-Level Code Generation Options**

You now can allocate constants for arrays, clusters, strings, variants, and waveforms with build options on the **Application Information** page in the **Build Specification Properties** dialog box.
Using stack variables overrides constant allocation. If you place a checkmark in the **Use stack variables** checkbox, **Allocate constants** is always **First Use** and **Deallocate constants** is always **Out of Scope**. **First Use** and **Out of Scope** was the default behavior in previous versions.

- **Allocate constants**—Specifies when LabVIEW allocates memory for constants.
- **First Use**—Allocates memory the first time you use constants on the block diagram.
- **Containing Loop**—Allocates memory outside of the loop that contains constants.
- **VI Initialization**—Allocates memory when the VI that contains the constants is called.
- **Application Initialization**—Allocates memory when the built application begins running on the target.
- **Deallocate constants**—Specifies when LabVIEW frees memory resources for constants.
- **Out of Scope**—Frees memory resources when the constants are no longer used.
- **VI End**—Frees memory resources when a VI containing constants finishes executing.
- **Application End**—Frees memory resources when the built application finishes executing on the target.

### New VIs and Functions

Refer to the *LabVIEW Help* for more information about the new and newly supported VIs and functions.

### In Place Element Structure Support

The In Place Element structure is now supported. The In Place Element structure controls how the LabVIEW compiler performs certain operations and, in some cases, increases memory and VI efficiency.

### Synchronization Functions Support

The following new **Synchronization** functions are supported:

- Lossy Enqueue Element
- Wait on Notification from Multiple with Notifier History
- Wait on Notification with Notifier History
New Touch Panel Navigation VIs

Use the Touch Panel Navigation VIs to manage user interface pages in an HMI application. With the Touch Panel Navigation VIs you can specify a home page, set the number of pages in the history, and navigate back and forth through pages.

The following new Touch Panel Navigation VIs are supported:
- TPC Get Next Navigation Page
- TPC Initialize Navigation
- TPC Set Next Navigation Page
- TPC Set Previous Navigation Page

New Front Panel Control

Multicolumn listboxes are now supported. The Top Left Visible Cell property sets and returns only the top row element of the cluster.

Windows CE Tutorial

Use this tutorial to learn how to configure a Touch Panel Windows CE device to use the NI TPC Service; how to use the Touch Panel Project Wizard to create a project; and how to build, deploy, run, and debug a Touch Panel application.

The VI in this tutorial simulates setting a temperature, displaying the current temperature in a graph and on a thermometer, and indicating if the temperature is not in range.

Configuring the Windows CE Device to Use the NI TPC Service

Note: If you want to use ActiveSync instead of the NI TPC Service, you must use a USB or serial connection to connect the Touch Panel device to the host computer. If you use a serial cable, connection time is longer.

Complete the following steps to configure the Touch Panel device to use the NI TPC Service.

1. Ensure the host and target are on the same subnet.
2. Enable FTP on the Touch Panel device. Refer to the National Instruments Web site at ni.com/info and enter the info code ex6pwq for the most recent information about configuring NI TPC devices to use FTP. For third-party devices, refer to your device documentation.
3. Install the NI TPC Service on the Touch Panel target. Refer to the *NI TPC Service Support* section for more information about installing the NI TPC Service on Touch Panel targets.

4. Use the NI TPC Service Manager to configure the service to run on the Touch Panel target.
   a. Select *Start*»*All Programs*»*National Instruments*»*NI TPC Service*»*NI TPC Service Manager* to launch the NI TPC Service Manager. The manager checks the status of the NI TPC Service and displays the status information.
   b. Tap the *Start* button to start the NI TPC Service if the NI TPC Service is not running.

**Creating the LabVIEW Project**

Use LabVIEW projects to group together LabVIEW files and non-LabVIEW files, create build specifications for building a Touch Panel VI into an application, and deploy the application to the target. You must use a project to build a Touch Panel VI into an application.

Using the Touch Panel Project Wizard, complete the following steps to create a LabVIEW project, add the target, and add an existing VI to the project.

1. Launch LabVIEW. In the *Getting Started* window, select *Touch Panel Project* from the *Targets* pull-down menu. Click the *Go* button to launch the Touch Panel Project Wizard.
2. Define the project information as shown in Figure 1.
   a. Select *New Touch Panel project, import VI* from the *Project type* pull-down menu to create the LabVIEW project using an existing VI.
   b. Specify a project name and the location where you want to save the project and the VI in the *Project location* text box. Save the project to a location other than the default location so you do not overwrite the shipping example with your changes. The default project name is *Untitled project.lvproj*. For this tutorial, name the project *Touch Panel Tutorial.lvproj* in the *Project location* text box.

   **Tip**  The blank VI project type creates a project with a new Touch Panel template VI rather than importing an existing VI.
c. Click the **Browse** button next to the **VI path** text box and navigate to `labview\examples\TouchPanel\tutorial\TouchPanel Tutorial.vi` to select the VI to import. Click the **OK** button to add the VI to the project you are creating.

![Create New Touch Panel Project](image)

**Figure 1.** Defining the Project Information

3. Click the **Next** button.
4. Select the Touch Panel device you are using from the **Device type** pull-down menu, as shown in Figure 2.

![Figure 2. Selecting the Target](image)

5. Click the **Next** button.

6. Configure connection information for the device as shown in Figure 3.
   a. Select **NI TPC Service (TCP/IP)** from the **Connection** pull-down menu if you configured the device to use the NI TPC Service.
   b. Enter the IP address for the device in the **Touch Panel device IP address** text box.
7. Click the **Next** button.

8. The **System preview** page, shown in Figure 4, shows a preview of the project the wizard creates when you click the **Finish** button. Notice the checkmark in the **Create a build specification** checkbox. This checkmark indicates you want to create a build specification immediately after you create the project. Refer to the **Creating the Build Specification** section for more information about creating a build specification.
9. Click the **Finish** button.

Because the **Create a build specification** checkbox contains a checkmark as shown in Figure 4, the **Touch Panel Build Specification Properties** dialog box opens.

**Creating the Build Specification**

Build specifications contain the build settings and code generation options to use when you build a Touch Panel VI into an application. You can create the build specification when you create a project or wait until you are ready to build the application. You must create a build specification before you can build a Touch Panel VI into an application.

You can have multiple build specifications for the same target. For example, you might want one build specification that generates debugging information and another build specification that does not generate this extra information.
**Note** This tutorial creates the build specification through the Touch Panel Project Wizard. You also can create a build specification at any time by right-clicking **Build Specifications** under the target in the **Project Explorer** window and selecting **New»Touch Panel Application (EXE)** from the shortcut menu.

Complete the following steps to create a Touch Panel build specification.

1. Define the settings for the Touch Panel application, as shown in Figure 5.
   a. Enter a name for the build specification in the **Build specification name** text box. This is the name that appears under **Build Specifications** in the **Project Explorer** window.
   b. (Optional) By default, the name of the Touch Panel application is the same as the top-level Touch Panel VI. If you do not want to use the top-level VI name for the application name, remove the checkmark from the **Same as top-level VI** checkbox and enter a name in the **Target filename** text box.
   c. Browse to and select the destination directory for the Touch Panel application on the host computer, which is where LabVIEW saves the .exe, in the **Destination directory** text box.
   d. Enter the destination directory for the Touch Panel application on the Touch Panel target in the **Remote path for target application** text box.
Note Although it is common to use the same name for the Touch Panel VI, application, and build specification, you are not required to do so.

2. (Optional) Click the Help button to open the LabVIEW Help and read a description of each build setting.

3. Select the Device Information category to view which target and processor this build specification applies to.
4. Select the **Source Files** category to select the source files to include when you build the Touch Panel VI into an application. When you use the Touch Panel Project Wizard to create a build specification, LabVIEW automatically uses the VI you import as the top-level VI. When you create build specifications outside of the wizard, you must manually select the top-level VI and click the blue arrow button to move the VI to the **Top-level VI** text box, as shown in Figure 6. Touch Panel applications can have only one top-level VI.

![Figure 6. Selecting the Source Files](image)

**Note**  The **Source File Settings** and **Machine Aliases** categories are not used in this tutorial. You use the **Source File Settings** page to view and set VI-level code generation options. You use the **Machine Aliases** page to overwrite the default IP address of a target hosting shared variables so you can move the shared variables to a different host without rebuilding the application. Refer to the *Using Shared Variables (Touch Panel Module)* topic in the *LabVIEW Help* for more information about using shared variables.
5. Select the Generated Files category to view the filenames and paths to the files the Touch Panel Module generates when you build the Touch Panel VI into a Touch Panel application.

6. Click the OK button. The build specification you just created appears in the Project Explorer window under the Touch Panel target, as shown in Figure 7.

![Project Explorer Window](image)

**Figure 7.** Project Explorer Window

7. Select File  Save Project in the Project Explorer window to save the project. LabVIEW saves any build specifications with the project.

8. If you configured the Touch Panel device to use the NI TPC Service, ensure that the NI TPC Service is running on the device.
   a. Right-click the Touch Panel target in the Project Explorer window and select Properties from the shortcut menu to display the Touch Panel Target Properties dialog box.
   b. On the General page, click the Test button to confirm that the NI TPC Service is running on the target.
Building the Touch Panel VI into an Application and Deploying

After you develop the Touch Panel VI on the host computer, you build the VI into an executable Touch Panel application that you can run on a Touch Panel target. Pick one of the options in the Using the Shortcut Menu section or the Using the Run Button section of this manual to build, deploy, and run the Touch Panel application.

Using the Shortcut Menu

Right-click the build specification in the Project Explorer window and select one of the following options from the shortcut menu:

- **Deploy**—Builds the Touch Panel VI into a Touch Panel application, if necessary, and deploys the application to the target. This option does not run the application automatically.

- **Run**—Builds the Touch Panel VI into a Touch Panel application, if necessary; deploys the application to the target; and runs the application automatically.

- **Build**—Builds the Touch Panel VI into a Touch Panel application. This option does not deploy or run the application automatically.

Using the Run Button

When you run a Touch Panel VI under the target in the Project Explorer window, the Run button behaves differently from when you run a VI under My Computer in the Project Explorer window:

- **If you want to build, deploy, and run**—Click the Run button in a Touch Panel VI to build the VI into a Touch Panel application, deploy the application to the target, and run the application on the Touch Panel target. LabVIEW prompts you to create a build specification if you do not have an existing build specification for the Touch Panel VI. If you have multiple build specifications, LabVIEW prompts you to select a build specification in the Select a Build Specification dialog box. Alternatively, you can specify a default build specification by right-clicking a build specification in the Project Explorer window and selecting Set as Default from the shortcut menu. LabVIEW indicates the default build specification with a green square around the Touch Panel build specification glyph in the Project Explorer window.

- **If you want to build without deploying or running**—Press the <Ctrl> key while you click the Run button in a Touch Panel VI to build the Touch Panel VI into a Touch Panel application without deploying or running the application. LabVIEW prompts you to create a build specification if you do not have an existing build specification for the Touch Panel VI. If you have multiple build specifications, LabVIEW prompts you to select a build specification in the Select a Build
**Specification** dialog box. Alternatively, you can specify a default build specification by right-clicking a build specification in the **Project Explorer** window and selecting **Set as Default** from the shortcut menu. LabVIEW indicates the default build specification with a green square around the Touch Panel build specification glyph in the **Project Explorer** window.

### Closing the Touch Panel Application

Tap the **Exit** button in the Touch Panel application on the Touch Panel target to close the Touch Panel application.

### Debugging the Touch Panel Application

You must create a build specification that enables debugging before you can debug a Touch Panel application. Enabling debugging generates extra debugging information and can significantly increase the size of the application.

When LabVIEW on the host computer connects to the Touch Panel target, the application runs on the Touch Panel target. The front panel is fully functional on the Touch Panel target. However, the front panel controls have no effect on the Touch Panel application, and the indicators in the Touch Panel VI on the host computer do not reflect the execution of the application on the Touch Panel target.

The block diagram acts as a conduit between the Touch Panel application running on the target and the Touch Panel VI running on the host computer, where you can probe signals, set breakpoints, and step through code as you do in any other VI.

**Tip** You can modify an existing build specification by double-clicking the build specification in the **Project Explorer** window or right-clicking the build specification and selecting **Properties** from the shortcut menu. This tutorial creates a second build specification for debugging.

### Creating a Debugging Build Specification

Complete the following steps to create a debugging build specification.

1. Right-click **Build Specifications** under the Touch Panel target and select **New»Touch Panel Application (EXE)** from the shortcut menu to open the **Touch Panel Build Specification Properties** dialog box.
2. Enter (Debug) Touch Panel Tutorial in the **Build specification name** text box.
3. Remove the checkmark from the **Same as top-level VI** checkbox so you can change the Touch Panel application name.
4. Enter (Debug) Touch Panel Tutorial.exe in the Target filename text box.

5. Place a checkmark in the Enable debugging checkbox to generate debugging information when you build the Touch Panel VI into an application, as shown in Figure 8.

![Figure 8. Creating the Debugging Build Specification](image)

6. Select Source Files from the Category list and select Touch Panel Tutorial.vi in the Project Files list. Click the blue right arrow button to move the VI from the source files list to the Top-level VI text box.
7. Click the **OK** button. The build specification you just created appears in the **Project Explorer** window, as shown in Figure 9.

![Figure 9. Two Build Specifications in the Project Explorer Window](image)

**Adding a Probe to the Touch Panel VI**

Probes display information about the data that passes through a wire. As you interact with the Touch Panel application on the Touch Panel target, you can see the data passing through the wire in the Touch Panel VI on the host computer.

Complete the following steps to add a probe to the Touch Panel Tutorial VI.

1. Select **Window»Show Block Diagram** in the VI to open the block diagram if it is not visible.

   **Tip** Double-click the VI in the **Project Explorer** window to open the VI if the VI is not already open.
2. Right-click the wire connecting the **Set Temperature** control and select **Probe** from the shortcut menu.

A floating **Probe** window appears when you create a probe. LabVIEW numbers the **Probe** windows automatically and displays the same number in a glyph on the wire you probe, as shown in Figure 10.

![Figure 10. Adding a Probe to the Block Diagram](image)

**Deploying and Debugging a Touch Panel Application**

You must use the debugging build specification to deploy the Touch Panel VI, which contains debugging information, to the Touch Panel target before the probe in the Touch Panel VI on the host computer can update the values passing through the wire.

Complete the following steps to deploy and debug the Touch Panel application.

1. Right-click the debugging build specification you want to build and deploy and select **Debug** from the shortcut menu. Save any VIs if prompted.

   LabVIEW builds the VI into an application, deploys the application to the Touch Panel target, and runs the application on the target.

2. Change the value of the **Set Temperature** knob in the Touch Panel application running on the Touch Panel target. The value in the **Probe** window on the block diagram on the host computer updates as you change the value of the knob in the Touch Panel application.
Note  Any changes you make on the front panel of the Touch Panel VI on the host computer have no effect on the Touch Panel application running on the Touch Panel target.

3. Tap the Exit button in the application on the Touch Panel target to stop the application and end the debugging session.

**XP Embedded Tutorial**

Use this tutorial to learn how to configure a Touch Panel XP Embedded device to use the NI TPC Service; how to use the Touch Panel Project Wizard to create a project; and how to build, deploy, run, and debug a Touch Panel application.

The VI in this tutorial simulates setting a temperature, displaying the current temperature in a graph and on a thermometer, and indicating if the temperature is not in range.

**Creating the LabVIEW Project**

Use LabVIEW projects to group together LabVIEW files and non-LabVIEW files, create build specifications for building a Touch Panel VI into an application, and deploy the application to the target. You must use a project to build a Touch Panel VI into an application.

Using the Touch Panel Project Wizard, complete the following steps to create a LabVIEW project, add the target, and add an existing VI to the project.

1. Launch LabVIEW. In the **Getting Started** window, select **Touch Panel Project** from the **Targets** pull-down menu. Click the **Go** button to launch the Touch Panel Project Wizard.

2. Define the project information, as shown in Figure 11.
   a. Select **New Touch Panel project, import VI** from the Project type pull-down menu to create the LabVIEW project using an existing VI.

   **Tip** The blank VI project type creates a project with a new Touch Panel template VI rather than importing an existing VI.

   b. Specify a project name and the location where you want to save the project and the VI in the Project location text box. Save the project to a location other than the default location so you do not overwrite the shipping example with your changes. The default project name is **Untitled project.lvproj**. For this tutorial, name the project **Touch Panel Tutorial.lvproj** in the Project location text box.
c. Click the **Browse** button next to the **VI path** text box and navigate to `labview\examples\TouchPanel\tutorial\Touch Panel Tutorial.vi` to select the VI to import. Click the **OK** button to add the VI to the project you are creating.

![Figure 11. Defining the Project Information](image)

3. Click the **Next** button.
4. Select the Touch Panel device you are using. Select **NI TPC-2512 Device** from the **Device type** pull-down menu, as shown in Figure 12.

![Selecting the Target](image)

**Figure 12.** Selecting the Target

*Note* If you are using a third-party XP Embedded device, select **Windows XP Embedded Device** from the **Device type** pull-down menu instead.

5. Click the **Next** button.
6. Configure connection information for the device. Enter the IP address for the device in the **Touch Panel device IP address** text box, as shown in Figure 13.

![Create New Touch Panel Project](image)

**Figure 13.** Configuring the Device

7. Click the **Next** button.
8. The System preview page, shown in Figure 14, shows a preview of the project the wizard creates when you click the Finish button. Notice the checkmark in the Create a build specification checkbox. This checkmark indicates you want to create a build specification immediately after you create the project. Refer to the Creating the Build Specification section for more information about creating a build specification.

![Create New Touch Panel Project](image)

**Figure 14.** Previewing the Project

9. Click the Finish button.

Because the Create a build specification checkbox contains a checkmark as shown in Figure 14, the Application Properties dialog box opens when you click the Finish button.
Creating the Build Specification

Build specifications contain the build settings and code generation options to use when you build a Touch Panel VI into an application. You can create the build specification when you create a project or wait until you are ready to build the application. You must create a build specification before you can build a Touch Panel VI into an application.

You can have multiple build specifications for the same target. For example, you might want one build specification that generates debugging information and another build specification that does not generate this extra information.

Note This tutorial creates the build specification through the Touch Panel Project Wizard. You also can create a build specification at any time by right-clicking Build Specifications under the target in the Project Explorer window and selecting New»Touch Panel Application (EXE) from the shortcut menu.

Complete the following steps to create a Touch Panel build specification.

1. Define the settings for the Touch Panel application, as shown in Figure 15.
   a. Enter a name for the build specification in the Build specification name text box. This is the name that appears under Build Specifications in the Project Explorer window.
   b. Enter a name for the application in the Target filename text box. For this tutorial, name the application Touch Panel Tutorial.exe.
   c. Browse to and select the destination directory for the Touch Panel application on the host computer, which is where LabVIEW saves the .exe, in the Local destination directory text box.
   d. Enter the destination directory for the Touch Panel application on the Touch Panel target in the Target destination directory text box.
2. (Optional) Click the Help button to open the LabVIEW Help and read a description of each build setting.

3. Select the Source Files category to select the source files to include when you build the Touch Panel VI into a Touch Panel application. When you use the Touch Panel Project Wizard to create a build specification, LabVIEW automatically uses the VI you import as the startup VI. When you create build specifications outside of the wizard, you must select the startup VI manually and click the blue arrow button to move the VI to the Startup VIs list box, as shown in Figure 16. You must define at least one VI as the startup VI for the application.
In this tutorial, you can use the default settings for the following categories:

- **Destinations**—Specifies destination settings, adds destination directories for the application, and indicates whether LabVIEW adds the files to a new project library.
- **Source File Settings**—Specifies destinations and properties for individual files and folders in the application.
- **Icon**—Specifies the icon file to associate with the application.
- **Advanced**—Configures advanced settings for the application.
- **Additional Exclusions**—Configures settings to disconnect type definitions, removes unused polymorphic VI instances, and removes unused members of project libraries to reduce the size of the application.
- **Version Information**—Specifies the version number and other application information.
- **Run-Time Languages**—Sets the language preferences for the application.
5. Select the **Preview** category and click the **Generate Preview** button to view the filenames and paths to the files the Touch Panel Module generates when you build the Touch Panel VI into a Touch Panel application.

6. Click the **OK** button. The build specification you created appears in the **Project Explorer** window under the Touch Panel target, as shown in Figure 17.

![Project Explorer Window](image)

7. Select **File»Save Project** in the **Project Explorer** window to save the project. LabVIEW saves any build specifications with the project.

8. Ensure that the NI TPC Service is running on the device.
   a. Right-click the Touch Panel target in the **Project Explorer** window and select **Properties** from the shortcut menu to display the **Touch Panel Target Properties** dialog box.
   b. On the **General** page, click the **Test** button to confirm that the NI TPC Service is running on the target.
Building the Touch Panel VI into an Application and Deploying

After you develop the Touch Panel VI on the host computer, you build the VI into an executable Touch Panel application that you can run on a Touch Panel target. Pick one of the options in the Using the Shortcut Menu section or the Using the Run Button section of this manual to build, deploy, and run the Touch Panel application.

Using the Shortcut Menu

Right-click the build specification in the Project Explorer window and select one of the following options from the shortcut menu:

- **Deploy**—Builds the Touch Panel VI into a Touch Panel application, if necessary, and deploys the application to the target. This option does not run the application automatically.

- **Run**—Builds the Touch Panel VI into a Touch Panel application, if necessary; deploys the application to the target; and runs the application automatically.

- **Build**—Builds the Touch Panel VI into a Touch Panel application. This option does not deploy or run the application automatically.

Using the Run Button

When you run a Touch Panel VI under the target in the Project Explorer window, the Run button behaves differently from when you run a VI under My Computer in the Project Explorer window:

- **If you want to build, deploy, and run**—Click the Run button in a Touch Panel VI to build the VI into a Touch Panel application, deploy the application to the target, and run the application on the Touch Panel target. LabVIEW prompts you to create a build specification if you do not have an existing build specification for the Touch Panel VI. If you have multiple build specifications, LabVIEW prompts you to select a build specification in the Select a Build Specification dialog box. Alternatively, you can specify a default build specification by right-clicking a build specification in the Project Explorer window and selecting Set as Default from the shortcut menu. LabVIEW indicates the default build specification with a green square around the Touch Panel build specification glyph in the Project Explorer window.

- **If you want to build without deploying or running**—Press the <Ctrl> key while you click the Run button in a Touch Panel VI to build the Touch Panel VI into a Touch Panel application without deploying or running the application. LabVIEW prompts you to create a build specification if you do not have an existing build specification for the Touch Panel VI. If you have multiple build specifications, LabVIEW prompts you to select a build specification in the Select a Build
**Specification** dialog box. Alternatively, you can specify a default build specification by right-clicking a build specification in the **Project Explorer** window and selecting **Set as Default** from the shortcut menu. LabVIEW indicates the default build specification with a green square around the Touch Panel build specification glyph in the **Project Explorer** window.

**Debugging the Touch Panel Application**

You must create a build specification that enables debugging before you can debug a Touch Panel application.

When LabVIEW on the host computer connects to the Touch Panel target, the application runs on the Touch Panel target. The front panel is fully functional on the Touch Panel target. The front panel controls affect the Touch Panel application, and the indicators in the Touch Panel VI on the host computer reflect the execution of the application on the Touch Panel target.

The block diagram acts as a conduit between the Touch Panel application running on the target and the Touch Panel VI running on the host computer, where you can probe signals, set breakpoints, and step through code as you do in any other VI.

Debugging Touch Panel applications for XP Embedded targets is similar to debugging stand-alone applications that you create with the Application Builder. For more information about debugging stand-alone applications, refer to the **Debugging Applications and Shared Libraries** topic in the **LabVIEW Help**.

**Tip** You can modify an existing build specification by double-clicking the build specification in the **Project Explorer** window or right-clicking the build specification and selecting **Properties** from the shortcut menu. This tutorial creates a second build specification for debugging.

**Creating a Debugging Build Specification**

Complete the following steps to create a debugging build specification.

1. Right-click **Build Specifications** under the Touch Panel target and select **New>Touch Panel Application (EXE)** from the shortcut menu to open the **Application Properties** dialog box.

2. Enter (Debug) Touch Panel Tutorial in the **Build specification name** text box.
3. Enter (Debug) Touch Panel Tutorial.exe in the Target filename text box, as shown in Figure 18.

![Figure 18. Creating the Debugging Build Specification](image)

4. Select Source Files from the Category list and select Touch Panel Tutorial.vi in the Project Files list. Click the blue right arrow button to move the VI from the source files list to the Startup VIs list box.

5. Select Advanced from the Category list.

6. Place a checkmark in the Enable debugging checkbox to generate debugging information when you build the Touch Panel VI into an application.
7. Click the OK button. The build specification you created appears in the Project Explorer window, as shown in Figure 19.

![Figure 19](image)

**Figure 19.** Two Build Specifications in the Project Explorer Window

### Adding a Probe to the Touch Panel VI

Probes display information about the data that passes through a wire. As you interact with the Touch Panel application on the Touch Panel target, you can see the data passing through the wire in the Touch Panel VI on the host computer.

Complete the following steps to add a probe to the Touch Panel Tutorial VI.

1. Select **Window»Show Block Diagram** in the VI to open the block diagram if it is not visible.

**Tip** Double-click the VI in the Project Explorer window to open the VI if the VI is not already open.
2. Right-click the wire flowing from the **Set Temperature** control and select **Probe** from the shortcut menu.

A floating **Probe** window appears when you create a probe. LabVIEW numbers the **Probe** windows automatically and displays the same number in a glyph on the wire you probe, as shown in Figure 20.

![Figure 20. Adding a Probe to the Block Diagram](image)

**Deploying and Debugging a Touch Panel Application**

You must use the debugging build specification to deploy the Touch Panel VI, which contains debugging information, to the Touch Panel target before the probe in the Touch Panel VI on the host computer can update the values passing through the wire.

Complete the following steps to deploy and debug the Touch Panel application.

1. Right-click the build specification for the VI you want to build and deploy, which is **(Debug) Touch Panel Tutorial**, and select **Debug** from the shortcut menu. Save any VIs if prompted.

   LabVIEW builds the VI into an application, deploys the application to the Touch Panel target, and runs the application on the target.

2. Change the value of the **Set Temperature** knob in the Touch Panel application running on the Touch Panel target. The value in the **Probe** window on the block diagram on the host computer updates as you change the value of the knob in the Touch Panel application.
3. Tap the Exit button in the application on the Touch Panel target to stop the application and end the debugging session.

Related Documentation

LabVIEW includes extensive online and print documentation for new and experienced LabVIEW users. The following documents contain information that you might find helpful as you use the Touch Panel Module:

- **LabVIEW Help**—Refer to the LabVIEW Help, available by selecting Help Search the LabVIEW Help in LabVIEW, for information about LabVIEW programming concepts, step-by-step instructions for using LabVIEW, and reference information about LabVIEW VIs, functions, palettes, menus, and tools. Refer to the Touch Panel Module book on the Contents tab of the LabVIEW Help for information specific to the Touch Panel Module and Touch Panel applications. The LabVIEW Help uses (TPC) in the index to indicate Touch Panel-specific topics.

- **LabVIEW Touch Panel Module Readme**—Refer to the LabVIEW Touch Panel Module Readme, available by selecting Start All Programs National Instruments LabVIEW Readme and opening readme_TPC.html, for last-minute information and known issues.

- **Touch Panel Module Examples**—Use the Touch Panel Module examples to learn how to use certain VIs and functions as well as a starting point for developing your own Touch Panel VIs and applications. You can modify an example to fit an application, or you can copy and paste from one or more examples into a VI that you create. Browse or search the example VIs with the NI Example Finder by selecting Help Find Examples.

- Documentation for your Touch Panel device.

- **LabVIEW PDFs**—In addition to this document, the Getting Started with LabVIEW manual, LabVIEW Quick Reference Card, LabVIEW Fundamentals manual, LabVIEW Release Notes, and LabVIEW Upgrade Notes are available as PDFs by selecting Start All Programs National Instruments LabVIEW LabVIEW Manuals.

**Note** You must have Adobe Reader 6.0.1 or later installed to view or search the PDF versions of these manuals. Refer to the Adobe Systems Incorporated Web site at www.adobe.com to download Adobe Reader. Refer to the National Instruments Product Manuals Library at ni.com/manuals for updated documentation resources.
Where to Go for Support

The National Instruments Web site is your complete resource for technical support. At ni.com/support you have access to everything from troubleshooting and application development self-help resources to email and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, Austin, Texas, 78759-3504. National Instruments also has offices located around the world to help address your support needs. For telephone support in the United States, create your service request at ni.com/support and follow the calling instructions or dial 512 795 8248. For telephone support outside the United States, contact your local branch office:

Australia 1800 300 800, Austria 43 662 457990-0, Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599, Canada 800 433 3488, China 86 21 5050 9800, Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, Finland 358 (0) 9 725 72511, France 01 57 66 24 24, Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737, Italy 39 02 41309277, Japan 0120-527196, Korea 82 02 3451 3400, Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466, New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851, Singapore 1800 226 5886, Slovenia 386 3 425 42 00, South Africa 27 0 11 805 8197, Spain 34 91 640 0085, Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, Taiwan 886 02 2377 2222, Thailand 662 278 6777, Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545