
Getting Started with the 
LabVIEW  Touch Panel Module 
for Windows CE
Version 8.5

The LabVIEW Touch Panel Module extends the LabVIEW graphical 
development environment to Touch Panel devices so you can create 
human-machine interface (HMI) applications for Touch Panel devices 
running Windows CE. You can create custom touch panel displays to 
communicate with National Instruments embedded real-time platforms, 
such as Compact FieldPoint, CompactRIO, and Compact Vision System.

This manual contains new features for version 8.5, system requirements, 
installation instructions, and a tutorial that shows you how to create a 
LabVIEW project and build, run, deploy, and debug a Touch Panel 
application.
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What’s New in the LabVIEW 8.5 Touch Panel Module
The LabVIEW 8.5 Touch Panel Module features and changes include
the NI TPC Service, support for front panel data binding, and expanded 
support for front panel controls and indicators.

Refer to the LabVIEW Upgrade Notes, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.5»Manuals and 
opening LV_Upgrade_Notes.pdf for more information about new 
features in LabVIEW 8.5.

Refer to the Touch Panel Module book on the Contents tab of the 
LabVIEW Help, available by selecting Help»Search the LabVIEW Help 
in LabVIEW, for more information specific to the Touch Panel Module and 
Touch Panel applications.

Refer to the Touch Panel Module Readme file, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.5»Readme and 
opening readme_TPC.html for known issues with version 8.5 of the 
Touch Panel Module.

General
The LabVIEW 8.5 Touch Panel Module includes the following 
enhancements and new features:

• NI TPC Service—The Touch Panel Module includes the NI TPC 
Service, which is an Ethernet-based service that you can use to deploy, 
run, and debug Touch Panel applications. Use the NI TPC Service 
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instead of ActiveSync if you are using Ethernet and need to deploy a 
Touch Panel application to multiple Touch Panel targets.

You must install the NI TPC Service on the Touch Panel target before 
you can use the NI TPC Service. Refer to the NI TPC Service Support 
section for more information about installing the NI TPC Service on 
Touch Panel targets. After you install the NI TPC Service on the Touch 
Panel target, use the NI TPC Service Manager to configure the service 
to run on the Touch Panel device. Select Start»All Programs»
National Instruments»NI TPC Service»NI TPC Service Manager 
1.0 to launch the NI TPC Service Manager. The manager checks the 
status of the NI TPC Service and displays the status information. Tap 
the Start button to start the NI TPC Service. Tap the Stop button to 
stop the NI TPC Service.

To configure a Touch Panel application to use the NI TPC Service, 
right-click the Touch Panel target in the Project Explorer window and 
select Properties to display the Touch Panel Target Properties 
dialog box. On the General page, select NI TPC Service (TCP/IP) 
from the Connection pull-down menu. You must enter the IP address 
of the Touch Panel device in the Touch Panel Device IP Address text 
box. Click the Test button to confirm that the NI TPC Service is 
running on the remote device.

• Reading and writing front panel data using data binding—You can 
use data binding to read or write front panel data for 
network-published shared variables. You can use data binding with 
any front panel control or indicator that the Touch Panel Module 
supports.

Note When you use front panel data binding in a Touch Panel subVI, LabVIEW closes 
data binding connections when the subVI finishes execution.

For more information about data binding, refer to the Reading and 
Writing Front Panel Data Using Data Binding topic in the LabVIEW 
Help. Select Help»Search the LabVIEW Help in LabVIEW to 
display the LabVIEW Help. For more information about using shared 
variables in Touch Panel VIs, refer to the Using Shared Variables in 
PDA and Touch Panel VIs topic in the LabVIEW Help. Refer to the 
Shared Variable Intro - Touch Panel.lvproj in the 
labview\examples\TouchPanel\shared variable directory 
for an example of using front panel data binding.

• LabVIEW Aliases File Editor—In previous versions of the Touch 
Panel Module, you changed the IP address of the shared variable host 
in the aliases file and manually downloaded the aliases file to the same 
directory as the corresponding application on the Touch Panel target. 
You now can use the LabVIEW Aliases File Editor to edit the aliases 
file on the target. 
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Tap LabVIEW Aliases File Editor.exe in the NI\Shared 
Variables Support 8.5 directory to launch the LabVIEW Aliases 
File Editor on the target. Tap the browse button to browse to and open 
an aliases file.

• Large application optimizations—For large applications with 
numerous front panel controls and indicators, the time it takes to build 
applications is significantly less than in previous versions. The Touch 
Panel Module also generates significantly less C code for large 
applications.

• Call by Reference Node supports local references—You now can 
use a local reference with the Call by Reference Node. Select the 
Source Files category of the Touch Panel Build Specification 
Properties dialog box to include any VIs that the Call by Reference 
Node calls locally in the project.

• Expression folding—Expression folding optimizes performance by 
collapsing groups of nodes into single expressions in the generated 
code that are easily recognized by C compilers. Place a checkmark in 
the Expression folding checkbox on the Application Information 
page of the Touch Panel Build Specification Properties dialog box 
to enable expression folding. You cannot debug a Touch Panel VI 
while using expression folding because expression folding eliminates 
some wires on the block diagram.

• Expression Node supports clusters and arrays—You now can use 
arrays or clusters as inputs to an Expression Node.

• Inline C Node—You can use the Inline C Node to add inline C code 
to the block diagram. The Inline C Node is similar to the Formula Node 
with additional support and functionality for low-level programming 
and header files without the overhead of a function call. Use the Inline 
C Node for short blocks of code that you cannot easily implement in 
VIs.

• New VISA examples—The Touch Panel Module includes new VISA 
examples, which are located in the labview\examples\
TouchPanel\comm\VISA directory.

Front Panel Controls and Indicators
• Blinking Boolean controls and indicators—The Touch Panel 

Module supports blinking for all Boolean controls and indicators 
except system controls. Use a Property Node with the Blinking 
property to enable blinking.

• Boolean mechanical action—The Touch Panel Module now supports 
the six types of mechanical action for Boolean controls, which include 
Switch when pressed, Switch when released, Switch until released, 
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Latch when pressed, Latch when released, and Latch until 
released.

• Control labels inside arrays—Labels on front panel controls and 
indicators that you place inside arrays are now visible in Touch Panel 
applications. Right-click the control or indicator and select Visible 
Items»Label from the shortcut menu to display the label.

• Resizing and changing the color of increment and decrement 
buttons—You now can resize and change the color of the increment 
and decrement buttons for numeric controls, enumerated type controls, 
and time stamp controls.

• Scroll bar control—The Touch Panel Module supports scroll bar 
controls, which include vertical and horizontal scroll bars that you can 
add to any front panel control or indicator with scrollable data. Use a 
Property Node to associate a scroll bar control with a front panel 
control or indicator.

• Text justification and underlining text for controls and 
indicators—You now can set the justification of text and underline 
text for buttons; enumerated type controls; and string, time stamp, and 
numeric controls and indicators. 

Select the Limit to Single Line option from the shortcut menu for the 
string control to disable justification.

• Events and overlapping controls—When controls overlap each 
other, the control with the higher tabbing order number no longer 
receives the event. The topmost control now receives the event.

• Free labels and decorations inside cluster controls and 
indicators—You now can use free labels and decorations inside 
cluster controls and indicators.

• Decorations inside tab controls—Decorations on one page of a tab 
control no longer appear on all the pages of the tab control.

• Decimal values in ring controls—You now can use decimal values 
for items in a ring control. 

Newly Supported VIs and Functions
• Get Special Folder Path—You can use the Get Special Folder Path 

VI to return the path to the application or directories that applications 
frequently use.

• PDA Picture to Pixmap—You can use the PDA Picture to Pixmap VI 
to convert a picture to a cluster of image data that you can use to 
perform certain tasks with the image, such as writing customized 
pictures to file.

• Run Application—You can use the Run Application VI to run a 
specified Touch Panel application.
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• Show Hide Input Panel—You can use the Show Hide Input Panel VI 
to display or hide the input panel for Touch Panel devices.

• Static VI Reference —You can use the Static VI Reference function 
to maintain a static reference to a VI. You can configure the Static VI 
Reference function to output a generic or strictly typed VI reference. 
After you place the Static VI Reference function on a block diagram, 
double-click the function to display a file dialog box in which you can 
select a VI.

• XML functions—The Touch Panel Module now includes the Escape 
XML, Flatten To XML, Read From XML File, Unescape XML, 
Unflatten From XML, and Write to XML File VIs and functions. You 
can use these VIs and functions to manipulate LabVIEW data in XML 
format.

Newly Supported Properties
• Cluster properties—The Touch Panel Module includes the following 

new cluster properties that you can use with cluster controls: Cluster 
Size, Cluster Size:Height, Cluster Size:Width, and Controls[]. You can 
use a Property Node with these properties to set the size of cluster 
controls and get references to cluster elements. 

The Touch Panel Module also includes the following new cluster 
properties that you can use with radio buttons controls: Cluster Size, 
Cluster Size:Height, Cluster Size:Width, and Color. You can use a 
Property Node with these properties to set the size and color of radio 
buttons controls.

• Data binding properties—The Touch Panel Module includes the 
following new data binding properties: Data Binding:Binding Type, 
Data Binding:LED Visible, Data Binding:Mode, Data Binding:Path, 
and Data Binding:Status. You can use a Property Node with these 
properties to return information about the data connection, configure 
the mode of the data connection, or show or hide the data binding 
indicator.

• Text property—You can use the Text property to read from or write to 
a string control or indicator.

• Waveform graph cursor properties—You can use the Allow Drag 
and Cursor Legend Visible properties with waveform graphs. Use a 
Property Node with the Allow Drag property to allow users to move 
the cursor in the plot area. Use a Property Node with the Cursor 
Legend Visible property to display the cursor legend for the waveform 
graph.
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System Requirements
The Touch Panel Module has the following requirements:

• A desktop computer with Windows Vista/XP or Windows 2000 with 
Service Pack 4.0 or later.

• LabVIEW 8.5 Base, Full, or Professional Edition.

• 2.5 GB available disk space.

• A Touch Panel device, such as the NI TPC-2006, running 
Windows CE 4.2 or 5.0.

Refer to the LabVIEW Release Notes, available by selecting Start»
All Programs»National Instruments»LabVIEW 8.5»LabVIEW 
Manuals and opening LV_Release_Notes.pdf, for standard
LabVIEW development system requirements.

Installing the Touch Panel Module
Complete the following steps to install the Touch Panel Module.

1. On Windows Vista/XP/2000, log in as an administrator or as a user 
with administrator privileges.

2. Install LabVIEW 8.5, if not already installed. Refer to the LabVIEW 
Release Notes for standard LabVIEW installation instructions.

3. Install the Touch Panel Module. 

The Touch Panel Module includes Microsoft tools, such as Microsoft 
ActiveSync on Windows XP/2000. Some of these Microsoft tools 
might interfere with any existing installations of Visual Studio, 
Windows Embedded, or Windows CE toolkits.

Note (Windows XP/2000) The Touch Panel Module installs ActiveSync 4.2 if you do not 
already have ActiveSync 4.2 or later installed. The Touch Panel Module works with 
ActiveSync 4.2 or later.

4. Activate the Touch Panel Module.

You must activate the Touch Panel Module before you can build 
Touch Panel VIs into Touch Panel applications. The Touch Panel 
Module runs in evaluation mode if you do not activate it. In evaluation 
mode, you can create Touch Panel VIs, but any Touch Panel 
applications you build run only for five minutes. You have the option 
of activating the Touch Panel Module at the end of the installation. You 
also can use the NI License Manager, available by selecting Start»
All Programs»National Instruments»NI License Manager, to 
activate National Instruments products. Refer to the National 
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Instruments License Manager Help, available by selecting 
Help»Contents in the National Instruments License Manager, for 
more information about activating NI products.

5. Restart the computer when the installer completes.

6. (Windows Vista) You must install Windows Mobile Device Center to use 
the Touch Panel Module. Refer to the Microsoft Web site at 
www.microsoft.com to download Windows Mobile Device Center.

7. Install the additional tools you need. Refer to the Installing the 
Additional Tools section for more information about the additional 
tools.

Uninstalling the Touch Panel Module
In addition to uninstalling the Touch Panel Module, you also must uninstall 
the following:

• (Windows XP/2000) Microsoft ActiveSync

• Microsoft Device Emulator version 1.0 – ENU

• Microsoft Visual C++ 2005 Redistributable

Installing the Additional Tools
You must install additional tools on the target depending on the 
functionality you need.

NI TPC Service Support
You must install the NI TPC Service on the Touch Panel target before you 
can use the NI TPC Service.

Complete the following steps to install support for the NI TPC Service on 
a Touch Panel target.

1. Depending on which type of target you are using, use FTP or an 
external storage device to copy NITPCService.cab from the 
labview\PDA\Utilities\NITPCService\ARM directory or 
labview\PDA\Utilities\NITPCService\x86 directory to
any location on the Touch Panel device. 

2. Run the .cab file on the Touch Panel device to install the NI TPC 
Service.

3. For NI TPC devices, use the default installation location. Tap the 
<Enter> key to accept the default installation location. 

For third-party devices, install the service in the non-volatile directory 
on the device.

http://www.microsoft.com
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Shared Variable Support
For third-party devices, you must install support for shared variables on the 
Touch Panel target before you can run a Touch Panel application with 
shared variables. For NI TPC devices, you must install the latest version of 
shared variable support on the Touch Panel target to use front panel data 
binding and Shared Variable nodes in your Touch Panel applications.

ActiveSync
Complete the following steps to install or uninstall support for shared 
variables on a Touch Panel target using ActiveSync.

1. Connect the Touch Panel device to ActiveSync on the host computer.

2. Navigate to and run labview\PDA\Utilities\Variables\ARM\
Setup.exe or labview\PDA\Utilities\Variables\x86\
Setup.exe, depending on which type of target you are using.

3. For NI TPC devices, use the default installation location. For 
third-party devices, install the service in the non-volatile directory on 
the device.

NI TPC Service
Complete the following steps to install or uninstall support for shared 
variables on a Touch Panel target using NI TPC Service.

1. Right-click the Touch Panel target in the Project Explorer window 
and select Install»Support for Shared Variables from the shortcut 
menu.

2. For NI TPC devices, use the default installation location. For 
third-party devices, install the service in the non-volatile directory on 
the device.

PNG Image Support
You must install support for PNG images on the Touch Panel target if the 
Touch Panel VI contains PNG images on the front panel.

Note  If you have an NI TPC-2006 device and you have already downloaded updated PNG 
support from KnowledgeBase 40EAE6X1: Improved Display Driver for TPC-2006 
Industrial Touch Panel Computer from the National Instruments Web site, you do not need 
to complete the following steps.

NI TPC-2012 devices already include support for PNG images.
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ActiveSync
Complete the following steps to install or uninstall support for PNG images 
on a Touch Panel target using ActiveSync.

1. Connect the Touch Panel device to ActiveSync on the host computer.

2. Navigate to and run labview\PDA\Utilities\LVPNG\ARM\
Setup.exe or labview\PDA\Utilities\LVPNG\x86\
Setup.exe, depending on which type of target you are using.

3. For NI TPC devices, use the default installation location. For 
third-party devices, install the service in the non-volatile directory on 
the device.

NI TPC Service
Complete the following steps to install or uninstall support for PNG images 
on a Touch Panel target using NI TPC Service.

4. Right-click the Touch Panel target in the Project Explorer window 
and select Install»Support for PNG Images from the shortcut menu.

5. For NI TPC devices, use the default installation location. For 
third-party devices, install the service in the non-volatile directory on 
the device.

NI-VISA Support
You must install NI-VISA on the Touch Panel target to use VISA in your 
applications. Select Start»All Programs»National Instruments»VISA 
and select Windows CE for ARM Driver Installation or Windows CE 
for x86 Driver Installation, depending on which type of target you are 
using. 

Tip You also can right-click the Touch Panel target in the Project Explorer window and 
select Install»Support for NI-VISA from the shortcut menu.

x86 Target Support for Third-Party Devices
If you need support for x86 Touch Panel targets running Windows CE 4.2, 
install the following Microsoft eMbedded Visual Tools:

• Microsoft eMbedded Visual C++ 4.0

• Microsoft eMbedded Visual C++ SP 4 or later

• SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at ni.com/info and 
enter the info code tpcevc for the most recent information about 
downloading and installing the Microsoft eMbedded Visual Tools.

http://www.ni.com/info
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Tutorial
Use this tutorial to learn how to configure a Touch Panel device to use the 
NI TPC Service; how to use the Touch Panel Project Wizard to create a 
project; and how to build, deploy, run, and debug a Touch Panel 
application.

The VI in this tutorial simulates setting a temperature, displaying the 
current temperature in a graph and on a thermometer, and indicating
if the temperature is not in range.

Configuring the Device to Use the NI TPC Service
The Touch Panel Module includes the NI TPC Service, which is an 
Ethernet-based service that you can use to deploy, run, and debug Touch 
Panel applications. Use the NI TPC Service instead of ActiveSync if you 
are using Ethernet and need to deploy a Touch Panel application to multiple 
Touch Panel targets.

Note If you want to use ActiveSync instead, ensure the computer is connected to the 
Touch Panel device via USB or serial cables. If you use a serial cable, connection time is 
longer.

Complete the following steps to configure the Touch Panel device to use the 
NI TPC Service.

1. Ensure the host and target are on the same subnet.

2. Enable FTP on the Touch Panel device. Refer to the National 
Instruments KnowledgeBase at ni.com/info and enter the info code 
ex6pwq for the most recent information about configuring NI TPC 
devices to use FTP. For third-party devices, refer to the device 
documentation.

3. Install the NI TPC Service on the Touch Panel target. Refer to the 
NI TPC Service Support section for more information about installing 
the NI TPC Service on Touch Panel targets.

4. Use the NI TPC Service Manager to configure the service to run on the 
Touch Panel device. 

a. Select Start»All Programs»National Instruments»NI TPC 
Service»NI TPC Service Manager 1.0 to launch the NI TPC 
Service Manager. The manager checks the status of the NI TPC 
Service and displays the status information. 

b. Tap the Start button to start the NI TPC Service if the NI TPC 
Service is not running.

http://www.ni.com/info
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Creating the LabVIEW Project
Use LabVIEW projects to group together LabVIEW files and 
non-LabVIEW files, create build specifications for building a Touch Panel 
VI into a Touch Panel application, and deploy the application to a 
Touch Panel device. You must use a project to build a Touch Panel VI into 
a Touch Panel application.

Using the Touch Panel Project Wizard, complete the following steps to 
create a LabVIEW project, add a Touch Panel target, and add an existing 
Touch Panel VI to the project.

1. Launch LabVIEW. In the Getting Started window, select Touch 
Panel Project under the Targets pull-down menu. Click the Go button 
to launch the Touch Panel Project Wizard.

2. Define the project information as shown in Figure 1.

a. Select New Touch Panel project, import VI from the Project 
type pull-down menu to create the LabVIEW project using an 
existing VI.

Tip The blank VI project type creates a project with a new Touch Panel template VI rather 
than importing an existing VI.

b. Specify a project name and the location where you want to save 
the project and the VI in the Project location text box. Save the 
project to a location other than the default location so you do not 
overwrite the shipping example with your changes. The default 
project name is Untitled project.lvproj. For this tutorial, 
enter Touch Panel Tutorial in the Project location text box.

c. Click the Browse button next to the VI path text box and navigate 
to labview\examples\TouchPanel\tutorial\Touch 
Panel Tutorial.vi to select the VI to import. Click the OK 
button to add the VI to the project you are creating.
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Figure 1.  Defining the Project Information

3. Click the Next button.
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4. Select the Touch Panel device you are using from the Device type 
pull-down menu as shown in Figure 2.

Figure 2.  Selecting the Touch Panel Device Type

5. Click the Next button.

6. The System preview page, shown in Figure 3, shows a preview of the 
project the wizard creates when you click the Finish button. Notice the 
checkmark in the Create a build specification checkbox. This 
checkmark indicates you want to create a build specification 
immediately after you create the project. Refer to the Creating the 
Touch Panel Build Specification section for more information about 
creating build specifications.
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Figure 3.  Previewing the Project

Because the Create a build specification checkbox contains a checkmark 
as shown in Figure 3, the Touch Panel Build Specification Properties 
dialog box opens when you click the Finish button.

Creating the Touch Panel Build Specification
Build specifications contain the build settings and code generation options 
to use when you build a Touch Panel VI into a Touch Panel application. 
You can create the build specification when you create the project or wait 
until you are ready to build the Touch Panel VI into a Touch Panel 
application. You must create a build specification before you can build a 
Touch Panel VI into a Touch Panel application.

You can have multiple build specifications for the same target. For example, 
you might want one build specification that generates debugging 
information and another build specification that does not generate this extra 
information.

Note This tutorial creates the build specification through the Touch Panel Project Wizard. 
You also can create a build specification at any time by right-clicking Build Specifications 
in the Project Explorer window and selecting New»Application (EXE) from the shortcut 
menu.
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Complete the following steps to create a Touch Panel build specification. 

1. Define the settings for the Touch Panel application as shown in 
Figure 4.

a. Enter a name for the build specification in the Build specification 
name text box. This is the name that appears under Build 
Specifications in the Project Explorer window. 

b. (Optional) By default, the name of the Touch Panel application is 
the same as the top-level Touch Panel VI. If you do not want to use 
the top-level Touch Panel VI name for the Touch Panel application 
name, remove the checkmark from the Same as top-level VI 
checkbox and enter a name in the Target filename text box.

c. Browse to and select the destination directory for the Touch Panel 
application on the host computer, which is where LabVIEW saves 
the .exe, in the Destination directory text box.

d. Enter the destination directory for the Touch Panel application on 
the Touch Panel target in the Remote path for target application 
text box.

Figure 4.  Defining the Touch Panel Application Information
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Note Although it is common to use the same name for the Touch Panel VI, application, 
and build specification, you are not required to do so.

2. Click the Help button to open the LabVIEW Help and read a 
description of each build setting.

3. Select the Device Information category to view which target and 
processor this build specification applies to.

4. Select the Source Files category to select the source files to include 
when you build the Touch Panel VI into a Touch Panel application. 
When you use the Touch Panel Project Wizard to create a build 
specification, LabVIEW automatically uses the VI you import as the 
top-level VI. When you create build specifications outside of the 
wizard, you must manually select the top-level VI and click the blue 
arrow button, shown at left, to move the VI to the Top-level VI text 
box as shown in Figure 5. Touch Panel applications can have only one 
top-level VI.

Figure 5.  Selecting the Source Files
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Note The Machine Aliases category is not used in this tutorial. You use the Machine 
Aliases category to overwrite the default IP address of a target hosting shared variables so 
you can move the shared variable to a different host without rebuilding the application. 
Refer to the Using Shared Variables in PDA and Touch Panel VIs topic in the LabVIEW 
Help for more information about using shared variables.

5. Select the Generated Files category to view the filenames and paths 
to the files the Touch Panel Module will generate when you build the 
Touch Panel VI into a Touch Panel application.

6. Click the OK button. The build specification you just created appears 
in the Project Explorer window under the Touch Panel target as 
shown in Figure 6.

 

Figure 6.  Project Explorer Window

7. Click File»Save Project in the Project Explorer window to save the 
project. LabVIEW saves build specifications with the project.

8. If you configured the Touch Panel device to use the NI TPC Service, 
configure the application to use the NI TPC Service.

a. Right-click the Touch Panel target in the Project Explorer 
window and select Properties to display the Touch Panel Target 
Properties dialog box. On the General page, select NI TPC 
Service (TCP/IP) from the Connection pull-down menu.

b. Enter the IP address of the Touch Panel device in the Touch Panel 
Device IP Address text box.

c. Click the Test button to confirm that the NI TPC Service is 
running on the remote device.
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Building the Touch Panel VI into a Touch Panel Application
and Deploying

After you develop the Touch Panel VI on the host computer, you build the 
VI into an executable Touch Panel application that you can run on a 
Touch Panel target. Pick one of the options in the Using the Shortcut Menu 
section or the Using the Run Button section to build, run, and deploy a 
Touch Panel application.

Using the Shortcut Menu
Right-click the build specification in the Project Explorer window and 
select one of the following from the shortcut menu:

• Deploy—Builds the Touch Panel VI into a Touch Panel application, 
if necessary, and deploys the application to the Touch Panel target. 
This option does not automatically run the Touch Panel application.

• Run—Builds the Touch Panel VI into a Touch Panel application, 
if necessary; deploys the application to the Touch Panel target; and 
automatically runs the Touch Panel application.

• Build—Builds the Touch Panel VI into a Touch Panel application. 
This option does not deploy or automatically run the Touch Panel 
application.

Using the Run Button
When you run a Touch Panel VI under a Touch Panel target in the Project 
Explorer window, the Run button behaves differently from when you run 
a VI under My Computer in the Project Explorer window:

• If you want to build, deploy, and run—Click the Run button in a 
Touch Panel VI to build the Touch Panel VI into a Touch Panel 
application, deploy the Touch Panel application to the Touch Panel 
target, and run the Touch Panel application on the Touch Panel target. 
LabVIEW prompts you to create a build specification if you do not 
have an existing build specification for the Touch Panel VI. If you have 
multiple build specifications, LabVIEW prompts you to select a build 
specification in the Select a Build Specification dialog box. 
Alternatively, you can specify a default build specification by 
right-clicking a build specification in the Project Explorer window 
and selecting Set as Default from the shortcut menu. The Touch Panel 
Module indicates with a green square around the Touch Panel build 
specification glyph in the Project Explorer window.

• If you want to build without deploying or running—Press the 
<Ctrl> key while you click the Run button in a Touch Panel VI to build 
the Touch Panel VI into a Touch Panel application without deploying 
or running the Touch Panel application. LabVIEW prompts you to 
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create a build specification if you do not have an existing build 
specification for the Touch Panel VI. If you have multiple build 
specifications, LabVIEW prompts you to select a build specification in 
the Select a Build Specification dialog box. Alternatively, you can 
specify a default build specification by right-clicking a build 
specification in the Project Explorer window and selecting Set as 
Default from the shortcut menu. The Touch Panel Module indicates 
with a green square around the Touch Panel build specification glyph 
in the Project Explorer window.

Closing the Touch Panel Application
Tap the Exit button in the Touch Panel application on the Touch Panel 
target to close the Touch Panel application.

Debugging the Touch Panel Application
You must create a build specification that enables debugging before you 
can debug a Touch Panel application. Enabling debugging generates extra 
debugging information and can significantly increase the size of the 
Touch Panel application.

When LabVIEW on the host computer connects to the Touch Panel target, 
the Touch Panel application runs on the Touch Panel target. The front panel 
is fully functional on the Touch Panel target. However, the front panel 
controls have no effect on the Touch Panel application, and the indicators 
of the Touch Panel VI on the host computer do not reflect the execution of 
the Touch Panel application on the Touch Panel target.

The block diagram acts as a conduit between the Touch Panel application 
running on the Touch Panel target and the Touch Panel VI running on the 
host computer, where you can probe signals, set breakpoints, and step 
through code as you do in any other VI.

Tip You can modify an existing build specification by double-clicking the build 
specification in the Project Explorer window or right-clicking the build specification and 
selecting Properties from the shortcut menu. This tutorial creates a second build 
specification for debugging.
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Creating a Debugging Build Specification
Complete the following steps to create a debugging build specification as 
shown in Figure 7.

1. Right-click Build Specifications under the Touch Panel target and 
select New»Application (EXE) from the shortcut menu to launch the 
Touch Panel Build Specification Properties dialog box.

2. Enter (Debug) Touch Panel Tutorial in the Build specification 
name text box.

3. Remove the checkmark from the Same as top-level VI checkbox so 
you can change the Touch Panel application name.

4. Enter (Debug) Touch Panel Tutorial.exe in the Target 
filename text box.

5. Place a checkmark in the Enable debugging checkbox to generate 
debugging information when you build the Touch Panel VI into a 
Touch Panel target.

Figure 7.  Creating the Debugging Build Specification
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6. Select Source Files from the Category list and select Touch Panel 
Tutorial.vi in the source files list. Click the blue right arrow button, 
shown at left, to move the VI from the source files list to the Top-level 
VI text box.

7. Click the OK button. The build specification you just created appears 
in the Project Explorer window as shown in Figure 8.

Figure 8.  Two Touch Panel Build Specifications in the Project Explorer Window

Adding a Probe to the Touch Panel VI
Probes display information about the data that passes through a wire. As 
you interact with the Touch Panel application on the Touch Panel target, 
you can see data passing through the wire in the Touch Panel VI on the host 
computer.

Complete the following steps to add a probe to the Touch Panel Tutorial VI.

1. Select Window»Show Block Diagram in the VI to open the block 
diagram if it is not visible.

Note Double-click the VI in the Project Explorer window to open the VI if the VI is not 
already open.

The block diagram acts as a conduit between the Touch Panel 
application running on the Touch Panel target and the Touch Panel VI 
running on the host computer.

2. Right-click the wire flowing from the Set Temperature control and 
select Probe from the shortcut menu.
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A floating Probe window appears after you create a probe. LabVIEW 
numbers the Probe windows automatically and displays the same 
number in a glyph on the wire you probe as shown in Figure 9.

Figure 9.  Adding a Probe to the Block Diagram

Deploying and Debugging a Touch Panel Application
You must use the debugging build specification to deploy the Touch Panel 
VI, which contains debugging information, to the Touch Panel target 
before the probe in the Touch Panel VI on the host computer can update the 
values passing through the wire.

Complete the following steps to deploy and debug the Touch Panel 
application.

1. Right-click the build specification for the Touch Panel VI you want to 
build and deploy, which is (Debug) Touch Panel Tutorial in Figure 8, 
and select Debug from the shortcut menu. Save any VIs if prompted.

The Touch Panel Module builds the Touch Panel VI into a Touch Panel 
application, deploys the Touch Panel application to the Touch Panel 
target, and runs the Touch Panel application on the Touch Panel.

Tip You also can start a debugging session by clicking the Step Over or Step Into buttons 
or by clicking the Pause button and then clicking the Run button on the block diagram 
toolbar.

2. Change the value of the Set Temperature knob in the Touch Panel 
application running on the Touch Panel target. The value in the Probe 
window on the block diagram on the host computer updates as you 
change the value of the knob in the Touch Panel application.
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Note Any changes you make on the front panel of the Touch Panel VI on the host 
computer have no effect on the Touch Panel application running on the Touch Panel target.

3. Tap the Exit button in the Touch Panel application on the Touch Panel 
target to stop the Touch Panel application and end the debugging 
session.

Related Documentation
LabVIEW includes extensive online and print documentation for new
and experienced LabVIEW users. The following documents contain 
information that you might find helpful as you use the Touch Panel 
Module:

• LabVIEW Help—Refer to the LabVIEW Help, available by selecting 
Help»Search the LabVIEW Help in LabVIEW, for information 
about LabVIEW programming concepts, step-by-step instructions for 
using LabVIEW, and reference information about LabVIEW VIs, 
functions, palettes, menus, and tools. Refer to the Touch Panel 
Module book on the Contents tab of the LabVIEW Help for 
information specific to the Touch Panel Module and Touch Panel 
applications. LabVIEW Help uses (TPC) in the index to indicate 
Touch Panel-specific topics.

• Touch Panel Module Readme—Refer to the Touch Panel Module 
Readme file, available by selecting Start»All Programs»National
Instruments»LabVIEW 8.5»Readme and opening 
readme_TPC.html, for known issues with version 8.5.

• Documentation for the Touch Panel target you use.

• LabVIEW PDFs—In addition to this document, the Getting Started 
with LabVIEW manual, LabVIEW Quick Reference Card, LabVIEW 
Fundamentals manual, LabVIEW Release Notes, and LabVIEW 
Upgrade Notes are available as PDFs by selecting Start»All 
Programs»National Instruments»LabVIEW 8.5»LabVIEW 
Manuals.

Note You must have Adobe Reader with Search and Accessibility 5.0.5 or later installed 
to view the PDFs. You must have Adobe Reader with Search and Accessibility 6.x or later 
installed to search PDF versions of these manuals. Refer to the Adobe Systems 
Incorporated Web site at www.adobe.com to download Adobe Reader. Refer to the 
National Instruments Product Manuals Library at ni.com/manuals for updated 
documentation resources.

http://www.adobe.com
http://www.ni.com/manuals
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Where to Go for Support
The National Instruments Web site is your complete resource for technical 
support. At ni.com/support you have access to everything from 
troubleshooting and application development self-help resources to email 
and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 
11500 North Mopac Expressway, Austin, Texas, 78759-3504. 
National Instruments also has offices located around the world to help 
address your support needs. For telephone support in the United States, 
create your service request at ni.com/support and follow the calling 
instructions or dial 512 795 8248. For telephone support outside the United 
States, contact your local branch office: 

Australia 1800 300 800, Austria 43 662 457990-0, 
Belgium 32 (0) 2 757 0020, Brazil 55 11 3262 3599, 
Canada 800 433 3488, China 86 21 5050 9800, 
Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 
Finland 385 (0) 9 725 72511, France 01 57 66 24 24, 
Germany 49 89 7413130, India 91 80 41190000, Israel 972 3 6393737, 
Italy 39 02 413091, Japan 81 3 5472 2970, Korea 82 02 3451 3400, 
Lebanon 961 (0) 1 33 28 28, Malaysia 1800 887710, 
Mexico 01 800 010 0793, Netherlands 31 (0) 348 433 466, 
New Zealand 0800 553 322, Norway 47 (0) 66 90 76 60, 
Poland 48 22 3390150, Portugal 351 210 311 210, Russia 7 495 783 6851, 
Singapore 1800 226 5886, Slovenia 386 3 425 42 00, 
South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 
Sweden 46 (0) 8 587 895 00, Switzerland 41 56 2005151, 
Taiwan 886 02 2377 2222, Thailand 662 278 6777, 
Turkey 90 212 279 3031, United Kingdom 44 (0) 1635 523545

http://www.ni.com/support
http://www.ni.com/support
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