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 Important Information

Warranty
The NI USB-6210, NI USB-6211, NI USB-6212, NI USB-6215, NI USB-6216, and NI USB-6218 are warranted against defects in materials 
and workmanship for a period of one year from the date of shipment, as evidenced by receipts or other documentation. National Instruments 
will, at its option, repair or replace equipment that proves to be defective during the warranty period. This warranty includes parts and labor. 

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects in 
materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National Instruments 
will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives notice of such defects 
during the warranty period. National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any 
equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by 
warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In 
the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document 
without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. In no event shall National 
Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL 
INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING 
FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of 
the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. Any action against 
National Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in 
performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service 
failures caused by owner’s failure to follow the National Instruments installation, operation, or maintenance instructions; owner’s modification of the 
product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside 
reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, 
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National 
Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other 
intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only 
to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

Trademarks
National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section 
on ni.com/legal for more information about National Instruments trademarks.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency, 
partnership, or joint-venture relationship with National Instruments.

Patents
For patents covering National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, 
the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF 
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN 
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT 
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE 
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, 
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS 
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE 
COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES, 
TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR 
ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER 
COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF 
HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY 
UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH, 
THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES, 
INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS 
CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION 
DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT 
EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY 
RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER 
NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT 
LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.
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About This Manual

The NI USB-621x User Manual contains information about using the 
National Instruments USB-621x data acquisition (DAQ) devices with 
NI-DAQmx 8.9 and later. NI USB-6210, USB-6211, USB-6212, 
USB-6215, USB-6216, and USB-6218 devices feature up to 32 analog 
input (AI) channels, up to two analog output (AO) channels, two counters, 
and up to eight lines of digital input (DI) and up to eight lines of digital 
output (DO), or 32 bidirectional static DIO lines.

Conventions
The following conventions are used in this manual:

<> Angle brackets that contain numbers separated by an ellipsis represent 
a range of values associated with a bit or signal name—for example, 
AO <3..0>.

» The » symbol leads you through nested menu items and dialog box options 
to a final action. The sequence File»Page Setup»Options directs you to 
pull down the File menu, select the Page Setup item, and select Options 
from the last dialog box.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 
avoid injury, data loss, or a system crash. When this symbol is marked on a 
product, refer to the Read Me First: Safety and Electromagnetic 
Compatibility document for information about precautions to take.

bold Bold text denotes items that you must select or click in the software, such 
as menu items and dialog box options. Bold text also denotes parameter 
names.

italic Italic text denotes variables, emphasis, a cross-reference, or an introduction 
to a key concept. Italic text also denotes text that is a placeholder for a word 
or value that you must supply.
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monospace Text in this font denotes text or characters that you should enter from the 
keyboard, sections of code, programming examples, and syntax examples. 
This font is also used for the proper names of disk drives, paths, directories, 
programs, subprograms, subroutines, device names, functions, operations, 
variables, filenames, and extensions.

Platform Text in this font denotes a specific platform and indicates that the text 
following it applies only to that platform.

Related Documentation
Each application software package and driver includes information about 
writing applications for taking measurements and controlling measurement 
devices. The following references to documents assume you have 
NI-DAQ 8.9 or later, and where applicable, version 7.1 or later of the 
NI application software.

NI-DAQmx for Windows
The NI-DAQmx for USB Devices Getting Started Guide describes 
how to install your NI-DAQmx for Windows software, your 
NI-DAQmx-supported DAQ device, and how to confirm that your device is 
operating properly. Select Start»All Programs»National Instruments»
NI-DAQ»NI-DAQmx for USB Devices Getting Started.

The NI-DAQ Readme lists which devices are supported by this version of 
NI-DAQ. Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQ Readme.

The NI-DAQmx Help contains general information about measurement 
concepts, key NI-DAQmx concepts, and common applications that are 
applicable to all programming environments. Select Start»All Programs»
National Instruments»NI-DAQ»NI-DAQmx Help.

NI-DAQmx Base (Linux/Mac OS X/LabVIEW Mobile Module 8.x/ 
LabVIEW Touch Panel Module 8.x)

The NI-DAQmx Base Getting Started Guide describes how to install your 
NI-DAQmx Base software, your NI-DAQmx Base-supported DAQ device, 
and how to confirm that your device is operating properly. In Windows, 
select Start»All Programs»National Instruments»NI-DAQmx Base»
Documentation»Getting Started Guide.
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Getting Started with NI-DAQmx Base for Linux and Mac Users describes 
how to install your NI-DAQmx Base software, your NI-DAQmx 
Base-supported DAQ device, and how to confirm that your device is 
operating properly on your Mac/Linux machine.

The NI-DAQmx Base Readme lists which devices are supported by this 
version of NI-DAQmx Base. In Windows, select Start»All Programs»
National Instruments»NI-DAQmx Base»DAQmx Base Readme.

The NI-DAQmx Base VI Reference Help contains VI reference and general 
information about measurement concepts. In LabVIEW, select Help»
NI-DAQmx Base VI Reference Help.

The NI-DAQmx Base C Reference Help contains C reference and general 
information about measurement concepts. In Windows, select Start» 
All Programs»National Instruments»NI-DAQmx Base»
Documentation»C Function Reference Help.

Note All NI-DAQmx Base documentation for Linux is installed at /usr/local/ 
natinst/nidaqmxbase/documentation.

Note All NI-DAQmx Base documentation for Mac OS X is installed at /Applications/ 
National Instruments/NI-DAQmx Base/documentation.

LabVIEW
If you are a new user, use the Getting Started with LabVIEW manual 
to familiarize yourself with the LabVIEW graphical programming 
environment and the basic LabVIEW features you use to build data 
acquisition and instrument control applications. Open the Getting Started 
with LabVIEW manual by selecting Start»All Programs»National 
Instruments»LabVIEW»LabVIEW Manuals or by navigating to the 
labview\manuals directory and opening LV_Getting_Started.pdf.
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Use the LabVIEW Help, available by selecting Help»Search the 
LabVIEW Help in LabVIEW, to access information about LabVIEW 
programming concepts, step-by-step instructions for using LabVIEW, and 
reference information about LabVIEW VIs, functions, palettes, menus, and 
tools. Refer to the following locations on the Contents tab of the LabVIEW 
Help for information about NI-DAQmx:

• Getting Started with LabVIEW»Getting Started with 
DAQ—Includes overview information and a tutorial to learn how to 
take an NI-DAQmx measurement in LabVIEW using the DAQ 
Assistant.

• VI and Function Reference»Measurement I/O VIs and 
Functions—Describes the LabVIEW NI-DAQmx VIs and properties.

• Taking Measurements—Contains the conceptual and how-to 
information you need to acquire and analyze measurement data 
in LabVIEW, including common measurements, measurement 
fundamentals, NI-DAQmx key concepts, and device considerations.

LabWindows/CVI
The Data Acquisition book of the LabWindows/CVI Help contains 
measurement concepts for NI-DAQmx. This book also contains Taking 
an NI-DAQmx Measurement in LabWindows/CVI, which includes 
step-by-step instructions about creating a measurement task using the DAQ 
Assistant. In LabWindows™/CVI™, select Help»Contents, then select 
Using LabWindows/CVI»Data Acquisition.

The NI-DAQmx Library book of the LabWindows/CVI Help contains 
API overviews and function reference for NI-DAQmx. Select Library 
Reference»NI-DAQmx Library in the LabWindows/CVI Help.

Measurement Studio
If you program your NI-DAQmx-supported device in Measurement Studio 
using Visual C++, Visual C#, or Visual Basic .NET, you can interactively 
create channels and tasks by launching the DAQ Assistant from MAX or 
from within Visual Studio .NET. You can generate the configuration code 
based on your task or channel in Measurement Studio. Refer to the DAQ 
Assistant Help for additional information about generating code. You also 
can create channels and tasks, and write your own applications in your 
ADE using the NI-DAQmx API.

For help with NI-DAQmx methods and properties, refer to the NI-DAQmx 
.NET Class Library or the NI-DAQmx Visual C++ Class Library included 
in the NI Measurement Studio Help. For general help with programming 
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in Measurement Studio, refer to the NI Measurement Studio Help, which 
is fully integrated with the Microsoft Visual Studio .NET help. To view 
this help file in Visual Studio. NET, select Measurement Studio» 
NI Measurement Studio Help.

To create an application in Visual C++, Visual C#, or Visual Basic .NET, 
follow these general steps:

1. In Visual Studio .NET, select File»New»Project to launch the New 
Project dialog box.

2. Find the Measurement Studio folder for the language you want to 
create a program in.

3. Choose a project type. You add DAQ tasks as a part of this step.

ANSI C without NI Application Software
The NI-DAQmx Help contains API overviews and general information 
about measurement concepts. Select Start»All Programs»National 
Instruments»NI-DAQmx Help.

The NI-DAQmx C Reference Help describes the NI-DAQmx Library 
functions, which you can use with National Instruments data acquisition 
devices to develop instrumentation, acquisition, and control applications. 
Select Start»All Programs»National Instruments»NI-DAQ»
NI-DAQmx C Reference Help.

.NET Languages without NI Application Software
With the Microsoft .NET Framework version 1.1 or later, you can use 
NI-DAQmx to create applications using Visual C# and Visual Basic .NET 
without Measurement Studio. You need Microsoft Visual Studio .NET 
2003 or Microsoft Visual Studio 2005 for the API documentation to be 
installed.

The installed documentation contains the NI-DAQmx API overview, 
measurement tasks and concepts, and function reference. This help is fully 
integrated into the Visual Studio .NET documentation. To view the 
NI-DAQmx .NET documentation, go to Start»Programs»National 
Instruments»NI-DAQ»NI-DAQmx .NET Reference Help. Expand 
NI Measurement Studio Help»NI Measurement Studio .NET Class 
Library»Reference to view the function reference. Expand 
NI Measurement Studio Help»NI Measurement Studio .NET Class 
Library»Using the Measurement Studio .NET Class Libraries to view 
conceptual topics for using NI-DAQmx with Visual C# and Visual 
Basic .NET.
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To get to the same help topics from within Visual Studio, go to Help»
Contents. Select Measurement Studio from the Filtered By drop-down 
list and follow the previous instructions.

Device Documentation and Specifications
The NI USB-621x Specifications contains all specifications for the 
USB-6210, USB-6211, USB-6212, USB-6215, USB-6216, and USB-6218 
M Series devices.

Documentation for supported devices and accessories, including PDF 
and help files describing device terminals, specifications, features, and 
operation are on the NI-DAQmx media that includes Device 
Documentation. Insert the media, open the Device Documentation 
directory, and double-click the Device Documents shortcut for your 
language to find, view, and print device documents.

Training Courses
If you need more help getting started developing an application with 
NI products, NI offers training courses. To enroll in a course or obtain a 
detailed course outline, refer to ni.com/training.

Technical Support on the Web
For additional support, refer to ni.com/support or zone.ni.com.

Note You can download these documents at ni.com/manuals.

DAQ specifications and manuals are available as PDFs. You must have 
Adobe Acrobat Reader with Search and Accessibility 5.0.5 or later 
installed to view the PDFs. Refer to the Adobe Systems Incorporated 
Web site at www.adobe.com to download Acrobat Reader. Refer to the 
National Instruments Product Manuals Library at ni.com/manuals for 
updated documentation resources.
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NI USB-621x devices feature up to 32 analog input (AI) channels, up to 
two analog output (AO) channels, two counters, and up to eight lines 
of digital input (DI) and up to eight lines of digital output (DO), or 
32 bidirectional static DIO lines.

Installing NI-DAQmx
The NI-DAQmx for USB Devices Getting Started Guide, which you can 
download from ni.com/manuals, offers NI-DAQmx users step-by-step 
instructions for installing software and hardware, configuring channels and 
tasks, and getting started developing an application.

Installing Other Software
If you are using other software, refer to the installation instructions that 
accompany your software.

Installing the Hardware
The NI-DAQmx for USB Devices Getting Started Guide contains 
non-software-specific information about how to install USB devices. 
Before installing your DAQ device, you must install the software you plan 
to use with the device.



Chapter 1 Getting Started

NI USB-621x User Manual 1-2 ni.com

Device Self-Calibration
NI recommends that you self-calibrate your USB-621x device after 
installation and whenever the ambient temperature changes. 
Self-calibration should be performed after the device has warmed up for the 
recommended time period. Refer to the NI USB-621x Specifications to find 
your device warm-up time. This function measures the onboard reference 
voltage of the device and adjusts the self-calibration constants to account 
for any errors caused by short-term fluctuations in the environment. 
Disconnect all external signals when you self-calibrate a device.

You can initiate self-calibration using Measurement & Automation 
Explorer (MAX), by completing the following steps.

1. Launch MAX.

2. Select My System»Devices and Interfaces»NI-DAQmx 
Devices»your device.

3. Initiate self-calibration using one of the following methods:

• Click Self-Calibrate in the upper right corner of MAX.

• Right-click the name of the device in the MAX configuration tree 
and select Self-Calibrate from the drop-down menu.

Note You can also programmatically self-calibrate your device with NI-DAQmx, 
as described in Device Calibration in the NI-DAQmx Help or the LabVIEW Help in 
version 8.0 or later.

Device Pinouts
Refer to Appendix A, Device-Specific Information, for USB-621x device 
pinouts.

Device Specifications
Refer to the NI USB-621x Specifications, available on the NI-DAQ Device 
Documentation Browser or from ni.com/manuals, for more detailed 
information about USB-621x devices.
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Applying Signal Labels to the USB-621x
(USB-621x Screw Terminal Devices) Your USB-621x kit includes labels for 
the combicon connectors on USB-621x Screw Terminal devices. You can 
choose labels with pin numbers or signal names or blank labels. Choose 
one of the labels, align the correct label with the terminals printed on the 
top panel of your device or the 16-position combicon connector, and apply 
the label, as shown in Figure 1-1.

Figure 1-1.  USB-621x Screw Terminal Signal Labels

1 Terminal Number Label
2 Single-Ended Signal Name Label

3 Differential Signal Name Label
4 User-Defined Custom Label

P/N 19XXXX REVX
msi               6000

4

3

2

1
or

or

or
or

or

or

1

4

3

2
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USB Cable Strain Relief
You can provide strain relief for the USB cable in the following ways:

• Cable Strain Relief Groove Method—(USB-621x Screw Terminal/Mass 
Termination Devices) Press the USB cable into one of the two grooves 
on the underside of the USB-621x. Choose the USB cable groove that 
matches your USB cable size, as shown in Figure 1-2a. 

• Zip Tie Method—(USB-621x Screw Terminal/Mass Termination Devices) 
Thread a zip tie through the zip tie bar on the underside of the 
USB-621x and tighten around the USB cable, as shown in Figure 1-2b.

Figure 1-2.  USB Cable Strain Relief Options on USB-621x Screw Terminal/Mass 
Termination Devices

1 USB Cable Strain Relief Groove (Large)
2 USB Cable Strain Relief Groove (Small)
3 USB Cable

4 Zip Tie
5 Zip Tie Bar
6 Stacking Groove

1

2

3

3

5

4

a b

or
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